Многопротокольная коммутация по меткам (MPLS) : MPLS

Выбор базовой конфигурации для MPLS VPN

23 марта 2008 - Перевод, выполненный профессиональным переводчиком
Другие версии: PDF-версия:pdf | Машинный перевод (28 июля 2013) | Английский (16 ноября 2007) | Отзыв

Содержание

Введение
Предварительные условия
      Требования
      Используемые компоненты
      Другая продукция этого типа
      Условные обозначения
Настройка
      Схема сети
      Процедуры конфигурации
      Конфигурации
Проверка
Устранение неполадок
Связанные обсуждения сообщества поддержки Cisco
Сопутствующая информация

Введение

В этом документе описывается стандартная конфигурация Multiprotocol Label Switching (MPLS) трафика виртуальной частной сети по ATM, когда на стороне клиентов работает протокол пограничных шлюзов BGP или протокол маршрутизации информации RIP.

Использование функции виртуальной частной сети с MPLS позволяет нескольким узлам взаимодействовать прозрачным образом посредством сети поставщика услуг. Одна сеть поставщика услуг может поддерживать несколько сетей VPN с разными IP-адресами. Любая из этих сетей для пользователей является частной сетью, отделенной от других сетей. В пределах сети VPN с каждого узла могут быть переданы IP-пакеты на другой узел этой же сети.

Каждая сеть VPN связана с одним или более коммутируемым или пересылаемым экземпляром (VRF). Экземпляр VRF состоит из таблицы IP-маршрутизации, производной таблицы функции Cisco Express Forwarding (CEF) и набора интерфейсов, использующих таблицу пересылки.

Маршрутизатор поддерживает отдельную маршрутизацию и таблицу CEF для каждого экземпляра VRF. Эта возможность предотвращает передачу данных за пределы сети VPN и разрешает использование одной подсети в нескольких VPN без дублирования IP-адресов.

Маршрутизатор, использующий мультипротокольный BGP (MP-BGP), распространяет сведения о маршрутизации VPN, используя расширенные сообщества MP-BGP.

Дополнительные сведения относительно распространения обновлений через VPN можно получить на следующих URL:

Предварительные условия

Требования

Для данного документа нет особых требований.

Используемые компоненты

Сведения, содержащиеся в данном документе, относятся к следующим версиям программного и аппаратного обеспечения.

Маршрутизаторы P и PE

  • ПО Cisco IOS® версии 12.2(6h) включает функцию MPLS VPN.

  • Все маршрутизаторы Cisco серии 7200 или выше поддерживают функции P. Маршрутизаторы Cisco серий 2691, 3640 и выше поддерживают функции PE.

Маршрутизаторы C и CE

  • Можно использовать любой маршрутизатор, поддерживающий обмен данными маршрутизации со своим маршрутизатором PE.

Сведения, представленные в данном документе, были получены на тестовом оборудовании в специально созданных лабораторных условиях. При написании данного документа использовались только данные, полученные от устройств с конфигурацией по умолчанию. При работе с реально функционирующей сетью необходимо полностью осознавать возможные последствия выполнения команд до их применения.

Другая продукция этого типа

Для реализации функции MPLS необходим маршрутизатор версии Cisco 2600 или выше. Чтобы выбрать требуемое ПО Cisco IOS с функцией MPLS, воспользуйтесь Software Advisor (только для зарегистрированных клиентов). Проверьте, чтобы оперативной и флэш-памяти было достаточно для запуска средства MPLS на маршрутизаторах. Можно использовать WIC-1T, WIC-2T и другие последовательные интерфейсы.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в разделе Технические советы Cisco. Условные обозначения.

Приведенные ниже буквы соответствуют различным типам используемых маршрутизаторов и коммутаторов.

  • P - Основной маршрутизатор провайдера.

  • PE - маршрутизатор на стороне поставщика.

  • CE – маршрутизатор на стороне клиента.

  • C– маршрутизатор клиента.

На данной диаграмме показана типичная конфигурация, иллюстрирующая описанные выше условия.

mplsvpn.gif

Настройка

В этом разделе приводятся сведения о настройке возможностей, описанных в данном документе.

Примечание. Для поиска дополнительной информации о командах в данном документе используйте средство "Command Lookup" (Поиск команд) (только для зарегистрированных клиентов).

Схема сети

В данном документе используется сеть, изображенная на следующей схеме.

new_mpls_vpn_basic1.gif

Процедуры конфигурации

Дополнительная информация содержится в разделе "Виртуальные частные сети MPLS".

Включение ip cef

Чтобы включить ip cef, воспользуйтесь следующей процедурой. Для улучшения производительности используйте ip cef distributed (при наличии). Выполните следующие действия с устройствами PE после настройки MPLS (настройка tag-switching ip на интерфейсах).

  1. Создайте одну VRF для каждой VPN, подключенной с помощью команды ip vrf <VPN routing/forwarding instance name>.

    При этом выполните следующие действия:

    • Укажите правильный отличительный признак маршрута, который используется для данной виртуальной частной сети. Таким образом выполняется расширение IP-адресов, с помощью чего можно определить, к какой сети VPN принадлежит адрес.

      rd <VPN route distinguisher>
      
      
    • Задайте свойства импорта и экспорта для расширенных сообществ MP-BGP. Данные свойства используются для фильтрации процессов экспорта-импорта.

      route-target [export|import|both] <target VPN extended community>
      
      
  2. С помощью команды ip vrf forwarding <VPN routing/forwarding instance name> настройте передачу для соответствующих интерфейсов. Не забудьте после этого настроить IP-адрес.

  3. В зависимости от используемого на участке PE-CE протокола маршрутизации можно настроить между PE и CE статичные маршруты, либо задействовать протоколы маршрутизации (RIP, Open Shortest Path First [OSPF] или BGP). Подробные настройки доступны на странице поддержки MPLS через ATM.

Настройка MP-BGP

Настройте MP-BGP между маршрутизаторами PE. Существует несколько способов настроить протокол BGP, например с помощью отражателя маршрутов или методов конфедерации. Используемый здесь метод - настройка непосредственного соседа - является наиболее простым и наименее масштабируемым решением.

  1. Объявите различных соседей.

  2. Для каждой VPN, присутствующей для данного маршрутизатора PE, введите команду address-family ipv4 vrf <VPN routing/forwarding instance name>.

    При необходимости выполните одно или несколько следующих действий:

    • Перераспределите статические маршруты, RIP или OSPF информацию.

    • Перераспределите данные о подключенных маршрутах.

    • Включите соседство BGP с CE-маршрутизаторами.

  3. Перейдите в режим address-family vpnv4 и выполните следующие действия:

    • Активируйте соседей.

    • Укажите необходимость использования расширенного сообщества. Данное действие является обязательным.

Конфигурации

В данном документе используются следующие конфигурации.

Pescara

Текущая конфигурация:
!
Версия 12.2
!
имя узла Pescara
!
ip cef
!



!--- Команды клиента A.

ip vrf Customer_A

!--- Включает маршрутизацию VPN и таблицу VRF.
!--- Эта команда может использоваться в глобальном режиме или
!--- режиме настройки маршрутизатора. 

 rd 100:110

!---Отличительный признак маршрута отвечает за маршрутизацию и передачу
!--- таблиц для VRF.

 route-target export 100:1000

!---Создает списки сообществ импорта и экспорта целевых групп маршрута
!--- для указанных VRF.

 route-target import 100:1000
!


!--- Команды клиента B.

ip vrf Customer_A
 rd 100:120
 route-target export 100:2000
 route-target import 100:2000
!
interface Loopback0
 ip address 10.10.10.4 255.255.255.255
 ip router isis


!--- Команды клиента A.

interface Loopback101
ip vrf forwarding Customer_A

!--- Связывает экземпляр VRF с интерфейсом или подинтерфейсом.

 ip address 200.0.4.1 255.255.255.0

!--- Loopback101 и 102 используют одинаковый IP-адрес 200.0.4.1. 
!--- Это разрешено, поскольку они принадлежат двум
!--- различным VRF клиентов. 

 нет широковещательной рассылки по IP-адресам
!


!--- Команды клиента B.

interface Loopback102
 ip vrf forwarding Customer_B
 ip address 200.0.4.1 255.255.255.0

!--- Loopback101 и 102 используют одинаковый IP-адрес 200.0.4.1. 
!--- Это разрешено, поскольку они принадлежат двум
!--- различным VRF клиентов.
 
 нет широковещательной рассылки по IP-адресам
!
Последовательный интерфейс0/1
 no ip address
 нет широковещательной рассылки по IP-адресам
 encapsulation frame-relay
 no fair-queue
!
Последовательный интерфейс0.1/1
 description link to Pauillac
 Команда "bandwidth 512"
 ip address 10.1.1.14 255.255.255.252
 нет широковещательной рассылки по IP-адресам
 ip router isis
 tag-switching ip
 frame-relay interface-dlci 401
!
Маршрутизатор ISIS
 net 49.0001.0000.0000.0004.00
 "-1" обозначает уровень.
!         
router bgp 100
 bgp log-neighbor-changes

!--- Включает регистрацию перезапусков соседа BGP.

 neighbor 10.10.10.6 remote-as 100

!--- Добавляет запись в таблицу соседей BGP или многопротокольного BGP.

 neighbor 10.10.10.6 update-source Loopback0

!--- Позволяет сеансам BGP использовать особый оперативный
!--- интерфейс для соединений TCP.

!
 

!--- Команды клиентов A и B.

 address-family vpnv4

!--- Используется для введения адреса режима настройки семейства
!--- с целью настройки сеансов маршрутизации, как, например, BGP, 
!--- который использует стандартные префиксы адреса VPN версии 4.

 neighbor 10.10.10.6 activate
 neighbor 10.10.10.6 send-community both
 
!--- Отправляет атрибут сообщества соседу BGP.

 exit-address-family
 !


!--- Команды клиента B.

 address-family ipv4 vrf Customer_B

!--- Используется для введения адреса режима настройки семейства
!--- с целью настройки сеансов маршрутизации, как, например, BGP, 
!--- который использует стандартные префиксы адреса VPN версии 4.

 redistribute connected
 no auto-summary
 no synchronization
 exit-address-family
 !
 

!--- Команды клиента A.

 address-family ipv4 vrf Customer_A
 redistribute connected
 no auto-summary
 no synchronization
 exit-address-family
!
Бесклассовый IP
!
end

Pesaro

Текущая конфигурация:
!
Версия 12.1
!
имя узла Pesaro
!


!--- Команды клиента A.

ip vrf Customer_A
 rd 100:110
 route-target export 100:1000
 route-target import 100:1000
!


!--- Команды клиента B.

ip vrf Customer_A
 rd 100:120
 route-target export 100:2000
 route-target import 100:2000
!
ip cef

!
interface Loopback0
 ip address 10.10.10.6 255.255.255.255
 ip router isis


!--- Команды клиента A.

interface Loopback101
 ip vrf forwarding Customer_A
 ip address 200.0.6.1 255.255.255.0
!


!--- Команды клиента B.

interface Loopback102
 ip vrf forwarding Customer_B
 ip address 200.0.6.1 255.255.255.0
!


!--- Команды клиента A.

interface Loopback111
 ip vrf forwarding Customer_A
 ip address 200.1.6.1 255.255.255.0
!
Последовательный интерфейс0/0
 no ip address
 encapsulation frame-relay
 no ip mroute-cache
 random-detect
!
interface Serial0/0.1 point-to-point
 description link to Pomerol
 Команда "bandwidth 512"
 ip address 10.1.1.22 255.255.255.252
 ip router isis
 tag-switching ip
 frame-relay interface-dlci 603
!
Маршрутизатор ISIS
 net 49.0001.0000.0000.0006.00
 "-1" обозначает уровень.
!
router bgp 100
 neighbor 10.10.10.4 remote-as 100
 neighbor 10.10.10.4 update-source Loopback0
 !


!--- Команды клиента B.

 address-family ipv4 vrf Customer_B
 redistribute connected
 no auto-summary
 no synchronization
 exit-address-family
 !


!--- Команды клиента A.

 address-family ipv4 vrf Customer_A
 redistribute connected
 no auto-summary
 no synchronization
 exit-address-family
 !


!--- Команды клиентов A и B.

 address-family vpnv4
 neighbor 10.10.10.4 activate
 neighbor 10.10.10.4 send-community both
 exit-address-family
!
Бесклассовый IP
!         
end

Pomerol

Текущая конфигурация:
!
Версия 12.0
!
имя узла Pomerol
!
ip cef

!
interface Loopback0
 ip address 10.10.10.3 255.255.255.255
 ip router isis

!
Последовательный интерфейс1/0
 no ip address
 нет широковещательной рассылки по IP-адресам
 encapsulation frame-relay
 random-detect
!
interface Serial0/1.1 point-to-point
 description link to Pauillac
 ip address 10.1.1.6 255.255.255.252
 нет широковещательной рассылки по IP-адресам
 ip router isis
 tag-switching mtu 1520
 tag-switching ip
 frame-relay interface-dlci 301
!
interface Serial0/1.2 point-to-point
 description link to Pulligny
 ip address 10.1.1.9 255.255.255.252
 нет широковещательной рассылки по IP-адресам
 ip router isis
 tag-switching ip
 frame-relay interface-dlci 303
!
interface Serial0/1.3 point-to-point
 description link to Pesaro
 ip address 10.1.1.21 255.255.255.252
 нет широковещательной рассылки по IP-адресам
 ip router isis
 tag-switching ip

 frame-relay interface-dlci 306
!
Маршрутизатор ISIS
 net 49.0001.0000.0000.0003.00
 "-1" обозначает уровень.
!
Бесклассовый IP
!
end

Pulligny

Текущая конфигурация:
!
Версия 12.1
!
имя узла Pulligny
!
!
ip cef

!
!
interface Loopback0
 ip address 10.10.10.2 255.255.255.255
!
Последовательный интерфейс1/0
 no ip address
 encapsulation frame-relay
 random-detect
!
interface Serial0/1.1 point-to-point
 description link to Pauillac
 ip address 10.1.1.2 255.255.255.252
 ip router isis
 tag-switching ip
 frame-relay interface-dlci 201
!
interface Serial0/1.2 point-to-point
 description link to Pomerol
 ip address 10.1.1.10 255.255.255.252
 ip router isis
 tag-switching ip
 frame-relay interface-dlci 203
!
Маршрутизатор ISIS
 passive-interface Loopback0
 net 49.0001.0000.0000.0002.00
 "-1" обозначает уровень.
!
Бесклассовый IP
!
end

Pauillac

!
Версия 12.1
!
имя узла pauillac
!
ip cef

!
interface Loopback0
 ip address 10.10.10.1 255.255.255.255
 ip router isis
!
Последовательный интерфейс0/0
 no ip address
 encapsulation frame-relay
 no ip mroute-cache
 tag-switching ip
 no fair-queue
!
interface Serial0/0.1 point-to-point
 description link to Pomerol
 bandwith 512
 ip address 10.1.1.1 255.255.255.252
 ip router isis
 tag-switching ip
 frame-relay interface-dlci 102
!
interface Serial0/0.2 point-to-point
 description link to Pulligny ip address 10.1.1.5 255.255.255.252

 ip router isis
 tag-switching ip
 frame-relay interface-dlci 103
!
interface Serial0/0.3 point-to-point
 description link to Pescara
 Команда "bandwidth 512"
 ip address 10.1.1.13 255.255.255.252
 ip router isis
 tag-switching ip
 frame-relay interface-dlci 104
!
Маршрутизатор ISIS
 net 49.0001.0000.0000.0001.00
 "-1" обозначает уровень.
!
Бесклассовый IP
!
end

Проверка

В данном разделе содержатся сведения о проверке работы конфигурации.

Некоторые команды show поддерживаются инструментом Output Interpreter Tool (только для зарегистрированных клиентов) , что позволяет выполнять анализ выходных данных команды show.

  • show ip vrf - Проверяет наличие верного VRF.

  • show ip vrf interfaces - Проверяет активированные интерфейсы.

  • show ip route vrf Customer_A - Проверяет данные маршрутизации на маршрутизаторах PE.

  • traceroute vrf Customer_A 200.0.6.1 - Проверяет данные маршрутизации на маршрутизаторах PE.

  • show ip bgp vpnv4 tag - Проверяет BGP.

  • show ip cef vrf Customer_A 200.0.6.1 detail - Проверяет данные маршрутизации на маршрутизаторах PE.

О многих командах подробно рассказано в руководстве по устранению неполадок решений MPLS VPN.

Пример выходных данных команды show ip vrf приводится ниже.

Pescara#show ip vrf 
  Name                             Default RD          Interfaces
  Customer_A                       100:110             Loopback101
  Customer_B                       100:120             Loopback102

Пример выходных данных команды show ip vrf interfaces:

Pesaro#show ip vrf interfaces 
Interface              IP-Address      VRF                              Protocol
Loopback101            200.0.6.1       Customer_A                       up      
Loopback111            200.1.6.1       Customer_A                       up      
Loopback102            200.0.6.1       Customer_B                       up      

В в выходных данных команд show ip route vrf присутствует одинаковый префикс 200.0.6.0/24. Это связано с тем, что удаленный маршрутизатор PE предоставляет одну и ту же сеть для двух клиентов, Customer_A и Customer_B. Это реализуется в рамках стандартного решения MPLS VPN.

Pescara#show ip route vrf Customer_A
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
       i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
       * - candidate default, U - per-user static route, o - ODR

Gateway of last resort is not set

C    200.0.4.0/24 is directly connected, Loopback101
B    200.0.6.0/24 [200/0] via 10.10.10.6, 05:10:11
B    200.1.6.0/24 [200/0] via 10.10.10.6, 04:48:11
 
Pescara#show ip route vrf Customer_B
Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
	   N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
	   E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
	   i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
	   * - candidate default, U - per-user static route, o - ODR       
	   P - periodic downloaded static route
	    
Gateway of last resort is not set
C 200.0.4.0/24 is directly connected, Loopback102
 
B 200.0.6.0/24 [200/0] via 10.10.10.6, 00:03:24

С помощью трассировки маршрута между двумя узлами клиента Customer_A можно увидеть стек меток, используемый сетью MPLS (если это поддерживается конфигурацией с помощью команды mpls ip ttl ...).

Pescara#traceroute vrf Customer_A 200.0.6.1

Type escape sequence to abort.
Tracing the route to 200.0.6.1

  1 10.1.1.13 [MPLS: Labels 20/26 Exp 0] 400 msec 276 msec 264 msec
  2 10.1.1.6 [MPLS: Labels 18/26 Exp 0] 224 msec 460 msec 344 msec
  3 200.0.6.1 108 msec *  100 msec

Примечание.  Для средств QoS используется экспериментальное поле Exp 0.

Устранение неполадок

Для этой конфигурации отсутствуют сведения об устранении неполадок.


Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Сопутствующая информация


Document ID: 13733