Качество обслуживания (QoS) : Политики QoS

Применение функций QoS к субинтерфейсам Ethernet

23 марта 2008 - Перевод, выполненный профессиональным переводчиком
Другие версии: PDF-версия:pdf | Машинный перевод (28 июля 2013) | Английский (10 августа 2005) | Отзыв

Содержание

Общие сведения
Предварительные условия
      Требования
      Используемые компоненты
      Условные обозначения
Применение политики обслуживания
      Применение иерархической политики
Настройка формирования на основе классов
      Конфигурация
Проверка
Связанные обсуждения сообщества поддержки Cisco
Дополнительные сведения

Общие сведения

В данном документе описано, как применить постановку в очередь на основе классов (CBWFQ) и другие функции качества обслуживания (QoS) операционной системы Cisco IOS® для субинтерфейса Ethernet. Субинтерфейс Ethernet является логическим интерфейсом в операционной системе Cisco IOS. Можно использовать модульный интерфейс командной строки QoS (MQC) для создания и применения служебной политики к субинтерфейсу Ethernet.

Предварительные условия

Требования

Для данного документа нет особых требований.

Используемые компоненты

Сведения, содержащиеся в данном документе, приведены для следующих версий программного и аппаратного обеспечения:

  • Операционная система Cisco IOS версии 12.2(2)T;

  • Маршрутизатор Cisco 2620 с сетевым модулем Fast Ethernet.

Сведения, представленные в данном документе, были получены на тестовом оборудовании в специально созданных лабораторных условиях. При написании данного документа использовались только устройства с пустой (стандартной) конфигурацией. При работе с реально функционирующей сетью необходимо полностью осознавать возможные результаты использования всех команд.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в разделе "Технические рекомендации Cisco. Условные обозначения".

Применение политики обслуживания

В общем случае, выбор варианта применения политики зависит от функций QoS, которые активирует политика. Субинтерфейс Ethernet поддерживает следующие функции:

  • Ограничение скорости на основе классов — Если пользователь применяет политику ограничения скорости с помощью команды police одновременно для интерфейса и субинтерфейса, то ограничитель скорости субинтерфейса будет активным только для трафика подходящего класса. Дополнительные сведения см. в документе Политики ограничения скорости трафика;

  • Маркирование на основе классов — для получения дополнительных сведений см. раздел Обзор способов классификации;

  • Формирование на основе классов — для получения дополнительных сведений см. раздел Настройка формирования на основе классов;

  • Организация очереди на основе классов — Постановка в очередь является специальной функцией для субинтерфейса Ethernet. Для получения дополнительных сведений см. оставшуюся часть данного раздела.

Маршрутизатор начинает формировать очередь из пакетов, если пропускная способность этого интерфейса оказывается недостаточной для передачи определенного числа пакетов. Избыточные пакеты ставятся в очередь. Метод постановки в очередь можно применять к пакетам, ожидающих передачи.

Логические интерфейсы операционной системы Cisco IOS в действительности не поддерживают состояние перегрузки и не поддерживают прямое применение политики обслуживания, которая применяет метод постановки в очередь. Вместо этого сначала необходимо применить формирование к субинтерфейсу с помощью группового формирования трафика (GTS) или формирования на основе классов. Дополнительные сведения см. в документе Ограничение и формирование трафика.

При настройке субинтерфейса Ethernet с помощью политики обслуживания, применяющей постановку в очередь без формирования, маршрутизатор выводит на печать следующее сообщение журнала:

router(config)# interface ethernet0/0.1
router(config-subif)# service-policy output test
 CBWFQ : Not supported on subinterfaces

Обратите внимание на то, что то же самое правило применимо и к субинтерфейсу Gigabit Ethernet.

c7400(config)# interface gig0/0.1
c7400(config-subif)# service-policy ou
c7400(config-subif)# service-policy output outFE
  CBWFQ : Not supported on subinterfaces

Иначе говоря, необходимо настроить иерархическую политику с помощью команды shape на родительском уровне. Используйте команду bandwidth для CBWFQ или команду priority для организации постановки в очередь с малой задержкой (LLQ) на более низких уровнях. Формирование на основе классов ограничивает выходную скорость и, вероятно, приводит к перегрузке на логическом субинтерфейсе. После чего субинтерфейс применяет "обратное давление", а операционная система Cisco IOS начинает помещать в очередь избыточные пакеты, удерживаемые формирователем.

Применение иерархической политики

Чтобы применить иерархическую политику, выполните следующие действия:

  1. Создайте дочернюю политику или политику нижнего уровня, которая настроит механизм постановки в очередь. В нижеследующем примере настройка LLQ производится с помощью команды priority, а настройка CBWFQ — с помощью команды bandwidth. Дополнительные сведения см. в документе Обзор управления перегрузкой в сети.

    policy-map child 
     class voice 
      priority 512
  2. Создайте родительскую политику или политику верхнего уровня, применяющую формирование на основе классов. Примените дочернюю политику как команду родительской политики, так как контроль на входе дочернего класса основан на формировании скорости трафика родительского класса.

    policy-map parent
     class class-default 
      shape average 2000000 
      service-policy child 
  3. Примените родительскую политику к субинтерфейсу.

    interface ethernet0/0.1
     service-policy parent 

Настройка формирования на основе классов

В данном разделе приводятся сведения о настройке функций, описанных в этом документе.

Примечание. Для поиска дополнительной информации о командах из данного документа используйте средство Command Lookup Tool (Инструмент поиска команд) (только для зарегистрированных пользователей).

Конфигурация

Маршрутизатор 2620A

имя главного узла сети — 2620A 
! 
ip cef 
! 
class-map match-any dscp46 
 match ip dscp 46 
class-map match-all telnet_ping_snmp 
 match access-group 150 
class-map match-all http 
 match access-group 154 
class-map match-all pop3_smtp 
 match access-group 153 
! 
! 
policy-map voice_traffic 
 class dscp46 
  shape average 30000 10000 
 class telnet_ping_snmp 
  shape average 20000 15440 
 class pop3_smtp 
  shape average 20000 15440 
 class http 
  shape average 20000 15440 
! 
interface FastEthernet0/0 
 ip address 10.10.247.2 255.255.255.0 
 duplex auto 
 speed auto 
! 
interface FastEthernet0/0.1 
 encapsulation dot1Q 1 native 
 ip address 10.1.1.1 255.255.255.0 
 service-policy output voice_traffic

Проверка

В данном разделе содержатся сведения о проверке работоспособности конфигурации.

Некоторые команды типа show поддерживаются утилитой Output Interpreter (Интерпретатор выходных данных), которая позволяет просматривать результат выполнения команды show.

  • show policy-map {policy name} - отображает настройки всех классов для определенной схемы политики обслуживания.

    2620A# show policy-map voice_traffic 
    Policy Map voice_traffic 
    Class dscp46 
    Traffic Shaping 
    Average Rate Traffic Shaping 
    CIR 30000 (bps) Max. Buffers Limit 1000 (Packets) 
    Bc 10000 
    Class telnet_ping_snmp 
    Traffic Shaping 
    Average Rate Traffic Shaping 
    CIR 20000 (bps) Max. Buffers Limit 1000 (Packets) 
    Bc 15440 
    Class pop3_smtp 
    Traffic Shaping 
    Average Rate Traffic Shaping 
    CIR 20000 (bps) Max. Buffers Limit 1000 (Packets) 
    Bc 15440 
    Class http 
    Traffic Shaping 
    Average Rate Traffic Shaping 
    CIR 20000 (bps) Max. Buffers Limit 1000 (Packets) 
    Bc 15440 
    
    2620A# show policy-map voice_traffic class dscp46 
    Class dscp46 
    Traffic Shaping 
    Average Rate Traffic Shaping 
    CIR 30000 (bps) Max. Buffers Limit 1000 (Packets) 
    Bc 10000
  • show policy-map interface fast - отображает счетчики совпадений для всех классов определенной схемы политики обслуживания.

    2620A# show policy-map interface fa0/0.1 
    FastEthernet0/0.1 
    Service-policy output: voice_traffic 
    Class-map: dscp46 (match-any) 
    0 packets, 0 bytes 
    5 minute offered rate 0 bps, drop rate 0 bps 
    Match: ip dscp 46 
    0 packets, 0 bytes 
    5 minute rate 0 bps 
    Traffic Shaping 
    Target    Byte   Sustain   Excess    Interval  Increment Adapt 
    Rate      Limit  bits/int  bits/int  (ms)      (bytes)   Active 
    30000     2500   10000     10000     333       1250      - 
    Queue     Packets   Bytes     Packets   Bytes     Shaping 
    Depth                         Delayed   Delayed   Active 
    0         0         0         0         0         no 
    Class-map: telnet_ping_snmp (match-all) 
    0 packets, 0 bytes 
    5 minute offered rate 0 bps, drop rate 0 bps 
    Match: access-group 150 
    Traffic Shaping 
    Target    Byte   Sustain   Excess    Interval  Increment Adapt 
    Rate      Limit  bits/int  bits/int  (ms)      (bytes)   Active 
    20000     3860   15440     15440     772       1930      - 
    Queue     Packets   Bytes     Packets   Bytes     Shaping 
    Depth                         Delayed   Delayed   Active 
    0         0         0         0         0         no 
    Class-map: pop3_smtp (match-all) 
    0 packets, 0 bytes 
    5 minute offered rate 0 bps, drop rate 0 bps 
    Match: access-group 153 
    Traffic Shaping 
    Target    Byte   Sustain   Excess    Interval  Increment Adapt 
    Rate      Limit  bits/int  bits/int  (ms)      (bytes)   Active 
    20000     3860   15440     15440     772       1930      - 
    Queue     Packets   Bytes     Packets   Bytes     Shaping 
    Depth                         Delayed   Delayed   Active 
    0         0         0         0         0         no 
    Class-map: http (match-all) 
    0 packets, 0 bytes 
    5 minute offered rate 0 bps, drop rate 0 bps 
    Match: access-group 154 
    Traffic Shaping 
    Target    Byte   Sustain   Excess    Interval  Increment Adapt 
    Rate      Limit  bits/int  bits/int  (ms)      (bytes)   Active 
    20000     3860   15440     15440     772       1930      - 
    Queue     Packets   Bytes     Packets   Bytes     Shaping 
    Depth                         Delayed   Delayed   Active 
    0         0         0         0         0         no 
    Class-map: class-default (match-any) 
    926 packets, 88695 bytes 
    5 minute offered rate 0 bps, drop rate 0 bps 
    Match: any

Примечание. Формирование на основе классов функционирует на уровне интерфейса и субинтерфейса. Операционная система Cisco IOS 12.2(2.5) обеспечивает возможность настройки параметров формирования для основного интерфейса и IP-адресов для субинтерфейсов.


Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 10104