Коммутация LAN : Коммутация и переадресация третьего уровня

Настройка маршрутизации InterVLAN и транкинга ISL/802.1Q на коммутаторах Catalyst 2900XL/3500XL/2940/2950/2970 с использованием внешнего маршрутизатора

23 марта 2008 - Перевод, выполненный профессиональным переводчиком
Другие версии: PDF-версия:pdf | Машинный перевод (28 июля 2013) | Английский (22 ноября 2005) | Отзыв

Содержание

Общие сведения
Перед началом работы
      Условные обозначения
      Предварительные условия
      Используемые компоненты
      Важные примечания
Настройка
      Схема сети
      Конфигурации
Команды "debug" и "show"
Пример вывода команды "show"
      Коммутатор Catalyst 3500XL
      Маршрутизатор Cisco 2600
Связанные обсуждения сообщества поддержки Cisco
Дополнительные сведения

Введение

В данном документе представлены примеры настройки канала InterSwitch (ISL) и транкинга 802.1Q между коммутатором Catalyst 3512-XL и маршрутизатором Cisco 2600; отображены результаты выполнения каждой команды. Чтобы получить такие же результаты в сценариях, представленных в данном документе, можно использовать маршрутизаторы Cisco 3600, 4500/4700 или семейства Cisco 2600 с интерфейсами FastEthernet, а также любые коммутаторы Catalyst 2900XL, 3500XL, 2940, 2950 или 2970.

С помощью транкинга осуществляется передача данных между двумя устройствами из нескольких сетей VLAN через двухточечное соединение. Транкинг Ethernet может быть реализован двумя способами:

  • ISL (собственный протокол Cisco, не поддерживается коммутаторами серий 2940 и 2950)

  • 802.1Q (стандарт IEEE)

Мы создадим магистраль, которая будет передавать трафик из двух VLAN (VLAN1 и VLAN2) через один канал между коммутатором Catalyst 3500 и маршрутизатором Cisco 2600.

Для создания маршрутизации между сетями VLAN1 и VLAN2 используется маршрутизатор Cisco 2600. Коммутаторы Catalyst 2900XL/3500XL/2940/2950/2970 - это коммутаторы уровня 2 (L2), не способные осуществлять маршрутизацию и коммуникацию между VLAN. Для получения дополнительных подробностей относительно маршрутизации внутри VLAN см. документ Обзор маршрутизации между виртуальными локальными сетями в руководстве по настройке служб коммутаторов Cisco IOS®, издание 12.1.

Для создания примеров в этом документе использовались следующие коммутаторы в лабораторной среде с чистыми конфигурациями:

  • Коммутатор Catalyst 3512XL с запущенной Cisco IOS 12.0(5.x)XU

  • Маршрутизатор Cisco 2621 с запущенной Cisco IOS 12.1(3)T

  • Маршрутизатор Cisco 2621 с запущенной Cisco IOS 12.1(1)T

Описываемые настройки были реализованы в изолированной лабораторной среде. Перед использованием любой настройки и команды необходимо изучить их потенциальное воздействие на сеть. Для приведения каждого устройства к единой конфигурации по умолчанию настройки на всех устройствах были очищены при помощи команды "write erase".

Перед началом работы

Условные обозначения

Дополнительные сведения об условных обозначениях в документах см. в разделе "Условные обозначения технических терминов Cisco".

Предварительные условия

Для данного документа нет особых предварительных условий.

Используемые компоненты

Данный документ не ограничен отдельными версиями программного и аппаратного обеспечения.

Важные примечания

Для коммутаторов Catalyst 2900XL/3500XL/2940/2950/2970:

Коммутаторы Catalyst 2940 и 2950 поддерживают только транкинг 802.1Q и не поддерживают ISL-транкинг.

На коммутаторе Catalyst 2900XL с модулем DRAM на 4 Мб транкинг поддерживается только на следующих модулях:

  • WS-X2914-XL-V: 4-портовый модуль коммутации 10/100 ISL/802.1Q

  • WS-X2922-XL-V: 2-портовый модуль коммутации 100BaseFX ISL/802.1Q

  • WS-X2924-XL-V: 4-портовый модуль коммутации 100BaseFX ISL/802.1Q

  • WS-X2931-XL: восходящий канал 1000BaseX для коммутатора Catalyst 2900 XL

  • WS-X2932-XL: восходящий канал 1000BaseX для коммутатора Catalyst 2900 XL

Действительный на данный момент список моделей коммутаторов, поддерживающих транкинг, приведен в таблице 1.

Таблица 1

Модели коммутаторов

Минимальная версия, необходимая для ISL-транкинга

Минимальная версия, необходимая для транкинга IEEE 802.1Q

Текущая версия, необходимая для транкинга (ISL/802.1Q)

WS-C2916M-XL (коммутатор 4 Мб)

11.2(8)SA4 (Enterprise Edition)

11.2(8)SA5 (Enterprise Edition)

11.2(8.6)SA6 (Original Edition)

C2912-XL

11.2(8)SA4 (Enterprise Edition)

11.2(8)SA5 (Enterprise Edition)

12.0(5)WC(1) или старше

C2924-XL

11.2(8)SA4 (Enterprise Edition)

11.2(8)SA5 (Enterprise Edition)

12.0(5)WC(1) или старше

WS-C2924C-XL

11.2(8)SA4 (Enterprise Edition)

11.2(8)SA5 (Enterprise Edition)

12.0(5)WC(1) или старше

WS-C2924M-XL

11.2(8)SA4 (Enterprise Edition)

11.2(8)SA5 (Enterprise Edition)

12.0(5)WC(1) или старше

WS-C2912MF-XL

11.2(8)SA4 (Enterprise Edition)

11.2(8)SA5 (Enterprise Edition)

12.0(5)WC(1) или старше

WS-C2924M-XL-DC

12.0(5)XU

12.0(5)XU

12.0(5)WC(1) или старше

WS-C3508G-XL

11.2(8)SA4 (Enterprise Edition)

11.2(8)SA5 (Enterprise Edition)

12.0(5)WC(1) или старше

WS-C3512-XL

11.2(8)SA4 (Enterprise Edition)

11.2(8)SA5 (Original Edition)

12.0(5)WC(1) или старше

WS-C3524-XL

11.2(8)SA4 (Enterprise Edition)

11.2(8)SA5 (Enterprise Edition)

12.0(5)WC(1) или старше

WS-C3548-XL

12.0(5)XP (Enterprise Edition)

12.0(5)XP (Enterprise Edition)

12.0(5)WC(1) или старше

WS-C3524-PWR-XL

12.0(5)XU

12.0(5)XU

12.0(5)WC(1) или старше

WS-C2940-8TF

ISL не поддерживается

12.1(13)AY

12.1(13)AY или старше для 802.1Q. ISL не поддерживается.

WS-C2940-8TT

ISL не поддерживается

12.1(13)AY

12.1(13)AY или старше для 802.1Q. ISL не поддерживается.

WS-C2950-12

ISL не поддерживается

12.0(5)WC(1)

12.0(5)WC(1) или старше для 802.1Q. ISL не поддерживается.

WS-C2950-24

ISL не поддерживается

12.0(5)WC(1)

12.0(5)WC(1) или старше для 802.1Q. ISL не поддерживается.

WS-C2950C-24

ISL не поддерживается

12.0(5)WC(1)

12.0(5)WC(1) или старше для 802.1Q. ISL не поддерживается.

WS-C2950T-24

ISL не поддерживается

12.0(5)WC(1)

12.0(5)WC(1) или старше для 802.1Q. ISL не поддерживается.

WS-C2950G-12-EI

ISL не поддерживается

12.0(5)WC(1)

12.0(5)WC(1) или старше для 802.1Q. ISL не поддерживается.

WS-C2950G-24-EI

ISL не поддерживается

12.0(5)WC(1)

12.0(5)WC(1) или старше для 802.1Q. ISL не поддерживается.

WS-C2950G-48-EI

ISL не поддерживается

12.0(5)WC(1)

12.0(5)WC(1) или старше для 802.1Q. ISL не поддерживается.

WS-C2950SX-24

ISL не поддерживается

12.0(5)WC(1)

12.0(5)WC(1) или старше для 802.1Q. ISL не поддерживается.

WS-C2950-24-EI-DC

ISL не поддерживается

12.0(5)WC(1)

12.0(5)WC(1) или старше для 802.1Q. ISL не поддерживается.

WS-C2955T-12

ISL не поддерживается

12.1(13)EA1

12.1(13)EA1 или старше для 802.1Q. ISL не поддерживается.

WS-C2955S-12

ISL не поддерживается

12.1(13)EA1

12.1(13)EA1 или старше для 802.1Q. ISL не поддерживается.

WS-C2955C-12

ISL не поддерживается

12.1(13)EA1

12.1(13)EA1 или старше для 802.1Q. ISL не поддерживается.

WS-C2970G-24T

12.1(11)AX

12.1(11)AX

12.1(11)AX или старше

WS-C2970G-24TS

12.1(14)EA1

12.1(14)EA1

12.1(14)EA1 или старше

Примечание: в вышеуказанной таблице коммутатором с DRAM 4 Мб является только WS-C2916M-XL. Все остальные перечисленные коммутаторы – это коммутаторы с DRAM на 8 Мб. Чтобы определить объем памяти коммутатора (4 Мб или 8 Мб динамического ОЗУ), на уровне пользователя введите команду "show version". Для получения дополнительной информации см. раздел "Как определить объем памяти коммутатора с помощью интерфейса командной строки" в документе "Обновление программного обеспечения коммутаторов Catalyst 2900-XL/3500-XL с помощью интерфейса командной строки (CLI)".

Примечание: В коммутаторах Catalyst 2900XL/3500XL/2940/2950/2970 можно создать интерфейс VLAN, например int vlan 1, int vlan 2, int vlan x, для каждой виртуальной локальной сети, которая настроена на коммутаторе. Однако одновременно в качестве управляющей виртуальной сети можно использовать только одну сеть. IP-адрес назначается только интерфейсу VLAN для управляющей сети. Если назначить IP-адрес интерфейсу другой сети, которая не используется как управляющая сеть VLAN, этот интерфейс не будет активирован. Желательно создать интерфейс VLAN только для управляющей VLAN.

Для маршрутизаторов Cisco 2600:

Для транкинга 802.1Q одна сеть VLAN не маркируется. Такая виртуальная сеть VLAN называется собственной VLAN. Собственная виртуальная локальная сеть используется для передачи неразмеченного трафика, когда порт находится в режиме транкинга 802.1Q. При настройке транкинга 802.1Q крайне важно учитывать то, что собственная виртуальная локальная сеть должна быть одинаково настроена на каждой стороне магистральной линии. Это частая ошибка - несогласованность собственной локальной виртуальной сети при настройке транкинга 802.1Q между маршрутизатором и коммутатором. Для получения подробностей относительно собственной виртуальной локальной сети см. раздел "IEEE 802.1Q" в документе "Создание моста между виртуальными локальными сетями IEEE 802.1Q" описания новых функций в издании 12.1(3)T.

В этом примере конфигурации собственная виртуальная локальная сеть - это по умолчанию VLAN1 как на маршрутизаторе Cisco 2621, так и на коммуникаторе Catalyst 3512XL. В зависимости от требований сети, возможно, следует использовать собственную виртуальную локальную сеть вместо установленной по умолчанию VLAN1. В разделе "Конфигурации" этого документа указаны команды для изменения собственной виртуальной локальной сети на маршрутизаторе Cisco 2600 и коммутаторе Catalyst 3500XL.

Представленные в этом документе примеры конфигураций можно использовать для маршрутизаторов серий Cisco 2600/3600/4500/4700 с интерфейсами Fast Ethernet или сетевыми модулями Fast Ethernet. Также нужно убедиться, что используется версия Cisco IOS, поддерживающая транкинг виртуальных локальных сетей ISL/802.1Q. Полный список маршрутизаторов Cisco 2600/3600/4500/4700, поддерживающих транкинг виртуальных локальных сетей ISL/802.1Q, и поддерживаемые версии Cisco IOS см. ниже в таблице 2.

Таблица 2

Модели маршрутизаторов

Минимальная версия для транкинга ISL

Минимальная версия для транкинга IEEE 802.1Q

Минимальный набор функций (ISL/802.1Q)

Cisco 2620

11.3(3a)T

12.0(1)T

IP PLUS / IP PLUS

Cisco 2621

11.3(3a)T

12.0(1)T

IP PLUS / IP PLUS

Cisco 2620

12.1(3a)T

12.1(3a)T

IP PLUS / IP PLUS

Cisco 2650

12.1(3a)T

12.1(3a)T

IP PLUS / IP PLUS

Cisco 3620

11.3(1)T

12.0(1)T

IP PLUS / IP PLUS

Cisco 3640

11.3(1)T

12.0(1)T

IP PLUS / IP PLUS

Cisco 3661

12.0(5)T

12.0(5)T

IP PLUS / IP PLUS

Cisco 3662

12.0(5)T

12.0(5)T

IP PLUS / IP PLUS

Cisco 4500-M

11.3(1)T

12.0(1)T

IP PLUS / IP PLUS

Cisco 4700-M

11.3(1)T

12.0(1)T

IP PLUS / IP PLUS

Примечание: в таблице 2 указаны только минимальные отладочные/основные версии, которые поддерживают данный пример конфигурации. Модели маршрутизаторов с определенными сетевыми модулями могут иметь различные минимальные версии Cisco IOS. Для получения полного списка минимально поддерживаемого программного обеспечения для любого семейства маршрутизаторов используйте средство Software Advisor (только для зарегистрированных пользователей) .

Примечание: минимально поддерживаемая версия не обязательно является рекомендуемой версией. Для определения наилучшей отладочной версии для конкретного продукта Cisco см. списки ошибок по компонентам продукта с помощью средства Bug Toolkit (только для зарегистрированных пользователей).

Примечание: в таблице 2 указан минимальный набор функций, необходимый для маршрутизации и транкинга IP внутри виртуальной локальной сети в данном примере конфигурации. Для получения полного списка других наборов функций, поддерживаемых в различных версиях Cisco IOS и на различных платформах, используйте средство Область загрузки ПО (только для зарегистрированных пользователей).

Настройка

В этом разделе приводятся сведения о настройке функций, описанных в данном документе.

Примечание: для поиска дополнительной информации о командах, применяемых в данном документе, используйте средство Command Lookup Tool (только для зарегистрированных пользователей).

Схема сети

В данном документе используется сеть, изображенная на следующей схеме.

50a.jpg

Конфигурации

В данном документе используются следующие конфигурации.

Примечание: модели маршрутизаторов с определенными сетевыми модулями могут иметь различные минимальные версии Cisco IOS, поддерживающие ISL-транкинг.

  • Catalyst 3512-XL

  • Маршрутизатор Cisco 2600

  • Конфигурация 802.1Q на маршрутизаторе для версий Cisco IOS 12.1(3)T и более ранних

Catalyst 3512-XL

Примечание: на следующих снимках экрана отображены команды, которые были введены на коммутаторе 3512XL. Комментарии между командами, написанные синим курсивом, служат для объяснения определенных команд и шагов.


!-- Установите привилегированный режим


!-- и пароль Telnet на коммутаторе.

switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
switch(config)#hostname 3512xl
3512xl(config)#enable password mysecret
3512xl(config)#line vty 0 4
3512xl(config-line)#login
3512xl(config-line)#password mysecret
3512xl(config-line)#exit
3512xl(config)#no logging console
3512xl(config)#^Z


!-- Установите IP-адрес и шлюз по умолчанию для управления VLAN1.

3512xl#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
3512xl(config)#int vlan 1
3512xl(config-if)#ip address 10.10.10.2 255.255.255.0
3512xl(config-if)#exit
3512xl(config)#ip default-gateway 10.10.10.1
3512xl(config)#end

!-- Установите режим VTP.
!-- В данном примере необходимо установить этот режим для прозрачности.
!-- Установите режим VTP в соответствии с существующей сетью.
!-- Подробную информацию о режиме VTP
!-- см. в разделе
!-- "Создание и обслуживание виртуальных локальных сетей на коммутаторах Catalyst 2900XL и 3500XL".

3512xl#vlan database
3512xl(vlan)#vtp transparent
Setting device to VTP TRANSPARENT mode.


!-- Добавление VLAN2. VLAN1 уже существует по умолчанию.

3512xl(vlan)#vlan 2
VLAN 2 added:
Name: VLAN0002
3512xl(vlan)#exit
APPLY completed.
Exiting....


!-- Включите транкинг на интерфейсе fastEthernet 0/1.

3512xl#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
3512xl(config)#int fastEthernet 0/1
3512xl(config-if)#switchport mode trunk


!-- Введите инкапсуляцию транкинга как isl

3512xl(config-if)#switchport trunk encapsulation isl

!-- или как dot1q:


3512xl(config-if)#switchport trunk encapsulation dot1q

!-- Для коммутаторов серий 2940/2950 ни одна из двух вышеуказанных команд не используется,
!-- коммутаторы 2940/2950 поддерживают только инкапсуляцию 802.1q, которая автоматически настраивается
!-- при включении транкинга на интерфейсе с помощью команды "switchport mode trunk".

!-- Для dot1q необходимо убедиться, что собственная
!-- виртуальная локальная сеть согласована по всей линии.
!-- На 3512XL собственная виртуальная локальная сеть по умолчанию - 1.
!-- В зависимости от требований сети можно изменить
!-- собственную виртуальную локальную сеть на отличную от VLAN1,
!-- но крайне важно аналогичным образом изменить
!-- собственную виртуальную локальную сеть на маршрутизаторе.
!-- При необходимости собственную виртуальную локальную сеть можно изменить с помощью следующей команды:
!-- 3512xl(config-if)#switchport trunk native vlan <vlan ID>

!-- Разрешить все виртуальные локальные сети на магистрали.

3512xl(config-if)#switchport trunk allowed vlan all
3512xl(config-if)#exit


!-- Следующий набор команд разместит FastEthernet 0/2
!-- в VLAN2 и активирует на интерфейсе режим portfast.

3512xl(config)#int fastEthernet 0/2
3512xl(config-if)#switchport access vlan 2
3512xl(config-if)#spanning-tree portfast
3512xl(config-if)#exit


!-- FastEthernet 0/3 уже находится в VLAN1 по умолчанию.
!-- Включите режим "portfast" на интерфейсе.

3512xl(config)#int fastEthernet 0/3
3512xl(config-if)#spanning-tree portfast
3512xl(config-if)#^Z

!-- Подробную информацию относительно причин включения режима portfast
!-- см в разделе
!-- "Использование команды PortFast и других команд для установки задержек связности во время запуска рабочей станции".
!-- Не забудьте сохранить конфигурацию.

3512xl#write memory
Building configuration...

3512xl#

--------------------------------------------------------------------------------

3512xl#show running-config
Building configuration...

Current configuration:

!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 3512xl
!
no logging console
enable password mysecret
!
!
!
!
!
ip subnet-zero
!
!
!
interface FastEthernet0/1
  switchport mode trunk
!

!-- При настроенном транкинге 802.1Q
!-- вместо вышеуказанных будут отображены следующие выходные данные:
!-- under interface FastEthernet0/1:
!-- interface FastEthernet0/1
!-- switchport trunk encapsulation dot1q
!-- switchport mode trunk

!
interface FastEthernet0/2
 switchport access vlan 2
 spanning-tree portfast
!
interface FastEthernet0/3
 spanning-tree portfast
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface GigabitEthernet0/1
!
interface GigabitEthernet0/2
!
interface VLAN1
 ip address 10.10.10.2 255.255.255.0
 no ip directed-broadcast
 no ip route-cache
!
ip default-gateway 10.10.10.1
!
line con 0
 transport input none
 stopbits 1
line vty 0 4
 password mysecret
 login
line vty 5 15
 login
!
end

Маршрутизатор 2600

Примечание: на следующих снимках экрана отображены команды, введенные в маршрутизаторе Cisco 2600. Комментарии между командами, написанные синим курсивом, служат для объяснения определенных команд и шагов.


!-- Установите привилегированный режим
!-- и пароль Telnet на маршрутизаторе.

Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname c2600

c2600(config)#enable password mysecret
c2600(config)#line vty 0 4
c2600(config-line)#login
c2600(config-line)#password mysecret
c2600(config-line)#exit
c2600(config)#no logging console
c2600(config)#^Z

c2600#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.


!-- Выберите FastEthernet 0/0 для настройки транкинга.
!-- Настройка L2 или уровня 3 (L3) здесь не производится.

c2600(config)#int fastEthernet 0/0
c2600(config-if)#no shut
c2600(config-if)#exit


!-- Включите транкинг на подчиненном интерфейсе FastEthernet 0/0.1.
!-- Обратите внимание, что действительные магистрали настроены на подчиненных интерфейсах.

c2600(config)#int fastEthernet 0/0.1


!-- Введите инкапсуляцию транкинга как isl

c2600(config-subif)#encapsulation isl 1


!-- или как dot1q:
!-- Для dot1q необходимо убедиться, что собственная
!-- виртуальная локальная сеть согласована по всей линии.
!-- На 3512XL собственная виртуальная локальная сеть по умолчанию - 1.
!-- На маршрутизаторе настройте в качестве собственной виртуальной локальной сети VLAN1.

c2600(config-subif)#encapsulation dot1Q 1 ?
  native  Make this is native vlan
  <cr>
c2600(config-subif)#encapsulation dot1Q 1 native

!-- Если на коммутаторе собственная виртуальная локальная сеть отлична от VLAN1,
!-- то на маршрутизаторе настройте ту же виртуальную локальную сеть в качестве собственной
!-- с помощью вышеуказанной команды.

Примечание: Команда encapsulation dot1Q 1 native была реализована в Cisco IOS версии 12.1(3)T. Если используется более ранняя версия Cisco IOS, то для настройки транкинга 802.1q на маршрутизаторе см. раздел данного документа "Настройка 802.1Q для версий Cisco IOS 12.1(3)T и более ранних".


!-- Настройте информацию L3 на подчиненном интерфейсе 0/0.1.

c2600(config-subif)#ip address 10.10.10.1 255.255.255.0
c2600(config-subif)#exit


!-- Включите транкинг на подчиненном интерфейсе FastEthernet 0/0.2.
!-- Обратите внимание, какие действительные магистрали настроены на подчиненных интерфейсах.

c2600(config)#int fastEthernet 0/0.2


!-- Введите инкапсуляцию транкинга как isl

c2600(config-subif)#encapsulation isl 2


!-- или как dot1q:

c2600(config-subif)#encapsulation dot1Q 2


!-- Настройте информацию L3 на подчиненном интерфейсе 0/0.2.

c2600(config-subif)#ip address 10.10.11.1 255.255.255.0
c2600(config-subif)#exit
c2600(config)#^Z


!-- Не забудьте сохранить конфигурацию.

c2600#write memory
Building configuration...
[OK]
c2600#

Примечание: чтобы эта настройка заработала, а между рабочими станциями 1 и 2 успешно проходили ping-пакеты, следует убедиться, что шлюзы по умолчанию на обеих станциях настроены верно. Для рабочей станции 1 шлюзом по умолчанию должен быть 10.10.11.1, а для рабочей станции 2 шлюзом по умолчанию должен быть 10.10.10.1. Подробные сведения о настройке шлюзов по умолчанию на рабочих станциях см. в соответствующих разделах настоящего документа.

Примечание: следующий абзац применяется при настройке транкинга 802.1Q между маршрутизатором или коммутатором.

Примечание: если вы выполнили шаги настройки, указанные в предыдущих разделах, но пакеты ping по виртуальным локальным сетям (между рабочими станциями 1 и 2) все еще не проходят, то существует вероятность ошибки CSCds42715, при которой ключевое слово собственной виртуальной локальной сети 802.1Q некорректно работает при включенной быстрой коммутации. Исправление этой ошибки было внедрено в следующие версии кода: 12.2(0.5), 12.2(0.5)T, 12.1(5)DC, 12.1(5)YB, 12.2(0.18)S, 12.1(5)YD02, 12.2(2)B, 12.2(15)ZN. Проверить наличие и краткое описание ошибки можно с помощью средства Bug Toolkit (только для зарегистрированных пользователей), введя идентификатор ошибки CSCds42715.


--------------------------------------------------------------------------------

c2600#show running-config
Building configuration...
 
Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname c2600
!
no logging console
enable password mysecret
!
!
!
!
!
ip subnet-zero
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
!
interface FastEthernet0/0.1
 encapsulation isl 1
 ip address 10.10.10.1 255.255.255.0
 no ip redirects
!

!-- При настроенном транкинге 802.1Q
!-- вместо вышеуказанных будут отображены следующие выходные данные:
!-- under interface FastEthernet0/0.1:
!-- interface FastEthernet0/0.1
!-- encapsulation dot1Q 1 native
!-- ip address 10.10.10.1 255.255.255.0

!
!
interface FastEthernet0/0.2
 encapsulation isl 2
 ip address 10.10.11.1 255.255.255.0
 no ip redirects
!

!-- При настроенном транкинге 802.1Q
!-- вместо вышеуказанных будут отображены следующие выходные данные:
!-- under interface FastEthernet0/0.2:
!-- interface FastEthernet0/0.2
!-- encapsulation dot1Q 2
!-- ip address 10.10.11.1 255.255.255.0

!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip classless
no ip http server
!
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password mysecret
 login
!
no scheduler allocate
end

Настройка 802.1Q на маршрутизаторе для версий Cisco IOS 12.1(3)T и более ранних

Как было описано выше в этом документе, при настройке транкинга 802.1Q очень важно добиться согласования собственной виртуальной локальной сети на линии. В версиях программного обеспечения Cisco IOS младше 12.1(3)T невозможно точно указать собственную виртуальную локальную сеть, поскольку команда "encapsulation dot1Q 1 native" недоступна в подчиненном интерфейсе. В ранних версиях Cisco IOS важно настраивать интерфейс виртуальной локальной сети не как подчиненный интерфейс, который в нашем примере - VLAN1. При неправильной настройке маршрутизатор будет ожидать фрейма "tag dot1q" на VLAN1, а коммутатор не ожидает тега на VLAN1. В результате между VLAN1 на коммутаторе и маршрутизаторе не будет проходить трафик. В подобных ситуациях всегда определяйте конфигурацию собственной виртуальной локальной сети в основном интерфейсе, а при транкинге создавайте подчиненный интерфейс для всех остальных VLAN.

В текущей лабораторной установке выполните следующие действия для настройки маршрутизатора Cisco 2600:


!-- Установите привилегированный режим
!-- и пароль Telnet на маршрутизаторе.

Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname c2600
c2600(config)#enable password mysecret
c2600(config)#line vty 0 4
c2600(config-line)#login;
c2600(config-line)#password mysecret
c2600(config-line)#exit
c2600(config)#no logging console
c2600(config)#^Z

c2600#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.


!-- Выберите FastEthernet 0/0 для настройки транкинга.

c2600(config)#int fastEthernet 0/0
c2600(config-if)#no shut


!-- Обратите внимание, что IP-адрес для VLAN1 настроен в главном интерфейсе,
!-- а инкапсуляция VLAN1 в подчиненном интерфейсе не производится.

c2600(config-if)#ip address 10.10.10.1 255.255.255.0
c2600(config-if)#exit


!-- Настройте инкапсуляцию dot1q для VLAN 2
!-- на подчиненном интерфейсе fastEthernet 0/0.2.

c2600(config)#int fastEthernet 0/0.2
c2600(config-subif)#encapsulation dot1Q 2
c2600(config-subif)#


!-- Настройка информации L3 на подчиненном интерфейсе 0/0.2.

c2600(config-subif)#ip address 10.10.11.1 255.255.255.0
c2600(config-subif)#exit
c2600(config)#^Z


!-- Не забудьте сохранить конфигурацию.

c2600#write memory
Building configuration...
[OK]
c2600#

Примечание: чтобы эта настройка заработала, а между рабочими станциями 1 и 2 успешно проходили ping-пакеты, следует убедиться, что шлюзы по умолчанию на обеих станциях настроены верно. Для рабочей станции 1 шлюзом по умолчанию должен быть 10.10.11.1, а для рабочей станции 2 шлюзом по умолчанию должен быть 10.10.10.1. Для получения дополнительной информации об установке шлюзов по умолчанию на рабочих станциях обратитесь к соответствующим разделам данного документа.

c2600#show running-config
Building configuration...

Current configuration:
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname c2600
!
no logging console
enable password mysecret
!
!
!
!
!
memory-size iomem 7
ip subnet-zero
!
!
!
!
!
!
!
interface FastEthernet0/0
 ip address 10.10.10.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/0.2
 encapsulation dot1Q 2
 ip address 10.10.11.1 255.255.255.0
!
interface FastEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip classless
no ip http server
!
!
line con 0
 transport input none
line aux 0
line vty 0 4
 password mysecret
 login
!
no scheduler allocate
end

c2600#

Команды "debug" и "show"

В данном разделе содержатся сведения о проверке работы конфигурации.

Некоторые команды show поддерживаются средством Output Interpreter Tool (только для зарегистрированных пользователей), это позволяет выполнять анализ выходных данных команды show.

На коммутаторе Catalyst 2900XL/3500XL/2950 используйте следующие команды:

  • show int {FastEthernet | GigabitEthernet} <module/port> switchport

  • show vlan

  • show vtp status

На маршрутизаторе Cisco 2600 используйте следующие команды:

  • show vlan

  • show interface

Пример вывода команды "show"

Коммутатор Catalyst 3500XL

show int {FastEthernet | GigabitEthernet} <module/port> switchport

Данная команда используется для проверки административного и рабочего состояния порта. Она также используется для проверки соответствия собственной виртуальной локальной сети по обе стороны магистрали. Собственная виртуальная локальная сеть используется для передачи неразмеченного трафика, когда порт находится в режиме транкинга 802.1Q. Для получения подробных сведений о собственных виртуальных локальных сетях см. раздел "Создание и обслуживание виртуальных локальных сетей на коммутаторах Catalyst 2900XL и 3500XL".

3512xl#show int fastEthernet 0/1 switchport
Name: Fa0/1
Switchport: Enabled
Administrative mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: isl
Operational Trunking Encapsulation: isl
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1,2
Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none
Appliance trust: none

Примечание: для транкинга 802.1Q выходные данные приведенной выше команды изменяются следующим образом:

3512xl#show int fastEthernet 0/1 switchport
Name: Fa0/1
Switchport: Enabled
Administrative mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Disabled
Access Mode VLAN: 0 ((Inactive))
Trunking Native Mode VLAN: 1 (default)
Trunking VLANs Enabled: ALL
Trunking VLANs Active: 1,2
Pruning VLANs Enabled: 2-1001

Priority for untagged frames: 0
Override vlan tag priority: FALSE
Voice VLAN: none

show vlan

Эта команда используется для проверки принадлежности интерфейсов (портов) правильной виртуальной локальной сети. В приведенном примере только интерфейс Fa0/2 принадлежит VLAN2. Оставшиеся интерфейсы принадлежат VLAN1.

3512xl#show vlan
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                          active    Fa0/3, Fa0/4, Fa0/5, Fa0/6,
                                                Fa0/7, Fa0/8, Fa0/9, Fa0/10,
                                                Fa0/11, Fa0/12, Gi0/1, Gi0/2
2    VLAN0002                         active    Fa0/2
1002 fddi-default                     active    
1003 token-ring-default               active    
1004 fddinet-default                  active    
1005 trnet-default                    active    

...(output suppressed)

show vtp status

Эта команда используется для проверки конфигурации протокола VLAN trunking protocol (VTP) на коммутаторе. В нашем примере использован прозрачный режим. Правильный режим VTP зависит от топологии сети. Для получения подробных сведений о VTP см. раздел "Создание и обслуживание виртуальных локальных сетей на коммутаторах Catalyst 2900XL и 3500XL".

3512xl#show vtp status
VTP Version                     : 2
Configuration Revision          : 0
Maximum VLANs supported locally : 254
Number of existing VLANs        : 6
VTP Operating Mode              : Transparent
VTP Domain Name                 : 
VTP Pruning Mode                : Disabled
VTP V2 Mode                     : Disabled
VTP Traps Generation            : Disabled
MD5 digest                      : 0xC3 0x71 0xF9 0x77 0x2B 0xAC 0x5C 0x97
Configuration last modified by 0.0.0.0 at 0-0-00 00:00:00

Маршрутизатор Cisco 2600

show vlan

Эта команда показывает, какие сведения уровня L2 или L3 настроены для каждой VLAN.

c2600#show vlan
 
Virtual LAN ID:  1 (Inter Switch Link Encapsulation)
 
   vLAN Trunk Interface:   FastEthernet0/0.1
 
   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.10.10.1                  40                  38
 
Virtual LAN ID:  2 (Inter Switch Link Encapsulation)
 
   vLAN Trunk Interface:   FastEthernet0/0.2
 
   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.10.11.1                   9                   9

Примечание: для транкинга 802.1Q выходные данные приведенной выше команды изменяются следующим образом:

c2600#show vlan
 
Virtual LAN ID:  1 (IEEE 802.1Q Encapsulation)
 
   vLAN Trunk Interface:   FastEthernet0/0.1
 
 This is configured as native Vlan for the following interface(s): FastEthernet0/0
 
   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.10.10.1                   0                   2
 
Virtual LAN ID:  2 (IEEE 802.1Q Encapsulation)
 
   vLAN Trunk Interface:   FastEthernet0/0.2
 
   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.10.11.1                  42                  19

Примечание: для транкинга 802.1Q с версиями Cisco IOS младше 12.1(3)T выходные данные приведенной выше команды изменяются следующим образом:

c2600#show vlan

Virtual LAN ID:  2 (IEEE 802.1Q Encapsulation)

   vLAN Trunk Interface:   FastEthernet0/0.2

   Protocols Configured:   Address:              Received:        Transmitted:
           IP              10.10.11.1                   6                   4

Примечание: для любого из подчиненных интерфейсов сети VLAN1 не отображается инкапсуляция IEEE 802.1Q.

show interface

Эта команда используется для проверки административного и рабочего статуса интерфейса.

c2600#show interfaces fastEthernet 0/0
FastEthernet0/0 is up, line protocol is up
  Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ARPA, loopback not set
  Keepalive set (10 sec)
  Full-duplex, 100Mb/s, 100BaseTX/FX
  ARP type: ARPA, ARP Timeout 04:00:00
  Last input 00:00:00, output 00:00:07, output hang never
  Last clearing of "show interface" counters never
  Queueing strategy: fifo
  Output queue 0/40, 0 drops; input queue 0/75, 0 drops
  5 minute input rate 0 bits/sec, 1 packets/sec
  5 minute output rate 0 bits/sec, 0 packets/sec
     217 packets input, 12884 bytes
     Received 217 broadcasts, 0 runts, 0 giants, 0 throttles
     0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
     0 watchdog
     0 input packets with dribble condition detected
     45 packets output, 6211 bytes, 0 underruns(0/0/0)
     0 output errors, 0 collisions, 4 interface resets
     0 babbles, 0 late collision, 0 deferred
     0 lost carrier, 0 no carrier
     0 output buffer failures, 0 output buffers swapped out

c2600#show interfaces fastEthernet 0/0.1
FastEthernet0/0.1 is up, line protocol is up
  Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
  Internet address is 10.10.10.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ISL Virtual LAN, Color 1.
  ARP type: ARPA, ARP Timeout 04:00:00

c2600#show interfaces fastEthernet 0/0.2
FastEthernet0/0.2 is up, line protocol is up
  Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
  Internet address is 10.10.11.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation ISL Virtual LAN, Color 2.
  ARP type: ARPA, ARP Timeout 04:00:00

Примечание: для транкинга 802.1Q выходные данные приведенной выше команды изменяются следующим образом:

c2600#show interfaces fastEthernet 0/0.1
FastEthernet0/0.1 is up, line protocol is up
  Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
  Internet address is 10.10.10.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation 802.1Q Virtual LAN, Vlan ID  1.
  ARP type: ARPA, ARP Timeout 04:00:00

c2600#show interfaces fastEthernet 0/0.2
FastEthernet0/0.2 is up, line protocol is up
  Hardware is AmdFE, address is 0003.e36f.41e0 (bia 0003.e36f.41e0)
  Internet address is 10.10.11.1/24
  MTU 1500 bytes, BW 100000 Kbit, DLY 100 usec,
     reliability 255/255, txload 1/255, rxload 1/255
  Encapsulation 802.1Q Virtual LAN, Vlan ID  2.
  ARP type: ARPA, ARP Timeout 04:00:00

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 14976