Коммутация LAN : Коммутация и переадресация третьего уровня

Настройка маршрутизации InterVLAN с коммутаторами Catalyst серии 3750/3560/3550

23 марта 2008 - Перевод, выполненный профессиональным переводчиком
Другие версии: PDF-версия:pdf | Машинный перевод (28 июля 2013) | Английский (23 февраля 2012) | Отзыв

Содержание

Введение
Предварительные условия
      Требования
      Используемые компоненты
      Родственные продукты
      Условные обозначения
      Теоретические сведения
Настройка
      Схема сети
      Конфигурации
Проверка
Поиск и устранение неисправностей
      Процедура устранения неполадок
Связанные обсуждения сообщества поддержки Cisco
Дополнительные сведения

Введение

В данном документе описана настройка маршрутизации InterVLAN с коммутаторами Cisco Catalyst серии 3750/3560/3550. Данный документ содержит пример конфигурации для маршрутизации interVLAN с использованием коммутаторов Catalyst серии 3550 под управлением ПО EMI (расширенный многослойный образ) в обычном сетевом сценарии. В данном документе в качестве коммутирующих центров уровня 2 (L2), подключенных к Catalyst 3550, используется коммутатор Catalyst серии 2950 и коммутатор Catalyst 2948G. Конфигурация Catalyst 3550 также имеет маршрут по умолчанию для всего трафика, передаваемого в Интернет, когда следующий прыжок указывает на маршрутизатор Cisco 7200VXR. Можно заменить брандмауэр или другие маршрутизаторы маршрутизатором Cisco 7200VXR.

Предварительные условия

Требования

Чтобы использовать эту конфигурацию, необходимо:

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Catalyst 3550-48, использующий ПО Cisco IOS® 12.1(12c)EA1 EMI

  • Catalyst 2950G-48, использующий ПО Cisco IOS 12.1(12c)EA1 EI

  • Catalyst 2948G, использующий ПО Catalyst OS (CatOS) 6.3(10)

Примечание. Конфигурация из Cisco 7200VXR не имеет отношение к данному вопросу, поэтому отсутствует в данном документе.

Сведения, представленные в данном документе, были получены на тестовом оборудовании в специально созданных лабораторных условиях. При написании данного документа использовались только данные, полученные от устройств с конфигурацией по умолчанию. При работе с реально функционирующей сетью необходимо полностью осознавать возможные последствия выполнения команд до их применения.

Родственные продукты

Эта конфигурация может также использоваться со следующим оборудованием и версиями программного обеспечения:

  • любой коммутатор Catalyst 3750/3560/3550, использующий EMI или стандартный многослойный образ (SMI) ПО Cisco IOS 12.1(11)EA1 и выше

  • любой Catalyst 2900XL/3500XL/2950/3550 или модель коммутатора CatOS, используемая в качестве коммутатора уровня доступа

Условные обозначения

Дополнительные сведения об условных обозначениях см. в разделе Технические советы Cisco. Условные обозначения.

Теоретические сведения

В коммутируемой сети виртуальные локальные сети отделяют устройства в различные коллизионные домены и подсети уровня 3 (L3). Для взаимодействия одного устройства с другим внутри VLAN маршрутизация не требуется, а вот для связи устройств в разных виртуальных локальных сетях требуется устройство маршрутизации.

Коммутаторы только L2 требуют устройство маршрутизации L3. Устройство является внешним по отношению к коммутатору или находится в другом модуле этого шасси. В коммутаторах нового поколения реализована возможность маршрутизации, например модель 3550. Коммутатор получает пакет, определяет, что он принадлежит другой сети VLAN, и отправляет этот пакет соответствующему порту другой VLAN.

В типичном проекте сеть сегментируется на основе групп или функций, с которыми связано устройство. Например, в техническую сеть VLAN будут входить только те устройства, которые связаны с техническим отделом, в то время как в финансовую сеть VLAN будут входить только устройства, имеющие отношение к финансовому отделу. Если включена маршрутизация, устройства в каждой VLAN могут взаимодействовать одно с другим, даже если они находятся в разных доменах широковещательной рассылки. Такая модель VLAN имеет также дополнительное преимущество. Такая модель позволяет администратору ограничивать взаимодействие между сетями при помощи списков доступа. В примере, приведенном в данном документе, списки доступа можно использовать для ограничения доступа устройств из технической сети VLAN к устройствам VLAN финансового отдела.

Настройка

В этом разделе приводятся сведения о настройке функций, описанных в данном документе.

Примечание. Для поиска дополнительной информации о командах, упоминаемых в данном документе, используйте средство Command Lookup Tool (только для зарегистрированных клиентов).

Схема сети

В данном документе используется следующая настройка сети:

189-a.gif

На этой схеме небольшая сеть с Catalyst 3550 обеспечивает маршрутизацию InterVLAN между различными сегментами. По умолчанию коммутатор Catalyst 3550 функционирует как устройство L2 с отключенной IP маршрутизацией. Чтобы этот коммутатор функционировал как устройство L3 и обеспечивал маршрутизацию interVLAN, необходимо глобально включить IP-маршрутизацию.

Пользователем определены следующие три сети VLAN:

  • VLAN 2 – пользовательская VLAN

  • VLAN 3 – серверная VLAN

  • VLAN 10 – управленческая VLAN

Настройка шлюза по умолчанию на каждом сервере и узле должна быть IP-адресом интерфейса VLAN, который соответствует 3550. Например, для серверов шлюзом по умолчанию является 10.1.3.1. Коммутаторы уровня доступа, которыми являются Catalyst 2950 и 2948G, соединены двумя магистралями с коммутатором Catalyst 3550.

Маршрут по умолчанию для Catalyst 3550 указывает на маршрутизатор Cisco 7200VXR. Catalyst 3550 использует этот маршрут по умолчанию для передачи трафика, предназначенного для Интернета, поэтому трафик, для которого коммутатор 3550 не имеет записи в таблице маршрутизации, направляется маршрутизатору 7200VXR для обработки.

Практические советы

  • Убедитесь, что собственная виртуальная локальная сеть для магистрали 802.1q одинакова на обоих концах магистрали. Если собственная VLAN на одном конце магистрали отличается от собственной VLAN на другом конце, трафик собственных VLAN с обоих концов не удастся корректно передать по магистрали. Это может вызвать определенные проблемы с сетевыми соединениями.

  • Отделите управленческую VLAN от пользовательской или серверной VLAN, как на этой схеме. Управленческая VLAN отличается от пользовательской и серверной VLAN. Благодаря такому разделению, любые лавины пакетов/широковещательной рассылки в пользовательской или серверной VLAN не влияют на управление коммутаторами.

  • Не используйте VLAN 1 для управления. Все порты в коммутаторах Catalyst по умолчанию входят в сеть VLAN 1 и любые устройства, подключаемые к ненастроенным портам, входят в VLAN 1. Использование VLAN 1 для управления может породить потенциальные проблемы в управлении коммутаторами, как описано во втором совете.

  • Для подключения к порту шлюза по умолчанию используйте порт уровня 3 (маршрутизируемый). В этом примере маршрутизатор Cisco 7200VXR можно легко заменить брандмауэром, подключенным к шлюзовому IP-маршрутизатору.

  • Не используйте протокол маршрутизации между Catalyst 3550 и шлюзовым IP-маршрутизатором. Вместо этого в этом примере осуществляется настройка статического маршрута по умолчанию на коммутаторе 3550. Это оптимальная настройка, если существует только один маршрут подключения к Интернету. Обязательно настройте статические маршруты (желательно суммарные) на межсетевом маршрутизаторе (7200VXR) для подсетей, которые могут быть достигнуты посредством Catalyst 3550. Это действие имеет очень большое значение, поскольку эта конфигурация не использует протоколы маршрутизации.

  • Если в сети имеется два коммутатора Catalyst 3550, то можно организовать спаренное подключение коммутаторов уровня доступа к обоим коммутаторам 3550. Используйте протокол маршрутизатора горячего резервирования (HSRP) между коммутаторами, чтобы обеспечить дублирование в сети. Дополнительную информацию о настройке HSRP см. в разделе Настройка HSRP документа Настройка IP-служб.

  • Если необходима дополнительная полоса пропускания для портов каскадного соединения, можно настроить EtherChannel. Кроме того, EtherChannel обеспечивает дублирование каналов на случай выхода канала из строя.

Конфигурации

В данном документе используются следующие конфигурации:

Catalyst 3550 (Catalyst 3550-48 Switch)

Cat3550#show running-config 
Building configuration...

Current configuration : 3092 bytes
!
version 12.1
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat3550
!
!
ip subnet-zero

!--- Включите IP-маршрутизацию для маршрутизации interVLAN.

ip routing
!!
!
spanning-tree extend system-id
!
!
!
interface FastEthernet0/1
 no ip address
!

!--- Выходные данные обрезаны.

!
interface FastEthernet0/5
 description to SERVER_1

!--- Настройка порта сервера на принадлежность к серверной VLAN, VLAN 3.

switchport access vlan 3

!--- Настройка порта в качестве порта доступа для предотвращения задержек из-за согласования магистрали.

 switchport mode access
 no ip address

!--- Настройка PortFast для начальной задержки протокола связующего дерева (STP). Дополнительную информацию см. в разделе
!--- Использование команды PortFast и других команд для установки задержек связности во время запуска рабочей станции
 

spanning-tree portfast
!

!--- Выходные данные обрезаны.

!
interface FastEthernet0/48
 description To Internet_Router

!--- Порт, подключенный к маршрутизатору, преобразуется к маршрутизируемому порту (L3).

no switchport

!--- Настройка IP-адреса на этом порту. 

ip address 200.1.1.1 255.255.255.252
!
interface GigabitEthernet0/1
 description To 2950

!--- Настройка IEEE 802.1 (dot1q) группирования магистралей с согласованием на коммутаторе L2.
!--- Если на дальнем коммутаторе отсутствует протокол динамического группирования магистралей (DTP),
!--- выполните команду switchport mode trunk для принудительного перевода порта коммутатора в магистральный режим.
!--- Примечание. По умолчанию режимом группирования магистралей является автоматический динамический режим. Если устанавливается магистральный канал
!--- с режимом группирования магистралей по умолчанию, магистраль не отображается
!--- в конфигурации, даже если магистраль установлена на
!--- интерфейсе. Используйте команду show interfaces trunk, чтобы проверить 
!--- создание магистрали. 

switchport trunk encapsulation dot1q
 no ip address
!
interface GigabitEthernet0/2
 description To 2948G
 switchport trunk encapsulation dot1q
 no ip address
!
interface Vlan1
 no ip address
 shutdown
!
interface Vlan2
 description USER_VLAN

!--- Этот IP-адрес является шлюзом по умолчанию для пользователей.

 ip address 10.1.2.1 255.255.255.0
!
interface Vlan3
 description SERVER_VLAN

!--- Этот IP-адрес является шлюзом по умолчанию для серверов.

ip address 10.1.3.1 255.255.255.0
!
interface Vlan10
 description MANAGEMENT_VLAN

!--- Этот IP-адрес является шлюзом по умолчанию для других коммутаторов L2.

 ip address 10.1.10.1 255.255.255.0
!
ip classless

!--- Эта инструкция маршрутизации позволяет коммутатору 3550 отправлять Интернет-трафик
!--- маршрутизатору по умолчанию, которым, в данном случае, является 7200VXR (интерфейс Fe 0/0).

ip route 0.0.0.0 0.0.0.0 200.1.1.2
ip http server
!
!
!
line con 0
line vty 5 15
!
end

Примечание. Поскольку коммутатор 3550 настроен в качестве сервера протокола магистралей VLAN (VTP), он не отображает конфигурацию VTP. Это стандартное поведение. Чтобы создать VTP-сервер с тремя виртуальными локальными сетями, определенными пользователем из режима глобальной настройки, на этом коммутаторе используются следующие команды.

Cat3550(config)#vtp domain cisco
Cat3550(config)#vtp mode server
Cat3550(config)#vlan 2
Cat3550(config-vlan)#name USER_VLAN
Cat3550(config-vlan)#exit
Cat3550(config)#vlan 3
Cat3550(config-vlan)#name SERVER_VLAN
Cat3550(config-vlan)#exit
Cat3550(config)#vlan 10
Cat3550(config-vlan)#name MANAGEMENT

Catalyst 2950 (Catalyst 2950G-48 Switch)

Cat2950#show running-config 
Building configuration...

Current configuration : 2883 bytes
!
version 12.1
no service single-slot-reload-enable
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cat2950
!
!
ip subnet-zero
!
spanning-tree extend system-id
!
!
interface FastEthernet0/1
 no ip address
!

!--- Выходные данные обрезаны.

interface FastEthernet0/16
 no ip address
!
interface FastEthernet0/17
 description SERVER_2
 switchport access vlan 3
 switchport mode access
 no ip address
 spanning-tree portfast
!

!--- Выходные данные обрезаны.

!
interface FastEthernet0/33
 description HOST_1

!--- Настройка HOST_1 в качестве пользовательской VLAN, VLAN 2.

 
 switchport access vlan 2
 switchport mode access
 no ip address
 spanning-tree portfast
!

!--- Выходные данные обрезаны.

interface GigabitEthernet0/1
 switchport trunk encapsulation dot1q
 no ip address
!
interface GigabitEthernet0/2
 no ip address
!
interface Vlan1
 no ip address
 no ip route-cache
 shutdown
!
interface Vlan10
 description MANAGEMENT

!--- Этот IP-адрес управляет этим коммутатором. 

ip address 10.1.10.2 255.255.255.0
 no ip route-cache
!

!--- Настройте шлюз по умолчанию так, чтобы коммутатор был доступен из других
!--- сетей VLAN/подсетей. Шлюз указывает на интерфейс VLAN 10 коммутатора 3550.

ip default-gateway 10.1.10.1
ip http server
!
!
line con 0
line vty 5 15
!
end

Примечание. Поскольку Catalyst 2950 настроен в качестве VTP-клиента, коммутатор не отображает конфигурацию VTP. Это стандартное поведение. Коммутатор 2950 получает информацию VLAN от VTP-сервера, которым является коммутатор 3550. Следующие команды используются на коммутаторе 2950, чтобы сделать его VTP-клиентом в VTP-домене cisco из режима глобальной настройки:

Cat2950(config)#vtp domain cisco
Cat2950(config)#vtp mode client

Catalyst 2948G Switch

Cat2948G> (enable) show config 
This command shows non-default configurations only.
Use 'show config all' to show both default and non-default configurations.
...........

..................
..

begin
!
# ***** NON-DEFAULT CONFIGURATION *****
!
!
#time: Fri Jun 30 1995, 05:04:47 
!
#version 6.3(10)
!
!
#system web interface version(s)
!
#test
!
#system
set system name  Cat2948G
!       
#frame distribution method
set port channel all distribution mac both
!
#vtp

!--- Настройте домен VTP так, чтобы он совпадал с 3550 (VTP-сервер).

set vtp domain cisco

!--- Выберите режим VTP в качестве клиента для этого коммутатора.

set vtp mode client
!
#ip

!--- Настройте IP-адреса управления в VLAN 10.

set interface sc0 10 10.1.10.3/255.255.255.0 10.1.10.255

set interface sl0 down
set interface me1 down

!--- Определите маршрут по умолчанию, чтобы коммутатор был доступен.

set ip route 0.0.0.0/0.0.0.0         10.1.10.1      
!
#set boot command
set boot config-register 0x2
set boot system flash bootflash:cat4000.6-3-10.bin
!
#module 1 : 0-port Switching Supervisor
!
#module 2 : 50-port 10/100/1000 Ethernet

!--- Настройте порты HOST_2 и SERVER_3 в соответствующих VLAN.

set vlan 2    2/2
set vlan 3    2/23
set port name       2/2  To HOST_2
set port name       2/23 to SERVER_3

!--- Настройте магистраль к 3550 с инкапсуляцией dot1q.

set trunk 2/49 desirable dot1q 1-1005
end

Проверка

В данном разделе содержатся сведения о проверке работы конфигурации.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Используйте OIT для просмотра аналитики выходных данных команды show.

Catalyst 3550

  • show vtp status

    Cat3550#show vtp status 
    VTP Version                     : 2
    Configuration Revision          : 3
    Maximum VLANs supported locally : 1005
    Number of existing VLANs        : 8
    VTP Operating Mode              : Server
    VTP Domain Name                 : cisco
    VTP Pruning Mode                : Disabled
    VTP V2 Mode                     : Disabled
    VTP Traps Generation            : Disabled
    MD5 digest                      : 0x54 0xC0 0x4A 0xCE 0x47 0x25 0x0B 0x49 
    Configuration last modified by 200.1.1.1 at 3-1-93 01:06:24
    Local updater ID is 10.1.2.1 on interface Vl2 (lowest numbered VLAN interface found)
  • show interfaces trunk

    Cat3550#show interfaces trunk 
    
    Port      Mode         Encapsulation  Status        Native vlan
    Gi0/1     desirable    802.1q         trunking      1
    Gi0/2     desirable    802.1q         trunking      1
    
    Port      Vlans allowed on trunk
    Gi0/1     1-4094
    Gi0/2     1-4094
    
    Port      Vlans allowed and active in management domain
    Gi0/1     1-3,10
    Gi0/2     1-3,10
    
    Port      Vlans in spanning tree forwarding state and not pruned
    
    Gi0/1     1-3,10
    Gi0/2     1-3,10
    
  • show ip route

    Cat3550#show ip route
    Codes: C - connected, S - static, I - IGRP, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
           i - IS-IS, L1 - IS-IS level-1, L2 - IS-IS level-2, ia - IS-IS inter area
           * - candidate default, U - per-user static route, o - ODR
           P - periodic downloaded static route
    
    Gateway of last resort is 200.1.1.2 to network 0.0.0.0
    
         200.1.1.0/30 is subnetted, 1 subnets
    C       200.1.1.0 is directly connected, FastEthernet0/48
         10.0.0.0/24 is subnetted, 3 subnets
    C       10.1.10.0 is directly connected, Vlan10
    C       10.1.3.0 is directly connected, Vlan3
    C       10.1.2.0 is directly connected, Vlan2
    S*   0.0.0.0/0 [1/0] via 200.1.1.2
    

Catalyst 2950

  • show vtp status

    Cat2950#show vtp status 
    VTP Version                     : 2
    Configuration Revision          : 3
    Maximum VLANs supported locally : 250
    Number of existing VLANs        : 8
    VTP Operating Mode              : Client
    VTP Domain Name                 : cisco
    VTP Pruning Mode                : Disabled
    VTP V2 Mode                     : Disabled
    VTP Traps Generation            : Disabled
    MD5 digest                      : 0x54 0xC0 0x4A 0xCE 0x47 0x25 0x0B 0x49 
    Configuration last modified by 200.1.1.1 at 3-1-93 01:06:24
    
  • show interfaces trunk

    Cat2950#show interfaces trunk  
    
    Port      Mode         Encapsulation  Status        Native vlan
    Gi0/1     desirable    802.1q         trunking      1
    
    Port      Vlans allowed on trunk
    Gi0/1     1-4094
    
    Port      Vlans allowed and active in management domain
    Gi0/1     1-3,10
    
    Port      Vlans in spanning tree forwarding state and not pruned
    Gi0/1     1-3,10
    

Catalyst 2948G

  • show vtp domain

    Cat2948G> (enable) show vtp domain 
    Domain Name                      Domain Index VTP Version Local Mode  Password
    -------------------------------- ------------ ----------- ----------- ----------
    cisco                            1            2           client      -
    
    Vlan-count Max-vlan-storage Config Revision Notifications
    ---------- ---------------- --------------- -------------
    8          1023             3               disabled
    
    Last Updater    V2 Mode  Pruning  PruneEligible on Vlans
    --------------- -------- -------- -------------------------
    200.1.1.1       disabled disabled 2-1000
  • show trunk

    Cat2948G> (enable) show trunk 
    * - indicates vtp domain mismatch
    Port      Mode         Encapsulation  Status        Native vlan
    --------  -----------  -------------  ------------  -----------
     2/49     desirable    dot1q          trunking      1
    
    Port      Vlans allowed on trunk
    --------  ---------------------------------------------------------------------
     2/49     1-1005
    
    Port      Vlans allowed and active in management domain 
    --------  ---------------------------------------------------------------------
     2/49     1-3,10
    
    Port      Vlans in spanning tree forwarding state and not pruned
    --------  ---------------------------------------------------------------------
     2/49     1-3,10
    

Поиск и устранение неисправностей

Используйте этот раздел для устранения неполадок своей конфигурации.

Процедура устранения неполадок

Следуйте приведенным ниже инструкциям:

  1. Если нельзя провести эхо-тестирование между двумя устройствами в одной и той же сети VLAN, проверьте распределение портов источника и назначения, чтобы убедиться, что они находятся в одной сети VLAN.

    Чтобы проверить назначение VLAN, выполните команду show port mod/port для CatOS или команду show interface status для ПО Cisco IOS.

    Если порты источника и назначения находятся на разных коммутаторах, убедитесь, что магистральная линия правильно настроена. Чтобы проверить конфигурацию, выполните команду show trunk для CatOS или команду show interfaces trunk для ПО Cisco IOS. Кроме того, проверьте сопоставления собственной VLAN на каждой стороне. Убедитесь, что маски подсети исходного и конечного устройств совпадают.

  2. Если не удается выполнить эхо-тестирование устройств в разных сетях VLAN, убедитесь, что запрос доходит до соответствующего шлюза по умолчанию.

    Примечание. См. п. 1.

    Кроме того, следует убедиться, что шлюз по умолчанию ссылается на правильный IP-адрес интерфейса VLAN и что маски подсети совпадают.

  3. Если не удается подключиться к Интернету, убедитесь, что маршрут по умолчанию на коммутаторе 3550 указывает на правильный IP-адрес, а адрес подсети совпадает с межсетевым Интернет маршрутизатором.

    Чтобы проверить выполните команду show ip interface interface-id и команду show ip route. Убедитесь, что межсетевой Интернет маршрутизатор имеет маршруты для подключения к Интернету и внутренним сетям.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 41260