Коммутаторы : Cisco Nexus 9000 Series Switches

Настройте и проверьте максимальный размер передаваемого блока данных на платформах Cisco Nexus

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Отзыв

Введение

Этот документ описывает, как настроить и проверить максимальный размер передаваемого блока данных (MTU) на коммутаторах Cisco Nexus.

Внесенный Амандой Хант, специалистом службы технической поддержки Cisco.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Настройка

Конфигурации MTU Уровня 3

MTU на конфигурации коммутируемого виртуального интерфейса (SVI)

Switch(config)#interface vlan 1
Switch(config-if)#mtu 9216

MTU на конфигурации порта Уровня 3

Switch(config)#interface ethernet 1/1
Switch(config-if)#no switchport
Switch(config-if)#mtu 9216

Конфигурации MTU Уровня 2

MTU Уровня 2 может быть установлен или через сетевую политику QoS или путем настройки самого порта на коммутаторах та поддержка для каждого порта MTU. Только Nexus 3048, 3064, 7000, 7700, 9000, и 9300 поддержки для каждого порта MTU.

Nexus 3100, 3500, 5000, 5500, и 6000 конфигураций

Для настройки поднятого MTU на Nexus 3100, 3500, 5000, 5500, и 6000 switchess, создайте сетевую политику качества обслуживания или модифицируйте существующую политику для определения поднятого MTU. Эта конфигурация применяется ко всем портам. Это включает любой Модуль ввода-вывода Cisco (FEX) порты, связанные с коммутатором. Для каждого порта MTU не поддерживается.

policy-map type network-qos jumbo
class type network-qos class-default
mtu 9216
system qos
service-policy type network-qos jumbo

Nexus 3048, 3064, 7000, 7700, 9000, и 9300 конфигураций

Для настройки MTU на для каждого порта основание, эта конфигурация необходима:

Switch(config)#interface ethernet 1/1
Switch(config-if)#mtu 9216

Конфигурация Nexus 7000

При настройке MTU FEX более обширная политика QoS необходима в версии 6.2 и позже:

Switch(conf)#class-map type network-qos match-any c-nq-8e-custom
(config-cmap-nqos)#match cos 0-7

Примечание: Если вы не уверены, которые обрабатывают по шаблону, чтобы использовать, ввести системную команду сетевого qos типа policy-map показа для наблюдения в настоящее время используемого шаблона.

Switch(config)#policy-map type network-qos nq-8e-custom template 8e    
Switch(config-pmap-nqos)#class type network-qos c-nq-8e-custom
Switch(config-pmap-nqos-c)#congestion-control tail-drop
Switch(config-pmap-nqos-c)#mtu 9216

Switch(config)#system qos
Switch(config-sys-qos)#service-policy type network-qos nq-8e-custom

Конфигурация Nexus 2000 года

Примечание: Nexus 2000 метрических тонн установлен с конфигурацией кадров большого размера на родительском коммутаторе. Для родительских коммутаторов, которые позволяют jumbo-кадр на для каждого порта основание, настройте Оптоволоконный port-channel (FPC) FEX. Если родительский коммутатор требует сетевой политики качества обслуживания тогда, jumbo-кадр установлен с конфигурацией политики QoS родительского коммутатора. Эти изменения автоматически оттолкнуты к FEX в обоих случаях.

Канал порта матрицы (FPC) на родителе конфигурация коммутатора Nexus

interface port-channel136
switchport mode fex-fabric
fex associate 136
vpc 136
mtu 9216

Примечание: Nexus 7000 не позволяет вам устанавливать MTU FEX с FPC в версии 6.2 и позже. Необходимо вместо этого создать пользовательскую политику QoS, поскольку следующая конфигурация показывает.

Позвольте кадры большого размера в конфигурации Nexus 7000 FEX

Примечание: Модифицируйте использующийся в настоящее время шаблон. Для обнаружения текущего шаблона в использовании введите системную команду сетевого qos типа policy-map показа.

Switch(conf)#class-map type network-qos match-any c-nq-8e-custom 
(config-cmap-nqos)#match cos 0-7

Switch(config)#policy-map type network-qos nq-8e-custom template 8e
Switch(config-pmap-nqos)#class type network-qos c-nq-8e-custom
Switch(config-pmap-nqos-c)#congestion-control tail-drop
Switch(config-pmap-nqos-c)#mtu 9216

Switch(config)#system qos
Switch(config-sys-qos)#service-policy type network-qos nq-8e-custom

Сетевая политика QoS на родителе конфигурация коммутатора Nexus

policy-map type network-qos jumbo
class type network-qos class-default
mtu 9216
system qos
service-policy type network-qos jumbo

Проверка.

Воспользуйтесь данным разделом для проверки правильности функционирования вашей конфигурации.

Средство интерпретации выходных данных (только зарегистрированные клиенты) поддерживает некоторые команды show. Используйте Средство интерпретации выходных данных, чтобы просмотреть анализ выходных данных команды show.

MTU Уровня 3

Проверьте MTU Уровня 3 на всех платформах Nexus с show interface eth x/y команда как показано в примере:

Nexus#show interface ethernet 1/19
Ethernet1/19 is up
Dedicated Interface
Hardware: 100/1000/10000 Ethernet, address: 547f.ee5d.413c (bia 547f.ee5d.40fa)
MTU 9216 bytes, BW 1000000 Kbit, DLY 10 usec

Проверьте MTU SVI с show interface vlan X команд как показано в выходных данных ниже:

Leaf3#show interface vlan 1
Vlan1 is down (Non-routable VDC mode), line protocol is down
Hardware is EtherSVI, address is 547f.eed8.ec7c
Internet Address is 1.1.1.1/23
MTU 9216 bytes, BW 1000000 Kbit, DLY 10 usec

MTU Уровня 2

В этом разделе описывается проверить метрическую тонну Уровня 2 на платформу. Команды выполнены от родительского коммутатора.

Nexus 3100, 3500, 5000, 5500, и 6000

Nexus#show queuing interface ethernet 1/1
Ethernet1/1 queuing information:
TX Queuing
qos-group sched-type oper-bandwidth
0 WRR 100
RX Queuing
qos-group 0
q-size: 469760, HW MTU: 9216 (9216 configured)

Nexus 3000, 7000, 7700, 9000

Nexus#show interface ethernet 1/12
Ethernet1/12 is up
admin state is up, Dedicated Interface
Hardware: 1000/10000 Ethernet, address: 7c0e.ceca.f183 (bia 7c0e.ceca.f183)
MTU 9216 bytes, BW 10000000 Kbit, DLY 10 usec

Nexus 2000

Примечание: При изменении MTU FEX FEX увеличивает свой MTU до более высокой, но предопределенной суммы, которая не совпадает с установленным значением точно. Родительское устройство принуждает настроенный MTU в Оптоволоконном port-channel (FPC) FEX.

Для FEX, связанного с Nexus 5000, 6000, и 7000:

Nexus#show queuing interface ethernet 136/1/1
if_slot 68, ifidx 0x1f870000
Ethernet136/1/1 queuing information:
Input buffer allocation:
Qos-group: 0
frh: 3
drop-type: drop
cos: 0 1 2 3 4 5 6 7
xon xoff buffer-size
---------+---------+-----------
19200 78080 90880

Queueing:
queue qos-group cos priority bandwidth mtu
--------+------------+--------------------+---------+----------------+--------
3 0 0 1 2 3 4 5 6 WRR 100 9280

Для FEX, связанного с Nexus 9000:

9396-B#show interface ethernet 104/1/1
Ethernet104/1/1 is up
admin state is up,
Hardware: 100/1000 Ethernet, address: 5475.d0e0.e5c2 (bia 5475.d0e0.e5c2)
MTU 9216 bytes, BW 1000000 Kbit, DLY 10 usec

Устранение неполадок

Этот раздел обеспечивает информацию, которую вы можете использовать для того, чтобы устранить неисправность в вашей конфигурации.

Средство интерпретации выходных данных (только зарегистрированные клиенты) поддерживает некоторые команды show. Используйте Средство интерпретации выходных данных, чтобы просмотреть анализ выходных данных команды show.

Примечание: Прежде чем выполнять какие-либо команды отладки , ознакомьтесь с документом "Важные сведения о командах отладки".

Иногда необходимо проверить изменения в программном обеспечении. Чтобы сделать это, проверьте менеджера Порта Ethernet (ethpm), чтобы проверить, что изменения были выдвинуты через программное обеспечение на любой платформе:

Switch#show system internal ethpm info interface eth 6/5 | egrep -i mtu
medium(broadcast), snmp trap(on), MTU(4000)

Также возможно на M1, M2, F1 и модулях F2 проверить в аппаратных средствах, что были оттолкнуты изменения:

module-1#show hardware internal mac port 20 state | i MTU
GD: Port speed Undecided GD MTU 10240 (fixed to max), PL MTU 9238 mode 0

Известные дефекты

Идентификатор ошибки Cisco CSCuf20035 - (Nexus 7000) изменения MTU FEX не вступает в силу на очередях FEX.


Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.