Многопротокольная коммутация по меткам (MPLS) : Многопротокольная коммутация по меткам (MPLS)

Настройте унифицированный MPLS в Cisco IOS XR

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (21 апреля 2016) | Отзыв

Введение

Этот документ описывает цель Унифицированной Многопротокольной коммутации по меткам (MPLS) и предоставляет пример конфигурации в Cisco IOS® XR.

Внесенный Люком Де Гееном, специалистом службы технической поддержки Cisco.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Этот документ является определенным для Cisco IOS XR, но это не ограничено определенным выпуском ПО или аппаратными средствами.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Общие сведения

Цель Унифицированного MPLS - все о масштабировании. Для масштабирования сети MPLS, где существуют различные типы платформ и сервисов в частях сети, они целесообразны разделять сеть на различные области. Типичный дизайн представляет иерархию, которая имеет ядро в центре с агрегацией на стороне. Для масштабирования могут быть другие Протоколы внутреннего шлюза (IGPs) в ядре по сравнению с агрегацией. Для масштабирования вы не можете распределить префиксы IGP от одного IGP в другой. Если вы не распределяете префиксы IGP от одного IGP в другой IGP, сквозные Пути коммутации меток (LSP) не возможны.

Для предоставления услуг MPLS от начала до конца, вам нужен LSP, чтобы быть сквозными. Цель состоит в том, чтобы поддержать сервисы MPLS (MPLS VPN, L2VPN MPLS), как они, но представляют большую масштабируемость. Чтобы сделать это, переместите некоторые префиксы IGP в Протокол BGP (петлевые префиксы маршрутизаторов Границы провайдера (PE)), который тогда распределяет префиксы от начала до конца.

Настройка

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

Рисунок 1 показывает сеть с тремя различными областями: одно ядро и две области агрегации на стороне. Каждая область выполняет свой собственный IGP без перераспределения между ними на Пограничном маршрутизаторе области (ABR). Использование BGP необходимо для обеспечения сквозного LSP MPLS. BGP объявляет loopback Периферийных маршрутизаторов с меткой через весь домен и предоставляет сквозной LSP. BGP развернут между PE и ABR с RFC 3107 (BGP Маркированная Индивидуальная рассылка), что означает, что BGP передает префикс IPv4 + метка (Идентификатор семейства адресов (AFI) 1 и Последующий идентификатор семейства адресов (SAFI) 4).

Рисунок 1

Так как ядро и части агрегации сети интегрированы, и сквозные LSP предоставлены, Унифицированное решение MPLS также упоминается как "Бесшовный MPLS".

Новые технологии или протоколы не используются здесь, только MPLS, Протокол распределения меток (LDP), IGP и BGP. Так как вы не хотите распределять петлевые префиксы Периферийных маршрутизаторов от одной части сети в другую часть, необходимо нести префиксы в BGP. Внутренний протокол граничного шлюза (iBGP) используется в одной сети, таким образом, адрес следующего узла префиксов является петлевыми префиксами Периферийных маршрутизаторов, который не известен IGP в других частях сети. Это означает, что адрес следующего узла не может использоваться для рекурсивного вызова к префиксу IGP. Прием должен сделать Рефлекторы маршрута (RR) маршрутизаторов ABR и установить следующий переход в сам, даже для отраженных префиксов iBGP.

Только RRs нужно программное обеспечение для поддержки этой архитектуры. Так как RRs объявляют префиксы BGP с набором следующего перехода себе, они назначают локального MPLS label на префиксы BGP. Это означает, что в плоскости данных, пакеты, переданные на этих сквозных LSP, имеют дополнительного MPLS label в стеке меток. RRs находятся в пути переадресации.

Примечание: По этой архитектуре предоставлен любой сервис MPLS. Например, сервисный L2VPN MPLS VPN или MPLS предоставлен между Периферийными маршрутизаторами. Различие в плоскости данных для этих пакетов - то, что у них теперь есть три метки в стеке меток, тогда как у них было две метки в стеке меток, когда не использовался Унифицированный MPLS.

Существует два возможных сценария:

  • ABR делает "not set" следующий переход к сам для объявленных префиксов (отраженный BGP) ABR в часть агрегации сети. Из-за этого ABR должен перераспределить петлевые префиксы ABR от базового IGP в IGP агрегации. Если это сделано, существует все еще масштабируемость. Только петлевые префиксы ABR (от ядра) должны быть объявлены в часть агрегации, не петлевые префиксы от Периферийных маршрутизаторов от удаленных частей агрегации.
  • ABR устанавливает следующий переход в сам для объявленных префиксов (отраженный BGP) ABR в часть агрегации. Из-за этого ABR не должен перераспределять петлевые префиксы ABR от базового IGP в IGP агрегации.

В обоих сценариях ABR устанавливает следующий переход в сам для объявленных префиксов (отраженный BGP) ABR от части агрегации сети в базовую часть. Если это не сделано, ABR должен перераспределить петлевые префиксы PE от IGP агрегации в базовый IGP. Если это сделано, нет никакой масштабируемости.

Для установки следующего перехода в сам для отраженного iBGP Маркированные Маршруты одноадресной передачи, необходимо настроить Язык политики маршрутизации (RPL) на ABR.

Эти решения не работают чтобы к RFC enable 3107 в Cisco IOS XR:

  • next-hop-self не работает.

    Пример:

    router bgp 1
     neighbor 10.100.1.1
     remote-as 1
     update-source Loopback0
     address-family ipv4 labeled-unicast
      route-reflector-client
       next-hop-self
     !
  • RPL с set next-hop сам не работает.

    Пример:

    router bgp 1
     neighbor 10.100.1.1
     remote-as 1
     update-source Loopback0
     address-family ipv4 labeled-unicast
      route-reflector-client
      route-policy nhs-ibgp-3107 out
      !

    route-policy nhs-ibgp-3107
     set next-hop self
    end-policy
  • set next-hop к адресу партнера (peer) не является действительным оператором для точки присоединения.

    Пример:

    route-policy nhs-ibgp-3107-peer
     set next-hop peer-address
    end-policy

    router bgp 1
     neighbor 10.100.1.1
     address-family ipv4 labeled-unicast
      route-policy nhs-ibgp-3107-peer out

    !!% Could not find entry in list: Policy [nhs-ibgp-3107-peer]
    uses 'set-to-peer-address next-hop'. 'set' is not a valid
    operator for the 'next-hop' attribute at the bgp neighbor-out-dflt attach point.
     !
     !
    !
    end

Единственное решение, которое работы должны установить адрес следующего маршрутизатора в действительный IP - адрес, имеет следующий переход - сам и имеет ibgp политику принуждать-модификации.

Пример:

router bgp 1
 ibgp policy out enforce-modifications
!
neighbor 10.100.1.1
 remote-as 1
 update-source Loopback0
 address-family ipv4 labeled-unicast
  route-reflector-client
  route-policy nhs-ibgp-3107 out
  next-hop-self
 !
 !
!

route-policy nhs-ibgp-3107
 set next-hop 10.100.1.3
end-policy

Конфигурация на PE1

hostname PE1
!
vrf one    <<< MPLS service is MPLS VPN
 address-family ipv4 unicast
 import route-target
  1:1
 !
 export route-target
  1:1
 !
 !
 address-family ipv6 unicast
 import route-target
  1:1
 !
 export route-target
  1:1
 !
 !
interface Loopback0
 ipv4 address 10.100.1.1 255.255.255.255
!
!
interface GigabitEthernet0/0/0/0
 ipv4 address 10.1.1.1 255.255.255.0
!
!
interface GigabitEthernet0/0/0/1  <<< VRF interface to CE1
 vrf one
 ipv4 address 10.9.1.3 255.255.255.0
!
!
router ospf 1
 router-id 10.100.1.1
 area 0
 interface Loopback0
 !
 interface GigabitEthernet0/0/0/0
  network point-to-point
 !
 !
!
router bgp 1
 address-family ipv4 unicast
 network 10.100.1.1/32   <<< advertise PE loopback in BGP
 allocate-label all
 !
 address-family vpnv4 unicast
 !
 neighbor 10.100.1.3
 remote-as 1
 update-source Loopback0
 address-family ipv4 labeled-unicast
 !
 !
 neighbor 10.100.1.7    <<< vpnv4 iBGP session to PE2
 remote-as 1
 update-source Loopback0
 address-family vpnv4 unicast
 !
 !
 vrf one
 rd 1:1
 address-family ipv4 unicast
 !
 neighbor 10.9.1.2   <<< eBGP session to CE1
  remote-as 65001
  address-family ipv4 unicast
   route-policy pass in
   route-policy pass out
  !
 !
 !
!
mpls ldp
 mldp
 logging notifications
 address-family ipv4
 !
 !
 router-id 10.100.1.1
 address-family ipv4
 !
 interface GigabitEthernet0/0/0/0
 address-family ipv4
 !
 !
!

Конфигурация на ABR1

hostname ABR1
!
interface Loopback0
 ipv4 address 10.100.1.3 255.255.255.255
!
!
interface GigabitEthernet0/0/0/0
 ipv4 address 10.1.3.3 255.255.255.0
!
interface GigabitEthernet0/0/0/1
 ipv4 address 10.1.2.3 255.255.255.0
!
route-policy nhs-ibgp-3107
 set next-hop 10.100.1.3   <<< set next hop to loopback
end-policy
!
route-policy connected-into-ospf2
 if destination in (10.100.1.3/32) then
   pass
 endif
end-policy
!
router ospf 1
 router-id 10.100.1.3
 area 0
 interface Loopback0
 !
 interface GigabitEthernet0/0/0/1
  network point-to-point
 !
 !
!
router ospf 2
 redistribute connected route-policy connected-into-ospf2
 area 0
 interface GigabitEthernet0/0/0/0
  network point-to-point
 !
 !
!
router bgp 1
 ibgp policy out enforce-modifications
 address-family ipv4 unicast
 allocate-label all
 !
 neighbor 10.100.1.1    <<< iBGP neighbor PE1
 remote-as 1
 update-source Loopback0
 address-family ipv4 labeled-unicast
  route-reflector-client
  route-policy nhs-ibgp-3107 out
  next-hop-self
 !
 !
 neighbor 10.100.1.5     <<< iBGP neighbor ABR2
 remote-as 1
 update-source Loopback0
 address-family ipv4 labeled-unicast
  route-policy nhs-ibgp-3107 out
  next-hop-self
 !
 !
!
mpls ldp
 mldp
 address-family ipv4
 !
 !
 router-id 10.100.1.3
 interface GigabitEthernet0/0/0/0
 address-family ipv4
  discovery transport-address interface
 !
 !
 interface GigabitEthernet0/0/0/1
 address-family ipv4
 !
 !

Примечание: allocate-label все или политика маршрутизации allocate-label необходимы. В противном случае маркированные маршруты одноадресной передачи не имеют локальной метки, в которой они нуждаются, так как ABR является следующим переходом для отраженных маршрутов iBGP.

Примечание: Перераспределение базового IGP (OSPF 2) в IGP агрегации (OSPF 1 или OSPF 3) или наоборот не выполнено. Однако петлевой префикс RR должен быть известен в IGP агрегации также, так, чтобы BGP на Периферийном маршрутизаторе мог взаимодействовать с loopback ABR/RR. Для этого перераспределение связанных маршрутов в IGP агрегации выполнено с RPL. Перераспределенные связанные маршруты ограничены петлевым префиксом ABR с RPL.

Проверка

Средство интерпретации выходных данных (только зарегистрированные клиенты) поддерживает некоторые команды show. Используйте Средство интерпретации выходных данных, чтобы просмотреть анализ выходных данных команды show.

Посмотрите рисунок 2 для проверки операции уровня управления:

Рис. 2

Посмотрите рисунок 3 для проверки рекламных объявлений MPLS label:

Рис. 3

Посмотрите рисунок 4 чтобы к сверению пересылки пакетов:

Рис. 4

Это - то, как пакеты переданы от PE1 до PE2. Петлевой префикс PE2 является 10.100.1.7/32, так, чтобы префикс представлял интерес.

RP/0/0/CPU0:PE1#traceroute                                 
Protocol [ipv4]:
Target IP address: 10.100.1.7
Source address: 10.100.1.1
Numeric display? [no]:
Timeout in seconds [3]:
Probe count [3]:
Minimum Time to Live [1]:
Maximum Time to Live [30]:
Port Number [33434]:
Loose, Strict, Record, Timestamp, Verbose[none]:

Type escape sequence to abort.
Tracing the route to 10.100.1.7

 1 10.1.1.2 [MPLS: Labels 24000/24005 Exp 0] 439 msec 119 msec 109 msec
 2 10.1.2.3 [MPLS: Label 24005 Exp 0] 109 msec 109 msec 109 msec
 3 10.1.3.4 [MPLS: Labels 24001/24003 Exp 0] 99 msec 99 msec 149 msec
 4 10.1.4.5 [MPLS: Label 24003 Exp 0] 119 msec 119 msec 99 msec
 5 10.1.5.6 [MPLS: Label 24001 Exp 0] 109 msec 139 msec 99 msec
 6 10.1.6.7 109 msec * 109 msec

Метка 24000 является меткой LDP, изученной из P2 для префикса 10.100.1.3/32. Метка 24005 является меткой BGP RFC 3107, изученной для префикса 10.100.1.7/32.

RP/0/0/CPU0:PE1#show route 10.100.1.7/32

Routing entry for 10.100.1.7/32
 Known via "bgp 1", distance 200, metric 0, [ei]-bgp, type internal
 BIER rid=0x0, flags=0x0, count=0
 Installed May 27 02:52:07.184 for 00:08:52
 Routing Descriptor Blocks
   10.100.1.3, from 10.100.1.3 <<< next-hop is ABR1
     Route metric is 0
 No advertising protos.
RP/0/0/CPU0:PE1#show cef 10.100.1.7/32  
10.100.1.7/32, version 89, internal 0x1000001 0x0 (ptr 0xa1470f74)
[1], 0x0 (0xa1456614), 0xa08 (0xa16181e0)
 Updated May 27 02:52:07.203
 Prefix Len 32, traffic index 0, precedence n/a, priority 4
  via 10.100.1.3, 3 dependencies, recursive [flags 0x6000]
   path-idx 0 NHID 0x0 [0xa16806f4 0x0]
   recursion-via-/32
   next hop 10.100.1.3 via 24001/0/21
    local label 24003
    next hop 10.1.1.2/32 Gi0/0/0/0   labels imposed {24000 24005}
RP/0/0/CPU0:PE1#show bgp ipv4 unicast labels 
BGP router identifier 10.100.1.1, local AS number 1
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000  RD version: 44
BGP main routing table version 44
BGP NSR Initial initsync version 2 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
             i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
  Network           Next Hop       Rcvd Label     Local Label
*> 10.100.1.1/32     0.0.0.0        nolabel        3              
*>i10.100.1.7/32     10.100.1.3     24005          24003          

Processed 2 prefixes, 2 paths

Существует вытеснение предпоследней пересылки (PHP) к ABR1.

RP/0/0/CPU0:P2#show mpls forwarding labels 24000
Local Outgoing   Prefix            Outgoing    Next Hop       Bytes      
Label Label      or ID             Interface                   Switched   
------ ----------- ------------------ ------------ --------------- ------------
24000 Pop        10.100.1.3/32     Gi0/0/0/1   10.1.2.3       694765     

Метка 24005 подкачана с меткой 24003 на ABR1.

RP/0/0/CPU0:ABR1#show bgp ipv4 unicast labels 
BGP router identifier 10.100.1.3, local AS number 1
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000  RD version: 60
BGP main routing table version 60
BGP NSR Initial initsync version 2 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
             i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
  Network           Next Hop       Rcvd Label     Local Label
*>i10.100.1.1/32     10.100.1.1     3              24003          
*>i10.100.1.7/32     10.100.1.5     24003          24005          

Processed 2 prefixes, 2 paths
RP/0/0/CPU0:ABR1#show mpls forwarding labels 24005
Wed May 27 04:08:24.255 UTC
Local Outgoing   Prefix            Outgoing    Next Hop       Bytes      
Label Label      or ID             Interface                   Switched   
------ ----------- ------------------ ------------ --------------- ------------
24005 24003      10.100.1.7/32                  10.100.1.5     6347       

Существует PHP от P1 до ABR2.

RP/0/0/CPU0:P1#show mpls forwarding labels 24001
Local Outgoing   Prefix            Outgoing    Next Hop       Bytes      
Label Label      or ID             Interface                   Switched   
------ ----------- ------------------ ------------ --------------- ------------
24001 Pop        10.100.1.5/32     Gi0/0/0/1   10.1.4.5       348835     

Метка BGP для маршрута 10.100.1.7/32 RFC 3107 receivd ABR2 от PE2 равняется 3. Это - неявная пустая метка, которая указывает на PHP.

RP/0/0/CPU0:ABR2#show bgp ipv4 unicast labels 
BGP router identifier 10.100.1.5, local AS number 1
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000  RD version: 47
BGP main routing table version 47
BGP NSR Initial initsync version 2 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
             i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
  Network           Next Hop       Rcvd Label     Local Label
*>i10.100.1.1/32     10.100.1.3     24003          24005          
*>i10.100.1.7/32     10.100.1.7     3              24003          

Processed 2 prefixes, 2 paths

Метка 24003 подкачана с меткой 24001 на ABR2.

RP/0/0/CPU0:ABR2#show mpls forwarding labels 24003
Local Outgoing   Prefix            Outgoing    Next Hop       Bytes      
Label Label      or ID             Interface                   Switched   
------ ----------- ------------------ ------------ --------------- ------------
24003 24001      10.100.1.7/32     Gi0/0/0/0   10.1.5.6       403676     

Существует PHP от P3 до PE2.

RP/0/0/CPU0:P3#show mpls forwarding labels 24001
Local Outgoing   Prefix            Outgoing    Next Hop       Bytes      
Label Label      or ID             Interface                   Switched   
------ ----------- ------------------ ------------ --------------- ------------
24001 Pop        10.100.1.7/32     Gi0/0/0/1   10.1.6.7       685191     
RP/0/0/CPU0:PE2#show bgp ipv4 unicast labels 
BGP router identifier 10.100.1.7, local AS number 1
BGP generic scan interval 60 secs
Non-stop routing is enabled
BGP table state: Active
Table ID: 0xe0000000  RD version: 42
BGP main routing table version 42
BGP NSR Initial initsync version 2 (Reached)
BGP NSR/ISSU Sync-Group versions 0/0
BGP scan interval 60 secs

Status codes: s suppressed, d damped, h history, * valid, > best
             i - internal, r RIB-failure, S stale, N Nexthop-discard
Origin codes: i - IGP, e - EGP, ? - incomplete
  Network           Next Hop       Rcvd Label     Local Label
*>i10.100.1.1/32     10.100.1.5     24005          24004          
*> 10.100.1.7/32     0.0.0.0        nolabel                     

Processed 2 prefixes, 2 paths

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.

Дополнительные сведения



Document ID: 119191