Коммутаторы : Коммутаторы Cisco Nexus серии 7000

Пример конфигурации RSPAN коммутатора Cisco Nexus серии 7000

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ описывает, как настроить удаленный коммутируемый анализатор для портов (RSPAN) сеанс на Коммутаторе Cisco Nexus серии 7000, который контролирует трафик между Портами Ethernet на двух других Коммутаторах Cisco Nexus серии 7000.

Предварительные условия

Требования

Рассматриваемая процедура настройки предполагает выполнение следующих условий:

  • Имейте базовые знания о конфигурации на Коммутаторах Cisco Nexus серии 7000

  • Имейте базовые знания об удаленном коммутируемом анализаторе для портов (RSPAN)

Используемые компоненты

Сведения в этом документе основываются на Nexus устройства NX-OS серии 7000.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Более подробную информацию о применяемых в документе обозначениях см. в описании условных обозначений, используемых в технической документации Cisco.

Общие сведения

Можно использовать коммутируемый анализатор для портов (SPAN) для анализа сетевого трафика, который проходит через порты или VLAN коммутатора, которые передают копию трафика в порт назначения, где анализатор сети соединяется с коммутатором.

Для расширения SPAN RSPAN включает удалeнный мониторинг нескольк блоков коммутаторов по сети. Коммутатор Cisco Nexus серии 7000 ограничен в том, что он может сделать с RSPAN. VLAN RSPAN не может использоваться в качестве назначения SPAN. Поэтому Коммутатор Nexus 7000 может только использовать RSPAN в качестве транзитной VLAN или исходной VLAN и вытянуть данные от VLAN RSPAN. Вы ничего не можете разместить в VLAN RSPAN от Коммутатора Nexus 7000.

Настройка

Этот пример конфигурации использует исходные порты на двух других Коммутаторах Cisco Nexus серии 7000 и порт назначения на одном Коммутаторе Nexus 7000, где соединился анализатор сети. Отдельная Ethernet 1/1 ссылки установлена между этими двумя устройствами: одна ссылка как назначение промежутка и другая ссылка как доступ к VLAN RSPAN.

Примечание: Используйте инструмент Command Lookup (только для зарегистрированных пользователей) для того, чтобы получить более подробную информацию о командах, использованных в этом разделе.

Схема сети

В этом документе использованы параметры данной сети:

http://www.cisco.com/c/dam/en/us/support/docs/switches/nexus-7000-series-switches/113438-rspan-nexus-7000-01.jpg

Данный пример использует порты, перечисленные в этой таблице:

Устройство Исходный порт Номер порта
Nexus 1 Ethernet 2/15 и 2/16 Ethernet 1/1
Nexus 2 Ethernet 1/1, 2/26 к 2/28 Ethernet 2/37 к 2/40

От коммутатора Nexus 1 трафик SPAN из источника переносят в порт назначения и копируют на VLAN RSPAN. Трафик тогда передан по ссылке на Nexus 2, включают Ethernet 1/1 интерфейс. Затем, трафик виртуальной локальной сети (VLAN) RSPAN передается порту назначения, где устройство, такое как Устройство SwitchProbe или другой зонд Удалeнного мониторинга (RMON) или устройство безопасности, может получить и проанализировать пакеты.

Конфигурации

Эти конфигурации используются в данном документе:

Nexus 1
Nexus1#configure terminal


!--- Configure the interface VLAN 15 as RSPAN VLAN.

Nexus1(config)#vlan 15 
Nexus1(config-vlan)#remote-span
Nexus1(config-vlan)#exit



!--- Configure the switchport interface as a SPAN destination.

Nexus1(config)#interface ethernet 1/1
Nexus1(config-if)#switchport monitor
Nexus1(config-if)#no shutdown
Nexus1(config-if)#exit



!--- Configure the SPAN session.

Nexus1(config)#monitor session 1


!---Configure the source port.

Nexus1(config-monitor)#source interface ethernet 2/15-16


!--- Configure the destination port.

Nexus1(config-monitor)#destination interface ethernet 1/1


!--- Enable the SPAN session (by default the session is in shutdown state).

Nexus1(config-monitor)#no shut
Nexus1(config-monitor)#exit

Nexus 2
Nexus2#configure terminal


!--- Configuration of interface VLAN 15 as RSPAN VLAN.

Nexus2(config)#vlan 15 
Nexus2(config-vlan)#remote-span
Nexus2(config-vlan)#exit


!--- Configure the switchport interface to access in RSPAN VLAN.

Nexus2(config)#interface ethernet 1/1
Nexus2(config-if)#switchport mode access
Nexus2(config-if)#switchport access vlan 15
Nexus2(config-if)#no shutdown
Nexus2(config-if)#exit



!--- Configure the switchport interfaces as a SPAN destination.

Nexus2(config)#interface ethernet 2/37-40
Nexus2(config-if)#switchport monitor
Nexus2(config-if)#exit



!--- Configure the SPAN session.

Nexus2(config)#monitor session 1


!--- Configure the source port.

Nexus2(config-monitor)#source interface ethernet 2/26-28
Nexus2(config-monitor)#source vlan 15


!--- Configure the destination port.

Nexus2(config-monitor)#destination interface ethernet 2/37-40


!--- Enable the SPAN session (by default the session is in shutdown state).

Nexus2(config-monitor)#no shut
Nexus2(config-monitor)#exit

Проверка.

Этот раздел позволяет убедиться, что конфигурация работает правильно.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Вот некоторые команды проверки RSPAN и SPAN:

Nexus 1:

  • Используйте команду show monitor для показа статуса сеансов RSPAN.

    Nexus1# show monitor
    Session  State        Reason                  Description
    -------  -----------  ----------------------  --------------------------------
    1        up           The session is up
  • Используйте show monitor session [открывают сеанс session_number] команда для показа конфигурации сеанса ERSPAN.

    Nexus1# show monitor session 1
       session 1
    ---------------
    type              : local
    state             : up
    source intf       :
        rx            : Eth1/15       Eth1/16
        tx            : Eth1/15       Eth1/16
        both          : Eth1/15       Eth1/16
    source VLANs      :
        rx            :
        tx            :
        both          :
    filter VLANs      : filter not specified
    destination ports : Eth1/1
    
    Legend: f = forwarding enabled, l = learning enabled
  • Используйте show monitor session вся команда для показа, весь ERSPAN открывает сеанс конфигурацию в устройстве.

Nexus 2:

  • Используйте команду show monitor для показа статуса сеансов ERSPAN.

    Nexus2# show monitor
    Session  State        Reason                  Description
    -------  -----------  ----------------------  --------------------------------
    1        up           The session is up
  • Используйте show monitor session [открывают сеанс session_number] команда для показа конфигурации сеанса ERSPAN.

    Nexus2# show monitor session 1
       session 1
    ---------------
    type              : local
    state             : up
    source intf       :
        rx            : Eth1/21       Eth1/22       Eth1/23
        tx            : Eth1/21       Eth1/22       Eth1/23
        both          : Eth1/21       Eth1/22       Eth1/23
    source VLANs      :
        rx            : 15
        tx            : 15
        both          : 15
    filter VLANs      : filter not specified
    destination ports : Eth1/27       Eth1/28       Eth1/29       Eth1/30
    
    Legend: f = forwarding enabled, l = learning enabled

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 113438