Коммутаторы : Cisco Nexus 9000 Series Switches

Настройте VXLAN

18 июня 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Отзыв

Введение

Этот документ предоставляет глобальный обзор Действительной Расширяемой LAN (VXLAN) и нескольких примеров конфигурации, придерживавшихся командами проверки и выходными данными.

Внесенный Аль Брайантом, специалистом службы технической поддержки Cisco.

Предварительные условия

Требования

Компания Cisco рекомендует предварительно ознакомиться со следующими предметами:

  • Понятия многоадресной маршрутизации, такие как Точка встречи (RP) и Независимая от платформы групповая адресация (PIM).
  • Понятия технологии Virtual PortChannel (vPC).

Этот документ предполагает, что IP routing и многоадресная маршрутизация были установлены до конфигурации VXLAN.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • 9396 Nexus как vPC Действительные Оконечные точки туннеля (VTEPs), которые выполняют Версию 7.0 (3) I1 (1b)
  • Nexus 3172, который выполняет Версию 6.0 (2) U5 (1)

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Общие сведения

Терминология

VXLAN (Действительная Расширяемая LAN) - технология, которая предоставляет тот же Уровень Ethernet 2 сетевых сервиса как VLAN, делает сегодня, но с большей расширяемостью и гибкостью.

VNID (Идентификатор сети Vxlan) - сегмент ID на 24 бита, который определяет широковещательный домен. Взаимозаменяемый "ID Сегмента VXLAN".

VTEP (Действительная Оконечная точка туннеля) - Это - устройство, которое делает инкапсуляцию и de-инкапсуляцию.

NVE (Сетевой Виртуальный интерфейс) - Логический интерфейс, где происходят инкапсуляция и de-инкапсуляция.

Что такое VXLAN?

  • VXLAN является технологией, которая позволяет накладывать сеть (L2) Уровня 2 по Уровню 3 (L3), лежал в основе с использованием любого протокола IP-маршрутизации.
  • Это использует MAC В UDP-ИНКАПСУЛЯЦИИ.

VXLAN решает три основных проблемы:

  • 16M VNIs (широковещательные домены) по сравнению с 4K предложен традиционными VLAN.
  • Позволяет L2 быть расширенным где угодно в IP - сети.
  • Оптимизированное затопление.

Почему VXLAN?

  • Масштабируемость VLAN - VXLAN расширяет поле L2 Segment ID до 24 битов, которое потенциально позволяет до 16 миллионов уникальных сегментов L2 по той же сети.
  • Эластичность Сегмента L2 по Границе L3 - VXLAN инкапсулирует кадр L2 в заголовке IP UDP, который позволяет смежность L2 по границам маршрутизатора.
  • Усиливает групповую адресацию в транспортной сети, чтобы моделировать лавинную адресацию для широковещания, одноадресного одноадресного, и передать в многоадресном режиме в сегменте L2.
  • Усильте Равноценное мультисоединение каналом (ECMP) для достижения использования оптимального пути по транспортной сети.

Настройка

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

Конфигурации

Эти конфигурации являются определенными для части VXLAN конфигурации. Обратите внимание на то, что 9396-A и B находятся в vPC domain, в то время как 3172-A не. Эти конфигурации принимают полную достижимость ко всем L3 интерфейсам в топологии с протоколом маршрутизации по Вашему выбору. Протокол OSPF использовался в данном примере. Это также предполагает, что многоадресная маршрутизация была установлена по этим тем же L3 интерфейсам.

3172-A

feature ospf
feature pim
feature vn-segment-vlan-based
feature nv overlay

vlan 10
 vn-segment 160010
vlan 20
 vn-segment 160020

interface nve1
 source-interface loopback1
 member vni 160010 mcast-group 231.1.1.1
 member vni 160020 mcast-group 231.1.1.1
 no shutdown
 
interface Ethernet1/3
 no switchport
 ip address 192.168.1.10/30
 ip router ospf 2 area 0.0.0.0
 ip pim sparse-mode

interface loopback1
 ip address 192.168.2.5/32
 ip router ospf 2 area 0.0.0.0
 ip pim sparse-mode
 

 

9396-A

Примечание: Когда vPCs используются в качестве VTEPs, вторичный IP интерфейса обратной связи используется и разделяется между двумя узлами. Это - то, как оба узла представляют себя как одиночный VTEP к удаленным узлам NVE.

feature ospf
feature pim
feature vn-segment-vlan-based
feature nv overlay

ip pim rp-address 192.168.1.100 group-list 224.0.0.0/4

vlan 1,10,20
vlan 10
 vn-segment 160010
vlan 20
 vn-segment 160020

vpc domain 1
 peer-switch
 peer-keepalive destination 10.122.140.99
 peer-gateway

interface port-channel1
 switchport mode trunk
 spanning-tree port type network
 vpc peer-link

interface port-channel48
 switchport mode trunk
 vpc 48 

interface nve1
 mtu 9216
 no shutdown
 source-interface loopback1
 member vni 160010 mcast-group 231.1.1.1
 member vni 160020 mcast-group 231.1.1.1

interface Ethernet1/7
 no switchport
 ip address 192.168.1.2/30
 ip router ospf 1 area 0.0.0.0
 ip pim sparse-mode
 no shutdown
 
interface loopback1
 ip address 192.168.2.2/32
 ip address 192.168.2.1/32 secondary
 ip router ospf 1 area 0.0.0.0
 ip pim sparse-mode

9396-B

Примечание: Когда vPCs используются в качестве VTEPs, вторичный IP интерфейса обратной связи используется и разделяется между двумя узлами. Это - то, как оба узла представляют себя как одиночный VTEP к удаленным узлам NVE.

feature ospf
feature pim
feature vn-segment-vlan-based
feature nv overlay

ip pim rp-address 192.168.1.100 group-list 224.0.0.0/4

vlan 1,10,20
vlan 10
 vn-segment 160010
vlan 20
 vn-segment 160020
 
vpc domain 1
 peer-switch
 peer-keepalive destination 10.122.140.98
 peer-gateway

interface port-channel1
 switchport mode trunk
 spanning-tree port type network
 vpc peer-link

interface port-channel48
 switchport mode trunk
 vpc 48

interface nve1
 mtu 9216
 no shutdown
 source-interface loopback1
 member vni 160010 mcast-group 231.1.1.1
 member vni 160020 mcast-group 231.1.1.1
   
interface Ethernet1/7
 no switchport
 ip address 192.168.1.6/30
 ip router ospf 1 area 0.0.0.0
 ip pim sparse-mode
 no shutdown
 
interface loopback1
 ip address 192.168.2.3/32
 ip address 192.168.2.1/32 secondary
 ip router ospf 1 area 0.0.0.0
 ip pim sparse-mode

Проверка.

Этот раздел позволяет убедиться, что конфигурация работает правильно.

 Средство интерпретации выходных данных (только зарегистрированные клиенты) поддерживает некоторые команды show . Используйте Средство интерпретации выходных данных, чтобы просмотреть анализ выходных данных команды show. 

  • покажите узлы nve <---, вы не будете видеть выходных данных для этого, пока трафик не будет инициироваться от обеих сторон наложения
  • покажите nve vni
  • интерфейс покажите выполненного nve1
  • покажите nve внутреннюю подробность интерфейса платформы (9K только)
  • show mac-address-table
  • подробность show ip mroute

Примеры выходных данных

Эти выходные данные находятся в установившемся режиме. Узлы VTEP обнаружили друг друга, и трафик прошел и между в encap и между decap направлениях.

3172-A

3172-A# show nve peers
Interface         Peer-IP          Peer-State
----------------  ---------------  -------------
nve1              192.168.2.1       Up        

3712-A# show nve vni
Interface         VNI       Multicast-group  VNI State
----------------  --------  ---------------  ---------
nve1              160010    231.1.1.1        Up  
nve1              160020    231.1.1.1        Up          

3172-A# show run interface nve1

!Command: show running-config interface nve1
!Time: Sat Apr 25 15:09:13 2015

version 6.0(2)U5(1)

interface nve1
 source-interface loopback1
 member vni 160010 mcast-group 231.1.1.1
 member vni 160020 mcast-group 231.1.1.1
 no shutdown

3172-A# show nve internal platform interface detail

3172-A# show mac address-table vlan 10
Legend:
       * - primary entry, G - Gateway MAC, (R) - Routed MAC, O - Overlay MAC
       age - seconds since first seen,+ - primary entry using vPC Peer-Link
  VLAN    MAC Address     Type     age    Secure NTFY  Ports/SWID.SSID.LID
---------+-----------------+--------+---------+------+----+------------------
* 10      0000.1111.1111   dynamic  5030      F   F Eth1/48
* 10      0000.2222.2222   dynamic  5010      F   F nve1(192.168.2.1)

3172-A# show ip mroute detail
IP Multicast Routing Table for VRF "default"

Total number of routes: 3
Total number of (*,G) routes: 1
Total number of (S,G) routes: 1
Total number of (*,G-prefix) routes: 1

(*, 231.1.1.1/32), uptime: 3w3d, static(1) pim(0) ip(0)
 Stats: 15/1539 [Packets/Bytes], 0.000  bps
 Incoming interface: Ethernet1/3, RPF nbr: 192.168.1.9, uptime: 1w0d
 Outgoing interface list: (count: 1)
   loopback1, uptime: 3w3d, static

(192.168.2.5/32, 231.1.1.1/32), uptime: 3w3d, ip(0) mrib(1) pim(1)
 Stats: 142751/9136064 [Packets/Bytes], 34.133 bps
 Incoming interface: loopback1, RPF nbr: 192.168.2.5, uptime: 3w3d
 Outgoing interface list: (count: 2)
   Ethernet1/3, uptime: 1w0d, pim
   loopback1, uptime: 3w3d, mrib, (RPF)

(*, 232.0.0.0/8), uptime: 3w3d, pim(0) ip(0)
 Stats: 0/0 [Packets/Bytes], 0.000  bps
 Incoming interface: Null, RPF nbr: 0.0.0.0, uptime: 3w3d
 Outgoing interface list: (count: 0)

9396-A

9396-A# show nve peers
Interface Peer-IP         State LearnType Uptime  Router-Mac      
--------- --------------- ----- --------- -------- -----------------
nve1     192.168.2.5     Up   DP       2d20h   n/a             

9396-A# show nve vni
Codes: CP - Control Plane       DP - Data Plane         
      UC - Unconfigured        SA - Suppress ARP
      
Interface VNI     Multicast-group  State Mode Type [BD/VRF]     Flags
--------- -------- ----------------- ----- ---- ------------------ -----
nve1     160010  231.1.1.1        Up   DP  L2 [10]    
nve1     160020  231.1.1.1        Up   DP  L2 [20]                            

9396-A# show run interface nve1

!Command: show running-config interface nve1
!Time: Sat Apr 25 15:20:45 2015

version 7.0(3)I1(1a)

interface nve1
 mtu 9216
 no shutdown
 source-interface loopback1
 member vni 160010 mcast-group 231.1.1.1
 member vni 160020 mcast-group 231.1.1.1

9396-A# show nve internal platform interface detail
Printing details of all NVE Interfaces
|======|=========================|===============|===============|=====|=====|
|Intf |State                   |PriIP         |SecIP         |Vnis |Peers|
|======|=========================|===============|===============|=====|=====|
|nve1 |UP                      |192.168.2.2   |192.168.2.1   |2   |1   |
|======|=========================|===============|===============|=====|=====|

SW_BD/VNIs of interface nve1:
================================================
|======|======|=========================|======|====|======|
|Sw BD |Vni  |State                   |Intf |Type|Vrf-ID|
|======|======|=========================|======|====|======|
|10   |160010|UP                      |nve1 |DP |0    
|20   |160020|UP                      |nve1 |DP |0    
|======|======|=========================|======|====|======|
Peers of interface nve1:
============================================

peer_ip: 192.168.2.5, peer_id: 1, state: UP MAC-learning: Enabled
active_swbds:
add_pending_swbds:
rem_pending_swbds:

9396-A# show mac address-table vlan 10
Legend:
       * - primary entry, G - Gateway MAC, (R) - Routed MAC, O - Overlay MAC
       age - seconds since last seen,+ - primary entry using vPC Peer-Link,
       (T) - True, (F) - False
  VLAN    MAC Address     Type     age    Secure NTFY Ports
---------+-----------------+--------+---------+------+----+------------------
+  10    0000.1111.1111  dynamic 0        F     F   nve1(192.168.2.5)
*  10    0000.2222.2222  dynamic 0        F     F   Po48
G   -    7c0e.ceca.f177  static  -        F     F   sup-eth1(R)

9396-A# show ip mroute detail
IP Multicast Routing Table for VRF "default"

Total number of routes: 4
Total number of (*,G) routes: 1
Total number of (S,G) routes: 2
Total number of (*,G-prefix) routes: 1

(*, 231.1.1.1/32), uptime: 2d21h, nve(1) ip(0) pim(0)
 Data Created: No
 Stats: 1/64 [Packets/Bytes], 0.000  bps
 Stats: Inactive Flow
 Incoming interface: Ethernet1/7, RPF nbr: 192.168.1.1
 Outgoing interface list: (count: 1)
   nve1, uptime: 2d21h, nve

(192.168.2.1/32, 231.1.1.1/32), uptime: 2d21h, nve(0) ip(0) mrib(0) pim(0)
 Data Created: Yes
 VXLAN Flags
   VXLAN Encap
 Stats: 1/51 [Packets/Bytes], 0.000  bps
 Stats: Inactive Flow
 Incoming interface: loopback1, RPF nbr: 192.168.2.1
 Outgoing interface list: (count: 0)

(192.168.2.5/32, 231.1.1.1/32), uptime: 2d21h, ip(0) mrib(0) nve(1) pim(0)
 Data Created: Yes
 Stats: 16474/1370086 [Packets/Bytes], 13.600 bps
 Stats: Active Flow
 Incoming interface: Ethernet1/7, RPF nbr: 192.168.1.1
 Outgoing interface list: (count: 1)
   nve1, uptime: 2d21h, nve

(*, 232.0.0.0/8), uptime: 2d21h, pim(0) ip(0)
 Data Created: No
 Stats: 0/0 [Packets/Bytes], 0.000  bps
 Stats: Inactive Flow
 Incoming interface: Null, RPF nbr: 0.0.0.0
 Outgoing interface list: (count: 0)

9396-A# show vpc
Legend:
               (*) - local vPC is down, forwarding via vPC peer-link

vPC domain id                    : 1  
Peer status                      : peer adjacency formed ok     
vPC keep-alive status            : peer is alive                
Configuration consistency status : success
Per-vlan consistency status      : success                      
Type-2 consistency status        : success
vPC role                         : secondary                    
Number of vPCs configured        : 1  
Peer Gateway                     : Enabled
Dual-active excluded VLANs       : -
Graceful Consistency Check       : Enabled
Auto-recovery status             : Disabled

vPC Peer-link status
---------------------------------------------------------------------
id  Port  Status Active vlans   
--  ----  ------ --------------------------------------------------
1   Po1   up    1,10,20                                               

vPC status
----------------------------------------------------------------------
id  Port  Status Consistency Reason                    Active vlans
--  ----  ------ ----------- ------                    ------------
48  Po48  up    success    success                   1,10

9396-B

9396-B# show nve peers 
Interface Peer-IP         State LearnType Uptime  Router-Mac      
--------- --------------- ----- --------- -------- -----------------
nve1     192.168.2.5     Up   DP       1w0d    n/a             

9396-B# show nve vni
Codes: CP - Control Plane       DP - Data Plane         
      UC - Unconfigured        SA - Suppress ARP
      
Interface VNI     Multicast-group  State Mode Type [BD/VRF]     Flags
--------- -------- ----------------- ----- ---- ------------------ -----
nve1     160010  231.1.1.1        Up   DP  L2 [10]  
nve1     160020  231.1.1.1        Up   DP  L2 [20]                              

9396-B# show run interface nve1

!Command: show running-config interface nve1
!Time: Sat Apr 25 15:23:25 2015

version 7.0(3)I1(1b)

interface nve1
 mtu 9216
 no shutdown
 source-interface loopback1
 member vni 160010 mcast-group 231.1.1.1
 member vni 160020 mcast-group 231.1.1.1
 
9396-B# show nve internal platform interface detail
Printing details of all NVE Interfaces
|======|=========================|===============|===============|=====|=====|
|Intf |State                   |PriIP         |SecIP         |Vnis |Peers|
|======|=========================|===============|===============|=====|=====|
|nve1 |UP                      |192.168.2.3   |192.168.2.1   |2   |1   |
|======|=========================|===============|===============|=====|=====|

SW_BD/VNIs of interface nve1:
================================================
|======|======|=========================|======|====|======|
|Sw BD |Vni  |State                   |Intf |Type|Vrf-ID|
|======|======|=========================|======|====|======|
|10   |160010|UP                      |nve1 |DP |0    
|20   |160020|UP                      |nve1 |DP |0    
|======|======|=========================|======|====|======|
Peers of interface nve1:
============================================

peer_ip: 192.168.2.5, peer_id: 1, state: UP MAC-learning: Enabled
active_swbds:
add_pending_swbds:
rem_pending_swbds:

9396-B# show mac address-table vlan 10
Legend:
       * - primary entry, G - Gateway MAC, (R) - Routed MAC, O - Overlay MAC
       age - seconds since last seen,+ - primary entry using vPC Peer-Link,
       (T) - True, (F) - False
  VLAN    MAC Address     Type     age    Secure NTFY Ports
---------+-----------------+--------+---------+------+----+------------------
*  10    0000.1111.1111  dynamic 0        F     F   nve1(192.168.2.5)
+  10    0000.2222.2222  dynamic 0        F     F   Po48
G   -    58f3.9ca3.64dd  static  -        F     F   sup-eth1(R)

9396-B# show ip mroute detail
IP Multicast Routing Table for VRF "default"

Total number of routes: 4
Total number of (*,G) routes: 1
Total number of (S,G) routes: 2
Total number of (*,G-prefix) routes: 1

(*, 231.1.1.1/32), uptime: 2w1d, nve(1) ip(0) pim(0)
 Data Created: No
 VXLAN Flags
   VXLAN Decap
 VPC Flags
   RPF-Source Forwarder
 Stats: 1/64 [Packets/Bytes], 0.000  bps
 Stats: Inactive Flow
 Incoming interface: Ethernet1/7, RPF nbr: 192.168.1.5
 Outgoing interface list: (count: 1)
   nve1, uptime: 2w1d, nve

(192.168.2.1/32, 231.1.1.1/32), uptime: 2w1d, nve(0) ip(0) mrib(0) pim(1)
 Data Created: Yes
 VXLAN Flags
   VXLAN Encap
 VPC Flags
   RPF-Source Forwarder
 Stats: 5/511 [Packets/Bytes], 0.000  bps
 Stats: Inactive Flow
 Incoming interface: loopback1, RPF nbr: 192.168.2.1
 Outgoing interface list: (count: 1)
   Ethernet1/7, uptime: 1w0d, pim

(192.168.2.5/32, 231.1.1.1/32), uptime: 2w1d, ip(0) mrib(0) pim(0) nve(1)
 Data Created: Yes
 VXLAN Flags
   VXLAN Decap
 VPC Flags
   RPF-Source Forwarder
 Stats: 86621/7241564 [Packets/Bytes], 13.600 bps
 Stats: Active Flow
 Incoming interface: Ethernet1/7, RPF nbr: 192.168.1.5
 Outgoing interface list: (count: 1)
   nve1, uptime: 2w1d, nve

(*, 232.0.0.0/8), uptime: 2w1d, pim(0) ip(0)
 Data Created: No
 Stats: 0/0 [Packets/Bytes], 0.000  bps
 Stats: Inactive Flow
 Incoming interface: Null, RPF nbr: 0.0.0.0
 Outgoing interface list: (count: 0)

9396-B# show vpc
Legend:
               (*) - local vPC is down, forwarding via vPC peer-link

vPC domain id                    : 1  
Peer status                      : peer adjacency formed ok     
vPC keep-alive status            : peer is alive                
Configuration consistency status : success
Per-vlan consistency status      : success                      
Type-2 consistency status        : success
vPC role                         : primary                      
Number of vPCs configured        : 1  
Peer Gateway                     : Enabled
Dual-active excluded VLANs       : -
Graceful Consistency Check       : Enabled
Auto-recovery status             : Disabled

vPC Peer-link status
---------------------------------------------------------------------
id  Port  Status Active vlans   
--  ----  ------ --------------------------------------------------
1   Po1   up    1,10,20                                               

vPC status
----------------------------------------------------------------------
id  Port  Status Consistency Reason                    Active vlans
--  ----  ------ ----------- ------                    ------------
48  Po48  up    success    success                   1,10

Захват пакета VXLAN

Захват пакета (PCAP) от предыдущей топологии и содержит OSPF hellos, Соединения/Регистры PIM и инкапсулированный трафик VXLAN для toplogy, показанного в схеме сети. Вы заметите некоторые флаги Протокола ICMP, такие как 'никакой ответ'. Это происходит из-за природы сеанса монитора, завершенного на RP.

Сеанс монитора включал интерфейсы Eth4/17-18 и Eth4/20, таким образом, это отбрасывает Wireshark некоторые. Важная информация является форматом и флагами.

Примечание: Все инкапсулированные пакеты (BUM или известная индивидуальная рассылка) получены от петлевого IP VTEP, предназначенного к удаленному петлевому IP VTEP. Это - вторичный петлевой IP на любом vPC VTEPs.

Трафик BUM будет предназначен группе mcast.

Трафик с конкретным адресом будет предназначен к удаленному петлевому IP VTEP.

VXLAN PCAP

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.

Дополнительные сведения


Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.