Протокол IP : Групповая адресация

Настройте Профили MVPN В Cisco IOS

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (21 апреля 2016) | Отзыв

Содержание

Связанные обсуждения сообщества поддержки Cisco

Введение

Этот документ описывает, как настроить каждую Multicast VPN (MVPN) профиль в Cisco IOS®.

Примечание: Конфигурации, которые описаны в этом документе, применяются к маршрутизаторам Границы провайдера (PE).

Внесенный Люком Де Гееном, специалистом службы технической поддержки Cisco.

Предварительные условия

Требования

Перед переходом конфигурацию, которая описана в этом документе, проверьте, существует ли поддержка профиля MVPN на определенной платформе, которая выполняет Cisco IOS.

Используемые компоненты

Сведения в этом документе основываются на всех версиях Cisco IOS.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Настройка

В этом разделе описывается настроить профили MVPN в Cisco IOS.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).  

Профили MVPN

Примечание: Не все профили в настоящее время поддерживаются в Cisco IOS.

Примечание: Виртуальная маршрутизация / Передача (VRF), который используется всюду по этому документу, является VRF один. Розен MLDP был переименован к По умолчанию MDT.

Профиль MVPN настроен для глобального контекста или на VRF. Можно использовать или старый или новый метод для определения VRF при настройке профилей MVPN в Cisco IOS.

Вот пример старого метода:

ip vrf one
rd 1:1
route-target export 1:1
route-target import 1:1

Вот пример нового метода:

vrf definition one
rd 1:1
!
address-family ipv4
 route-target export 1:1
 route-target import 1:1
exit-address-family

Для профилей в глобальном контексте должен быть включен multicast-routing:

ip multicast-routing

Для профилей в VRF context multicast-routing должен быть включен для VRF:

ip multicast-routing vrf one

Можно включить регистрацию Многоточечного протокола распределения меток (MLDP) с этой командой global для профилей с MLDP:

mpls mldp logging notifications

Независимая от протокола многоадресная передача (PIM) должна быть включена для маршрутизатора Границы провайдера (PE) на Порте заказчика Customer Edge границы провайдера (PE-CE) ссылку для обоих случаи (глобальный или VRF context):

interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode

FRR для MLDP

Быстро перенаправить (FRR) для MLDP доступен в Cisco IOS. Многоадресный трафик, для которого MLDP является протоколом уровня управления, должен использовать основной туннель Регулирования трафика (TE) для защищения трафика FRR. Основным Туннелем TE может быть ручной Туннель TE или основной автотуннель. Ссылка должна быть защищена FRR TE, или ручным резервным туннелем или резервным автотуннелем.

Данный пример использует ручной основной и ручной резервный туннель.

Эта команда global должна быть настроена для MLDP для использования Туннелей TE Многопротокольной коммутации по меткам (MPLS):

mpls mldp path traffic-eng

Эта конфигурация используется для защищенного интерфейса, который используется основным туннелем с одним переходом:

interface Ethernet3/0
 ip address 10.1.6.6 255.255.255.0
 load-interval 30
 mpls ip
 mpls traffic-eng tunnels
 mpls traffic-eng backup-path Tunnel0
 ip rsvp bandwidth 10000
end

Эта конфигурация используется для резервного туннеля:

interface Tunnel0
 ip unnumbered Loopback0
 load-interval 30
 tunnel source Loopback0
 tunnel mode mpls traffic-eng
 tunnel destination 10.100.1.3
 tunnel mpls traffic-eng path-option 1 explicit name P6-to-P3

Эта конфигурация используется для основного туннеля с одним переходом:

interface Tunnel1
 ip unnumbered Loopback0
 load-interval 30
 mpls ip
 tunnel source Loopback0
 tunnel mode mpls traffic-eng
 tunnel destination 10.100.1.3
 tunnel mpls traffic-eng autoroute announce
 tunnel mpls traffic-eng path-option 1 explicit name P6-to-P3-direct
 tunnel mpls traffic-eng fast-reroute

Примечание: Конфигурация IP mpls требуется на основном туннеле, потому что MLDP должен быть включен на защищенном туннеле. Конфигурация autoroute announce требуется, чтобы гарантировать, что Туннель TE используется для передачи трафика.

MBB для MLDP

Функция Сделать перед разрывом (MBB) поддерживается в Cisco IOS, но только метод, который использует фиксированную задержку после нового пути, доступен. Существует, не Сделали запрос/Подтвердили механизма в Cisco IOS.

Это - команда global, которая используется для настройки фиксированной задержки MBB:

P1(config)#mpls mldp make-before-break delay ?
<0-60000> Delay in milliseconds

Значение по умолчанию 0, таким образом, нет никакого MBB по умолчанию.

Профили

В этом разделе описываются требуемые конфигурации для каждого профиля MVPN.

Представьте 0 по умолчанию MDT - GRE - сигнализация C-mcast PIM

Используйте эту конфигурацию для профиля 0:

vrf definition one
rd 1:1
!
address-family ipv4
 mdt default 232.1.1.1
 route-target export 1:1
 route-target import 1:1
exit-address-family
!       
ip multicast-routing
ip multicast-routing vrf one

interface Loopback0
ip address 10.100.1.1 255.255.255.255
ip pim sparse-mode
!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!

router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family vpnv4
 neighbor 10.100.1.7 activate
 neighbor 10.100.1.7 send-community extended
 neighbor 10.100.1.7 route-reflector-client
exit-address-family
!
address-family ipv4 mdt
 neighbor 10.100.1.7 activate
 neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
 redistribute connected
 neighbor 10.2.1.8 remote-as 65001
 neighbor 10.2.1.8 activate
exit-address-family
!

Примечание: Для этого профиля PIM должен быть включен на глобальном интерфейсе обратной связи. Дерево распределения групповой адресации (MDT) IPv4 Семейства адресов (AF) должно использоваться для всех типов PIM, сигнализирующего в ядре (не только для Source Specific Multicast (SSM) PIM).

Представьте 1 по умолчанию MDT - MP2MP MLDP - сигнализация C-mcast PIM

Используйте эту конфигурацию для профиля 1:

vrf definition one
rd 1:2
vpn id 1000:2000
!
address-family ipv4
 mdt default mpls mldp 10.100.1.1
 route-target export 1:1
 route-target import 1:1
exit-address-family
!

ip multicast-routing vrf one

mpls mldp logging notifications

router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family vpnv4
 neighbor 10.100.1.7 activate
 neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
 redistribute connected
 neighbor 10.2.2.9 remote-as 65002
 neighbor 10.2.2.9 activate
exit-address-family

Представьте 2 разделенных MDT - MP2MP MLDP - сигнализация C-mcast PIM

     

Профиль 2 в настоящее время не поддерживается в Cisco IOS, и MLDP не поддерживает Разделенный MDT с "Много точек - много точек" (MP2MP).

Представьте 3 по умолчанию MDT - GRE - AD BGP - сигнализация C-mcast PIM

Используйте эту конфигурацию для профиля 3:

vrf definition one
rd 1:1
!
address-family ipv4
 mdt auto-discovery pim
 mdt default 232.1.1.1
 route-target export 1:1
 route-target import 1:1
exit-address-family
!

ip multicast-routing vrf one
!
interface Loopback0
ip address 10.100.1.1 255.255.255.255
ip pim sparse-mode
!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
 neighbor 10.100.1.7 activate
 neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
 neighbor 10.100.1.7 activate
 neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
 redistribute connected
 neighbor 10.2.1.8 remote-as 65001
 neighbor 10.2.1.8 activate
exit-address-family

  

Примечание: Для этого профиля PIM должен быть включен на глобальном интерфейсе обратной связи. Поскольку Автоматическое обнаружение Border Gateway Protocol (AD BGP) для PIM используется, больше нет потребности в IPv4 AF MDT, который был необходим для профиля 0.

Представьте 4 разделенных MDT - MP2MP MLDP - AD BGP - сигнализация C-mcast PIM

Профиль 4 в настоящее время не поддерживается в Cisco IOS, и MLDP не поддерживает Разделенный MDT с MP2MP.

Представьте 5 разделенных MDT - P2MP MLDP - AD BGP - сигнализация C-mcast PIM

Профиль 5 в настоящее время не поддерживается в Cisco IOS, и сигнализация PIM не поддерживается по Разделенному MDT.

Представьте 6 VRF MLDP - внутриполосная передача сигнала

Используйте эту конфигурацию для профиля 6:

vrf definition one
rd 1:1
!
address-family ipv4
 route-target export 1:1
 route-target import 1:1
exit-address-family
!
ip multicast-routing vrf one
ip multicast vrf one mpls mldp


!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!

router bgp 1
bgp log-neighbor-changes
neighbor 10.2.1.8 remote-as 65001
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
!
address-family vpnv4
 neighbor 10.100.1.7 activate
 neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
 redistribute connected
 neighbor 10.2.1.8 remote-as 65001
 neighbor 10.2.1.8 activate
exit-address-family
!


ip pim vrf one mpls source Loopback0

Представьте 7 глобальных внутриполосных передач сигнала MLDP

Используйте эту конфигурацию для профиля 7:

ip multicast-routing

ip multicast mpls mldp

interface Loopback0
ip address 10.100.1.1 255.255.255.255
ip pim sparse-mode
!

interface Ethernet2/0
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode

router bgp 1
bgp log-neighbor-changes
neighbor 10.2.1.8 remote-as 65001
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4
 redistribute connected
 neighbor 10.2.1.8 activate
 neighbor 10.100.1.7 activate
exit-address-family

ip pim ssm default

ip pim mpls source Loopback0

Представьте 8 глобальных помех - TE P2MP

В этом разделе описываются требуемые конфигурации для профиля 8 на головном узле TE и маршрутизаторах хвостовой части TE.

Маршрутизатор головного узла TE

Используйте эту конфигурацию для профиля 8 на маршрутизаторе головного узла TE:

ip multicast-routing
ip multicast mpls traffic-eng

mpls traffic-eng tunnels
mpls traffic-eng destination list name from-PE3
ip 10.100.1.1 path-option 1 dynamic
ip 10.100.1.2 path-option 1 dynamic
ip 10.100.1.4 path-option 1 explicit name to-PE4

interface Tunnel0
ip unnumbered Loopback0
ip pim passive
ip igmp static-group 232.1.1.1 source 10.2.3.10
tunnel mode mpls traffic-eng point-to-multipoint
tunnel destination list mpls traffic-eng name from-PE3
!

interface Ethernet1/0
ip address 10.1.10.3 255.255.255.0
mpls traffic-eng tunnels
ip rsvp bandwidth 10000

!
router ospf 1
network 10.1.7.0 0.0.0.255 area 0
network 10.1.10.0 0.0.0.255 area 0
network 10.100.0.0 0.0.255.255 area 0
mpls traffic-eng router-id Loopback0
mpls traffic-eng area 0
!

router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4
 redistribute connected
 neighbor 10.100.1.7 activate
exit-address-family

ip pim ssm default

Примечание: Целевой список требуется для маршрутизаторов хвостовой части Точка - многоточка (P2MP) Туннель TE. Path-option к маршрутизатору хвостовой части может быть явным или динамичным.

Маршрутизатор хвостовой части TE

Используйте эту конфигурацию для профиля 8 на маршрутизаторе хвостовой части TE:

ip multicast-routing
ip multicast mpls traffic-eng

mpls traffic-eng tunnels
interface Ethernet0/0
ip address 10.1.1.1 255.255.255.0
mpls traffic-eng tunnels
ip rsvp bandwidth 10000
        

router bgp 1
bgp log-neighbor-changes
neighbor 10.2.1.8 remote-as 65001
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4
 redistribute connected
 neighbor 10.2.1.8 activate
 neighbor 10.100.1.7 activate
exit-address-family

ip pim ssm default

ip mroute 10.2.3.0 255.255.255.0 10.100.1.3

Примечание: Статическое mroute требуется для источника к маршрутизатору головного узла TE в глобальном контексте.

Представьте 9 по умолчанию MDT - MLDP - MP2MP - AD BGP - сигнализация C-mcast PIM

Используйте эту конфигурацию для профиля 9:

vrf definition one
rd 1:1
vpn id 1000:2000
!
address-family ipv4
 mdt auto-discovery mldp
 mdt default mpls mldp 10.100.1.3
 route-target export 1:1
 route-target import 1:1
exit-address-family
!       
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode

router bgp 1
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
 neighbor 10.100.1.7 activate
 neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
 neighbor 10.100.1.7 activate
 neighbor 10.100.1.7 send-community extended
exit-address-family
!

Представьте 10 статичных VRF - TE P2MP - AD BGP

Профиль 10 в настоящее время не поддерживается в Cisco IOS, и AD BGP не поддерживается для TE P2MP.

Представьте 11 по умолчанию MDT - GRE - AD BGP - сигнализация C-mcast BGP

Используйте эту конфигурацию для профиля 11:

vrf definition one
rd 1:1
!
address-family ipv4
 mdt auto-discovery pim
 mdt default 232.1.1.1 
 mdt overlay use-bgp
route-target export 1:1
 route-target import 1:1
exit-address-family
!

ip multicast-routing vrf one
!
interface Loopback0
ip address 10.100.1.1 255.255.255.255
ip pim sparse-mode
!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!
router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
 neighbor 10.100.1.7 activate
 neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
 neighbor 10.100.1.7 activate
 neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
 redistribute connected
 neighbor 10.2.1.8 remote-as 65001
 neighbor 10.2.1.8 activate
exit-address-family

Примечание: Для этого профиля PIM должен быть включен на глобальном интерфейсе обратной связи. Поскольку AD BGP для PIM используется, больше нет потребности в IPv4 AF MDT, который был необходим для профиля 0.

Представьте 12 по умолчанию MDT - MLDP - P2MP - AD BGP - сигнализация C-mcast BGP

Используйте эту конфигурацию для профиля 12:

vrf definition one
rd 1:1
!
address-family ipv4
 mdt auto-discovery mldp
 mdt default mpls mldp p2mp
 mdt overlay use-bgp
 route-target export 1:1
 route-target import 1:1
exit-address-family
!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!

router bgp 1
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
 neighbor 10.100.1.7 activate
 neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
 neighbor 10.100.1.7 activate
 neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
 redistribute connected
 neighbor 10.2.1.8 remote-as 65001
 neighbor 10.2.1.8 activate
exit-address-family
!

Представьте 13 по умолчанию MDT - MLDP - MP2MP - AD BGP - сигнализация C-mcast BGP

Используйте эту конфигурацию для профиля 13:

vrf definition one
rd 1:1
vpn id 1000:2000
!
address-family ipv4
 mdt auto-discovery mldp
 mdt default mpls mldp 10.100.1.3
 mdt overlay use-bgp
 route-target export 1:1
 route-target import 1:1
exit-address-family
!       

interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode

router bgp 1
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
 neighbor 10.100.1.7 activate
 neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
 neighbor 10.100.1.7 activate
 neighbor 10.100.1.7 send-community extended
exit-address-family
!

Представьте 14 разделенных MDT - P2MP MLDP - AD BGP - сигнализация C-мачты BGP

Используйте эту конфигурацию для профиля 14:

vrf definition one
rd 1:1
!
address-family ipv4
 mdt auto-discovery mldp
mdt strict-rpf interface
 mdt partitioned mldp p2mp
 mdt overlay use-bgp
 route-target export 1:1
 route-target import 1:1
exit-address-family
!
interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!

router bgp 1
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
 neighbor 10.100.1.7 activate
 neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
 neighbor 10.100.1.7 activate
 neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
 redistribute connected
 neighbor 10.2.1.8 remote-as 65001
 neighbor 10.2.1.8 activate
exit-address-family
!

Представьте 15 разделенных MDT - MP2MP MLDP - AD BGP - сигнализация C-мачты BGP

Профиль 15 в настоящее время не поддерживается в Cisco IOS, и MLDP не поддерживает Разделенный MDT с MP2MP.

Представьте 16 по умолчанию статичный MDT - TE P2MP - AD BGP - сигнализация C-mcast BGP

Профиль 16 в настоящее время не поддерживается в Cisco IOS.

Представьте 17 по умолчанию MDT - MLDP - P2MP - AD BGP - сигнализация C-mcast PIM

Используйте эту конфигурацию для профиля 17:

vrf definition one
rd 1:1
!
address-family ipv4
 mdt auto-discovery mldp
 mdt default mpls mldp p2mp
 route-target export 1:1
 route-target import 1:1
exit-address-family
!

interface Ethernet2/0
vrf forwarding one
ip address 10.2.1.1 255.255.255.0
ip pim sparse-mode
!

router bgp 1
neighbor 10.100.1.7 remote-as 1
neighbor 10.100.1.7 update-source Loopback0
!
address-family ipv4 mvpn
 neighbor 10.100.1.7 activate
 neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family vpnv4
 neighbor 10.100.1.7 activate
 neighbor 10.100.1.7 send-community extended
exit-address-family
!
address-family ipv4 vrf one
 redistribute connected
 neighbor 10.2.1.8 remote-as 65001
 neighbor 10.2.1.8 activate
exit-address-family
!

Представьте 18 по умолчанию статичный MDT - TE P2MP - AD BGP - сигнализация C-mcast PIM

Профиль 18 в настоящее время не поддерживается в Cisco IOS.

Представьте 19 по умолчанию MDT - ИК - AD BGP - сигнализация C-mcast PIM

Представьте 19, и Входная репликация (IR) в настоящее время не поддерживаются в Cisco IOS.

Представьте 20 по умолчанию MDT - TE P2MP - AD BGP - PIM - сигнализация C-mcast

Представьте 20, и Автотуннельный TE P2MP в настоящее время не поддерживаются в Cisco IOS.

Представьте 21 по умолчанию MDT - ИК - AD BGP - BGP - сигнализация C-mcast

Представьте 21, и ИК в настоящее время не поддерживаются в Cisco IOS.       

Представьте 22 по умолчанию MDT - TE P2MP - AD BGP BGP - сигнализация C-mcast

Представьте 22, и Автотуннельный TE P2MP в настоящее время не поддерживаются в Cisco IOS.  

   

Представьте 23 разделенных MDT - ИК - AD BGP - сигнализация C-mcast PIM

Представьте 23, и ИК в настоящее время не поддерживаются в Cisco IOS.          

Представьте 24 разделенных MDT - TE P2MP - AD BGP - сигнализация C-mcast PIM

Представьте 24, и Автотуннельный TE P2MP в настоящее время не поддерживаются в Cisco IOS.

Представьте 25 разделенных MDT - ИК - AD BGP - сигнализация C-mcast BGP

Представьте 25, и ИК в настоящее время не поддерживаются в Cisco IOS.       

Представьте 26 разделенных MDT - TE P2MP - AD BGP - сигнализация C-mcast BGP

Представьте 26, и Автотуннельный TE P2MP в настоящее время не поддерживаются в Cisco IOS.

Межавтономный MVPN

Информация в этом разделе предоставлена под предположением, что правильная конфигурация внедрена на маршрутизаторах для создания INTER-AS MPLS VPN в рабочем состоянии для индивидуальной рассылки.

Опция D не поддерживается для MVPN.

Вариант A

Обычная mVPN конфигурация требуется для Опции A. У вас может быть любой профиль в автономных системах, и профили не должны совпадать в других автономных системах.

PIM

Для Опций B и C, если IP-адреса интерфейса обратной связи перераспределены от Протокола BGP в Протокол IGP других Автономных систем (AS), то вектор PIM не требуется.

Вариант В

Только самоуправляемая система (межAS) MVPN поддерживается с профилем 0 (с несегментированными туннелями).

Обычная mVPN конфигурация требуется для Опции B. Только IPv4 AF MDT может использоваться; MVPN IPv4 AF не поддерживается.

Происхождение вектора PIM с Признаком маршрута (RD) требуется на Периферийных маршрутизаторах с этой дополнительной настройкой:

ip multicast vrf one rpf proxy rd vector

Пограничным маршрутизаторам автономной системы (ASBR) нужно было включить PIM на ссылке от ASBR к ASBR. ASBR должны также иметь IPv4 AF MDT, настроенный для соседних узлов внутреннего протокола граничного шлюза (iBGP) и соседнего узла внешнего протокола пограничного шлюза (eBGP) ASBR.

Эта дополнительная настройка требуется на ASBR:

interface Ethernet0/0
description inter-as link
ip address 10.3.1.3 255.255.255.0
ip pim sparse-mode
mpls bgp forwarding

router bgp 1
bgp log-neighbor-changes
no bgp default route-target filter
neighbor 10.3.1.4 remote-as 2
neighbor 10.100.1.6 remote-as 1
neighbor 10.100.1.6 update-source Loopback0
!
address-family vpnv4
neighbor 10.3.1.4 activate
neighbor 10.3.1.4 send-community extended
neighbor 10.100.1.6 activate
neighbor 10.100.1.6 send-community extended
exit-address-family
!
address-family ipv4 mdt
neighbor 10.3.1.4 activate
neighbor 10.3.1.4 send-community extended
neighbor 10.100.1.6 activate
neighbor 10.100.1.6 send-community extended
exit-address-family

Опция C

Только самоуправляемая система (межAS) MVPN поддерживается с профилем 0 (с несегментированными туннелями).

Обычная mVPN конфигурация требуется для Опции C. Петлевые префиксы PE других AS объявлены BGP в IPv4 AF.

Происхождение вектора PIM без RD требуется на Периферийных маршрутизаторах также с этой дополнительной настройкой:

ip multicast rpf proxy vector

ASBR нужно было включить PIM на ссылке от ASBR к ASBR. ASBR должны также иметь IPv4 AF MDT, настроенный для соседей iBGP и соседа по протоколу EBGP ASBR.

Эта дополнительная настройка требуется на ASBR:

interface Ethernet0/0
description inter-as link
ip address 10.3.1.3 255.255.255.0
ip pim sparse-mode
mpls bgp forwarding

router bgp 1
bgp log-neighbor-changes
neighbor 10.3.1.4 remote-as 2
neighbor 10.100.1.6 remote-as 1
neighbor 10.100.1.6 update-source Loopback0
!
address-family ipv4
redistribute ospf 1 metric 100 route-map loopbacks-into-BGP
neighbor 10.3.1.4 activate
neighbor 10.3.1.4 send-community extended
neighbor 10.3.1.4 send-label
neighbor 10.100.1.6 activate
neighbor 10.100.1.6 send-community extended
neighbor 10.100.1.6 send-label
exit-address-family
!     
address-family ipv4 mdt
neighbor 10.3.1.4 activate
neighbor 10.3.1.4 send-community extended
neighbor 10.100.1.6 activate
neighbor 10.100.1.6 send-community extended
exit-address-family
!        

Примечание: IPv4 AF MDT между Автономными системами может также быть настроен на Рефлекторах маршрута (RRs) на сеансе EBGP с несколькими переходами вместо на ASBR.

MLDP

Опция B в настоящее время не поддерживается.

Опция C

Нет никакой поддержки Рекурсивного Forwarding Equivalence Class (FEC) в Cisco IOS. Следовательно, перераспределение loopback PE iBGP в другой AS не достаточно как P (Поставщик), маршрутизаторы испытывают недостаток в знании Периферийных маршрутизаторов в другом AS.

Если loopback PE перераспределены IGP в другой AS, существует поддержка. В этом случае профили с Разделенным MDT и P2MP полной сетки MLDP поддерживаются. IPv4 AF MDT не может использоваться здесь; MVPN IPv4 AF должен использоваться. Сеанс MVPN BGP может работать между PE и RRs. Между RRs уже существует сеанс EBGP с несколькими переходами, который выполняется для VPNv4/6 AF.

AD BGP MLDP должен быть включен. Межпоскольку ключевое слово требуется на Периферийных маршрутизаторах, чтобы гарантировать, что AD BGP маршруты Типа 1 не имеют сообщества no-export.

Профили с P2MP полной сетки MLDP

В этом разделе описываются конфигурации для профилей 12 и 17.

Представьте 17 конфигураций

Вот конфигурация на Периферийных маршрутизаторах для профиля 17:

vrf definition one
rd 1:2
!
address-family ipv4
mdt auto-discovery mldp inter-as
mdt default mpls mldp p2mp
mdt data mpls mldp 100
route-target export 1:1
route-target import 1:1
exit-address-family

Вот конфигурация на ASBR для профиля 17:

interface Ethernet0/0
ip address 10.3.1.3 255.255.255.0
ip pim sparse-mode
mpls ip
mpls bgp forwarding
end

Примечание: Конфигурация IP mpls требуется на ссылке между ASBR для имения соседства MLDP между ними.

Вот конфигурация на RRs для профиля 17:

router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.1 remote-as 1
neighbor 10.100.1.1 update-source Loopback0
neighbor 10.100.1.3 remote-as 1
neighbor 10.100.1.3 update-source Loopback0
neighbor 10.100.1.8 remote-as 2
neighbor 10.100.1.8 ebgp-multihop 244
neighbor 10.100.1.8 update-source Loopback0
!
address-family ipv4
neighbor 10.100.1.1 activate
neighbor 10.100.1.1 route-reflector-client
neighbor 10.100.1.1 send-label
neighbor 10.100.1.3 activate
neighbor 10.100.1.3 route-reflector-client
neighbor 10.100.1.3 send-label
no neighbor 10.100.1.8 activate
exit-address-family
!
address-family ipv4 mvpn
neighbor 10.100.1.1 activate
neighbor 10.100.1.1 send-community extended
neighbor 10.100.1.1 route-reflector-client
neighbor 10.100.1.8 activate
neighbor 10.100.1.8 send-community extended
exit-address-family
!     
address-family vpnv4
neighbor 10.100.1.1 activate
neighbor 10.100.1.1 send-community extended
neighbor 10.100.1.1 route-reflector-client
neighbor 10.100.1.3 activate
neighbor 10.100.1.3 send-community extended
neighbor 10.100.1.3 route-reflector-client
neighbor 10.100.1.8 activate
neighbor 10.100.1.8 send-community extended
neighbor 10.100.1.8 next-hop-unchanged
exit-address-family
!

Представьте 12 конфигураций

Эта конфигурация совпадает с, который использовал для профиля 17, но существует дополнительная C-групповая-адресация, сигнализирующая BGP.

Вот конфигурация на Периферийных маршрутизаторах для профиля 12:

vrf definition one
rd 1:2
!
address-family ipv4
mdt auto-discovery mldp inter-as
mdt default mpls mldp p2mp
mdt data mpls mldp 100
mdt overlay use-bgp
route-target export 1:1
route-target import 1:1
exit-address-family

Профили с MLDP разделенный MDT

В этом разделе описываются конфигурацию для профиля 14.

Представьте 14 конфигураций

Вот конфигурация на Периферийных маршрутизаторах для профиля 14:

vrf definition one
rd 1:2
!
address-family ipv4
mdt auto-discovery mldp inter-as
mdt default mpls mldp p2mp
mdt data mpls mldp 100
mdt overlay use-bgp
route-target export 1:1
route-target import 1:1
exit-address-family

Вот конфигурация на ASBR для профиля 14:

interface Ethernet0/0
ip address 10.3.1.3 255.255.255.0
ip pim sparse-mode
mpls ip
mpls bgp forwarding

Примечание: Ip mpls требуется на ссылке между ASBR для имения соседства MLDP между ними.

Вот конфигурация на RRs для профиля 14:

router bgp 1
bgp log-neighbor-changes
neighbor 10.100.1.1 remote-as 1
neighbor 10.100.1.1 update-source Loopback0
neighbor 10.100.1.3 remote-as 1
neighbor 10.100.1.3 update-source Loopback0
neighbor 10.100.1.8 remote-as 2
neighbor 10.100.1.8 ebgp-multihop 244
neighbor 10.100.1.8 update-source Loopback0
!
address-family ipv4
neighbor 10.100.1.1 activate
neighbor 10.100.1.1 route-reflector-client
neighbor 10.100.1.1 send-label
neighbor 10.100.1.3 activate
neighbor 10.100.1.3 route-reflector-client
neighbor 10.100.1.3 send-label
no neighbor 10.100.1.8 activate
exit-address-family
!
address-family ipv4 mvpn
neighbor 10.100.1.1 activate
neighbor 10.100.1.1 send-community extended
neighbor 10.100.1.1 route-reflector-client
neighbor 10.100.1.8 activate
neighbor 10.100.1.8 send-community extended
exit-address-family
!     
address-family vpnv4
neighbor 10.100.1.1 activate
neighbor 10.100.1.1 send-community extended
neighbor 10.100.1.1 route-reflector-client
neighbor 10.100.1.3 activate
neighbor 10.100.1.3 send-community extended
neighbor 10.100.1.3 route-reflector-client
neighbor 10.100.1.8 activate
neighbor 10.100.1.8 send-community extended
neighbor 10.100.1.8 next-hop-unchanged
exit-address-family
!

CsC

Эта информация предоставлена под предположением, что правильная конфигурация внедрена на маршрутизаторах для имения Носителя Носителя (CsC) MPLS VPN, в рабочем состоянии для индивидуальной рассылки.

Только профиль 0 поддерживается для CsC. Это означает, что может быть иерархический CsC с поддерживающими групповую адресацию VPN. VPN CsC имеет профиль MVPN 0 настроенных. Сеть Носителя имеет профиль MVPN 0 настроенных также. Это означает, что существует обычная mVPN конфигурация на Периферийных маршрутизаторах CSC CsC и на Периферийных маршрутизаторах Носителя, и затем нет никакой дополнительной настройки, необходимой для групповой адресации.

Проверка

В настоящее время для этой конфигурации нет процедуры проверки.

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.



Document ID: 118985