Многопротокольная коммутация по меткам (MPLS) : MPLS

Унифицированная функциональность MPLS, функции и Пример конфигурации

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв

Введение

Этот документ описывает Унифицированную Многопротокольную коммутацию по меткам (MPLS), которая является всем о масштабировании. Это служит основой технологических решений для обеспечения простого сквозного трафика и/или сервисов по традиционно сегментированной инфраструктуре. Это использует и преимущества иерархической инфраструктуры, поскольку это улучшает масштабируемость и простоту организации сети.

Внесенный Атэхэром Ханом и Садхиром Кумаром, специалистами службы технической поддержки Cisco.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Настройка

Развитие сети

При рассмотрении истории сетевых пакетных сервисов затем изменение в сетевых бизнес-ценностях может наблюдаться. Это идет от дискретных улучшений возможности подключения для подавания заявок, максимально быстрых к технологиям совместной работы для поддержки мобильной совместной работы. Наконец, по требованию облачные сервисы начаты с сервисов приложения, чтобы оптимизировать программные средства, используемые с организацией, и улучшить устойчивость и стоимость владения.


Рис. 1

Это непрерывное усовершенствование значения и функциональности сети приводит к намного более распространяющейся потребности в сетевой простоте, управляемости, интеграции и устойчивости, где сети были сегментированы в результате разделенных в рабочем состоянии островов и никакого реального контроля за сквозным путем. Теперь существует потребность объединить все это с единой архитектурой, которой просто управлять, предоставляет масштабируемость 100,000's узлов и использует текущие технологии Высокой доступности и Быстрой конвергенции. Это - то, что Унифицированный MPLS приносит к таблице, которая является сегментированной сетью в одиночный уровень управления и видимость сквозного пути.

Требования современной сети

  • Требование пропускной способности увеличения (Видео)
  • Увеличьте сложность приложений (Облако и виртуализация)
  • Потребность увеличения в конвергенции (Мобильность)

Как можно упростить операции MPLS во все более и более больших сетях с большим количеством требований сложного приложения?

Традиционные проблемы MPLS с другими технологиями доступа

  • Сложность для достижения 50 конвергенций миллисекунды с Регулированием трафика Fast ReRoute (FRR TE)
  • Потребность в сложных протоколах маршрутизации и взаимодействии с Протоколами Уровня 2
  • Раздельные большие сети в домены, в то время как услуги предоставлены от начала до конца
  • Общая сквозная конвергенция и механизмы упругости
  • Устранение неполадок и условие от начала до конца по составным доменам

Унифицированная привлекательность MPLS суммирована в этом списке:

  • Сокращенное количество в рабочем состоянии точек.
    • В общих транспортных платформах сервис должен быть настроен на каждом сетевом элементе через В рабочем состоянии Точки. Система управления должна знать топологию.
    • В Унифицированном MPLS, с интеграцией всех островов MPLS, достигнут минимальный номер В рабочем состоянии Точек.
  • Возможность легко обеспечить сервисы: Уровень 3 (L3) VPN, Действительная частная проводная связь (VPWS), служба виртуальной локальной частной сети (VPLS), без сшивания pseudowire (PW-сшивание) или механизмы InterAS. С введением MPLS в агрегации избегают некоторой статичной конфигурации, который создает Острова MPLS.
  • Предоставьте сквозной транспорт MPLS.
  • Поддержите области Протокола IGP разделенные и маленькие таблицы маршрутизации.
  • Быстрая конвергенция.
  • Простой настроить и устранить неполадки.
  • Возможность интегрироваться с любой технологией доступа.
  • Готовность IPv6.

Cisco унифицированный MPLS

Унифицированный MPLS определен добавлением дополнительных функций с классическим/традиционным MPLS, и это дает больше масштабируемости, безопасности, простоты и управляемости. Для предоставления услуг MPLS от начала до конца, сквозной Маркированный путь коммутаторов (LSP) необходим. Цель состоит в том, чтобы поддержать сервисы MPLS (MPLS VPN, L2VPN MPLS), как они, но представляют большую масштабируемость. Чтобы сделать это, переместите некоторые префиксы IGP в Протокол BGP (петлевые префиксы маршрутизаторов Границы провайдера (PE)), который тогда распределяет префиксы от начала до конца.


Рис. 2

Перед Cisco обсуждена Унифицированная архитектура MPLS, важно понять ключевые характеристики, используемые, чтобы сделать это реальностью.

Функции и компоненты

Информация о метке переноса в BGP4 (RFC 3107)

Это - предпосылка для имения масштабируемого метода для обмена префиксами между сегментами сети. Вы могли просто объединить IGPs (Протокол OSPF, Обмен информацией между промежуточными системами (IS-IS) или Протокол EIGRP) в одиночный домен. Однако, IGP не разработан для переноса 100,000 с префиксов. Предпочтительный протокол с этой целью является BGP. Это - хорошо доказанный протокол, который поддерживает Интернет с 100,000's маршрутов и сред MPLS-VPN с миллионами записей. Cisco Унифицированный MPLS использует BGP4 с обменом данными метки (RFC3107). Когда BGP распределяет маршрут, он может также распределить MPLS label, который сопоставлен с тем маршрутом. Данные сопоставления MPLS label для маршрута переносят в сообщении Обновления BGP, которое содержит информацию о маршруте. Если следующий переход не изменен, метка сохранена и изменения метки, если изменяется следующий переход. В Унифицированном MPLS следующий переход изменяется в Пограничных маршрутизаторах области (ABR).

Когда вы, которых RFC enable 3107 на обоих маршрутизаторах под управлением BGP, маршрутизаторы объявляют друг другу, что они могут тогда передать Mpls label с маршрутами. Если маршрутизаторы успешно выполняют согласование о своей возможности передать Mpls label, маршрутизаторы добавляют Mpls label ко всем исходящим Обновлениям BGP.

Обмен метки необходим, чтобы хранить информацию сквозного пути между сегментами. В результате каждый сегмент становится достаточно маленьким для управления операторами и в то же время существует информация о канале, распределенная для осведомленности пути между двумя другими динамиками IP.

Принципы работы?


Рис. 3

На рисунке 3 вы видите, что существует три сегмента с Протоколом обнаружения Метки, который Маркированному Пути Коммутаторов (LSP LDP) и доступ к сети не включали LDP. Цель состоит в том, чтобы присоединиться к ним вместе так, чтобы был одиночный путь MPLS (Внутренний BGP (iBGP) hierarchal LSP) между Предварительной агрегацией (Pre-Agg) Узлы. Поскольку сетью является одиночная Автономная система (AS) BGP, все сеансы являются сеансами IBGP. Каждый сегмент выполняет свой собственный IGP (OSPF, IS-IS или EIGRP) и пути LSP LDP в домене IGP. В Cisco Унифицированный MPLS, маршрутизаторы (ABR), которые присоединяются к сегментам, должен быть BGP встроенные рефлекторы маршрута с Next-Hop-Self и RFC 3107 для переноса IPv4 + Метка, настроенная на сеансах. Эти динамики BGP являются в Cisco Унифицированной архитектурой MPLS, на которую ссылаются к как ABR.

Почему являются ABR встроенными рефлекторами маршрута?

Одна из целей Унифицированного MPLS состоит в том, чтобы иметь хорошо масштабируемую сквозную инфраструктуру. Таким образом каждый сегмент должен быть сохранен простым для работы. Все peerings являются iBGP peerings, поэтому существует потребность в полной сетке peerings между всеми динамиками iBGP в полной сети. Если существуют тысячи динамиков BGP, это приводит к очень непрактичной сетевой среде. Если ABR сделаны рефлекторами маршрута, количество однорангового телефонного соединения IBGP сокращено к количеству динамиков BGP 'на сегмент' вместо между 'всеми' динамиками BGP завершенного AS.

Почему Next-Hop-Self?

BGP воздействует на ядро поисков рекурсивной маршрутизации. Это сделано для размещения масштабируемости в базовом IGP, который используется. Для рекурсивного поиска BGP использует Следующий переход, подключенный для каждой записи маршрута BGP. Таким образом, например, если Исходный узел требует передать пакет к Узлу - адресату и если пакет поражает маршрутизатор под управлением BGP, то маршрутизатор под управлением BGP делает поиск маршрутизации в своей таблице маршрутизации BGP. Это находит маршрут к Узлу - адресату и находит Следующий переход как следующий шаг. Этот Следующий переход должен быть известен базовым IGP. Как заключительный шаг, маршрутизатор под управлением BGP передает пакет, и далее основанный на IP и информации о Mpls label, подключенной к тому Следующему переходу.

Чтобы удостовериться, что в каждом сегменте только Следующие переходы необходимы для знания IGP, необходимо, чтобы Следующий переход, подключенный к записи BGP, был в сегменте сети а не в соседнем узле или еще дальше сегменте. Если вы переписываете BGP Next-Hop с функцией Next-Hop-Self, гарантируете, что Следующий переход в локальном сегменте.

Обобщение изложенного


Рис. 4

Рисунок 4 предоставляет пример того, как VPN L3 снабжает префиксом и маркирует обмен, работает и как стек MPLS label создан для имения информации о сквозном пути для трафика между обоими PE.

Сеть разделена как три независимых домена IGP/LDP. Уменьшенный размер маршрутизации и таблиц пересылки на маршрутизаторах должен включить лучшую устойчивость и более быструю конвергенцию. LDP используется для построения внутридоменных LSP в доменах. RFC 3107 BGP IPv4 + метки используются в качестве междоменного протокола распределения меток для построения иерархических LSP BGP по доменам. BGP3107 вставляет одну дополнительную метку в передающий стек меток в Унифицированной архитектуре MPLS.

Intradomain - LSP LDP

Междоменный - BGP иерархический LSP


Рис. 5

Префикс VPN объявленного PE31 к PE11 с сервисной меткой 30 L3VPN и следующим переходом как loopback PE31 через сквозной междоменный иерархический LSP BGP. Теперь, посмотрите на путь переадресации для префикса VPN от PE11 до PE31.

  • На PE11 Префикс A известен через сеанс BGP с PE31 как следующий переход, PE31 и PE31 рекурсивно достижимы через P1 с полученным IPv4 метки 100. PE11 BGP + информация о Метке от P1 как Обновления BGP, потому что это включено с функцией RFC 3107 для передачи IPv4 + информация о Метке.
  • P1 достижим от PE11 через внутридоменный LSP LDP, и это добавляет другую метку LDP поверх метки BGP. Наконец, пакет выходит из узла PE11 с тремя метками. Например, 30 сервисных меток L3VPN, 100 меток BGP и 200 меток IGP LDP.
  • Метка вершины LDP продолжает загружать внутридоменный LSP LDP, и пакет достигает P1 с двумя метками после Вытеснения предпоследней пересылки (PHP).
  • P1 настроен как встроенный Рефлектор маршрута (RR) со следующим переходом сам, и это присоединяется к двум доменам IGP или LSP LDP.
  • На P1 следующий переход для PE31 изменен на P2, и обновление получено через BGP с IPv4 + Метка (RFC3107). Метка BGP подкачана с новой меткой, потому что следующий переход изменен, и метка IGP выдвинута на вершине.
  • Пакет выходит из узла P1 с тремя метками, и сервисная метка 30 является нетронутой. Т.е. 30 сервисных меток L3VPN, 101 метка BGP и 201 метка LDP.
  • Метка вершины LDP загружает внутридоменный LSP LDP, и пакет достигает P2 с двумя метками после PHP.
  • На P2 следующий переход для PE31 изменен снова, и это достижимо через IGP. Метка BGP удалена, поскольку неявно-пустая метка BGP получена от PE31 для PHP.
  • Пакет уезжает с двумя метками. Например, 30 сервисных меток L3VPN и 110 меток LDP.
  • На PE31 пакет поступает с одной меткой после PHP метки LDP и на основе сервисной метки 30. Пакет без метки передан назначению CE31 под Виртуальной маршрутизацией и Передачей (VRF).

То, когда вы посмотрели на стек MPLS label, коммутацию пакета между устройствами источника и получателя, основанными на предыдущем префиксе, и маркируете обмен, наблюдается в коммутируемой среде MPLS.


Рис. 6

BGP независимая от префикса конвергенция (PIC BGP)

Это - технология Cisco, которая используется в сценариях отказов BGP. Сеть сходится без потери традиционных секунд в повторном схождении BGP. Когда PIC BGP используется, большинство сценариев отказов может быть уменьшено до времени повторного схождения ниже 100 мс.

Как это сделано?

Традиционно, когда BGP обнаруживает сбой, он повторно вычисляет для каждой записи BGP для оптимального пути. Когда существует таблица маршрутизации с тысячами записей маршрута, это может взять заметное количество времени. Кроме того, этот маршрутизатор под управлением BGP должен распределить все те новые оптимальные пути каждому из его соседних узлов для информирования им об измененной топологии сети и измененных лучших путях. Как заключительный шаг, каждый из динамиков BGP получателя должен сделать вычисление оптимального пути для обнаружения новых оптимальных путей.

Каждый раз, когда первый динамик BGP обнаруживает что-то не так, это запускает вычисление оптимального пути, пока динамики BGP всего окружения не сделали свой перерасчет, трафик мог бы быть отброшен.


Рис. 7

PIC BGP для IP и функции MPLS VPN улучшает согласование BGP после ошибки сети. Эта конвергенция применима, чтобы и удалить сердцевину и ограничить сбои и может использоваться и в IP и в сетях MPLS. PIC BGP для IP и функции MPLS VPN создает и хранит резервную копию/альтернативный путь в Routing Information Base (RIB), базе данных переадресации (FIB) и технологии CEF так, чтобы, когда сбой обнаружен, резервная копия/альтернативный путь могла сразу вступить во владение, таким образом это включает быстрое аварийное переключение.

С одиночной перезаписью информации о следующем переходе восстановлен трафик. Дополнительно сетевое согласование BGP происходит в фоновом режиме, но на трафики не влияют больше. Эта перезапись происходит в течение 50 мс. При использовании этой технологии схождение сети уменьшено до от секунд до 50 мс плюс конвергенция IGP.

Добавлять-путь BGP

Добавлять-путь BGP является улучшением о том, как записи BGP переданы между динамиками BGP. Если на определенном, некоторый динамике BGP существуют больше, чем одиночная запись к определенному, некоторый назначению, то тот динамик BGP только передает запись, которая является ее оптимальным путем для того назначения ее соседним узлам. Результат состоит в том, что никакие условия не сделаны для разрешения рекламы разнообразных путей для того же назначения.

Добавлять-путь BGP является функцией BGP для разрешения больше как только оптимальный путь и позволяет разнообразные пути для того же назначения без новых путей, неявно заменяющих любые предыдущие. Это расширение к BGP особенно важно для помощи с PIC BGP, когда рефлекторы маршрута BGP используются, так, чтобы у других динамиков BGP в AS был доступ к большему количеству путей BGP как просто 'Лучший путь BGP' в соответствии с рефлектором маршрута.

Замены исключающего зацикливания и rLFA для Быстрой конвергенции IGP

Операции для достижения восстановления с 50 миллисекундами после ссылки или сбоя узла могут быть упрощены существенно с введением новой технологии, названной заменами исключающего зацикливания (LFAs). LFA улучшает протоколы маршрутизации на основе состояния соединений (IS-IS и OSPF) для обнаружения путей формирования резервных маршрутов способом исключающего зацикливания. Если смежность (узел сети или ссылка) отказывает, LFA позволяет каждому маршрутизатору определять и использовать предопределенный резервный путь. Для отправки в 50 раз мсека восстановление в случае ссылки или сбоев узла, FRR MPLS TE может быть развернут. Однако это требует добавления другого протокола (Протокол резервирования ресурсов (RSVP) или RSVP) для настройки и управления Туннелей TE. В то время как это могло бы быть необходимо для управления пропускной способностью, операция защиты и восстановления не требует управления пропускной способностью. Следовательно, издержки, привязанные к добавлению TE RSVP, считают высокими для простой защиты ссылок и узлов.

LFA может предоставить простой и легкий способ без развертываний TE RSVP в таких сценариях. В результате этих способов сегодняшние соединенные маршрутизаторы в крупномасштабных сетях могут отправить 50 мсеков восстановление для ссылки и сбоев узла без конфигурационного требования для оператора.


Рис. 8

FRR LFA является механизмом, который обеспечивает локальную защиту для трафика с конкретным адресом в IP, MPLS, Ethernet по MPLS (EoMPLS), Инверсивном мультиплексировании по ATM (IMA) по MPLS, Сервисе эмуляции соединений по Packet Switched Network (CESoPSN) по MPLS и Агностическом структурой Мультиплексировании с разделением по времени по Пакету (SAToP) по сетям MPLS. Однако некоторая топология (такая как топология кольца) требует защиты, которая не предоставлена одним только FRR LFA. Удаленная функция FRR LFA полезна в таких ситуациях.

Удаленный FRR LFA расширяет основное поведение FRR LFA к любой топологии. Это передает трафик вокруг неисправного узла к удаленному LFA, который является несколькими переходами далеко. На рисунке 9, если ссылка между C1 и C2 не в состоянии достигать A1 тогда, C2 передает пакет по направленному сеансу LDP к C5, который имеет достижимость к A1.


Рис. 9

В Удаленном FRR LFA узел динамично вычисляет свой узел LFA. После того, как альтернативный узел определен (который непосредственно не связан), узел автоматически устанавливает направленный сеанс Протокола распределения меток (LDP) к альтернативному узлу. Направленный сеанс LDP обменивается метками для определенного прямого исправления ошибок (FEC).

Когда ссылка отказывает, укладка метки использования узла для туннелирования трафика к удаленному узлу LFA, для передачи трафика назначению. Все обмены метки и туннелирующий к удаленному узлу LFA являются динамичными в природе, и предварительная инициализация не требуется. Целый обмен метки и механизм туннелирования являются динамичными и не включают ручной инициализации.

Для внутридоменных LSP удаленный FRR LFA используется для трафика MPLS индивидуальной рассылки в топологиях кольца. Удаленный FRR LFA предварительно вычисляет резервный путь для каждого префикса в таблице маршрутизации IGP, которая позволяет узлу быстро переключаться к резервному пути, когда встречаются со сбоем. Это предоставляет времена восстановления на заказе 50 мс.

Cisco унифицированный пример архитектуры MPLS

Когда все предыдущие программные средства и функции соединены в сетевой среде, она создает Cisco Унифицированная среда сети MPLS. Это - пример архитектуры для крупных поставщиков услуг.


Рисунок 10

  • Ядро и Агрегация организованы как отдельные домены IGP/LDP.
  • Междоменные иерархические LSP на основе RFC 3107, IPv4 BGP + Метки, которые расширены на Pre-agg.
  • Внутридоменные LSP на основе LDP.
  • Междоменные LSP Ядра/Агрегации расширены в Доступах к сети распределением Протокола внутреннего шлюза сетей с радиодоступом (ВЫПОЛНИЛ IGP) в междоменный iBGP, и распределите необходимые маркированные префиксы iBGP (MPC (Мобильное Пакетное ядро), шлюз) в ВЫПОЛНИЛ IGP (через атрибуты BGP-community).

Унифицированный пример конфигурации MPLS

Здесь ia упрощенный пример Унифицированного MPLS.

Базовый пограничный маршрутизатор области - Cisco IOS� XR

Предварительная агрегация и маршрутизатор/шлюзы ретрансляционной станции - Cisco IOS


Рисунок 11

200:200Сообщество MPC
300:300Сообщество агрегации

Базовый домен IGPУровень 2 ISIS
Домен IGP агрегацииУровень 1 ISIS
Домен IGP доступаOSPF 0 областей

Базовая конфигурация пограничного маршрутизатора области


Рисунок 12

! IGP Configuration
router isis core-agg
net 49.0100.1010.0001.0001.00
address-family ipv4 unicast
metric-style wide
propagate level 1 into level 2 route-policy drop-all ! Disable L1 to L2 redistribution
!
interface Loopback0
ipv4 address 10.10.10.1 255.255.255.255
passive
!
interface TenGigE0/0/0/0                                              
!
interface TenGigE0/0/0/1                                             
circuit-type level-2-only                  ! Core facing ISIS L2 Link

!
interface TenGigE0/0/0/2                 
circuit-type level-1                    ! Aggregation facingis ISIS L1 Link

  !
route-policy drop-all
drop
end-policy
 
! BGP Configuration

router bgp 100
bgp router-id 10.10.10.1
address-family ipv4 unicast
allocate-label all                           ! Send labels with BGP routes
!
session-group infra
remote-as 100
cluster-id 1001
update-source Loopback0
!
neighbor-group agg                          
use session-group infra
address-family ipv4 labeled-unicast      
  route-reflector-client                                                                    

  route-policy BGP_Egress_Filter out      ! BGP Community based Egress filtering

  next-hop-self
!
neighbor-group mpc
use session-group infra
address-family ipv4 labeled-unicast      
  route-reflector-client
  next-hop-self
!
neighbor-group core
use session-group infra                                
address-family ipv4 labeled-unicast      
  next-hop-self

community-set Allowed-Comm
200:200,                        
300:300,                          
!
route-policy BGP_Egress_Filter
if community matches-any Allowed-Comm then      
  pass

Конфигурация перед агрегацией


Рисунок 13

interface Loopback0
ipv4 address 10.10.9.9 255.255.255.255
!
interface Loopback1
ipv4 address 10.10.99.9 255.255.255.255

! Pre-Agg IGP Configuration

router isis core-agg
net 49.0100.1010.0001.9007.00
is-type level-1                    ! ISIS L1 router
metric-style wide
passive-interface Loopback0                          ! Core-agg IGP loopback0

!RAN Access IGP Configuration

router ospf 1
router-id 10.10.99.9
redistribute bgp 100 subnets route-map BGP_to_RAN   ! iBGP to RAN IGP redistribution
network 10.9.9.2 0.0.0.1 area 0
network 10.9.9.4 0.0.0.1 area 0
network 10.10.99.9 0.0.0.0 area 0                
distribute-list route-map Redist_from_BGP in          Inbound filtering to prefer
     labeled BGP learnt prefixes


ip community-list standard MPC_Comm permit 200:200
!
route-map BGP_to_RAN permit 10               ! Only redistribute prefixes
     marked with
MPC community
match community MPC_Comm
set tag 1000
route-map Redist_from_BGP deny 10
match tag 1000
!
route-map Redist_from_BGP permit 20


! BGP Configuration
router bgp 100
bgp router-id 10.10.9.10
bgp cluster-id 909
neighbor csr peer-group
neighbor csr remote-as 100
neighbor csr update-source Loopback100               ! Cell Site - Routers RAN IGP
     loopback100
as source
neighbor abr peer-group
neighbor abr remote-as 100
neighbor abr update-source Loopback0                 ! Core POP ABRs - core-agg IGP
     loopback0 as source

neighbor 10.10.10.1 peer-group abr
neighbor 10.10.10.2 peer-group abr
neighbor 10.10.13.1 peer-group csr
!
address-family ipv4
bgp redistribute-internal
network 10.10.9.10 mask 255.255.255.255 route-map AGG_Comm  ! Advertise with
     Aggregation Community (100:100)

redistribute ospf 1                      ! Redistribute RAN IGP prefixes
neighbor abr send-community
neighbor abr next-hop-self

neighbor abr send-label                             ! Send labels with BGP routes
neighbor 10.10.10.1 activate
neighbor 10.10.10.2 activate
exit-address-family
!
route-map AGG_Comm permit 10
set community 300:300

Ретрансляционная станция шлюз (CSG) конфигурация


Рисунок 14

interface Loopback0
ip address 10.10.13.2 255.255.255.255

! IGP Configuration
router ospf 1
router-id 10.10.13.2
network 10.9.10.0 0.0.0.1 area 0
network 10.13.0.0 0.0.255.255 area 0
network 10.10.13.3 0.0.0.0 area 0                

Конфигурация MTG


Рисунок 15

Interface lookback0
ip address 10.10.11.1 255.255.255.255
 
! IGP Configuration
router isis core-agg
is-type level-2-only             ! ISIS L2 router
net 49.0100.1010.0001.1001.00
address-family ipv4 unicast
metric-style wide
 
! BGP Configuration
router bgp 100
bgp router-id 10.10.11.1
address-family ipv4 unicast
network 10.10.11.1/32 route-policy MPC_Comm  ! Advertise Loopback-0 with MPC Community
allocate-label all                           ! Send labels with BGP routes
!
session-group infra

remote-as 100
update-source Loopback0
!
neighbor-group abr
use session-group infra
address-family ipv4 labeled-unicast
  next-hop-self
!
neighbor 10.10.6.1
use neighbor-group abr
!
neighbor 10.10.12.1
use neighbor-group abr
 
community-set MPC_Comm
200:200
end-set
!
route-policy MPC_Comm
set community MPC_Comm
end-policy

Проверка.

Петлевой префикс Мобильного пакета шлюза (MPG) является 10.10.11.1/32, так, чтобы префикс представлял интерес. Теперь, посмотрите на то, как пакеты переданы от CSG до MPG.

Префикс MPC 10.10.11.1 известен маршрутизатору CSG от Pre-agg с тегом маршрута 1000, и это может быть передано как помеченный пакет с исходящей меткой 31 LDP (intra доменный LSP LDP). В то время как перераспределение находится в OSPF, сообщество MPC 200:200 было сопоставлено с тегом маршрута 1000 в узле Pre-agg.

Выходные данные узла CSG

CSG#sh mpls forwarding-table 10.10.11.1 detail
Local    Outgoing  Prefix         Bytes Label Outgoing  Next Hop  
Label    Label    or Tunnel Id    Switched    interface            
34        31        10.10.11.1/32  0           Vl40      10.13.1.0  
      MAC/Encaps=14/18, MRU=1500, Label Stack{31}

Выходные данные узла Pre-Agg

В узле Pre-agg префикс MPC перераспределен от BGP до, ВЫПОЛНИЛ процесс OSPF доступа с основанным на сообществе фильтрованием, и процесс OSPF перераспределен в BGP. Это управляемое перераспределение необходимо для создания сквозного IP reachabilty, в то же время каждый сегмент имеет минимальные требуемые маршруты.

Префикс 10.10.11.1/32 известен через hierarichal BGP 100 с MPC 200:200 подключенное сообщество. 16020 меток BGP 3107, полученных от базового Пограничного маршрутизатора области (ABR) и метки 22 LDP, добавлены на вершине для внутридомена, передавая после следующего перехода рекурсивный поиск.

Pre-AGG1#sh ip route 10.10.11.1
Routing entry for 10.10.11.1/32
Known via "bgp 100", distance 200, metric 0, type internal
Redistributing via ospf 1
Advertised by ospf 1 subnets tag 1000 route-map BGP_TO_RAN
Routing Descriptor Blocks:
* 10.10.10.2, from 10.10.10.2, 1d17h ago
    Route metric is 0, traffic share count is 1
    AS Hops 0
    MPLS label: 16020

Pre-AGG1#sh bgp ipv4 unicast 10.10.11.1
BGP routing table entry for 10.10.11.1/32, version 116586
Paths: (2 available, best #2, table default)
Not advertised to any peer
Local
  <SNIP>
Local
  10.10.10.2 (metric 30) from 10.10.10.2 (10.10.10.2)
    Origin IGP, metric 0, localpref 100, valid, internal, best
    Community: 200:200
    Originator: 10.10.11.1, Cluster list: 0.0.3.233, 0.0.2.89
    mpls labels in/out nolabel/16020

Pre-AGG1#sh bgp ipv4 unicast labels
  Network        Next Hop    In label/Out label
  10.10.11.1/32 10.10.10.1  nolabel/16021
                  10.10.10.2  nolabel/16020

Pre-AGG1#sh mpls forwarding-table 10.10.10.2 detail
Local    Outgoing  Prefix          Bytes Label  Outgoing  Next Hop  
Label    Label    or Tunnel Id    Switched    interface            
79        22        10.10.10.2/32 76109369    Vl10      10.9.9.1  
      MAC/Encaps=14/18, MRU=1500, Label Stack{22}

Pre-AGG#sh mpls forwarding-table 10.10.11.1 detail
Local    Outgoing  Prefix          Bytes Label  Outgoing  Next Hop  
Label    Label    or Tunnel Id    Switched    interface            
530      16020    10.10.11.1/32 20924900800  Vl10      10.9.9.1  
      MAC/Encaps=14/22, MRU=1496, Label Stack{22 16020}

Базовые выходные данные узла ABR

Префикс 10.10.11.1 известен через внутридоменный IGP (ISIS-L2) и согласно таблице пересылки MPLS. Это достижимо через LSP LDP.

ABR-Core2#sh ip route 10.10.11.1
Routing entry for 10.10.11.1/32
Known via "isis core-agg", distance 115, metric 20, type level-2
Installed Sep 12 21:13:03.673 for 2w3d
Routing Descriptor Blocks
  10.10.1.0, from 10.10.11.1, via TenGigE0/0/0/0, Backup
    Route metric is 0
  10.10.2.3, from 10.10.11.1, via TenGigE0/0/0/3, Protected
    Route metric is 20
No advertising protos.

Для распределения префиксов между сегментированными областями используется BGP с меткой (RFC 3107). Какие потребности находиться все еще в сегментированных областях IGP loopback PE и адресов, отнесенных к центральной инфраструктуре.

Маршрутизаторы под управлением BGP, которые подключают различные области вместе, являются ABR, которые действуют как Рефлектор маршрута BGP. Эти устройства используют функцию Next-Hop-Self, во избежание потребности иметь все Следующие переходы завершенной Автономной системы в IGP, вместо только IP-адресов PE и центральной инфраструктуры. Обнаружение петли завершено основанное на Кластерных ID BGP.

Для Сетевой упругости PIC BGP с BGP Добавляет опцию Пути, должен использоваться с BGP и LFA с IGP. Эти функции не использованы в предыдущем примере.

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.

Дополнительные сведения


Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Document ID: 118846