Безопасность : Защищенный мобильный клиент Cisco AnyConnect Secure Mobility

Проверка подлинности с помощью secureid RSA для клиентов AnyConnect на примере конфигурации головной станции Cisco IOS

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (6 ноября 2015) | Отзыв

Введение

Этот документ описывает, как настроить устройство Cisco IOS® для аутентификации клиентов AnyConnect с Одноразовыми паролями (OTP) и использование сервера SecurID алгоритма цифровой подписи райвеста шамира адлемана (RSA).

Примечание: Аутентификация OTP не работает на версии Cisco IOS, которые не имеют исправления для запросов на расширение CSCsw95673 и CSCue13902.

Внесенный Атри Basu, специалист службы технической поддержки Cisco, и Вазави Иэллампалли, разработка Cisco.

Предварительные условия

Требования

Компания Cisco рекомендует предварительно ознакомиться со следующими предметами:

  • Настройка Сервера RSA SecurID
  • Конфигурация SSLVPN на головной станции Cisco IOS
  • WEB-VPN

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного обеспечения и оборудования:

  • CISCO2951/K9
  • Программное обеспечение Cisco IOS, программное обеспечение C2951 (C2951-UNIVERSALK9-M), версия 15.2 (4) M4, РЕЛИЗ ПРОГРАММНОГО ОБЕСПЕЧЕНИЯ (fc1)

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Общие сведения

Несмотря на то, что клиент AnyConnect всегда поддерживал основанную на OTP аутентификацию до исправления для идентификатора ошибки Cisco CSCsw95673, головная станция Cisco IOS не обработала Challenge - сообщения доступа к серверу RADIUS. После приглашения первоначального входа в систему (где пользователи вводят свои "постоянные" имена пользователя и пароли), RADIUS передает сообщение "проблемы Доступа" к шлюзу Cisco IOS, который просит, чтобы пользователи ввели свой OTP:

 RADIUS/ENCODE: Best Local IP-Address 10.7.7.1 for Radius-Server 10.7.7.129
 RADIUS(0000001A): Sending a IPv4 Radius Packet
 RADIUS(0000001A): Send Access-Request to 10.7.7.129:1812 id 1645/17,len 78
 RADIUS: authenticator C3 A1 B9 E1 06 95 8C 65 - 7A C3 01 70 E1 E1 7A 3A
 RADIUS: User-Name          [1]  6  "atbasu"
 RADIUS: User-Password      [2]  18 *
 RADIUS: NAS-Port-Type      [61] 6  Virtual                  [5]
 RADIUS: NAS-Port           [5]  6  6
 RADIUS: NAS-Port-Id        [87] 16 "203.0.113.238"
 RADIUS: NAS-IP-Address     [4]  6  10.7.7.1
 RADIUS(0000001A): Started 5 sec timeout
 RADIUS: Received from id 1645/17 10.7.7.129:1812, Access-Challenge, len 65
 RADIUS: authenticator 5D A3 A6 9D 1A 38 E2 47 - 37 E8 EF A8 18 94 25 1C
 RADIUS: Reply-Message      [18] 37
 RADIUS:  50 6C 65 61 73 65 20 65 6E 74 65 72 20 79 6F 75 [Please enter you]
 RADIUS:  72 20 6F 6E 65 2D 74 69 6D 65 20 70 61 73 73 77 [r one-time passw]
 RADIUS:  6F 72 64              [ ord]
 RADIUS: State              [24] 8
 RADIUS:  49 68 36 76 38 7A           [ Ih6v8z]

На этом этапе клиент AnyConnect, как ожидают, покажет дополнительное всплывающее окно, что пользователи запросов для их OTP, но так как устройство Cisco IOS не обработало Challenge - сообщение доступа, это, никогда не происходят, и клиент сидит сложа руки до времен соединения.

Однако с Version15.2 (4) M4, устройства Cisco IOS должны быть в состоянии обработать основанный на проблеме механизм аутентификации.

Настройка

Схема сети

Одно из различий между Устройством адаптивной защиты (ASA) и головными станциями Cisco IOS - то, что маршрутизатор Cisco IOS/switches/Access Точки (AP) только поддерживает RADIUS и TACACS. Они не поддерживают SDI частного протокола RSA, сервер RSA, однако, поддерживает и SDI и RADIUS. Поэтому для использования аутентификации OTP на головной станции Cisco IOS, устройство Cisco IOS должно быть настроено для Протокола RADIUS и сервера RSA как символический сервер RADIUS.

Примечание: Для получения дополнительной информации о различиях между RADIUS и SDI, обратитесь к разделу Теории Символического сервера RSA и Использования Протокола SDI для ASA и ACS. Если SDI требуется, то ASA должен использоваться.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

  1. Настройте метод аутентификации и группу аутентификации, авторизации и учета (AAA):
    aaa new-model
    !
    !
    aaa group server radius OTP-full
    server 10.7.7.129
    !
    aaa group server radius OTP-split
    server 10.7.7.129 auth-port 1812
    !
    aaa authentication login default local
    aaa authentication login webvpn-auth group OTP-split
    aaa authorization exec default local
    aaa authorization network webvpn-auth local
  2. Настройка RADIUS-сервера:
    radius-server host 10.7.7.129 auth-port 1812
    radius-server host 10.7.7.129
    radius-server key Cisco12345
  3. Настройте маршрутизатор для действия как VPN Уровня защищенных сокетов (SSLVPN) сервера:
    crypto pki trustpoint VPN-test2
    enrollment selfsigned
    revocation-check crl
    rsakeypair VPN-test2
    !
    !
    crypto pki certificate chain VPN-test2
    certificate self-signed 02
    3082021B 30820184 A0030201 02020102 300D0609 2A864886 F70D0101 05050030
    29312730 2506092A 864886F7 0D010902 1618494E 4E424545 2D524F30 312E636F
    7270726F 6F742E69 6E74301E 170D3133 30313134 31313434 32365A17 0D323030
    31303130 30303030 305A3029 31273025 06092A86 4886F70D 01090216 18494E4E
    4245452D 524F3031 2E636F72 70726F6F 742E696E 7430819F 300D0609 2A864886
    F70D0101 01050003 818D0030 81890281 8100B03E D15F7D2C DF84855F B1055ACD
    7BE43AAF EEB99472 50477348 45F641C6 5A244CEE 80B2A426 55CA223A 7F4F89DD
    FA0BD882 7DAA24EF 9EA66772 2CC5A065 584B9866 2530B67E EBDE8F57 A5E0FF19
    88C38FF2 D238A136 B32A114A 0187437C 488073E9 0E96FF75 F565D684 987F2CD1
    8CC7F53C 2D419F90 EF4B9678 6BDFCD4B C7130203 010001A3 53305130 0F060355
    1D130101 FF040530 030101FF 301F0603 551D2304 18301680 146B56E9 F770734C
    B0AB7360 B806E9E1 E1E15921 B3301D06 03551D0E 04160414 6B56E9F7 70734CB0
    AB7360B8 06E9E1E1 E15921B3 300D0609 2A864886 F70D0101 05050003 81810006
    0D68B990 4F927897 AFE746D8 4C9A7374 3CA6016B EFFA1CA7 7AAD4E3A 2A0DE989
    0BC09B17 5A4C75B6 D1F3AFDD F97DC74C D8834927 3F52A605 25518A42 9EA454AA
    C5DCBA20 A5DA7C7A 7CEB7FF1 C35F422A 7F060556 647E74D6 BBFE116F 1BF04D0F
    852768C3 2E972EEE DAD676F1 A3941BE6 99ECB9D0 F826C1F6 A944340D 14EA32
    quit
    ip cef
    !
    !
    crypto vpn anyconnect flash0:/webvpn/anyconnect-win-3.1.02026-k9.pkg sequence 1
    !
    interface Loopback1
    ip address 192.168.201.1 255.255.255.0
    !
    interface GigabitEthernet0/0
    description WAN 0/0 VODAFONE WAN
    ip address 203.0.113.63 255.255.255.240
    no ip redirects
    no ip unreachables
    duplex auto
    speed auto
    !
    !
    interface Virtual-Template3
    ip unnumbered Loopback1
    !
    ip local pool SSLVPN-pool 192.168.201.10 192.168.201.250
    !
    webvpn gateway gateway_1
    hostname vpn.cisco.com
    ip address 203.0.113.63 port 443
    http-redirect port 80
    ssl trustpoint VPN-test2
    inservice
    !
    webvpn context webvpn-context
    secondary-color white
    title-color #669999
    text-color black
    virtual-template 3
    aaa authentication list webvpn-auth
    gateway gateway_1
    !
    ssl authenticate verify all
    inservice
    !
    policy group policy_1
    functions svc-enabled
    svc address-pool "SSLVPN-pool" netmask 255.255.255.0
    svc keep-client-installed
    svc split include 192.168.174.0 255.255.255.0
    svc split include 192.168.91.0 255.255.255.0
    default-group-policy policy_1
    !
    end

Примечание: Для больше руководства подробной конфигурации о том, как установить SSLVPN на устройстве Cisco IOS, обратитесь к VPN AnyConnect (SSL) Клиента на Маршрутизаторе IOS с Примером конфигурации CCP.

Проверка

В настоящее время для этой конфигурации нет процедуры проверки.

Устранение неполадок

Для устранения проблем всего процесса проверки подлинности для входящего клиентского соединения AnyConnect можно использовать эти отладки:

  • debug radius authentication
  • debug aaa authentication
  • аутентификация debug webvpn

Средство интерпретации выходных данных (только зарегистрированные клиенты) поддерживает некоторые команды show. Используйте Средство интерпретации выходных данных, чтобы просмотреть анализ выходных данных команды show.

Примечание: Обратитесь к документу Важная информация о командах отладки, прежде чем использовать команды debug.



Document ID: 118778