Протокол IP : Протокол OSPF

OSPF с мультиобластью Adjacency Configuration Example

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв

Введение

Этот документ описывает, как настроить протокол маршрутизации состояния канала Протокола OSPF для мультиобласти Adjacency.

Внесенный Narendra Naukwal, специалистом службы технической поддержки Cisco.

Предварительные условия

Требования

Компания Cisco рекомендует предварительно ознакомиться со следующими предметами:

  • OSPF

  • Мультиобласть Adjacency

Cisco также рекомендует, чтобы эти требования были удовлетворены перед попыткой конфигурации, которая описана в этом документе:

  • Протокол маршрутизации состояния канала OSPF должен быть предварительно сконфигурирован в сети.

  • Только два докладчика OSPF используют интерфейс, между которым работает функциональность мультиобласти OSPF. Мультиобласть OSPF только работает на Двухточечные типы сети.

Используемые компоненты

Сведения в этом документе основываются на мультиобласти OSPF.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Общие сведения

Протокол маршрутизации состояния канала OSPF использует понятия областей, которые являются субдоменами в домене OSPF. Маршрутизатор в области поддерживает завершенную информацию о топологии той области. По умолчанию интерфейс может только принадлежать одной ОБЛАСТИ OSPF. Это может не только вызвать субоптимальную маршрутизацию в сети, но это может также привести к другим проблемам, если сеть не разработана правильно.

Когда мультиобласть Adjacency настроена на интерфейсе, динамики OSPF формируют несколько Смежностей (ADJ) по той ссылке. Интерфейс мультиобласти является логическим, интерфейсом точка-точка, по которому сформирован ADJ. Этот документ описывает ADJ OSPF мультиобласти where сценария, может использоваться, чтобы обойти проблему и встретить требования к сети.

Настройка

Схема сети

В этой схеме сети используется СЕТЬ/ЕОМЕН OSPF. Система требует, чтобы трафик от Маршрутизатора 5 (R5) до R1 (10.1.1.1) всегда прошел через R3. Предположите, что R3 является Межсетевой экран в сети, через которую весь трафик должен маршрутизироваться, или что ссылка между R3 и R4 имеет больше пропускной способности, чем ссылка между R2 и R4. В любом случае система требует, чтобы трафик тек через R3, когда это проходит от R5 до R1 (10.1.1.1/32 префикс).

Начальные конфигурации

В этом разделе описываются начальные конфигурации для R1 через R5.

_________________________ М1

!
interface Ethernet0/0
ip address 192.168.12.1 255.255.255.0
end

!
interface Loopback0
ip address 10.1.1.1 255.255.255.255
end

!
ip route 0.0.0.0 0.0.0.0 192.168.12.2
!

_________________________ М2

!
interface Ethernet0/0
ip address 192.168.12.2 255.255.255.0
end

!
interface Ethernet0/1
ip address 192.168.23.2 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 0
end

!
interface Ethernet0/2
ip address 192.168.24.2 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
end

!
interface Loopback0
ip address 10.2.2.2 255.255.255.255
end

!
ip route 10.1.1.1 255.255.255.255 192.168.12.1

!
router ospf 1
router-id 0.0.0.2
redistribute static metric-type 1 subnets
!

R3

!
interface Ethernet0/0
ip address 192.168.34.3 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
end

!
interface Ethernet0/1
ip address 192.168.23.3 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 0
end

!
interface Loopback0
ip address 10.3.3.3 255.255.255.255
end

!
router ospf 1
router-id 0.0.0.3
!

R4

!
interface Ethernet0/0
ip address 192.168.34.4 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
end

!
interface Ethernet0/1
ip address 192.168.45.4 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
end

!
interface Ethernet0/2
ip address 192.168.24.4 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
end

!
interface Loopback0
ip address 10.4.4.4 255.255.255.255
end

!
router ospf 1
router-id 0.0.0.4
!

R5

!
interface Ethernet0/1
ip address 192.168.45.5 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
end

!
interface Loopback0
ip address 10.5.5.5 255.255.255.255
end

!
router ospf 1
router-id 0.0.0.5
!

Поведение по умолчанию

С предыдущими конфигурациями на месте, этот раздел описывает способы поведения маршрутизатора по умолчанию.

Вот след от R5 до 10.1.1.1. Заметьте, что трафик проходит через R2, не R3:

R5#traceroute 10.1.1.1
Type escape sequence to abort.
Tracing the route to 10.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
1 192.168.45.4 6 msec 6 msec 6 msec  <<< R4
2 192.168.24.2 6 msec 6 msec 8 msec  <<< R2
3 192.168.12.1 8 msec * 3 msec       <<< R1

В этой сети маршрутизатор R4 должен принять решение и должен направить трафик к R3, не к R2 непосредственно, согласно системным требованиям.

Вот пример таблицы маршрутизации на R4:

R4#show ip route 10.1.1.1
Routing entry for 10.1.1.1/32
Known via "ospf 1", distance 110, metric 30, type extern 1
Last update from 192.168.24.2 on Ethernet0/2, 00:14:33 ago
Routing Descriptor Blocks:
* 192.168.24.2, from 0.0.0.2, 00:14:33 ago, via Ethernet0/2 <<< Towards R2
Route metric is 30, traffic share count is 1

Метрика 30 привязана к этому маршруту для префикса 10.1.1.1/32. Это происходит из-за метрики по умолчанию 20, который используется Граничным маршрутизатором автономной системы (ASBR) (R2) и стоимость 10 на интерфейсном Eth0/2 на R4.

Путь от R4 до префикса 10.1.1.1/32 через R3 более длинен. Здесь, стоимость для Интерфейса "Ethernet" 0/2 на R4 (путь к R2) изменена, чтобы проверить, изменяет ли это поведение:

!
interface Ethernet0/2
ip address 192.168.24.4 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
ip ospf cost 100
end

Вот след от R5 и выходные данные команды show ip route от R4:

R5#traceroute 10.1.1.1
Type escape sequence to abort.
Tracing the route to 10.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
1 192.168.45.4 4 msec 9 msec 8 msec  <<< R4
2 192.168.24.2 8 msec 9 msec 10 msec  <<< R2
3 192.168.12.1 10 msec * 5 msec       <<< R1
R4#show ip route 10.1.1.1
Routing entry for 10.1.1.1/32
Known via "ospf 1", distance 110, metric 120, type extern 1
Last update from 192.168.24.2 on Ethernet0/2, 00:01:50 ago
Routing Descriptor Blocks:
* 192.168.24.2, from 0.0.0.2, 00:01:50 ago, via Ethernet0/2
 Route metric is 120, traffic share count is 1

Поскольку след показывает, трафик от R5 берет тот же путь, и трафик не течет через R3. Кроме того, как показано в выходных данных show ip route 10.1.1.1 команды на R4, стоимости 100, который прибавлялся, R4 (Интерфейс "Ethernet" 0/2) вступает в силу, и стоимость маршрута к префиксу равняется 120 (настроенный против 30). Однако путь все еще не изменялся, и требование для трафика для течения по R3 еще не удовлетворено.

Для определения причины этого поведения вот выходные данные команды show ip ospf border-routers R4 (стоимость на Интерфейсе "Ethernet" R4 0/2 все еще установлен в 100):

R4#show ip ospf border-routers
           OSPF Router with ID (0.0.0.4) (Process ID 1)
               Base Topology (MTID 0)
 Internal Router Routing Table
Codes: i - Intra-area route, I - Inter-area route

i 0.0.0.2 [100] via 192.168.24.2, Ethernet0/2, ABR/ASBR, Area 99, SPF 3
i 0.0.0.3 [10] via 192.168.34.3, Ethernet0/0, ABR, Area 99, SPF 3

На R4 вы видите, что существует два Пограничных маршрутизатора области (ABR) (0.0.0.2, который является R2, и 0.0.0.3, который является R3), и что R2 является ASBR. Эти выходные данные также показывают Внутри-областную (i) информацию для ASBR.

Теперь, Интерфейс "Ethernet" 0/2 закрыт на R4, чтобы определить, ли трафики через R3 и чтобы видеть, как появляются выходные данные команды show ip ospf border-routers:

interface Ethernet0/2
ip address 192.168.24.4 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
ip ospf cost 100
shutdown 
end

Вот след от R5 и выходные данные команды show ip route от R4:

R5#traceroute 10.1.1.1
Type escape sequence to abort.
Tracing the route to 10.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
1 192.168.45.4 7 msec 7 msec 8 msec  <<< R4
2 192.168.34.3 9 msec 8 msec 8 msec  <<< R3
3 192.168.23.2 9 msec 9 msec 7 msec  <<< R2
4 192.168.12.1 8 msec * 4 msec        <<< R1
R4#show ip route 10.1.1.1
Routing entry for 10.1.1.1/32
Known via "ospf 1", distance 110, metric 40, type extern 1 <<< Metric 40
Last update from 192.168.34.3 on Ethernet0/0, 00:01:46 ago <<< Traffic to R2
Routing Descriptor Blocks:
* 192.168.34.3, from 0.0.0.2, 00:01:46 ago, via Ethernet0/0
 Route metric is 40, traffic share count is 1

Как показано, когда Интерфейс "Ethernet" 0/2 закрыт на R4, трафик проходит через R3. Кроме того, стоимость, которая привязана к маршруту к R3, является только 40, в то время как стоимость к 10.1.1.1/32 через R2 равнялась 120. Протокол OSPF все еще предпочитает направлять трафик через R2 вместо R3, даже при том, что стоимость для достижения 10.1.1.1/32 ниже через R3.

Вот выходные данные show ip ospf border-routers еще раз на R4:

R4#show ip ospf border-routers
          OSPF Router with ID (0.0.0.4) (Process ID 1)
              Base Topology (MTID 0)
Internal Router Routing Table
Codes: i - Intra-area route, I - Inter-area route

I 0.0.0.2 [20] via 192.168.34.3, Ethernet0/0, ASBR, Area 99, SPF 4
i 0.0.0.3 [10] via 192.168.34.3, Ethernet0/0, ABR, Area 99, SPF 4

Информацией, которая запрошена для достижения ASBR является информация о Промежуточной области. Однако Внутри-областная информация, которая детализирует, как достигнуть ASBR, предпочтена по информации о Промежуточной области независимо от стоимости OSPF, которая привязана к двум путям.

Поэтому путь через R3 не был предпочтен, даже при том, что стоимость через R3 ниже.

Здесь, Интерфейс "Ethernet" 0/2 принесен резервное копирование на R4:

interface Ethernet0/2
no shutdown
end
!

След от R5 указывает, что направляющие действия возвращаются к ранее соблюденным (трафик не течет через R3):

R5#traceroute 10.1.1.1
Type escape sequence to abort.
Tracing the route to 10.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
1 192.168.45.4 6 msec 7 msec 7 msec  <<< R4
2 192.168.24.2 7 msec 8 msec 7 msec  <<< R2
3 192.168.12.1 8 msec * 12 msec       <<< R1

Существуют различные способы, что можно решить этот вопрос (этот список не является исчерпывающим):

  • Измените область между R2 и R3 к 90, и затем модифицируйте стоимость.

  • Добавьте другую ссылку между R2 и R3 и настройте его, чтобы быть в области 99.

  • Используйте мультиобласть ADJ.

Обратитесь к следующему разделу для наблюдения пути, которым работает мультиобласть OSPF ADJ и как это может решить эту проблему под рукой.

Мультиобласть Adjacency Configuration

Как ранее упомянуто, мультиобласть ADJ может использоваться для формирования множественных логических смежностей "точка-точка" по одному соединению. Требование - то, что должно быть только два динамика OSPF на ссылке, и в широковещательной сети, необходимо вручную изменить Тип сети OSPF на точка-точка на ссылке.

Эта функция позволяет одиночному физическому соединению быть разделенным множественными областями и создает Внутри-областной путь в каждой из областей, которые делятся ссылкой.

Для соответствия этому требованию необходимо настроить ADJ мультиобласти OSPF между R2 и R3 по Ethernet ссылки 0/1, который находится в настоящее время только в области 0.

Вот конфигурация для R2:

!
interface Ethernet0/1
ip address 192.168.23.2 255.255.255.0
ip ospf network point-to-point
ip ospf multi-area 99
ip ospf 1 area 0
end

Вот конфигурация для R3:

!
interface Ethernet0/1
ip address 192.168.23.3 255.255.255.0
ip ospf network point-to-point
ip ospf multi-area 99
ip ospf 1 area 0
end

ADJ OSPF подходит по Виртуальному соединению:

%OSPF-5-ADJCHG: Process 1, Nbr 0.0.0.2 on OSPF_MA0 from LOADING to FULL, Loading Done

%OSPF-5-ADJCHG: Process 1, Nbr 0.0.0.3 on OSPF_MA0 from LOADING to FULL, Loading Done

Вот недавно сформированный ADJ:

R2#show ip ospf neighbor 0.0.0.3
<Snip>
Neighbor 0.0.0.3, interface address 192.168.23.3
  In the area 99 via interface OSPF_MA0
  Neighbor priority is 0, State is FULL, 6 state changes
  DR is 0.0.0.0 BDR is 0.0.0.0
  Options is 0x12 in Hello (E-bit, L-bit)
  Options is 0x52 in DBD (E-bit, L-bit, O-bit)
  LLS Options is 0x1 (LR)
  Dead timer due in 00:00:39
  Neighbor is up for 00:03:01
  Index 2/3, retransmission queue length 0, number of retransmission 0
  First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0)
  Last retransmission scan length is 0, maximum is 0
  Last retransmission scan time is 0 msec, maximum is 0 msec
R3#show ip ospf neighbor 0.0.0.2
<Snip>
Neighbor 0.0.0.2, interface address 192.168.23.2
  In the area 99 via interface OSPF_MA0
  Neighbor priority is 0, State is FULL, 6 state changes
  DR is 0.0.0.0 BDR is 0.0.0.0
  Options is 0x12 in Hello (E-bit, L-bit)
  Options is 0x52 in DBD (E-bit, L-bit, O-bit)
  LLS Options is 0x1 (LR)
  Dead timer due in 00:00:39
  Neighbor is up for 00:01:41
  Index 2/3, retransmission queue length 0, number of retransmission 0
  First 0x0(0)/0x0(0) Next 0x0(0)/0x0(0
  Last retransmission scan length is 0, maximum is 0
  Last retransmission scan time is 0 msec, maximum is 0 msec

Проверка.

Чтобы проверить, работает ли конфигурация должным образом, введите команду show ip ospf border-routers в R4:

R4#show ip ospf border-routers
          OSPF Router with ID (0.0.0.4) (Process ID 1)
               Base Topology (MTID 0)
Internal Router Routing Table
Codes: i - Intra-area route, I - Inter-area route

i 0.0.0.3 [10] via 192.168.34.3, Ethernet0/0, ABR, Area 99, SPF 10
i 0.0.0.2 [20] via 192.168.34.3, Ethernet0/0, ABR/ASBR, Area 99, SPF 10

Как показано Внутри-областная информация, которая используется для маршрутизации трафика к R2 (0.0.0.2) / ASBR через R3. Это должно решить ранее упомянутую проблему.

Вот след от R5:

R5#traceroute 10.1.1.1
Type escape sequence to abort.
Tracing the route to 10.1.1.1
VRF info: (vrf in name/id, vrf out name/id)
1 192.168.45.4 8 msec 9 msec 8 msec  <<< R4
2 192.168.34.3 8 msec 8 msec 8 msec  <<< R3
3 192.168.23.2 7 msec 8 msec 8 msec  <<< R2
4 192.168.12.1 8 msec * 4 msec       <<< R1

Как показано трафик от R5, который предназначен к 10.1.1.1 должным образом потоки через R3 и системные требования, встречен.

Введите команду show ip ospf neighbor в R2, R3 и R4, чтобы проверить, установлены ли ADJs:

R2#show ip ospf neighbor
Neighbor ID Pri State   Dead Time Address       Interface
0.0.0.3      0 FULL/ - 00:00:39  192.168.23.3  Ethernet0/1 
0.0.0.4      0 FULL/ - 00:00:37  192.168.24.4  Ethernet0/2
0.0.0.3      0 FULL/ - 00:00:33  192.168.23.3  OSPF_MA0 
R3#show ip ospf neighbor
Neighbor ID Pri State   Dead Time Address       Interface
0.0.0.2      0 FULL/ - 00:00:34  192.168.23.2  Ethernet0/1 
0.0.0.2      0 FULL/ - 00:00:35  192.168.23.2  OSPF_MA0 
0.0.0.4      0 FULL/ - 00:00:39  192.168.34.4  Ethernet0/0
R4#show ip ospf neighbor
Neighbor ID Pri State   Dead Time Address       Interface
0.0.0.2      0 FULL/ - 00:00:32  192.168.24.2  Ethernet0/2  
0.0.0.5      0 FULL/ - 00:00:32  192.168.45.5  Ethernet0/1
0.0.0.3      0 FULL/ - 00:00:35  192.168.34.3  Ethernet0/0

Примечание: В этих выходных данных Вхождения interface Ethernet0/1 указывают на ADJ по области 0, и Вхождения interface OSPF_MA0 указывают на мультиобласть ADJ over Area 99.

Интерфейс "Ethernet" R4 0/2 все еще имеет стоимость 100, и путь через R3 предпочтен на R4. Если эта стоимость удалена, то R4 направляет трафик непосредственно к R2 как прежде.

Вот конфигурация и выходные данные команды show ip route на R4 с IP OSPF cost 100 все еще настроены на Интерфейсе "Ethernet" R4 0/2:

!
interface Ethernet0/2
 ip address 192.168.24.4 255.255.255.0
 ip ospf network point-to-point
 ip ospf 1 area 99
 ip ospf cost 100
!
R4#show ip route 10.1.1.1
Routing entry for 10.1.1.1/32
Known via "ospf 1", distance 110, metric 40, type extern 1
Last update from 192.168.34.3 on Ethernet0/0, 00:28:45 ago
Routing Descriptor Blocks:
* 192.168.34.3, from 0.0.0.2, 00:28:45 ago, via Ethernet0/0
 Route metric is 40, traffic share count is 1

Вот конфигурация и выходные данные команды show ip route на R4 при удалении стоимости:

interface Ethernet0/2
ip address 192.168.24.4 255.255.255.0
ip ospf network point-to-point
ip ospf 1 area 99
end
R4#show ip route 10.1.1.1
Routing entry for 10.1.1.1/32
Known via "ospf 1", distance 110, metric 30, type extern 1
Last update from 192.168.24.2 on Ethernet0/2, 00:00:13 ago
Routing Descriptor Blocks:
* 192.168.24.2, from 0.0.0.2, 00:00:13 ago, via Ethernet0/2 <<< Route changed back to R2
    Route metric is 30, traffic share count is 1

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.


Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Document ID: 118879