Коммутаторы : Коммутаторы Cisco Catalyst серии 6500

Менеджер EARL 8 классификации: поведенческое исследование LOUs, L4Op и таблиц Capmap

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв

Введение

Менеджер классификации (CM) управляет Ternary Content Addressable Memory (TCAM) классификации и привязанными ресурсами, такими как метки, Модули Логической операции (LOUs), capmap записи и другие. Сервисы CM используются Менеджером функции (FM) и Менеджером QoS (QM) для программирования множеств технических разделов для поддержки Cisco функции Качества обслуживания (QoS) и IOS® Access Control List (ACL). Этот документ описывает, как LOUs и Операции Уровня 4 (L4Op) запрограммированы в capmap таблицу. Это предоставляет сценарии отказов, типы ошибок, с которыми вы, как правило, встречаетесь в этих ситуациях, и что необходимо вывести из этих ошибок.

Внесенный Aninda Chatterjee, специалистом службы технической поддержки Cisco.

Общие сведения

LOUs и L4Op - LOUs обозначает Модули Логической операции, которые являются аппаратными регистрами, которые используются для хранения {оператора, операнд} кортежи для номеров портов TCP/UDP, заданных в ACL и Списках контроля доступом VLAN (VACL). Эти кортежи также вызывают как L4Op. Например, при соответствии с хостом X хоста Y gt 1023 тогда кортеж становится {gt, 1023}.

L4Op - операции уровня 4.

Таблицы Capmap - L4Op, описанные ранее, запрограммированы в регистры LOU, на которые ссылаются записи в capmap таблицах. Каждая capmap таблица имеет предел 10 (каждый зарезервирован для направления, которое переводит предел в нерабочее состояние девять), записи (L4Op). Таблицы Capmap индексированы самой меткой TCAM. 

Существует два TCAM, A и B; каждый TCAM имеет метки 8K. Для каждого TCAM существует одна capmap таблица 2K записей. Так как каждый TCAM имеет метки 8K, существует 4:1 наложение здесь - четыре метки сопоставляют с одной capmap записью. Наложение: 1=2049=4097=6145

В основном это означает, что метки 1, 2049, 4097 TCAM, и 6145 используют тот же индекс capmap. Традиционный implemenation Cisco выделения метки TCAM привел к проблемам из-за этого наложения. Cisco выделила метки TCAM с разрывом 2K (2048, чтобы быть точной). Это подразумевает, что выделение приняло бы форму 1, 2049, 4097, 6145, 2, 2050, 4098, 6146, и так далее.

Так, от запуска это распределение TCAM было таково, что наложились capmap таблицы. Вот пример для демонстрации этого (взятый от идентификатора ошибки Cisco CSCuo02666). Здесь два ACL, a1 и a2, определенный, и применились к interface VLAN 1 и interface VLAN 2 как показано здесь:

Sup2T(config)#ip access-list extended a1
Sup2T(config-ext-nacl)# permit ip host 1.1.1.1 any dscp 1
Sup2T(config-ext-nacl)# permit ip host 1.1.1.1 any dscp 2
Sup2T(config-ext-nacl)# permit ip host 1.1.1.1 any dscp 3
Sup2T(config-ext-nacl)# permit ip host 1.1.1.1 any dscp 4
Sup2T(config-ext-nacl)# permit ip host 1.1.1.1 any dscp 5
Sup2T(config-ext-nacl)#exit

Sup2T(config)#int vlan 1
Sup2T(config-if)#ip access-group a1 in
Sup2T(config-if)#exit

Sup2T(config)#ip access-list extended a2
Sup2T(config-ext-nacl)# permit ip host 1.1.1.2 any dscp 6
Sup2T(config-ext-nacl)# permit ip host 1.1.1.2 any dscp 7
Sup2T(config-ext-nacl)# permit ip host 1.1.1.2 any dscp cs1
Sup2T(config-ext-nacl)# permit ip host 1.1.1.2 any dscp 9
Sup2T(config-ext-nacl)#exit

Sup2T(config)#int vlan 2
Sup2T(config-if)#ip access-group a2 in
Sup2T(config-if)#end

Вот TCAM для этих интерфейсов теперь:

Sup2T#show platform hardware acl entry interface vlan 1 security in ip detail 
mls_if_index:20000001 dir:0 feature:0 proto:0


pass#0 features
UAPRSF: U-urg, A-ack, P-psh, R-rst, S-syn, F-fin
MLGFI: M-mpls_plus_ip_pkt, L-L4_hdr_vld, G-gpid_present,F-global_fmt_match,
I-ife/ofe
's' means set; 'u' means unset; '-' means don't care
----------------------------------------------------------------
----------------------------------------------------------------
----------------------------------------------------------------
------
I    INDEX LABEL FS ACOS   AS          IP_SA       SRC_PORT
IP_DA       DST_PORT F FF L4PROT TCP-F:UAPRSF MLGFI OtherL4OPs
RSLT                 CNT
---------------------------------------------------------------
---------------------------------------------------------------
---------------------------------------------------------------
---------


fno:0

tcam:B, bank:0, prot:0   Aces

I V 16366  2049 0   0    0        1.1.1.1              -        0.0.0.0
- 0 0     0     -      ----- dscp=5;                      0x0000000000000038
0
I M 16366 0x1FFF 0 0x00 0x000 255.255.255.255              -        0.0.0.0
- 0 0   0x0
I V 16367  2049 0   0    0        1.1.1.1              -        0.0.0.0
- 0 0     0     -      ----- dscp=4;                      0x0000000000000038
0
I M 16367 0x1FFF 0 0x00 0x000 255.255.255.255              -        0.0.0.0
- 0 0   0x0
I V 16368  2049 0   0    0        1.1.1.1              -        0.0.0.0
- 0 0     0     -      ----- dscp=3;                      0x0000000000000038
0
I M 16368 0x1FFF 0 0x00 0x000 255.255.255.255              -        0.0.0.0
- 0 0   0x0
I V 16369  2049 0   0    0        1.1.1.1              -        0.0.0.0
- 0 0     0     -      ----- dscp=2;                      0x0000000000000038
0
I M 16369 0x1FFF 0 0x00 0x000 255.255.255.255              -        0.0.0.0
- 0 0   0x0
I V 16370  2049 0   0    0        1.1.1.1              -        0.0.0.0
- 0 0     0     -      ----- dscp=1;                      0x0000000000000038
0
I M 16370 0x1FFF 0 0x00 0x000 255.255.255.255              -        0.0.0.0
- 0 0   0x0
I V 16371  2049 0   0    0        0.0.0.0              -        0.0.0.0
- 0 0     0     -      -----         -                   0x0000000040000038
0
I M 16371 0x1FFF 0 0x00 0x000        0.0.0.0              -        0.0.0.0
- 0 0   0x0



Sup2T#show platform hardware acl entry interface vlan 2 security in ip detail
mls_if_index:20000002 dir:0 feature:0 proto:0


pass#0 features
UAPRSF: U-urg, A-ack, P-psh, R-rst, S-syn, F-fin
MLGFI: M-mpls_plus_ip_pkt, L-L4_hdr_vld, G-gpid_present,F-global_fmt_match, I-ife/ofe
's' means set; 'u' means unset; '-' means don't care
----------------------------------------------------------------
----------------------------------------------------------------
----------------------------------------------------------------
------
I    INDEX LABEL FS ACOS   AS          IP_SA       SRC_PORT
IP_DA       DST_PORT F FF L4PROT TCP-F:UAPRSF MLGFI OtherL4OPs
RSLT                 CNT
-----------------------------------------------------------------
-----------------------------------------------------------------
-----------------------------------------------------------------


fno:0

tcam:B, bank:1, prot:0   Aces

I V 32738  4097 0   0    0        1.1.1.2              -        0.0.0.0
- 0 0     0     -      ----- dscp=9;                      0x0000000000000038
0
I M 32738 0x1FFF 0 0x00 0x000 255.255.255.255              -        0.0.0.0
- 0 0   0x0
I V 32739  4097 0   0    0        1.1.1.2              -        0.0.0.0
- 0 0     0     -      ----- dscp=8;                      0x0000000000000038
0
I M 32739 0x1FFF 0 0x00 0x000 255.255.255.255              -        0.0.0.0
- 0 0   0x0
I V 32740  4097 0   0    0        1.1.1.2              -        0.0.0.0
- 0 0     0     -      ----- dscp=7;                      0x0000000000000038
0
I M 32740 0x1FFF 0 0x00 0x000 255.255.255.255              -        0.0.0.0
- 0 0   0x0
I V 32741  4097 0   0    0        1.1.1.2              -        0.0.0.0
- 0 0     0     -      ----- dscp=6;                      0x0000000000000038
0
I M 32741 0x1FFF 0 0x00 0x000 255.255.255.255              -        0.0.0.0
- 0 0   0x0
I V 32745  4097 0   0    0        0.0.0.0              -        0.0.0.0
- 0 0     0     -      -----         -                   0x0000000040000038
0
I M 32745 0x1FFF 0 0x00 0x000        0.0.0.0              -        0.0.0.0
- 0 0   0x0

Метка TCAM, выделенная для interface VLAN 1, является 2049, и метка TCAM, выделенная interface VLAN 2, 4097. Это означает, что оба из этих интерфейсов используют ту же capmap таблицу для ссылки на регистры LOU для их программирования L4Op.

Можно подтвердить это с этой командой (пять ACE в ACL a1, и четыре ACE в a2 ACL подразумевает, что необходимо рассмотреть capmap таблицу как полную):

Sup2T#show platform hardware acl capmap tcam B label 4097
Hardware Capmap Table Entry For TCAM B. Free items are not shown

Index  Loc[9] [8] [7] [6] [5] [4] [3] [2] [1] [0]
-----  ------ --- --- --- --- --- --- --- --- ---
   1     212  10   9   8   7   6   5   4   3   2


Sup2T#show platform hardware acl capmap tcam B label 2049
Hardware Capmap Table Entry For TCAM B. Free items are not shown

Index  Loc[9] [8] [7] [6] [5] [4] [3] [2] [1] [0]
-----  ------ --- --- --- --- --- --- --- --- ---
   1     212  10   9   8   7   6   5   4   3   2

Таким образом, теперь, на данном этапе, при попытке установить другой основанный на L4Op Элемент управления доступом (ACE), который не расширяем ни для одного из этих интерфейсов, вы не получили бы свободную capmap запись доступная ошибка.

Sup2T(config)#ip access-list extended a2
Sup2T(config-ext-nacl)#permit ip host 1.1.1.2 any dscp 10
Sup2T(config-ext-nacl)#end

*Sep 16 14:57:55.983: %EARL_CM-5-NOCAPMAP: No free capmap entry available
*Sep 16 14:57:55.991: %FMCORE-4-RACL_REDUCED: Interface Vlan2 routed traffic
will be software switched in ingress direction. L2 features may not be applied
at the interface

Это приводит к программному обеспечению, соединяющему весь интерфейс, который потенциально вызвал бы более медленную коммутацию, высокую загрузку ЦП и другие связанные проблемы.

Примечание: Идентификатор ошибки Cisco CSCuo02666 был повышен для решения этой проблемы. Самое большое изменение в логике, которую это представляет, - то, как выделены метки TCAM. Теперь Cisco выделяет метки TCAM постоянно (2,3,4,5, и так далее) до 2048 вместо в разрывах 2K. Это означает, что capmap таблицы больше не разделяются с начала.

Помните, что ограничены LOUs, как любой другой аппаратный ресурс. Существуют в общей сложности 104 LOUs доступны для использования:

Sup2T#show platform software acl lou 
LOUs Registers (shadow copies)

Index     Type A_Op A_Val A_Cnt B_Op B_Val B_Cnt
----- -------- ---- ----- ----- ---- ----- -----
   0PKT_QOS_GI A is free.           NEQ     0     1
   1 DST_PORT   LT    81     2 B is free.        
   2 B & A are free
   3 B & A are free
   4 B & A are free
   5 B & A are free
   6 B & A are free
   7 B & A are free
   8 B & A are free
   9 B & A are free
  10 B & A are free
  11 B & A are free
  12 B & A are free
  13 B & A are free
  14 B & A are free
  15 B & A are free

*snip*
 
  95 B & A are free
  96 B & A are free
  97 B & A are free
  98 B & A are free
  99 B & A are free
 100 B & A are free
 101 B & A are free
 102 B & A are free
 103 B & A are free

Программа таблицы Capmap и регистры LOU

Таблицы Capmap используются только, когда операции L4 должны быть приняты во внимание. Обратите внимание на то, что соответствие на Кодовой точке дифференцированных сервисов (DSCP) / Класс обслуживания (CoS) оценивает, также рассмотрен как L4Op. Вот простой пример (использующий версию кода, которая включает исправление CSCuo02666), что этот документ основывается инкрементно:

Sup2T#show ip access-lists a3
Extended IP access list a3
   10 permit ip host 192.168.1.1 host 192.168.1.2

I have this applied to interface VLAN 1.

Sup2T#show run int vlan 1
Building configuration...

Current configuration : 84 bytes
!
interface Vlan1
 ip address 192.168.1.1 255.255.255.0
 ip access-group a3 in
end

Это правильно запрограммировано в TCAM:

Sup2T#show platform hardware acl entry interface vlan 1 security in ip
mls_if_index:20000001 dir:0 feature:0 proto:0


pass#0 features


fno:0

tcam:B, bank:1, prot:0   Aces


Permit               ip host 192.168.1.1 host 192.168.1.2  
L3_Deny              ip any any

Sup2t-MA1.7#show platform hardware acl entry interface vlan 1 security in ip detail  
mls_if_index:20000001 dir:0 feature:0 proto:0


pass#0 features
UAPRSF: U-urg, A-ack, P-psh, R-rst, S-syn, F-fin
MLGFI: M-mpls_plus_ip_pkt, L-L4_hdr_vld, G-gpid_present,F-global_fmt_match, I-ife/ofe
's' means set; 'u' means unset; '-' means don't care
----------------------------------------------------------------
----------------------------------------------------------------
----------------------------------------------------------------
------
I    INDEX LABEL FS ACOS   AS          IP_SA       SRC_PORT
IP_DA       DST_PORT F FF L4PROT TCP-F:UAPRSF MLGFI OtherL4OPs
RSLT                 CNT
----------------------------------------------------------------
----------------------------------------------------------------
-----------------------------------------------------------------
-----


fno:0

tcam:B, bank:1, prot:0   Aces

I V 32741  2 0   0    0       192.168.1.1              -    192.168.1.2
- 0 0     0     -      -----         -                   0x0000000000000038
0
I M 32741 0x1FFF 0 0x00 0x000 255.255.255.255              - 255.255.255.255
- 0 0   0x0
I V 32745  2 0   0    0           0.0.0.0              -        0.0.0.0
- 0 0     0     -      -----         -                   0x0000000040000038
0
I M 32745 0x1FFF 0 0x00 0x000        0.0.0.0              -        0.0.0.0
- 0 0   0x0

На таблицы Capmap ссылаются через саму метку TCAM. Можно использовать метку TCAM в программном обеспечении show platform [аппаратные средства] acl capmap tcam <> метка <> команда для просмотра соответствующей таблицы (программное обеспечение или аппаратные средства) для этой метки TCAM.

Sup2T#show platform hardware acl capmap tcam B label 2
Hardware Capmap Table Entry For TCAM B. Free items are not shown

Index  Loc[9] [8] [7] [6] [5] [4] [3] [2] [1] [0]
-----  ------ --- --- --- --- --- --- --- --- ---
   1     212   0   0   0   0   0   0   0   0   0

Ничто не выделено в capmap таблице для этой метки. Определенный ACL не имеет никаких L4Op; нет никакого требования для установки записи в capmap таблице.

Измените этот ACE на это:

Sup2T#show ip access-lists a3
Extended IP access list a3
   10 permit tcp host 192.168.1.1 host 192.168.1.2 eq www

Посмотрите на capmap таблицу снова.

Sup2T#show platform software acl capmap tcam B label 2
Shadow Capmap Table Entry For TCAM B

-----------------------------------------------------------------------
Output in a RST/INV/CNT format: RST - result value; INV - inverted;
                               CNT - aggregated reference account;

CBF - number of free cap bits (one per entry);
Free items are not shown
-----------------------------------------------------------------------

Index  CBF      [9]             [8]             [7]             [6]
[5]             [4]             [3]             [2]             [1]
[0]      
----- ----- ---------------- ---------------- ---------------- ---------
------- ---------------- ---------------- ---------------- -------------
--- ---------------- ----------------
   1    9        Reserved            Free            Free            Free
Free            Free            Free            Free            Free
Free

Если вы непосредственно составляете уравнение к port-number, он не рассчитывает как L4Op также.

Измените его на это:

Sup2T#show ip access-lists a3
Extended IP access list a3
   10 permit tcp host 192.168.1.1 host 192.168.1.2 gt www

Исследуйте capmap таблицу еще раз:

Sup2T#show platform software acl capmap tcam B label 2
Shadow Capmap Table Entry For TCAM B

-----------------------------------------------------------------------
Output in a RST/INV/CNT format: RST - result value; INV - inverted;
                               CNT - aggregated reference account;

CBF - number of free cap bits (one per entry);
Free items are not shown
-----------------------------------------------------------------------

Index  CBF      [9]             [8]             [7]             [6]
[5]             [4]             [3]             [2]             [1]
[0]      
----- ----- ---------------- ---------------- ---------------- ---------
------- ---------------- ---------------- ---------------- ------------
---- ---------------- ----------------
   2    8 212/0/1                     Free            Free            Free
Free            Free            Free            Free            Free  3/1/1 

В capmap таблице существует теперь запись. ACE был преобразован в 3/1/1 в capmap таблице. Это имеет формат RST/INV/CNT. RST здесь задает, какие LOU регистрируются, этот L4Op был установлен в, и CNT описывает объединенный счет для этого LOU (дополнительные сведения об этом позже). Посмотрите на эти выходные данные, чтобы понять, как индексировано значение RST:

Sup2T#show platform software acl capmap mapping 
      L4op_sel value    Reference  
      ==============    =========
      0    ------      LOU0 B register
      1    ------      LOU0 A register
      2    ------      LOU1 B register
      3    ------      LOU1 A register
     .....             ..............
     .....             ..............
     206    -----      LOU103 B register
     207    -----      LOU103 A register
     208    -----      Global format match for global acl
     209    -----      Group id present
     210    -----      L4_hdr_vld
     211    -----      Mpls_plus_ip_pkt
     212    -----      ife/ofe for direction
    (213-223)   ----    Reserved
    (224-239)   ----    16 TCP flags map
    (240-255)   ----    16 IPv6 ext header map

Вы видите что значение L4op_sel 0 точек к регистру LOU0 B, значение 1 точки к LOU0 регистр, значение 2 точек к регистру LOU1 B, значение 3 точек к регистру LOU1 B, и так далее. Регистр всегда программируется сначала. Выходные данные 3/1/1 имеют больше смысла теперь, когда вы видите это.

В этих выходных данных, 3 средства, что L4Op был запрограммирован в LOU1 регистр. Можно также проверить, где L4Op запрограммирован при изучении содержания регистров LOU непосредственно:

Sup2T#show platform software acl lou
LOUs Registers (shadow copies)

Index     Type A_Op A_Val A_Cnt B_Op B_Val B_Cnt
----- -------- ---- ----- ----- ---- ----- -----
   0PKT_QOS_GI A is free.           NEQ     0     1
   1 DST_PORT   LT    81     1 B is free.        
   2 B & A are free
   3 B & A are free
   4 B & A are free

*snip*

Sup2T#show platform hardware acl lou
Dumping h/w lou values

Index lou_mux_sel A_Opcode A_Value B_Opcode B_Value
----- ----------- -------- ------- -------- -------
   0           7      NEQ       0      NEQ       0
   1           1       LT      81      NEQ       0
   2           0      NEQ       0      NEQ       0
   3           0      NEQ       0      NEQ       0

*snip*

Как вы можете видеть, (gt, X) кортеж запрограммирован как (LT, X+1) в регистрах LOU.

Примечание: L4Op запрограммированы в регистры LOU ONLY, когда они применены к интерфейсам. Если ACL созданы с L4Op (без ACL, фактически применяемого к интерфейсу), он не программирует применимые L4Op в регистры LOU.

Удалите ACL из interface VLAN 1 и посмотрите на регистры LOU снова:

Sup2T(config)#int vlan 1
Sup2T(config-if)#no ip access-group a3 in

Sup2T#show platform software acl lou
LOUs Registers (shadow copies)

Index     Type A_Op A_Val A_Cnt B_Op B_Val B_Cnt
----- -------- ---- ----- ----- ---- ----- -----
   0PKT_QOS_GI A is free.           NEQ     0     1
   1 B & A are free
   2 B & A are free
   3 B & A are free
   4 B & A are free


*snip*

Sup2T#show platform hardware acl lou
Dumping h/w lou values

Index lou_mux_sel A_Opcode A_Value B_Opcode B_Value
----- ----------- -------- ------- -------- -------
   0           7      NEQ       0      NEQ       0
   1           1      NEQ       0      NEQ       0
   2           0      NEQ       0      NEQ       0
   3           0      NEQ       0      NEQ       0

*snip*

Пример практического применения #1 - ACL с флагами TCP

Флаги TCP имеют специальный набор регистров, выделенных в диапазоне регистров LOU. Можно просмотреть этот диапазон через acl программного обеспечения show platform capmap сопоставление команды как показано здесь:

Sup2T#show platform software acl capmap mapping
      L4op_sel value    Reference  
      ==============    =========
      0    ------      LOU0 B register
      1    ------      LOU0 A register
      2    ------      LOU1 B register
      3    ------      LOU1 A register
     .....             ..............
     .....             ..............
     206    -----      LOU103 B register
     207    -----      LOU103 A register
     208    -----      Global format match for global acl
     209    -----      Group id present
     210    -----      L4_hdr_vld
     211    -----      Mpls_plus_ip_pkt
     212    -----      ife/ofe for direction
    (213-223)   ----    Reserved
    (224-239)   ----    16 TCP flags map
    (240-255)   ----    16 IPv6 ext header map

L4op_sel оценивает 224-239, доступны для использования для флагов TCP, который дает вам ряд 16 регистров для использования. Вот является простой пример к demostrate этим. Этот ACL определен:

Sup2T(config)#ip access-list extended a13 
Sup2T(config-ext-nacl)#permit tcp host 192.168.13.10 host 192.168.13.20 syn
Sup2T(config-ext-nacl)#exit

Примените это входящее на interface VLAN 13:

Sup2T(config)#int vlan 13
Sup2T(config-if)#ip access-group a13 in
Sup2T(config-if)#end


Sup2T#show platform hardware acl entry interface vlan 13 security in ip detail  
mls_if_index:2000000D dir:0 feature:0 proto:0


pass#0 features
UAPRSF: U-urg, A-ack, P-psh, R-rst, S-syn, F-fin
MLGFI: M-mpls_plus_ip_pkt, L-L4_hdr_vld, G-gpid_present,F-global_fmt_match, I-ife/ofe
's' means set; 'u' means unset; '-' means don't care
----------------------------------------------------------------
---------------------------------------------------------------
---------------------------------------------------------------
--------
I    INDEX LABEL FS ACOS   AS          IP_SA       SRC_PORT
IP_DA       DST_PORT F FF L4PROT TCP-F:UAPRSF MLGFI OtherL4OPs
RSLT                 CNT
----------------------------------------------------------------
----------------------------------------------------------------
----------------------------------------------------------------
------


fno:0

tcam:B, bank:1, prot:0   Aces

I V 32545    13 0   0    0  192.168.13.10              -  192.168.13.20
- 0 0     1  ANY:----s- -----         -                   0x0000000000000038
0
I M 32545 0x1FFF 0 0x00 0x000 255.255.255.255              - 255.255.255.255
- 0 0   0xF
I V 32546    13 0   0    0  192.168.13.10              -  192.168.13.20
- 1 0     1     -      -----         -                   0x0000000000000038
0
I M 32546 0x1FFF 0 0x00 0x000 255.255.255.255              - 255.255.255.255
- 1 0   0xF
I V 32547    13 0   0    0        0.0.0.0              -        0.0.0.0
- 0 0     0     -      -----         -                   0x0000000040000038
0
I M 32547 0x1FFF 0 0x00 0x000        0.0.0.0              -        0.0.0.0
- 0 0   0x0
Sup2T#show platform software acl capmap tcam B label 13
Shadow Capmap Table Entry For TCAM B

-----------------------------------------------------------------------
Output in a RST/INV/CNT format: RST - result value; INV - inverted;
                               CNT - aggregated reference account;

CBF - number of free cap bits (one per entry);
Free items are not shown
-----------------------------------------------------------------------

Index  CBF      [9]             [8]             [7]             [6]
[5]             [4]             [3]             [2]             [1]
[0]      
----- ----- ---------------- ---------------- ---------------- ----------------
---------------- ---------------- ---------------- ---------------- -----------
----- ----------------
  13    8 212/0/1                     Free            Free            Free
Free            Free            Free            Free            Free 224/0/1

В данном примере флаг TCP запрограммирован в регистре 224 (это соответствует первому доступному регистру для флагов TCP). Составной счет для этого соответствует количеству потоков TCP (ACE чтения) с тем же флагом TCP.

Добавьте другой ACE к текущему ACL a13. Это должно иметь другой флаг TCP:

Sup2T(config)#ip access-list extended a13
Sup2T(config-ext-nacl)#permit tcp host 192.168.1.1 host 192.168.1.2 ack
Sup2T(config-ext-nacl)#exit

При рассмотрении capmap таблицы снова вы видите, что используется другой регистр TCP:

Sup2T#show platform software acl capmap tcam b label 13
Shadow Capmap Table Entry For TCAM B

-----------------------------------------------------------------------
Output in a RST/INV/CNT format: RST - result value; INV - inverted;
                               CNT - aggregated reference account;

CBF - number of free cap bits (one per entry);
Free items are not shown
-----------------------------------------------------------------------

Index  CBF      [9]             [8]             [7]             [6]
[5]             [4]             [3]             [2]             [1]
[0]      
----- ----- ---------------- ---------------- ---------------- ----------------
---------------- ---------------- ---------------- ---------------- -----------
----- ----------------
  13    7 212/0/1                     Free            Free            Free
Free            Free            Free            Free 225/0/1         224/0/1 

Таким образом, как вы видите, программирование сделано на флаг; для каждого флага используется независимый регистр TCP, и вы поддерживаете количество против этого. Это означает, что для каждого флага вы также используете одну capmap запись. Это далее подразумевает, что технически вы не можете фактически пойти вне девяти флагов в вашем ACL, или вы достигнете предела capmap перед 16 пределами флага TCP. 

Увеличьте масштаб своих флагов TCP так, чтобы вы достигли предела регистра TCP для наблюдения то, что происходит. Данный пример показывает несколько ACL, которые были настроены и применены к другой interface vlan для достижения 100%-го использования регистра TCP как показано здесь:

Sup2T#show platform hardware capacity acl
Classification Mgr Tcam Resources
 Key: Ttlent - Total TCAM entries, QoSent - QoS TCAM entries, LOU - LOUs,
      RBLent - RBACL TCAM entries, Lbl - Labels, TCP - TCP Flags,
      Dstbl - Destinfo Table, Ethcam - Ethertype Cam Table,
      ACTtbl - Accounting Table, V6ext - V6 Extn Hdr Table

 Module Ttlent QoSent RBLent Lbl  LOU TCP Dstbl Ethcam ACTtbl V6ext
 1      3%    7%    0%    1%  96% 100%  1%   0%    0%    0%
 3      3%    7%    0%    1%  96% 100%  1%   0%    0%    0%
 4      3%    7%    0%    1%  96% 100%  1%   0%    0%    0%
 6      3%    7%    0%    1%  96% 100%  2%   0%    0%    0%

На данном этапе, если вы решаете настроить другой ACL с уникальным флагом TCP (или комбинация флагов TCP, которая делает его уникальным), и примените это к интерфейсу, тогда необходимо программировать новый флаг TCP (или комбинация флагов) к регистру TCP. Однако нет никаких доступных аппаратных регистров. В этой ситуации вы соединяете весь интерфейс.

Sup2T(config)#ip access-list extended a29
Sup2T(config-ext-nacl)#permit tcp host 192.168.1.1 host 192.168.1.2 psh rst

Sup2T(config-if)#int vlan 29
Sup2T(config-if)#ip access-group a29 in

 *Oct 6 13:57:47.612: %FMCORE-4-RACL_REDUCED: Interface Vlan29 routed traffic
will be software switched in ingress direction. L2 features may not be applied
at the interface


Sup2T#show platform hardware acl entry interface vlan 29 security in ip
mls_if_index:2000001D dir:0 feature:0 proto:0


pass#0 features


fno:0

tcam:B, bank:1, prot:0   Aces


Bridge               ip any any  

Пример практического применения #2 - 100%-е использование регистра LOU

Помните, что LOUs являются ограниченным ресурсом - у можно закончиться пространство для тех также. Можно контролировать использование LOU с этой командой:

Sup2T#show platform hardware capacity acl 
Classification Mgr Tcam Resources
 Key: Ttlent - Total TCAM entries, QoSent - QoS TCAM entries, LOU - LOUs,
      RBLent - RBACL TCAM entries, Lbl - Labels, TCP - TCP Flags,
      Dstbl - Destinfo Table, Ethcam - Ethertype Cam Table,
      ACTtbl - Accounting Table, V6ext - V6 Extn Hdr Table

 Module Ttlent QoSent RBLent Lbl  LOU TCP Dstbl Ethcam ACTtbl V6ext
 1      2%    7%    0%    1%   1%  0%  1%   0%    0%    0%
 3      2%    7%    0%    1%   1%  0%  1%   0%    0%    0%
 4      2%    7%    0%    1%   1%  0%  1%   0%    0%    0%
 6      2%    7%    0%    1%   1%  0%  2%   0%    0%    0%

Масштабируйте ACL для использования большего количества LOUs. После установки нескольких ACL (с командой диапазона, которая берет два регистра LOU, и A и B), данный пример показывает 96%-е использование LOU:

Sup2T#show platform hardware capacity acl
Classification Mgr Tcam Resources
 Key: Ttlent - Total TCAM entries, QoSent - QoS TCAM entries, LOU - LOUs,
      RBLent - RBACL TCAM entries, Lbl - Labels, TCP - TCP Flags,
      Dstbl - Destinfo Table, Ethcam - Ethertype Cam Table,
      ACTtbl - Accounting Table, V6ext - V6 Extn Hdr Table

 Module Ttlent QoSent RBLent Lbl  LOU TCP Dstbl Ethcam ACTtbl V6ext
 1      3%    7%    0%    1%  96%  0%  1%   0%    0%    0%
 3      3%    7%    0%    1%  96%  0%  1%   0%    0%    0%
 4      3%    7%    0%    1%  96%  0%  1%   0%    0%    0%
 6      3%    7%    0%    1%  96%  0%  2%   0%    0%    0%

Создайте другой ACL и примените это к интерфейсу, который заставил бы использование LOU идти вне 100%.

Sup2T(config)#ip access-list extended a12
Sup2T(config-ext-nacl)#$68.14.1 host 192.168.14.2 range 1401 1410     
Sup2T(config-ext-nacl)#$68.14.1 host 192.168.14.2 range 1411 1420     
Sup2T(config-ext-nacl)#$68.14.1 host 192.168.14.2 range 1421 1430     
Sup2T(config-ext-nacl)#$68.14.1 host 192.168.14.2 range 1431 1440     
Sup2T(config-ext-nacl)#$68.14.1 host 192.168.14.2 range 1441 1450     
Sup2T(config-ext-nacl)#$68.14.1 host 192.168.14.2 range 1451 1460     
Sup2T(config-ext-nacl)#$68.14.1 host 192.168.14.2 range 1461 1470     
Sup2T(config-ext-nacl)#$68.14.1 host 192.168.14.2 range 1471 1480     
Sup2T(config-ext-nacl)#$68.14.1 host 192.168.14.2 range 1481 1490     
Sup2T(config-ext-nacl)#$68.14.1 host 192.168.14.2 range 1491 1500

Sup2T(config-ext-nacl)#exit
Sup2T(config)#int vlan 12
Sup2T(config-if)#ip access-group a12 in

Пример достиг 100%-го использования LOU; однако, заметьте, что не было получено никакое сообщение об ошибках.

Sup2T#show platform hardware capacity acl
Classification Mgr Tcam Resources
 Key: Ttlent - Total TCAM entries, QoSent - QoS TCAM entries, LOU - LOUs,
      RBLent - RBACL TCAM entries, Lbl - Labels, TCP - TCP Flags,
      Dstbl - Destinfo Table, Ethcam - Ethertype Cam Table,
      ACTtbl - Accounting Table, V6ext - V6 Extn Hdr Table

 Module Ttlent QoSent RBLent Lbl  LOU TCP Dstbl Ethcam ACTtbl V6ext
 1      3%    7%    0%    1%  100%  0%  1%   0%    0%    0%
 3      3%    7%    0%    1%  100%  0%  1%   0%    0%    0%
 4      3%    7%    0%    1%  100%  0%  1%   0%    0%    0%
 6      3%    7%    0%    1%  100%  0%  2%   0%    0%    0%

Вот другой тест. Теперь, когда LOU в 100%, возьмите очень простой L4Op и попытку установить это для интерфейса. Настройте этот ACL:

Sup2T#show ip access-lists a13
Extended IP access list a13
   10 permit tcp host 192.168.14.1 host 192.168.14.2 range 1600 1650

Примените это входящее к interface VLAN 13.

Sup2T#show run int vlan 13
Building configuration...

Current configuration : 87 bytes
!
interface Vlan13
 ip address 192.168.13.1 255.255.255.0
 ip access-group a13 in
end

Посмотрите на TCAM для этой VLAN теперь:

Sup2T#show platform hardware acl entry interface vlan 13 sec in ip
mls_if_index:2000000D dir:0 feature:0 proto:0


pass#0 features


fno:0

tcam:B, bank:0, prot:0   Aces


Permit               tcp host 192.168.14.1 host 192.168.14.2 eq 1650  
Permit               tcp host 192.168.14.1 host 192.168.14.2 range 1648 1649  
Permit               tcp host 192.168.14.1 host 192.168.14.2 range 1632 1647  
Permit               tcp host 192.168.14.1 host 192.168.14.2 range 1600 1631  
Permit               tcp host 192.168.14.1 host 192.168.14.2 fragments
L3_Deny              ip any any  

L4Op были расширены. При рассмотрении capmap таблицы для этой метки TCAM вы видите, что ничто не установлено.

Sup2T#show platform hardware acl entry interface vlan 13 sec in ip detail
mls_if_index:2000000D dir:0 feature:0 proto:0


pass#0 features
UAPRSF: U-urg, A-ack, P-psh, R-rst, S-syn, F-fin
MLGFI: M-mpls_plus_ip_pkt, L-L4_hdr_vld, G-gpid_present,F-global_fmt_match, I-ife/ofe
's' means set; 'u' means unset; '-' means don't care
---------------------------------------------------------------
---------------------------------------------------------------
---------------------------------------------------------------
---------
I    INDEX LABEL FS ACOS   AS          IP_SA       SRC_PORT
IP_DA       DST_PORT F FF L4PROT TCP-F:UAPRSF MLGFI OtherL4OPs
RSLT                 CNT
----------------------------------------------------------------
----------------------------------------------------------------
----------------------------------------------------------------
------


fno:0

tcam:B, bank:0, prot:0   Aces

I V 16136    14 0   0    0   192.168.14.1              -   192.168.14.2
1650 0 0     1     -      -----         -                   0x0000000000000038
0
I M 16136 0x1FFF 0 0x00 0x000 255.255.255.255              - 255.255.255.255
0xFFFF 0 0   0xF
I V 16137    14 0   0    0   192.168.14.1              -   192.168.14.2
1648 0 0     1     -      -----         -                   0x0000000000000038
0
I M 16137 0x1FFF 0 0x00 0x000 255.255.255.255              - 255.255.255.255
0xFFFE 0 0   0xF
I V 16138    14 0   0    0   192.168.14.1              -   192.168.14.2
1632 0 0     1     -      -----         -                   0x0000000000000038
0
I M 16138 0x1FFF 0 0x00 0x000 255.255.255.255              - 255.255.255.255
0xFFF0 0 0   0xF
I V 16139    14 0   0    0   192.168.14.1              -   192.168.14.2
1600 0 0     1     -      -----         -                   0x0000000000000038
0
I M 16139 0x1FFF 0 0x00 0x000 255.255.255.255              - 255.255.255.255
0xF
I V 16140    14 0   0    0   192.168.14.1              -   192.168.14.2
- 1 0     1     -      -----         -                   0x0000000000000038
0


Sup2T#show platform software acl capmap tcam B label 14
Shadow Capmap Table Entry For TCAM B

-----------------------------------------------------------------------
Output in a RST/INV/CNT format: RST - result value; INV - inverted;
                               CNT - aggregated reference account;

CBF - number of free cap bits (one per entry);
Free items are not shown
-----------------------------------------------------------------------

Index  CBF      [9]             [8]             [7]             [6]
[5]             [4]             [3]             [2]             [1]
[0]      
----- ----- ---------------- ---------------- ---------------- ----------------
---------------- ---------------- ---------------- ---------------- -----------
----- ----------------
  14    9 212/0/1                     Free            Free            Free
Free            Free            Free            Free            Free
Free

Вот пояснение того, что произошло. Поскольку регистры LOU полны, вы больше не можете устанавливать новые L4Op там, и ни на что нельзя сослаться в capmap таблице. На данном этапе вы все еще пытаетесь установить L4Op в TCAM путем расширения их. Если L4Op нерасширяемы, то вы программный коммутатор весь интерфейс в данном направлении.

Что делает 100%-е использование регистра LOU, подразумевают? Ваш TCAM начинает заполняться быстро (из-за расширения L4Op). При попытке установить нерасширяемые L4Op, то с текущей реализацией, ваш весь интерфейс соединил программное обеспечение.

Как есть теперь, когда вы пытаетесь установить нерасширяемый L4Op в такой ситуации, ошибка только генерируется. Данный пример модифицировал текущий ACL a13, который был применен к interface VLAN 13 с добавлением нерасширяемого L4Op.

Sup2T(config)#ip access-list extended a13
Sup2T(config-ext-nacl)#permit tcp host 192.168.14.1 host 192.168.14.2 dscp 40

Oct 5 04:50:13.104: %FMCORE-4-RACL_REDUCED: Interface Vlan13 routed traffic will
be software switched in ingress direction. L2 features may not be applied at the
interface

Oct 5 04:50:13.096: %EARL_CM-DFC3-5-NOLOU: No free LOU entry available on the EARL
Oct 5 04:50:13.096: %EARL_CM-DFC1-5-NOLOU: No free LOU entry available on the EARL
Oct 5 04:50:13.096: %EARL_CM-DFC4-5-NOLOU: No free LOU entry available on the EARL

Sup2T#show platform hardware acl entry interface vlan 13 security in ip        
mls_if_index:2000000D dir:0 feature:0 proto:0


pass#0 features


fno:0

tcam:B, bank:0, prot:0   Aces


Bridge               ip any any

Пример практического применения #3 - программирование QoS с L4Op

Политики QoS могли бы также сослаться на L4Op; эти L4Op должны быть установлены как любой другой L4Op. Это подразумевает, что для интерфейса, даже для ваших политик QoS, вы ограничены ограничениями, которые по сути имеют capmap таблицы и LOUs. Вот пример для иллюстрирования этого скромно:

Sup2T#show ip access-lists a1
Extended IP access list a1
   10 permit tcp host 192.168.1.10 host 192.168.2.10 dscp ef

Sup2T#show class-map a1-class
 Class Map match-all a1-class (id 37)
  Match access-group name a1

Sup2T#show policy-map a1-policy
 Policy Map a1-policy
   Class a1-class
    police cir 80000 bc 2500
      conform-action transmit
      exceed-action drop

Данный пример имеет policy-map, совпадающий с class-map, который вызывает access-list a1, который совпадает с трафиком от 192.168.1.10 до 192.168.2.10, который отмечен Ускоренной пересылкой (EF). Соответствие на DSCP-значении является нерасширяемым L4Op; это требуется, чтобы быть запрограммированным в регистр LOU и сосланным через запись в capmap таблице. Этот policy-map теперь установлен входящий к gig3/23.

Sup2T#show run int gig3/23
Building configuration...

Current configuration : 176 bytes
!
interface GigabitEthernet3/23
 switchport
 switchport trunk allowed vlan 1-30
 switchport mode trunk
 service-policy input a1-policy
end

Для рассмотрения программирования QoS для интерфейса используйте эту команду:

Sup2T#show platform hardware acl entry interface gig3/23 qos in ip module 3
mls_if_index:8096000 dir:0 feature:1 proto:0


pass#0 features


fno:0

tcam:A, bank:0, prot:0   Aces


0x0000E0100000D00B   tcp host 192.168.1.10 host 192.168.2.10 dscp eq 46  
0x000000000080D00B   ip any any 

Детализация этой команды дает вам, для чего используется метка TCAM на этом интерфейсе.

Sup2T#show platform hardware acl entry interface gig3/23 qos in ip detail module 3
mls_if_index:8096000 dir:0 feature:1 proto:0


pass#0 features
UAPRSF: U-urg, A-ack, P-psh, R-rst, S-syn, F-fin
MLGFI: M-mpls_plus_ip_pkt, L-L4_hdr_vld, G-gpid_present,F-global_fmt_match, I-ife/ofe
's' means set; 'u' means unset; '-' means don't care
-----------------------------------------------------------------------
-----------------------------------------------------------------------
--------------------------------------------------------
I    INDEX LABEL FS ACOS   AS          IP_SA       SRC_PORT
IP_DA       DST_PORT F FF L4PROT TCP-F:UAPRSF MLGFI OtherL4OPs
RSLT                 CNT
------------------------------------------------------------------------------------
------------------------------------------------------------------------------------
------------------------------


fno:0

tcam:A, bank:0, prot:0   Aces
         
I V 16238     2 0   0    0   192.168.1.10              -   192.168.2.10
- 0 0     1     -      ----- dscp=46;                     0x0000E0100000D00B
0
I M 16238 0x1FFF 0 0x00 0x000 255.255.255.255              - 255.255.255.255
- 0 0   0xF
I V 16239     2 0   0    0        0.0.0.0              -        0.0.0.0
- 0 0     0     -      -----         -                   0x000000000080D00B
0
I M 16239 0x1FFF 0 0x00 0x000        0.0.0.0              -        0.0.0.0
- 0 0   0x0

Метка TCAM, которая используется, равняется 2. Посмотрите на capmap таблицу для этого теперь:

Sup2T#show platform software acl capmap tcam A label 2 module 3
Shadow Capmap Table Entry For TCAM A

-----------------------------------------------------------------------
Output in a RST/INV/CNT format: RST - result value; INV - inverted;
                               CNT - aggregated reference account;

CBF - number of free cap bits (one per entry);
Free items are not shown
-----------------------------------------------------------------------

Index  CBF      [9]             [8]             [7]             [6]
[5]             [4]             [3]             [2]             [1]
[0]      
----- ----- ---------------- ---------------- ---------------- ----------------
---------------- ---------------- ---------------- ---------------- -----------
----- ----------------
   2    8 212/0/1                     Free            Free            Free
Free            Free            Free            Free            Free  2/1/1  

Примечание: Для TCAM QoS необходимо задать номер модуля. Без этого выходные данные не приводят ни к каким результатам.

Sup2T#show platform software acl capmap mapping 
      L4op_sel value    Reference  
      ==============    =========
      0    ------      LOU0 B register
      1    ------      LOU0 A register
      2    ------      LOU1 B register
      3    ------      LOU1 A register

*snip*

Значение LOU 2 точек к LOU1, зарегистрируйте B. Можно подтвердить это программирование с этой командой:

Sup2T#show platform hardware acl lou 
Dumping h/w lou values

Index lou_mux_sel A_Opcode A_Value B_Opcode B_Value
----- ----------- -------- ------- -------- -------
   0           7      NEQ       0      NEQ       0
   1           4      NEQ       0      NEQ      46
   2           1      NEQ       0      NEQ       0
*snip*

Увеличьте масштаб конфигурации.

Sup2T#show ip access-lists a1
Extended IP access list a1
   10 permit tcp host 192.168.1.10 host 192.168.2.10 dscp ef
   20 permit tcp host 192.168.2.11 host 192.168.2.11 dscp ef
   30 permit tcp host 192.168.3.11 host 192.168.3.11 dscp ef
   40 permit tcp host 192.168.4.11 host 192.168.4.11 dscp ef
   50 permit tcp host 192.168.5.11 host 192.168.5.11 dscp ef
   60 permit tcp host 192.168.6.11 host 192.168.6.11 dscp ef
   70 permit tcp host 192.168.7.11 host 192.168.7.11 dscp ef
   80 permit tcp host 192.168.8.11 host 192.168.8.11 dscp ef


Sup2T#show platform software acl capmap tcam A label 2 module 3
Shadow Capmap Table Entry For TCAM A

-----------------------------------------------------------------------
Output in a RST/INV/CNT format: RST - result value; INV - inverted;
                               CNT - aggregated reference account;

CBF - number of free cap bits (one per entry);
Free items are not shown
-----------------------------------------------------------------------

Index  CBF      [9]             [8]             [7]             [6]
[5]             [4]             [3]             [2]             [1]
[0]      
----- ----- ---------------- ---------------- ----------------
---------------- ---------------- ---------------- ----------
------ ---------------- ---------------- ----------------
   2    8 212/0/1                     Free            Free            Free
Free            Free            Free            Free            Free  2/1/8

Это больше не использует записи; вместо этого, это увеличивает составной подсчет ссылок против самой первой записи, которая целесообразна. От capmap таблицы и перспективы регистра LOU, нет никакого беспокойства по поводу источника и назначения. Это просто хранит информацию L4Op. Так как это совпадает против того же DSCP-значения на всех ACE, вам только нужна одна запись для того DSCP-значения.

Модифицируйте это так, чтобы вы использовали девять других DSCP-значений.

Sup2T#show ip access-lists a1
Extended IP access list a1
   10 permit tcp host 192.168.1.10 host 192.168.2.10 dscp af11
   20 permit tcp host 192.168.2.11 host 192.168.2.11 dscp af12
   30 permit tcp host 192.168.3.11 host 192.168.3.11 dscp af13
   40 permit tcp host 192.168.4.11 host 192.168.4.11 dscp af21
   50 permit tcp host 192.168.5.11 host 192.168.5.11 dscp af22
   60 permit tcp host 192.168.6.11 host 192.168.6.11 dscp af23
   70 permit tcp host 192.168.7.11 host 192.168.7.11 dscp af31
   80 permit tcp host 192.168.8.11 host 192.168.8.11 dscp af32
   90 permit tcp host 192.168.9.11 host 192.168.9.11 dscp af33

Теперь при рассмотрении capmap таблицы вы видите, что это полно:

Sup2T#show platform software acl capmap tcam A label 2 module 3
Shadow Capmap Table Entry For TCAM A

-----------------------------------------------------------------------
Output in a RST/INV/CNT format: RST - result value; INV - inverted;
                               CNT - aggregated reference account;

CBF - number of free cap bits (one per entry);
Free items are not shown
-----------------------------------------------------------------------

Index  CBF      [9]             [8]             [7]             [6]
[5]             [4]             [3]             [2]
[1]             [0]      
----- ----- ---------------- ---------------- ---------------- -----------
----- ---------------- ---------------- ---------------- ----------------
---------------- ----------------
   2    0 212/0/1          10/1/1           9/1/1           8/1/1
7/1/1           6/1/1           5/1/1           4/1/1           3/1/1
2/1/1        

Вот то, что происходит, при попытке установить другую нерасширяемую основанную на L4Op запись:

Sup2T(config-ext-nacl)#permit tcp host 192.168.10.11 host 192.168.10.11 dscp 2
Sup2T(config-ext-nacl)#end


%QM-4-TCAM_ENTRY: Hardware TCAM entry programming failed for slot 3 intf Gi3/23
dir IN: <CONFIG_UPDATE_REQ> TCAM Req Error: FAIL (4): Low TCAM Entries (1)
%QM-4-TCAM_ENTRY: Hardware TCAM entry programming failed for slot 3 intf Gi3/23
dir IN: <CONFIG_UPDATE_REQ> TCAM Req Error: FAIL (4): Low TCAM Entries (1)
%QM-4-TCAM_ENTRY: Hardware TCAM entry programming failed for slot 3 intf Gi3/23
dir IN: <CONFIG_UPDATE_REQ> TCAM Req Error: FAIL (4): Low TCAM Entries (1)
%QM-4-TCAM_ENTRY: Hardware TCAM entry programming failed for slot 3 intf Gi3/23
dir IN: <CONFIG_UPDATE_REQ> TCAM Req Error: FAIL (4): Low TCAM Entries (1)
%QM-4-TCAM_ENTRY: Hardware TCAM entry programming failed for slot 3 intf Gi3/23
dir IN: <CONFIG_UPDATE_REQ> TCAM Req Error: FAIL (4): Low TCAM Entries (1)
%FMCORE-6-RACL_ENABLED: Interface GigabitEthernet3/23 routed traffic is hardware
switched in ingress direction
Oct 20 17:12:54.304: %EARL_CM-DFC3-5-NOCAPMAP: No free capmap entry available

Посмотрите на TCAM для этого интерфейса теперь:

Sup2T#show platform hardware acl entry interface gig3/23 qos in ip module 3

mls_if_index:8096000 dir:0 feature:1 proto:0

 Couldnt find feature for mls_if_index 0x8096000, dir 0

Ни одна из Характеристик QoS больше не устанавливается в TCAM для этого интерфейса.

Заметьте, что маркировка не использует L4Op. Таким образом, если у вас есть простой ACL, который не имеет L4Op, и вы устанавливаете DSCP-значение на соответствии, никакие регистры LOU не используются для этого. Например:

Sup2T#show policy-map a1-policy
 Policy Map a1-policy
   Class a1-class
     set dscp ef

Sup2T#show class-map a1-class
 Class Map match-all a1-class (id 37)
  Match access-group name a1

Sup2T#show ip access-lists a1
Extended IP access list a1
   10 permit tcp host 192.168.1.1 host 192.168.2.1

Это применено к интерфейсу gig3/23:

Sup2T#show run interface gig3/23
Building configuration...

Current configuration : 176 bytes
!
interface GigabitEthernet3/23
 switchport
 switchport trunk allowed vlan 1-30
 switchport mode trunk
 service-policy input a1-policy
end


Sup2T#show platform hardware acl entry interface gig3/23 qos in ip detail module 3

mls_if_index:8096000 dir:0 feature:1 proto:0


pass#0 features
UAPRSF: U-urg, A-ack, P-psh, R-rst, S-syn, F-fin
MLGFI: M-mpls_plus_ip_pkt, L-L4_hdr_vld, G-gpid_present,F-global_fmt_match, I-ife/ofe
's' means set; 'u' means unset; '-' means don't care
----------------------------------------------------------------
----------------------------------------------------------------
---------------------------------------------------------------
-------
I    INDEX LABEL FS ACOS   AS          IP_SA       SRC_PORT
IP_DA       DST_PORT F FF L4PROT TCP-F:UAPRSF MLGFI OtherL4OPs
RSLT                 CNT
---------------------------------------------------------------
---------------------------------------------------------------
---------------------------------------------------------------
---------


fno:0

tcam:A, bank:0, prot:0   Aces
         
I V 16238     3 0   0    0    192.168.1.1              -    192.168.2.1
- 0 0     1     -      -----         -                   0x0000E010005D100B
0
I M 16238 0x1FFF 0 0x00 0x000 255.255.255.255              - 255.255.255.255
- 0 0   0xF
I V 16239     3 0   0    0        0.0.0.0              -        0.0.0.0
- 0 0     0     -      -----         -                   0x000000000080D00B
0
I M 16239 0x1FFF 0 0x00 0x000        0.0.0.0              -        0.0.0.0
- 0 0   0x0

Sup2T#show platform software acl capmap tcam A label 3 module 3
Shadow Capmap Table Entry For TCAM A

-----------------------------------------------------------------------
Output in a RST/INV/CNT format: RST - result value; INV - inverted;
                               CNT - aggregated reference account;

CBF - number of free cap bits (one per entry);
Free items are not shown
-----------------------------------------------------------------------

Index  CBF      [9]             [8]             [7]             [6]
[5]             [4]             [3]             [2]             [1]
[0]      
----- ----- ---------------- ---------------- ---------------- ----------------
---------------- ---------------- ---------------- ---------------- -----------
----- ----------------
   3    9 212/0/1                     Free            Free            Free
Free            Free            Free            Free            Free
Free


Document ID: 118649