Коммутаторы : коммутаторы Cisco Catalyst серии 3850

3750 мл к 3850 преобразованиям MQC конфигурации QoS

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв

Содержание

Введение

Документ описывает основное отличие между 3750 Многоуровневой коммутацией (MLS) Качество обслуживания (QoS) и Cisco Catalyst 3850 QoS Командной строки Modular QoS CLI (MQC) Коммутаторов. Это также предоставляет подробные сведения о преобразовании через примеры конфигурации. Этот документ только применяется к Проводному QoS. Этот документ для специалистов по сетевым технологиям, кто ответственен за дизайн, implemention, или administation сети, которая включает автономный Cisco Catalyst 3850 Коммутаторов или Cisco Catalyst 3850 Стеков коммутаторов, называемых коммутатором.

Внесенный Ярославом Гороном и Вивеком Шармой, специалистами службы технической поддержки Cisco.

Предварительные условия

Требования

Компания Cisco рекомендует предварительно ознакомиться со следующими предметами:

  • ПО Cisco IOS®
  • Понятия и терминология MLS и QoS MQC

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Обзор для различия между 3750 MLS QoS и 3850 QoS MQC

Конфигурация QoS в 3850 линиях была улучшена из-за ее реализации MQC (универсальная модель конфигурации QoS) конфигурация вместо старого MLS QoS (зависимая от платформы конфигурация QoS) команды от 3750 и 3560 линий коммутаторов.

Основные различия выделены в этой таблице:

Switch Type (Тип коммутатора)

3750

3850

Базовая структура

MLS

MQC

По умолчанию QoS

Отключенный

Включенный

Глобальная конфигурация

MLS QoS поддержки

Поддержите часть MQC во входе

Не поддерживает MLS QoS

MQC поддержки [class-map, policy-map]

Интерфейсный config

MLS QoS поддержки конфигурируется и часть CLI MQC во входе

Подключите политику к интерфейсу

По умолчанию уровня надежности порта

Отключенный

Включенный

Вход порта

Classification/Policing/Marking/

Организация очереди

Классификация/Применение политик/маркировка

[НИКАКАЯ организация очереди Iingress!]

Выход порта

Организация очереди

Классификация/Применение политик/маркировка/организация очереди

Вход коммутируемого виртуального интерфейса (SVI)

Классификация/Применение политик/Маркировать

Классификация/Маркировать

Выход SVI

Нет

Классификация/Маркировать

Важно распознать основное коренное изменение в подходе QoS.

На этих 3750 по умолчанию отключено QoS, тогда как на этих 3850, оно включено. Также для сохранения Уровня 2 (L2) / Уровень 3 (L3) маркировка QoS на 3750 платформах, трастовая конфигурация должна быть применена.

В случае этих 3850 всем пакетам по умолчанию доверяют (маркировка QoS L2/L3 сохранена), пока вы не изменяете ее с приложением определенной карты политик на входе или исходящем интерфейсе.

3750 моделей QoS

3850 моделей QoS

Подробная сравнительная таблица функции

Вход

Функция

3750

3850

Классификация

Кодовая точка дифференцированных сервисов (DSCP) соответствия class-map, Приоритеты (Prec), Список контроля доступа (ACL)

Поддерживает и match-all и match-any

Класс обслуживания (CoS) class-map, Prec, DSCP, ACL

И VLAN

Match-any поддержек только

Маркирование

[безусловный набор]

Set DSCP и Prec

Set CoS, Prec, DSCP и группа QoS

Маркирование

[условная маркировка]

Мутация DSCP

Table-map class-default

Применение политик

1r2c

1r2c и 2r3c

Применение политик скидки с цены

Применение политик превышает скидку с цены

[Только поддерживает DSCP]

Применение политик превышает и нарушает скидку с цены

[CoS поддержек, DSCP, Prec]

Составное применение политик

Поддержки

Agg-применение-политик [один тип HQoS]

Входная организация очереди

Поддерживает только на 3750, но не поддерживает на 3750x

Неподдерживаемые платы

Иерархическое QoS (HQoS)

VLAN базировала HQoS только

На основе порта Agg-применение-политик и ДЛЯ КАЖДОЙ VLAN (PV)

Выход

Функция

3750

3850

Поддержка классификации ни одного помещающего действие в очередь

Неподдерживаемые платы

CoS, Prec, DSCP, группа QoS, ACL

и VLAN

Поддержка классификации организации очереди действия

CoS и DSCP

CoS, Prec, DSCP и группа QoS

Маркирование

Неподдерживаемые платы

Set CoS, Prec и DSCP

Применение политик

Неподдерживаемые платы

1r2c, 2r3c с превышают/нарушают, снижают цену через table-map

Максимальное число очередей и типов очереди

1P3Q3T [4 очереди]

Незатрудненная очередь-> Очередь с приоритетами

2P6Q3T [до 8 очередей]

Выходная организация очереди

Общий режим, режим формы, queue-limit, приоритет и буфер очереди

Пропускная способность, bandwidth remaining, формирование, queue-limit, приоритет и буфер очереди

HQoS

Неподдерживаемые платы

HQoS: Agg-применение-политик, PV, формирователь порта и Родительский пользовательский формирователь с потомком, непомещающим действие в очередь

Общие команды показа QoS

3750

Входные команды показа:

show run class-map  [name_of_class-map]
show run policy-map [name of policy-map]
show policy-map int [interface_name]

Общие команды показа:

show mls qos maps
show mls qos maps <options>
show mls qos queue-set
show mls qos interface [interface_name] queuing
show platform port-asic stats drop [interface_name] statistics
show mls qos aggregate-policer

3850

show run class-map [name_of_class-map]
show run policy-map [name of policy-map]
show table-map [name_of_table-map]
show run policy-map [name_of_policy-map]
show policy-map int [interface_name]
show platform qos policies port sw [sw#]
show platform qos queue config interface_type [interface_name]
show platform qos queue stats interface_type [interface_name]

3750 - 3850 выборок преобразования QoS

Config QoS

3750

Глобальный

          3750

       интерфейс

    3850 *

 

Типовая ссылка

QoS отключает

Никакой MLS QoS

Две очереди

Контроль-> очередь (2)

Данные -> очередь (4)

Выход без политики

Контроль-> очередь (1)

Данные-> очередь (2)

Пример 1

Доверие или набор во входе и выходе

Организация очереди действия на основе входа

Доверие или набор

Mls qos

о

MLS QoS trust CoS

Выходная политика организации очереди классифицирует на CoS [вход должен сконфигурировать трастовый CoS]

Пример 2

b)

MLS QoS trust DSCP

выходная политика организации очереди классифицирует на DSCP

Пример 3

c

Политика для входящих пакетов с действием набора для маркировки DSCP-значения

Выходная политика организации очереди классифицирует на DSCP

Пример 4

d)

Никакой config MLS QoS trust [оба CoS/DSCP не будет установлен нуль]

Политика для входящих пакетов с class-default

Set CoS / DSCP 0

Пример 5

Сопоставление очередности CoS/DSCP

Совместно используемый циклический выбор (SRR) MLS QoS - работа очередь [Cos-map / Карта DSCP]

A, b, c и d будет использовать соответствующее новое сопоставление

Выведите явную классификацию [CoS/DSCP] с организацией очереди действия

Пример 6

Мутация DSCP

Мутация DSCP MLS QoS

Интерфейсная конфигурация потребности

MLS QoS trust DSCP

MLS QoS DSCP-mutation [название]

Политика входного интерфейса с table-map

Пример 7

Agg-применение-политик

MLS QoS aggregatepolicing

Нужна интерфейсная конфигурация

Agg-применение-политик [один тип HQoS]

Пример 8

Скидка с цены политики

MLS QoS map policed-DSCP [10] [11] к [63]

Политика ограничения скорости, подключающая для взаимодействия через интерфейс, превысьте не, понижаются, глобальный охраняемый DSCP вступит в силу

[Ввод]

Один table-map для превышает и один table-map forviolate действие применения политик

[Ввод/вывод]

Пример 9

Queue-limit

Выходной queue-set [1] порог MLS QoS [1] [100] [100] [50] [200]

1-> queue-set 1

<1-> очередь 1

Порог 1

Порог 2

Зарезервированный буфер

Max Threshold

queue-set [2] config

[queue-set 1 по умолчанию]

Выходная политика организации очереди с организацией очереди действия и конфигурации queue-limit

Пример 10

Буфера очереди

Выходные queue-set [1] буферы MLS QoS

[15] [25] [40] [20]

Интерфейсный queue-set config

Policy-map с организацией очереди действия и соотношения буферов очереди [0-100]

Пример 11

Ресурс общего доступа/пропускная способность

Mls qos

Config уровня интерфейса

"SRR-queue bandwidth share 1 30 35 5" [Общий режим]

Пропускная способность в policy-map

Пример 12

приоритетная очередь

[Незатрудненная очередь]

Mls qos

Config уровня интерфейса "priority-queue", это сделает 1-ю очередь соответствующего queue-set как очередь с приоритетами

Уровень приоритета 1 в policy-map

Пример 13

Формирователь

Mls qos

SRR-queue bandwidth shape [формирует режим]

Shape average в policy-map

Пример 14

Формирователь порта

Mls qos

SRR-queue bandwidth limit

Формирователь порта

Пример 15

HQoS

Mls qos

SVI [подключает политику к SVI] и интерфейсный MLS QoS "конфигурации потребностей VLAN_based"

Политика PV

И политика присоединения к порту во входном направлении

Пример 16

Пример 1: QoS отключает

3750 (Глобальная конфигурация)

3750 (интерфейс)

3850

Никакой MLS QoS

Две очереди [управляют одной очередью 2, данные одна очередь 4]

 

Выход без политики

[Pkts контроля в очереди 1 и пакеты данных в очереди 2]

3750

3750#show mls qos
QoS is disabled <- disable
QoS ip packet dscp rewrite is enabled

3750#show mls qos interface gig1/0/1 statistics | b output queues enqueued
output queues enqueued:
queue: threshold1 threshold2 threshold3
-----------------------------------------------
queue 0: 4 0 0
queue 1: 0 0 0 <- control
queue 2: 0 0 0
queue 3: 0 0 0 <- data

output queues dropped:
queue: threshold1 threshold2 threshold3
-----------------------------------------------
queue 0: 0 0 0
queue 1: 0 0 0 <- control
queue 2: 0 0 0
queue 3: 0 0 0 <- data

Policer: Inprofile: 0 OutofProfile: 0

3850

3850#show ru int gig1/0/1
interface GigabitEthernet1/0/1
end

3850#show platform qos queue config gigabitEthernet 1/0/1 sw 1
DATA Port:21 GPN:1 AFD:Disabled QoSMap:0 HW Queues: 168 - 175
DrainFast:Disabled PortSoftStart:1 - 600
----------------------------------------------------------
DTS Hardmax Softmax PortSMin GlblSMin PortStEnd
--- -------- -------- -------- --------- ---------
0 1 5 120 6 480 0 0 0 0 0 800 <- control
1 1 4 0 7 720 2 480 2 180 2 800 <- data
2 1 4 0 5 0 0 0 0 0 0 800
3 1 4 0 5 0 0 0 0 0 0 800
4 1 4 0 5 0 0 0 0 0 0 800
5 1 4 0 5 0 0 0 0 0 0 800
6 1 4 0 5 0 0 0 0 0 0 800
7 1 4 0 5 0 0 0 0 0 0 800
Priority Shaped/shared weight shaping_step
-------- ------------ ------ ------------
0 0 Shared 50 0
1 0 Shared 75 0
2 0 Shared 10000 179
3 0 Shared 10000 0
4 0 Shared 10000 0
5 0 Shared 10000 0
6 0 Shared 10000 192
7 0 Shared 10000 0

Weight0 Max_Th0 Min_Th0 Weigth1 Max_Th1 Min_Th1 Weight2 Max_Th2 Min_Th2
------- ------- ------ ------ ------ ------ ------ ------ ------
0 0 478 0 0 534 0 0 600 0
1 0 573 0 0 641 0 0 720 0
2 0 0 0 0 0 0 0 0 0
3 0 0 0 0 0 0 0 0 0
4 0 0 0 0 0 0 0 0 0
5 0 0 0 0 0 0 0 0 0
6 0 0 0 0 0 0 0 0 0
7 0 0 0 0 0 0 0 0 0

Пример 2: QoS включает доверие COS

3750 (Глобальный)

3750 (интерфейс)

3850

Mls qos

Интерфейсный "Mls qos trust, потому что" (на основе сопоставления CoS по умолчанию к queue-set 1)

Выходная политика организации очереди на основе CoS (вход должны сконфигурировать трастовый CoS),

 

3750

Global config:
3750(config)#mls qos

Interface config:

interface GigabitEthernet1/0/1
mls qos trust cos

Related show cli:

3750#sh mls qos
QoS is enabled
QoS ip packet dscp rewrite is enabled

3750#sh mls qos int gig1/0/1
GigabitEthernet1/0/1
trust state: trust cos
trust mode: trust cos
trust enabled flag: ena
COS override: dis
default COS: 0
DSCP Mutation Map: Default DSCP Mutation Map
Trust device: none
qos mode: port-based

3750 #show mls qos maps cos-output-q
Cos-outputq-threshold map:
cos: 0 1 2 3 4 6 7
------------------------------------------------------------
queue-threshold: 2-1 2-1 3-1 3-1 4-1 1-1 4-1 4-1

Note: cos value 0 maps to 2-1 [queue-set1 : queue2 threshold 1]

3850

Ingress: apply policy-map trust-cos
Egress: create class based on cos and have queuing action for each class

Ingress policy:
3850#show run policy-map trust-cos
class class-default
set cos cos table default

3850#show table-map default
Table Map default
default copy

Egress policy:
3850#show run policy-map example2
class cos5
bandwidth percent 15
class cos0_1
bandwidth percent 25
class cos2_3
bandwidth percent 40
class cos4_6_7
bandwidth percent 20

3850#show run class-map cos5
class-map match-any cos5
match cos 5

3850#show run class-map cos0_1
class-map match-any cos0_1
match cos 0
match cos 1

3850#show run class-map cos2_3
class-map match-any cos2_3
match cos 2
match cos 3

3850#show run class-map cos4_6_7
class-map match-any cos4_6_7
match cos 4
match cos 6
match cos 7

Пример 3: QoS включает Trust DSCP

3750 (Глобальный)

3750 (интерфейс)

3850

Mls qos

Интерфейсный "MLS QoS trust DSCP" [на основе Сопоставления DSCP по умолчанию к queue-set 1]

Входной trust DSCP по умолчанию

Выходная политика организации очереди на основе DSCP

3750

config
3750(config)#mls qos <- Global
interface GigabitEthernet1/0/1 <- Interface
mls qos trust dscp


3750#sh mls qos int gig1/0/1
GigabitEthernet1/0/1
trust state: trust dscp
trust mode: trust dscp
trust enabled flag: ena
COS override: dis
default COS: 0
DSCP Mutation Map: Default DSCP Mutation Map
Trust device: none
qos mode: port-based

3750#show mls qos maps dscp-output-q
Dscp-outputq-threshold map:
d1 :d2 0 1 2 3 4 5 6 7 8 9
---------------------------------------------------------------
0 : 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01 02-01
1 : 02-01 02-01 02-01 02-01 02-01 02-01 03-01 03-01 03-01 03-01
2 : 03-01 03-01 03-01 03-01 03-01 03-01 03-01 03-01 03-01 03-01
3 : 03-01 03-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01
4 : 01-01 01-01 01-01 01-01 01-01 01-01 01-01 01-01 04-01 04-01
5 : 04-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01 04-01
6 : 04-01 04-01 04-01 04-01

3850

Ingress: default trust dscp, no policy needed

Egress: use dscp as classification and add queuing action based on customer need

One Sample config:
Plolicy-map:
3850#show run policy-map dscp-shape
class dscp56
shape average percent 10
class dscp48
shape average percent 11
class dscp40
shape average percent 12
class dscp32
shape average percent 13
Class-map:
3850#show run class-map dscp56
class-map match-any dscp56
match dscp cs7

3850#show run class-map dscp48

class-map match-any dscp48
match dscp cs6

3850#show run class-map dscp40
class-map match-any dscp40
match dscp cs5

3850#show run class-map dscp32
class-map match-any dscp32
match dscp cs4

Пример 4: QoS Включает с Интерфейсом, который Имеет Политику Набора

3750 (глобальный)

3750 (интерфейс)

3850

Mls qos

Политика входного интерфейса с действием набора для маркировки значения CoS/DSCP

[Маркированное значение будет использоваться для выходного сопоставления]

Нужна явная выходная политика, чтобы сделать сопоставление организации очереди

3750

3750#show run class-map dscp-1
class-map match-any dscp-1
match ip dscp 1

c3750#show run policy-map set-dscp-63
class dscp-1
set dscp 63

3750#show run int f7/0/2
interface FastEthernet7/0/2
mls qos trust dscp
service-policy input set-dscp-63

3750#show policy-map int f7/0/2
FastEthernet7/0/2

Service-policy input: set-dscp-63

Class-map: dscp-1 (match-any)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: ip dscp 1

Class-map: class-default (match-any)
0 packets, 0 bytes
5 minute offered rate 0 bps, drop rate 0 bps
Match: any
0 packets, 0 bytes
5 minute rate 0 bps

Note: Pkts come in interface fa7/0/2, dscp1 will be marked to dscp63 which mapping
based on the existing mapping table, other pkts will retain original dscp value
mapping accordingly

3850

Input will be same as 3750 config 

Egress: will add queuing action under class dscp-63


One sample config:

3850#show run policy-map dscp63-queuing
class dscp63
bandwidth percent 50

3850#show class-map dscp63
Class Map match-any dscp63

Match dscp 63

Пример 5: QoS включает без MLS QoS Trust на интерфейсе

3750 (глобальный)

3750 (интерфейс)

3850

Mls qos

Интерфейс не конфигурирует DSCP CoS / MLS QoS trust

[CoS/DSCP будет установлен в 0]

Политика входного интерфейса с class-default

Set DSCP 0, политика вывода с классом DSCP0 с организацией очереди действия

3750

Global:
c3750(config)#mls qos

Interface:
interface GigabitEthernet2/0/45
!

3850

Input policy:
c3850#show run policy-map example5-input
class class-default
set dscp default

Output policy:
c3850#show run policy-map example5-output
class dscp0
shape average percent 10 <- queuing action based on customer need

Attach to the ingress port:
c3850#show run int gig1/0/1
interface GigabitEthernet1/0/1
service-policy input example5-input

Attach to the egress port:
c3850#show ru int gig1/0/2
interface GigabitEthernet1/0/2
service-policy output example5-output

Пример 6: QoS Включает с Сопоставлением очередности CoS/DSCP Изменения

3750 (глобальный)

3750 (интерфейс)

3850

Config сопоставления очередности SRR MLS QoS

(Работа очередь SRR MLS QoS [Очередь CoS-map [1] порог [3] [4 5])

A, b, c и d будет использовать новую таблицу соответствий

[CoS 4 и 5 будет картой для организации очереди 1 порога 3]

Выходная явная классификация с организацией очереди действия

3750

Before config:
3750#show mls qos maps cos-output-q
Cos-outputq-threshold map:
cos: 0 1 2 3 4 5 6 7
------------------------------------------------
queue-threshold: 2-1 2-1 3-1 3-1 4-1 1-1 4-1 4-1

User config mapping:
3750(config)#mls qos srr-queue output cos-map queue 3 threshold 3 0

New mapping table after config
3750#show mls qos maps cos-output-q
Cos-outputq-threshold map:
cos: 0 1 2 3 4 5 6 7
------------------------------------------------
queue-threshold: 3-3 2-1 3-1 3-1 4-1 1-1 4-1 4-1

3850

Input : need apply trust-cos policy:
3850#show run policy-map trust-cos
class class-default
set cos cos table default

3850#show table-map default
Table Map default
default copy


Egress policy:

Before changing mapping:
Sample config:
3850#show run policy-map example2
class cos5
bandwidth percent 15
class cos0_1
bandwidth percent 25
class cos2_3
bandwidth percent 40
class cos4_6_7
bandwidth percent 20

3850#show run class-map cos5
class-map match-any cos5
match cos 5

3850#show run class-map cos0_1
class-map match-any cos0_1
match cos 0
match cos 1

3850#show run class-map cos2_3
class-map match-any cos2_3
match cos 2
match cos 3

3850#show run class-map cos4_6_7
!
class-map match-any cos4_6_7
match cos 4
match cos 6
match cos 7

After mapping changing , corresponding sample config:

3850#show run policy-map example6
class cos5
bandwidth percent 15
class cos1
bandwidth percent 25
class cos0_2_3
bandwidth percent 40
class cos4_6_7
bandwidth percent 20

3850#show class-map cos5
Class Map match-any cos5 (id 25)
Match cos 5

3850#show run class-map cos1
class-map match-any cos1
match cos 1

3850#show run class-map cos0_2_3
class-map match-any cos0_2_3
match cos 0
match cos 2
match cos 3

3850#show run class-map cos4_6_7
class-map match-any cos4_6_7
match cos 4
match cos 6
match cos 7

Пример 7: MLS включает с мутацией DSCP

3750 (глобальный)

3750 (интерфейс)

3850

Мутация DSCP MLS QoS

Интерфейсный MLS QoS trust DSCP config потребности

Название MLS QoS DSCP-mutation [название определено в глобальном]

Политика входного интерфейса с table-map, сопоставляющим другой DSCP

3750

Global config :
3750(config)#mls qos map dscp-mutation dscp-mutation 0 1 to 63
3750(config)#mls qos map dscp-mutation dscp-mutation 2 3 to 62

Global show cli:
c3750#show mls qos maps dscp-mutation

Dscp-dscp mutation map:
dscp-mutation:
d1 : d2 0 1 2 3 4 5 6 7 8 9
---------------------------------------
0 : 63 63 62 62 04 05 06 07 08 09
1 : 10 11 12 13 14 15 16 17 18 19
2 : 20 21 22 23 24 25 26 27 28 29
3 : 30 31 32 33 34 35 36 37 38 39
4 : 40 41 42 43 44 45 46 47 48 49
5 : 50 51 52 53 54 55 56 57 58 59
6 : 60 61 62 63
Dscp-dscp mutation map:
Default DSCP Mutation Map:
d1 : d2 0 1 2 3 4 5 6 7 8 9
---------------------------------------
0 : 00 01 02 03 04 05 06 07 08 09
1 : 10 11 12 13 14 15 16 17 18 19
2 : 20 21 22 23 24 25 26 27 28 29
3 : 30 31 32 33 34 35 36 37 38 39
4 : 40 41 42 43 44 45 46 47 48 49
5 : 50 51 52 53 54 55 56 57 58 59
6 : 60 61 62 63

Interface config:

interface FastEthernet7/0/3
description trust dscp
mls qos trust dscp
mls qos dscp-mutation dscp-mutation

c3750#show mls qos int f7/0/3
FastEthernet7/0/3
trust state: trust dscp
trust mode: trust dscp
trust enabled flag: ena
COS override: dis
default COS: 0
DSCP Mutation Map: dscp-mutation
Trust device: none
qos mode: port-based

Interface using default dscp-table:

c3750#show mls qos int g3/0/1
GigabitEthernet3/0/1
trust state: not trusted
trust mode: not trusted
trust enabled flag: ena
COS override: dis
default COS: 0
DSCP Mutation Map: Default DSCP Mutation Map
Trust device: none
qos mode: port-based

3850

Ingress : apply policy with dscp table-map
Egress: classify on new dscp value with queuing action

Ingress:
3850#show table-map dscp-2-dscp
Table Map dscp-2-dscp
from 0 to 63
from 1 to 63
from 2 to 62
from 3 to 62
default copy
3850#show run policy-map example7-input
class class-default
set dscp dscp table dscp-2-dscp

Egress:
3850#show run policy-map example7-output

class dscp63
shape average percent 20 [ queuing action based on the user need]
class dscp62
shape average percent 30 [queuing action based on user need]

Пример 8: MLS QoS включает с составным применением политик

3750 (глобальный)

3750 (интерфейс)

3850

Применение политик агрегата MLS QoS

[Все классы с помощью agg-применения-политик совместно используют ограничение скорости]

Config уровня интерфейса потребности

Agg-применение-политик (HQoS)

Сброс в случае превышения agg_traffic 8000 8000 MLS QoS aggregate-policer

Интерфейс, имеющий политику, которая имеет agg_traffic как agg название ограничителя

3750

Global:
mls qos aggregate-policer agg_traffic 8000 8000 exceed-action drop

Access-list:
access-list 1 permit 192.168.0.0 0.0.0.255
access-list 2 permit 10.0.0.0 0.0.0.255

Class-map:
class-map match-all agg1
match access-group 1
class-map match-all agg2
match access-group 2

Policy-map:
policy-map agg_policer
class agg1
set dscp 40
police aggregate agg_traffic
class agg2
set dscp 55
police aggregate agg_traffic

Note: class agg1 and agg2 will share the same policing rate

3850

policy-map agg_police
class class-default
police cir 8000
service-policy child

policy-map child
class agg1
set dscp 40
class agg2
set dscp 55

Пример 9: MLS включает с применением политик, снижают цену

3750 (Глобальная конфигурация)

3750 (интерфейс)

3850

MLS QoS map policed-DSCP x к y

Пока интерфейс имеет политику ограничения скорости, превысьте, передача, глобальный CLI вступит в силу [вводят только]

Один table-map для превышает и один для действия нарушения применения политик, ввода, и вывел

3750

Default policed-dscp map:
3750#show mls qos map policed-dscp
Policed-dscp map:
d1 : d2 0 1 2 3 4 5 6 7 8 9
---------------------------------------
0 : 00 01 02 03 04 05 06 07 08 09
1 : 10 11 12 13 14 15 16 17 18 19
2 : 20 21 22 23 24 25 26 27 28 29
3 : 30 31 32 33 34 35 36 37 38 39
4 : 40 41 42 43 44 45 46 47 48 49
5 : 50 51 52 53 54 55 56 57 58 59
6 : 60 61 62 63

User define policed-dscp map:
3750(config)#mls qos map policed-dscp 0 10 18 24 46 to 8
3750#show mls qos map policed-dscp
Policed-dscp map:
d1 : d2 0 1 2 3 4 5 6 7 8 9
---------------------------------------
0 : 08 01 02 03 04 05 06 07 08 09
1 : 08 11 12 13 14 15 16 17 08 19
2 : 20 21 22 23 08 25 26 27 28 29
3 : 30 31 32 33 34 35 36 37 38 39
4 : 40 41 42 43 44 45 08 47 48 49
5 : 50 51 52 53 54 55 56 57 58 59
6 : 60 61 62 63

Policy config:
class-map match-all policed-dscp
match access-group 2
class policed-dscp
police 8000 8000 exceed-action policed-dscp-transmit

Attach the above policy at ingress:

Note : Mark down table can be used by policing and interface policing
as long as exceed action is transmit

3850

3850(config)#table-map policed-dscp
3850(config-tablemap)#map from 0 to 8
3850(config-tablemap)#map from 10 to 8
3850(config-tablemap)#map from 18 to 8
3850(config-tablemap)#map from 24 to 8
3850(config-tablemap)#map from 46 to 8
3850#show table-map policed-dscp
Table Map policed-dscp
from 0 to 8
from 10 to 8
from 18 to 8
from 24 to 8
from 46 to 8
default copy

3850#show policy-map policed-dscp
Policy Map policed-dscp
Class class-default
police cir percent 10
conform-action transmit
exceed-action set-dscp-transmit dscp table policed-dscp

Пример 10: MLS QoS включает с конфигурацией Queue-Limit

3750 (глобальный)

3750 (интерфейс)

3850

Выходной queue-set 1 порог MLS QoS 1100 100 50 200 (queue-limit)

[1-> queue-set 1,

1-> первая очередь,

100-> порог 1,

100-> порог 2,

50-> зарезервированный буфер,

200-> максимальный порог]

Интерфейсный queue-set config

[По умолчанию является queue-set 1]

Выходная политика организации очереди с организацией очереди действия и q-предельного config

3750

Global config:
mls qos srr-queue output cos-map queue 2 threshold 1 2
mls qos srr-queue output cos-map queue 2 threshold 2 3
mls qos srr-queue output cos-map queue 2 threshold 3 6 7


If no interface config, the queue-set 1 will be used:

3750#show mls qos queue-set 1
Queueset: 1
Queue : 1 2 3 4
----------------------------------------------
buffers : 15 25 40 20
threshold1: 100 125 100 60
threshold2: 100 125 100 150
reserved : 50 100 100 50
maximum : 200 400 400 200

For interface config queue-set 2 explicitly:

3750#show mls qos queue-set 2
Queueset: 2
Queue : 1 2 3 4
----------------------------------------------
buffers : 25 25 25 25
threshold1: 100 200 100 100
threshold2: 100 200 100 100
reserved : 50 50 50 50
maximum : 400 400 400 400

3850

(multiple class with queue-limit turn on)
3850#show policy-map q-limit
Policy Map q-limit
Class users-class
Queuing action ( shaper, bandwidth and bandwidth remaining)
queue-limit cos 2 percent 50
queue-limit cos 3 percent 50
queue-limit cos 6 percent 70
queue-limit cos 7 percent 70
Note: using the above config, cos 2 and cos 3 will be dropped earlier then cos 6 and 7

Пример 11: MLS QoS включает с конфигурацией буфера очереди

3750 (глобальный)

3750 (интерфейс)

3850

Выходные queue-set [1] буферы MLS QoS [15 25 40 20]

Интерфейсный queue-set config [queue-set 1 по умолчанию]

Policy-map с организацией очереди действия и соотношения буферов очереди [0-100]

3750

Default queue-buffer :
3750#show mls qos queue-set 1
Queueset: 1
Queue : 1 2 3 4
----------------------------------------------
buffers : 25 25 25 25
threshold1: 100 200 100 100
threshold2: 100 200 100 100
reserved : 50 50 50 50
maximum : 400 400 400 400

User define queue-buffer:
mls qos queue-set output 1 buffers 15 25 40 20

3750#show mls qos queue-set 1
Queueset: 1
Queue : 1 2 3 4
----------------------------------------------
buffers : 15 25 40 20
threshold1: 100 125 100 60
threshold2: 100 125 100 150
reserved : 50 100 100 50
maximum : 200 400 400 200

3850

3850#show policy-map  queue-buffer
Policy Map queue-buffer
Class cos7
bandwidth percent 10
queue-buffers ratio 15
Class cos1
bandwidth percent 30
queue-buffers ratio 25

class-map:
========
3850#show class-map cos7
Class Map match-any cos7 (id 22)

Match cos 7

3850#show class-map cos1
Class Map match-any cos1 (id 28)

Match cos 1

Attach to the interface at egress direction:

Пример 12: MLS QoS включает с настройкой пропускной способности

3750 (глобальный)

3750 (интерфейс)

3850

MLS QoS (совместно используют режим),

Config уровня интерфейса

"SRR-queue bandwidth share 1 30 35 5"

Bandwith в policy-map

3750

Default share and shape mode:
3750-3stack#show mls qos interface gig 1/0/1 queueing
GigabitEthernet1/0/1
Egress Priority Queue : disabled
Shaped queue weights (absolute) : 25 0 0 0
Shared queue weights : 25 25 25 25
The port bandwidth limit : 100 (Operational Bandwidth:100.0)
The port is mapped to qset : 1

User config share mode under interface:
interface GigabitEthernet1/0/1
srr-queue bandwidth share 40 30 20 10
srr-queue bandwidth shape 0 0 0 0


3750#show mls qos interface gig1/0/1 queueing
GigabitEthernet1/0/1
Egress Priority Queue : disabled
Shaped queue weights (absolute) : 0 0 0 0
Shared queue weights : 40 30 20 10
The port bandwidth limit : 100 (Operational Bandwidth:100.0)
The port is mapped to qset : 1

3850

3850#show policy-map  bandwidth
Policy Map bandwidth
Class cos1
bandwidth percent 40
Class cos2
bandwidth percent 30
Class cos3
bandwidth percent 20
Class class-default
bandwidth percent 10
3850#show class-map cos1
Class Map match-any cos1

Match cos 1

3850#show class-map cos2
Class Map match-any cos2

Match cos 2

3850#show class-map cos3
Class Map match-any cos3 (id 26)

Match cos 3

3850#show class-map cos4
Class Map match-any cos4 (id 25)

Match cos 4

Пример 13: MLS QoS включает с приоритетом

3750 (Глобальный)

3750 (Интерфейс)

3850

MLS QoS [ускоряет очередь]

Примечание: незатрудненная очередь то же как очередь с приоритетами

Config уровня интерфейса "priority-queue" [делает 1-ю очередь соответствующего queue-set как очередь строго по приоритету]

Уровень 1 Prioriy в policy-map

3750

interface GigabitEthernet1/0/2
priority-queue out
end

3750#show mls qos interface gig1/0/2 queueing
GigabitEthernet1/0/2
Egress Priority Queue : enabled
Shaped queue weights (absolute) : 25 0 0 0
Shared queue weights : 25 25 25 25
The port bandwidth limit : 100 (Operational Bandwidth:100.0)
The port is mapped to qset : 1

3850

3850#show run policy-map  priority-queue
class cos7
priority level 1 ? strict priority
class cos1
shape average percent 10
Attach the above policy to interface at egress side:

Пример 14: MLS QoS включает с конфигурацией формирователя

3750

Default shape mode:
GigabitEthernet1/0/3
Egress Priority Queue : disabled
Shaped queue weights (absolute) : 25 0 0 0
Shared queue weights : 25 25 25 25
The port bandwidth limit : 100 (Operational Bandwidth:100.0)
The port is mapped to qset : 1

User define shape mode:
interface GigabitEthernet1/0/3
srr-queue bandwidth shape 4 4 4 4


3750-3stack#show mls qos interface gigabitEthernet 1/0/3 queueing
GigabitEthernet1/0/3
Egress Priority Queue : disabled
Shaped queue weights (absolute) : 4 4 4 4
Shared queue weights : 25 25 25 25
The port bandwidth limit : 100 (Operational Bandwidth:100.0)
The port is mapped to qset : 1

3850

3850#show policy-map shape
Policy Map shape
Class cos1
Average Rate Traffic Shaping
cir 25%
Class cos2
Average Rate Traffic Shaping
cir 25%
Class cos3
Average Rate Traffic Shaping
cir 25%
Class cos4
Average Rate Traffic Shaping
cir 25%

Пример 15: MLS QoS включает с Bandwith

3750 (Глобальный)

3750 (Интерфейс)

3850

Mls qos

SRR-queue bandwidth limit

Скорость, пропускная способность

3750

interface GigabitEthernet1/0/4
srr-queue bandwidth limit 50


3750-3stack#show mls qos interface g1/0/4 queueing
GigabitEthernet1/0/4
Egress Priority Queue : disabled
Shaped queue weights (absolute) : 25 0 0 0
Shared queue weights : 25 25 25 25
The port bandwidth limit : 50 (Operational Bandwidth:50.0)
The port is mapped to qset : 1

3850

3850#show policy-map default-shape
Policy Map default-shape
Class class-default
Average Rate Traffic Shaping
cir 50%
service-policy child [ queuing based on customer need]

Пример 16: HQoS

3750 (Глобальная конфигурация)

3750 (Интерфейс)

3850

Class-map,

Policy-map

Политика присоединения к SVI

Интерфейсу нужна конфигурация "MLS QoS vlan_based"

Политика входа PV

3750

Note:
SVI: Parent [class acl based class-map->policing]

Child [class interface range class-map->marking]


Child class-map:

3750(config)# class-map cm-interface-1
3750(config-cmap)# match input gigabitethernet3/0/1 - gigabitethernet3/0/2

Child policy-map:
3750(config)# policy-map port-plcmap-1
3750(config-pmap)# class cm-interface-1
3750(config-pmap-c)# police 900000 9000 drop


Parent class-map matching acl:
3750(config)# access-list 101 permit ip any any

Parent class-map:
3750(config)# class-map cm-1
3750(config-cmap)# match access 101

3750(config)# policy-map vlan-plcmap
3750(config-pmap)# class cm-1
3750(config-pmap-c)# set dscp 7
3750(config-pmap-c)# service-policy port-plcmap-1
3750(config-pmap-c)# exit
3750(config-pmap)# class cm-2
3750(config-pmap-c)# service-policy port-plcmap-1
3750(config-pmap-c)# set dscp 10

Attach the policy to the interface:
3750(config)# interface vlan 10
3750(config-if)# service-policy input vlan-plcmap

3850

Note: Due to target change, this can't be one to one mapping, need config based on
customer requirement.


Target is at port level
Parent classify on vlan
Child: none vlan classification [for example cos/dscp]


3850#sh run policy-map PV_parent_marking_child_policing
class vlan10
set dscp 63
service-policy child_class_dscp_policing
class vlan11
set cos 5
service-policy child_class_dscp_policing
class vlan12
set precedence 6
service-policy child_class_dscp_policing

3850#sh run policy-map child_class_dscp_policing
class dscp1
police cir percent 12
class dscp2
police cir percent 15
class dscp3
police cir percent 20
class class-default
police cir percent 22

3850#sh run class-map vlan10
class-map match-any vlan10
match vlan 10

3850#sh run class-map vlan11
class-map match-any vlan11
match vlan 11

3850#sh run class-map vlan12
class-map match-any vlan12
match vlan 12

3850#sh run class-map dscp1
class-map match-any dscp1
match dscp 1

3850#sh run class-map dscp2
class-map match-any dscp2
match dscp 2

3850#sh run class-map dscp3
class-map match-any dscp3
match dscp 3


Document ID: 118629