Голосовая связь и система унифицированных коммуникаций : Cisco Jabber для Windows

Jabber для Windows Install или устранения проблем сбоя при обновлении

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв

Введение

Этот документ описывает, как решить проблему, которая вызвана персистентными ключами реестра, когда вы устанавливаете или обновляете Cisco Jabber для Windows.

Внесенный Manjunath D S и Gangabhavani Sankar Voleti, специалистами службы технической поддержки Cisco.

Предварительные условия

Требования

Корпорация Cisco рекомендует ознакомиться со следующими темами:

  • Cisco Jabber для Windows
  • Операционная система Версии 7 Microsoft Windows (32 и 64 бита)

Используемые компоненты

Этот документ не ограничен определенными аппаратными средствами или версиями программного обеспечения.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Проблема

Когда вы пытаетесь установить или обновить Cisco Jabber для Версии Windows 9.6 или 9.7, сбоев попытки, и вы получаете это сообщение об ошибках:

Error 1714. The older version of Cisco Jabber cannot be removed. Contact your
technical Support team

Причина

Программы, которые установлены через файл установщика MSi, содержат запись в ключе удаления со значением Windows Installer одного. Когда функция Add/Remove Programs встречается с этим, она рассматривает ключевое название и изменяет его. Это тогда ищет ключ, который называют с переупорядоченным GUID в этом местоположении:

HKLM> программное обеспечение> Классы> Установщик> продукты

Так как ключ реестра поврежден, это должно быть удаленный.

Решение

Нажмите Ok, чтобы собрать журналы Windows Installer и найти реестр, который указывает к ARPPRoduction.

От клиентского компьютера Нажмите Run> Regedit и перейдите к этим местоположениям:

HKLM> программное обеспечение> Классы> Установщик> продукты> 6CEE3E513E63CD64A84A65D86E7EDADF

HKLM> программное обеспечение> Классы> Установщик> продукты> CA70A39C45D45FE449F78FC06961663

Удалите ключи и перезапустите установку или процесс обновления. Это должно решить проблему.

Примечание: Административный доступ мог бы требоваться для доступа к ключам реестра на компьютере.



Document ID: 118161