Коммутаторы : Коммутаторы Cisco Nexus серии 5000

Конфигурация FCoE между адаптером VIC на сервере стойки UCS и коммутатором Nexus 5500

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв

Содержание

Связанные обсуждения сообщества поддержки Cisco

Введение

Этот документ описывает, как настроить подключение Fibre Channel по Ethernet (FCoE) между адаптерами Платы виртуальных интерфейсов (VIC), установленными на системе Cisco UCS (UCS) серверы стойки и Cisco Nexus 5500 (Nexus 5K) Коммутаторы Серии. Два примера топологии включают Модуль ввода-вывода Cisco (FEX) устройства, и один пример топологии не делает.

Внесенный Padmanabhan, специалистом службы технической поддержки Cisco.

Предварительные условия

Требования

Компания Cisco рекомендует предварительно ознакомиться со следующими предметами:

  • Коммутаторы серии 5500 Cisco Nexus
  • UCS Cisco устанавливает сервер в стойку - конфигурация интегрированного контроллера управления Cisco (CIMC)
  • Основное понимание FCoE

Эта конфигурация существует в среде:

  • Массив сети хранения данных (SAN) настроен для обеспечения доступа к номерам логического устройства (LUN) для действительных Host Bus Adapter (vHBAs) на карте VIC Cisco.
  • Версия 5.1 (3) N1 (1a) Cisco Nexus или позже установлена на коммутаторах Cisco Nexus 5K.
  • Необходимые лицензии установлены на Nexus 5K коммутаторы.

См. руководство по конфигурации каждого определенного аппаратного устройства для ограничений и Информации о совместимости.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного обеспечения и оборудования:

  • Сервер Cisco UCS C220 M3 с VIC 1225
  • CIMC 1.5.4 микропрограммных связок (bundle)
  • Nexus 5548UP с версией 6.0 (2) N2 (1)
  • Модель FEX - Nexus 2232PP

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Обзор

Это - обзор процесса конфигурирования:

  1. Для новой настройки выполните базовую конфигурацию на Nexus 5K коммутаторы. Если вы добавляете сервер к существующей сети, можно пропустить этот шаг.
  2. Настройте адаптер VIC на сервере UCS.
  3. Настройте Nexus 5K коммутаторы на основе вашей топологии.

Сервер может быть развернут в одной из этих трех топологии:

  • Топология 1 - канал Виртуального порта (vPC), настроенный на Nexus 5K коммутаторы и порты конвергентного сетевого адаптера (CNA), непосредственно связанные с Nexus 5K коммутатор
  • Топология 2 - FEX подключила с Nexus 5K коммутатор в сквозном режиме и CNA, связанный с портами FEX
  • Топология 3 - FEX подключила с Nexus 5K коммутатор в расширенном режиме vPC и CNA, связанный с портами FEX

Документ предоставляет примеры конфигурации для подключения FCoE для каждой топологии.

Примечания:

Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Средство интерпретации выходных данных (только зарегистрированные клиенты) поддерживает некоторые команды show. Используйте Средство интерпретации выходных данных, чтобы просмотреть анализ выходных данных команды show.

Шаг 1: Настройте новую настройку

Даже при том, что этот документ фокусирует на конфигурации FCoE на адаптерах VIC и Nexus 5K коммутаторы, это также включает требуемую базовую конфигурацию на vPC и функций FCoE полноты.

Топология в данном примере использует виртуальную сеть устройств хранения данных (VSAN) 100 и VSAN 200 как две SAN матрицы. Эти VSAN созданы на, сторона и Сторона b Nexus 5K переключаются и сопоставлены с VLAN 100 FCoE и 200, соответственно.

Для новой настройки эта процедура описывает, как выполнить базовую конфигурацию на Nexus 5K коммутаторы:

  1. Включите необходимые характеристики (Протокол обнаружения уровня соединения [LLDP], Протокол управления агрегацией каналов [LACP], FCoE, FEX, vPC) на Nexus 5K коммутаторы. Посмотрите Конфигурацию Необходимых характеристик для примера этого шага.
  2. Завершите основную конфигурацию vPC:
    1. Создайте vPC domain.
    2. Создайте одноранговые ссылки поддержки активности vPC.
    3. Настройте одноранговые каналы vPC. Посмотрите Основную Конфигурацию vPC для примера того, как выполнить Шаги 1-3 и как включить vPC на обоих Nexus 5K коммутаторы.
    4. Создайте vPC или снова используйте каналы порта.
    5. Проверьте vPC.
  3. Настройте VSAN. Посмотрите Конфигурацию VSAN для примера этого шага.

Примечание: Если вы добавляете сервер к существующей сети, можно пропустить эти шаги; перейдите к шагу 2: Настройте Сервер UCS и Адаптер VIC.

Конфигурация необходимых характеристик

5548-switch# configure terminal
5548-switch(config)# feature lldp
5548-switch(config)# feature lacp
5548-switch(config)# feature fcoe
5548-switch(config)# feature fex
5548-switch(config)# feature vpc
5548-switch(config)# end

Основная Конфигурация vPC

5548-switch# configure terminal
5548-switch(config)# vpc domain 150
5548-switch (config-vpc-domain)# peer-keepalive destination <peer-switch-ip>
source <source-ip> vrf management
5548-switch(config-vpc-domain)# interface port-channel 150
5548-switch(config-if)# switchport mode trunk
5548-switch(config-if)# vpc peer-link
5548-switch(config-if)# no shut

Конфигурация VSAN

5548-switch-A # configure terminal
5548-switch-A(config)# vsan database
5548-switch-A(config-vsan-db)#vsan 100
5548-switch-A(config)#exit

5548-switch-A(config)#vlan 100
5548-switch-A(config-vlan)#fcoe vsan 100

5548-switch-B # configure terminal
5548-switch-B(config)#vsan database
5548-switch-B(config-vsan-db)#vsan 200
5548-switch-B(config)#exit

5548-switch-B(config)#vlan 200
5548-switch-B(config-vlan)#fcoe vsan 200

Шаг 2: Настройте сервер UCS и адаптер VIC

Настройте адаптер VIC на сервере UCS. Эта процедура описывает, как применить эту конфигурацию ко всему VIC Cisco (P81E или VIC 1225 или VIC 1225T) адаптеры:

  1. Используйте Утилиту обновления Хоста для обновления микропрограммного обеспечения компонентов оборудования сервера к последней версии. Обязательно обновите микропрограммное обеспечение VIC.
  2. По умолчанию адаптер VIC работает в режиме Классической Ethernet (CE) и настроен с двумя контроллерами виртуального сетевого интерфейса (vNICs) и двумя vHBAs. Каждый из этих vNICs и vHBAs прикреплен к соединительному физическому интерфейсу DCE; т.е. fc0 прикреплен к соединительному порту 0 DCE, и fc1 прикреплен к соединительному порту 1 DCE адаптера:

    117280-config-fcoe-01.png
  3. Включите сервер и обратите внимание, что подробные данные адаптера VIC заполнены в разделе материально-технических ресурсов.
  4. Нажмите vHBAs вкладку и выберите интерфейс vHBA (fc0 или fc1).
  5. Нажмите свойства, затем настройте свойства FCoE на адаптере VIC. Обязательно определите ИДЕНТИФИКАТОР VLAN FCoE в текстовом поле Виртуальной локальной сети (VLAN) по умолчанию:

    117280-config-fcoe-02.png

    Если вы планируете загрузиться от SAN, проверьте флажок FC SAN Boot и добавьте целевой WWPN к загрузочной таблице:

    117280-config-fcoe-03.png
  6. Перезагрузите сервер для изменений конфигурации для вступления в силу.

Шаг 3: Настройте Nexus 5K коммутаторы для другой топологии

Сервер может быть развернут в одной из трех топологии. В этом разделе описывается настроить Nexus 5K коммутаторы на основе вашей топологии.

Обычная конфигурация рекомендации для всех трех топологии:

  1. Интерфейс Действительного Fibre Channel (VFC) связан с участвующим портом (физический Интерфейс Ethernet) канала порта.
  2. Switchports находятся в режиме магистрали, и FCoE VLAN настроен как несобственный VLAN.
  3. Тип связующего дерева портов коммутатора настроен так, они соединяются с сервером как граничный транк.

Этот документ предоставляет примеры конфигурации для Матрицы A; необходимо выполнить подобную конфигурацию на другом коммутаторе для Матрицы B.

Топология 1: порты CNA, непосредственно связанные к Nexus 5K коммутатор

Обзор

В этом сценарии Nexus 5K коммутаторы находится в vPC, и порты CNA сервера напрямую подключаются к обоим Nexus 5K коммутаторы. Эта процедура описывает конфигурацию для этой топологии:

  1. Привяжите Интерфейс Ethernet к новому интерфейсу порт-канала.
  2. Настройте канал порта как транк с FCoE VLAN, помеченным, и привяжите канал порта к ID vPC.
  3. Создайте интерфейс VFC и свяжите его с участником port-channel (Интерфейс Ethernet).
  4. Привяжите интерфейс VFC к соответствующему ID VSAN. Посмотрите Пример конфигурации на Стороне Nexus 5K Коммутатор для примера Шагов 1-4.
  5. Повторите Шаги 1-4 для настройки Стороны b Nexus 5K коммутатор.
  6. Проверка конфигурации.

117280-config-fcoe-04.png

Пример конфигурации на стороне Nexus 5K коммутатор

N5548UP-A(config)# int eth 1/1
N5548UP-A(config-if)# channel-group 1
N5548UP-A(config-if)# no shut
N5548UP-A(config-if)# exit
N5548UP-A# configure terminal
N5548UP-A(config)# interface port-channel 1
N5548UP-A(config-if)# switchport mode trunk
N5548UP-A(config-if)# switchport trunk native vlan 10
N5548UP-A(config-if)# switchport trunk allowed vlan 10,100
N5548UP-A(config-if)# spanning-tree port type edge trunk
N5548UP-A(config-if)# vpc 1
N5548UP-A(config-if)# no shut
N5548UP-A(config-if)# exit
N5548UP-A(config)# int vfc 1
N5548UP-A(config-if)# bind interface ethernet 1/1
N5548UP-A(config-if)# switchport trunk allowed vsan 100
N5548UP-A(config-if)# no shut
N5548UP-A(config-if)# exitN5548UP-A(config)# vsan database
N5548UP-A(config-vsan-db)# vsan 100 interface vfc 1
N5548UP-A(config-vsan-db)# end

Проверка

N5548UP-A# show run int port-channel 1 membership

interface port-channel 1
switchport mode trunk
switchport trunk native vlan 10
switchport trunk allowed vlan 10,100
spanning-tree port type edge trunk
speed 10000
vpc 1
interface Ethernet1/1
switchport mode trunk
switchport trunk native vlan 10
switchport trunk allowed vlan 10,100
channel-group 1

N5548UP-A# show run int vfc 1
interface vfc1
bind interface Ethernet1/1
switchport trunk allowed vsan 100
no shutdown

Топология 2: FEX, связанный к Nexus 5K коммутатор в сквозном режиме и CNA, связанном к портам FEX

Обзор

В этом сценарии FEX связан с Nexus 5K коммутатор в сквозном режиме, и CNA связан с портами FEX. Эта процедура описывает конфигурацию для этой топологии:

Сквозная конфигурация FEX:

  1. Назначьте ID FEX.
  2. Привяжите Интерфейс Ethernet к новому ID интерфейса порт-канала и настройте новый канал порта с оптоволоконными параметрами FEX. Посмотрите Пример конфигурации для примера Шагов 1-2.

    Конфигурация vPC хоста:

  3. Привяжите интерфейсы хоста FEX (HIF) к новому ID интерфейса порт-канала и настройте параметры port-channel.
  4. Привяжите канал порта HIF к интерфейсу vPC.
  5. Создайте интерфейс VFC и свяжите его с участником (Ethernet) порт канала порта хоста. Посмотрите Конфигурацию vPC Хоста для примера Шагов 3-5.
  6. Проверка конфигурации.

Повторите Шаги 1-4 в Сторону b Nexus 5K коммутатор и используйте тот же номер интерфейса vPC под каналом порта HIF.

117280-config-fcoe-05.png

Пример конфигурации

N5548UP-A# configure terminal 
N5548UP-A(config)# fex 101
N5548UP-A(config-fex)# exit

N5548UP-A(config)# interface ethernet 1/5 - 6
N5548UP-A(config-if-range)# channel-group 210
N5548UP-A(config-if-range)#no shut
N5548UP-A(config-if-range)# exit

N5548UP-A(config)# interface port-channel 210
N5548UP-A(config-if)# switchport mode fex-fabric
N5548UP-A(config-if)# fex associate 101
N5548UP-A(config-if)#no shut
N5548UP-A(config-if)# exit

Конфигурация vPC хоста

<---Create HIF port-channel-->

N5548UP-A(config-if)# interface ethernet 101/1/1
N5548UP-A(config-if)# channel-group 1
N5548UP-A(config-if)# no shut
N5548UP-A(config-if)# exit

<---Configure port-channel parameters-->

N5548UP-A(config)# interface port-channel 1
N5548UP-A(config-if)#switchport mode trunk
N5548UP-A(config-if)# switchport trunk native vlan 10
N5548UP-A(config-if)# switchport trunk allowed vlan 10,100
N5548UP-A(config-if)# spanning-tree port type edge trunk
N5548UP-A(config-if)# vpc 10
N5548UP-A(config-if)# no shut
N5548UP-A(config-if)# exit

<---Create vfc interfvace and bind to port-channel (Ethernet interface)-->

N5548UP-A(config)# int vfc 1
N5548UP-A(config-if)# bind interface ethernet 101/1/1
N5548UP-A(config-if)# switchport trunk allowed vsan 100
N5548UP-A(config-if)# no shut
N5548UP-A(config-if)# exit

<---Associate vfc interface to corresponding VSAN ID-->

N5548UP-A(config)# vsan database
N5548UP-A(config-vsan-db)# vsan 100 interface vfc 1
N5548UP-A(config-vsan-db)# end

Проверка

N5548UP-A# show run int port-channel 210 membership

interface port-channel210
switchport mode fex-fabric
fex associate 101

interface Ethernet1/5
switchport mode fex-fabric
fex associate 101
channel-group 210

interface Ethernet1/6
switchport mode fex-fabric
fex associate 101
channel-group 210

N5548UP-A# show int fex
Fabric Fabric Fex FEX
Fex Port Port State Uplink Model Serial
---------------------------------------------------------------
101 Eth1/5 Active 1 N2K-C2232PP-10GE SSI142602QN
101 Eth1/6 Active 2 N2K-C2232PP-10GE SSI142602QN

N5548UP-A# show run int port-channel 1 membership

interface port-channel 1
switchport mode trunk
switchport trunk native vlan 10
switchport trunk allowed vlan 10,100
spanning-tree port type edge trunk
speed 10000
vpc 10

interface Ethernet101/1/1
switchport mode trunk
switchport trunk native vlan 10
switchport trunk allowed vlan 10,100
channel-group 1

N5548UP-A# show run int vfc 1
interface vfc1
bind interface Ethernet101/1/1
switchport trunk allowed vsan 100
no shutdown

Топология 3: FEX, Связанный к Nexus 5K Коммутатор в Расширенном Режиме vPC и CNA, Связанном к портам FEX

Обзор

В этом сценарии FEX связан с Nexus 5K коммутатор в расширенном режиме vPC, и CNA связан с портами FEX.

SAN Матрица трафик (VLAN 100 FCoE) привязана к FEX 101 / сторона Nexus 5K коммутатор. SAN Матрица B трафик (FCoE VLAN 200) привязана к FEX 102 / Сторона b Nexus 5K коммутатор.

Для двух задействованных каналов порта хоста необходимо настроить порты HIF на обоих устройства FEX на обоих Nexus 5K коммутаторы; т.е. требуются в общей сложности четыре конфигурации порта HIF.

Эта процедура описывает конфигурацию для этой топологии:

Активный - Активная конфигурация FEX:

  1. Назначьте ID FEX.
  2. Добавьте 'fcoe' ключевое слово под одиночным FEX на каждом Nexus 5K коммутатор для включения SAN оптоволоконной изоляции.
  3. Создайте канал порта матрицы FEX.
  4. Повторите Шаги 1 и 3 для другого FEX на том же Nexus 5K коммутатор.
  5. Повторите Шаги 1-4 в Сторону b Nexus 5K коммутатор. Посмотрите Активный - Активное Ключевое слово Конфигурации и FCoE FEX на FEX 102 на Стороне b Nexus 5K Коммутатор для примера.

    Конфигурация vPC хоста:

  6. Создайте интерфейс порт-канала и настройте необходимые VLAN.
  7. Настройте порт HIF (интерфейс FEX, связанный с CNA) и на FEXs, и позвольте FCoE VLAN и Виртуальные локальные сети Ethernet, затем привяжите порт HIF к ID port-channel хоста, созданному в Шаге 6.
  8. Создайте интерфейс VFC и свяжите его с участником (Ethernet) порт канала порта хоста.
  9. Повторите Шаги 6-8 в Сторону b Nexus 5K коммутатор и используйте тот же ID интерфейса порт-канала хоста. Посмотрите Конфигурацию vPC Хоста для примера.

    Конфигурация интерфейса VFC:

  10. Создайте интерфейс VC и свяжите его с участником port-channel (HIF) порт.
  11. Назначьте интерфейс VFC на соответствующий VSAN.
  12. Повторите Шаги 10-11 в Сторону b Nexus 5K коммутатор. Посмотрите Конфигурацию VFC для примера.
  13. Проверка конфигурации.

117280-config-fcoe-06.png

Активный - активная конфигурация FEX

N5548UP-A# configure terminal 
N5548UP-A(config)# fex 101
N5548UP-A(config-fex)# fcoe
N5548UP-A(config-fex)# exit

N5548UP-A(config)# interface ethernet 1/3 - 4
N5548UP-A(config-if-range)# channel-group 201
N5548UP-A(config-if-range)#no shut
N5548UP-A(config-if-range)# exit
N5548UP-A(config)# interface port-channel 201
N5548UP-A(config-if)# switchport mode fex-fabric
N5548UP-A(config-if)# fex associate 101
N5548UP-A(config-if)# vpc 201
N5548UP-A(config-if)#no shut
N5548UP-A(config-if)# exit

N5548UP-A# configure terminal
N5548UP-A(config)# fex 102
N5548UP-A(config-fex)# exit

N5548UP-A(config)# interface ethernet 1/5 - 6
N5548UP-A(config-if-range)# channel-group 202
N5548UP-A(config-if-range)#no shut
N5548UP-A(config-if-range)# exit

N5548UP-A(config)# interface port-channel 202
N5548UP-A(config-if)# switchport mode fex-fabric
N5548UP-A(config-if)# fex associate 102
N5548UP-A(config-if)# vpc 202
N5548UP-A(config-if)#no shut
N5548UP-A(config-if)# exit

Ключевое слово FCoE на FEX 102 на стороне b Nexus 5K коммутатор

N5548UP-B# configure terminal 
N5548UP-B(config)# fex 102
N5548UP-B(config-fex)# fcoe
N5548UP-B(config-fex)# exit

Конфигурация vPC хоста

N5548UP-A(config-if)# interface ethernet 101/1/1
N5548UP-A(config-if)# channel-group 1
N5548UP-A(config-if)# no shut
N5548UP-A(config-if)# exit

N5548UP-A(config)# interface ethernet 102/1/1
N5548UP-A(config-if)# channel-group 1
N5548UP-A(config-if)# no shut
N5548UP-A(config-if)# exit

N5548UP-A(config)# interface port-channel 1
N5548UP-A(config-if)#switchport mode trunk
N5548UP-A(config-if)# switchport trunk native vlan 10
N5548UP-A(config-if)# switchport trunk allowed vlan 10,100
N5548UP-A(config-if)# spanning-tree port type edge trunk
N5548UP-A(config-if)# no shut
N5548UP-A(config-if)# exit

Конфигурация VFC

<---Create vfc interface and bind to port-channel member (ethernet interface)-->

N5548UP-A(config)# int vfc 1
N5548UP-A(config-if)# bind interface ethernet 101/1/1
N5548UP-A(config-if)# switchport trunk allowed vsan 100
N5548UP-A(config-if)# no shut
N5548UP-A(config-if)# exit

<---Associate vfc interface to corresponding VSAN ID-->

N5548UP-A(config)# vsan database
N5548UP-A(config-vsan-db)# vsan 100 interface vfc 1
N5548UP-A(config-vsan-db)# end

Проверка

N5548UP-A# show fex
FEX FEX FEX FEX
Number Description State Model Serial
------------------------------------------------------------------------
101 FEX0101 Online N2K-C2232PP-10GE SSI142602QN
102 FEX0102 Online N2K-C2232PP-10GE SSI14260EVV

N5548UP-A# show interface fex
Fabric Fabric Fex FEX
Fex Port Port State Uplink Model Serial
---------------------------------------------------------------
101 Eth1/3 Active 2 N2K-C2232PP-10GE SSI142602QN
102 Eth1/4 Active 1 N2K-C2232PP-10GE SSI14260EVV

N5548UP-A# show fex 101 detail
FEX: 101 Description: FEX0101 state: Online
FEX version: 6.0(2)N2(1) [Switch version: 6.0(2)N2(1)]
FEX Interim version: 6.0(2)N2(1)
Switch Interim version: 6.0(2)N2(1)
Extender Serial: SSI142602QN
FCoE Admin: true
FCoE Oper: true
FCoE FEX AA Configured: true

N5548UP-A# show run interface port-channel 1 membership

interface port-channel1
switchport mode trunk
switchport trunk native vlan 10
switchport trunk allowed vlan 10,100
spanning-tree port type edge trunk
speed 10000

interface Ethernet102/1/1
switchport mode trunk
switchport trunk native vlan 10
switchport trunk allowed vlan 10,100
spanning-tree port type edge trunk
channel-group 1

interface Ethernet101/1/1
switchport mode trunk
switchport trunk native vlan 10
switchport trunk allowed vlan 10,100
spanning-tree port type edge trunk
channel-group 1

N5548UP-A# show int vfc 1
vfc1 is trunking
Bound interface is Ethernet101/1/1
Port WWN is 20:00:54:7f:ee:e1:6a:bf
Admin port mode is F, trunk mode is on
Port mode is TF
Port vsan is 100
Trunk vsans (admin allowed and active) (100)
Trunk vsans (up) (100)
Trunk vsans (isolated) ()
Trunk vsans (initializing) ()

N5548UP-A# show run int port-channel 201 membership

interface port-channel201
switchport mode fex-fabric
fex associate 101
vpc 201

interface Ethernet1/3
switchport mode fex-fabric
fex associate 101
channel-group 201

interface Ethernet1/4
switchport mode fex-fabric
fex associate 101
channel-group 201

N5548UP-A# show run int port-channel 202 membership

interface port-channel202
switchport mode fex-fabric
fex associate 102
vpc 202

interface Ethernet1/5
switchport mode fex-fabric
fex associate 102
channel-group 202

interface Ethernet1/6
switchport mode fex-fabric
fex associate 102
channel-group 202

Этот снимок экрана от последовательности загрузки сервера проверяет конфигурацию коммутатора, поскольку микропрограммное обеспечение VIC успешно обнаруживает LUN и обновляет загрузочную таблицу:

117280-config-fcoe-07.png

Проверка

Процедуры проверки включены в примерах конфигурации.

Устранение неполадок

Этот раздел обеспечивает информацию, которую вы можете использовать для того, чтобы устранить неисправность в вашей конфигурации.

Выполните эти проверки, чтобы определить, подходит ли VFC:

  1. Проверьте, что кабели связаны правильно между портами адаптера, сопоставленными с vHBA и что Nexus 5K порты коммутатора имеет необходимые VSAN.
  2. Удостоверьтесь, что административно не закрыты интерфейсы.
  3. Проверьте, что FCoE VLAN настроен на Интерфейсе Ethernet, ограниченном VFC.

Используйте эти команды для проверки конфигурации:

  • покажите выполненный fcoe
  • покажите vsan
  • show vlan fcoe
  • show interface vfc ID
  • покажите vpc
  • покажите базу данных flogi

Дополнительные сведения



Document ID: 117280