Маршрутизаторы : Маршрутизаторы агрегации Cisco ASR серии 9000

Обзор ASR 9000 VPLS Групповой адресации с коммутацией по меткам (LSM) и Пример конфигурации

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Отзыв

Введение

Этот документ описывает Групповую адресацию с коммутацией по меткам (LSM) службы виртуальной локальной частной сети (VPLS) для Маршрутизатора агрегации (ASR), серии 9000, которые выполняют Cisco программное обеспечение IOS® XR.

Внесенный Вишнапрэкэшем Сельвараджэном и Дэвидом Пауэрсом, специалистами службы технической поддержки Cisco.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Обзор Групповой адресации с коммутацией по меткам (LSM) VPLS

VPLS эмулирует сервисы LAN (локальной сети) по ядру Многопротокольной коммутации по меткам (MPLS). Полная сетка точка-точка (P2P), псевдопровода (PWs) установлены между всеми маршрутизаторами Границы провайдера (PE), которые участвуют в домене VPLS для обеспечения эмуляции VPLS. Широковещание, групповая адресация и трафик одноадресного одноадресного лавинно рассылаются в домене VPLS ко всем PE. Входная репликация используется для передачи того лавинного трафика по каждому P2P PWs ко всем удаленным маршрутизаторам PE, которые являются частью того же домена VPLS.

Недостатки входной репликации

  • Входная репликация является пропускной способностью, неэффективной, потому что тот же пакет мог бы быть передан многократно по той же ссылке для каждого P2P PW.
  • Когда существует тяжелое широковещание и групповая адресация трафик VPLS, входная репликация может привести к значительной потраченной впустую пропускной способности соединения.
  • Входная репликация является также загруженностью ресурсов, потому что входной Периферийный маршрутизатор переносит полную нагрузку репликации.

Функции LSM VPLS

VPLS является широко развернутой технологией L2VPN поставщика услуг, которая также используется для транспорта групповой адресации. Несмотря на то, что технология L2 позволяет snooping, чтобы использоваться для оптимизации репликации многоадресного трафика в псевдопровода L2, ядро остается агностиком к многоадресному трафику. В результате множественные копии того же потока пересекают базовые сети. Для смягчения этой неэффективности парного LSM с VPLS для представления деревьев групповой адресации LSM по ядру. В Выпуске 5.1.0 программного обеспечения Cisco IOS XR, ASR Cisco внедрение серии 9000 LSM VPLS с регулированием трафика точка - много точек (TE P2MP) содержащие деревья. Оконечная точки VPLS автоматически обнаружены, и деревья TE P2MP установлены с использованием Регулирования трафика Протокола резервирования ресурсов (RSVP) (TE RSVP) без в рабочем состоянии вмешательства.

  • LSM VPLS преодолевает недостатки входной репликации.

  • Решение для LSM VPLS использует LSP P2MP в ядре MPLS для переноса широковещания, передайте в многоадресном режиме, и трафик одноадресного одноадресного для домена VPLS.

  • LSP P2MP позволяют репликацию в сети MPLS в самом оптимальном узле и минимизируют сумму репликации пакетов в сети.

  • Решение для LSM VPLS только передает лавинно рассылаемый трафик VPLS по LSP P2MP.

  • Индивидуальная рассылка трафик VPLS все еще передается по P2P PWs. Трафик, передаваемый по Доступу PWs, продолжает передаваться с входной репликацией.

  • PWs P2MP однонаправлены в противоположность P2P PWs, которые являются двунаправленными.

  • Решение для LSM VPLS включает создание P2MP PW на домен VPLS для эмуляции сервиса P2MP VPLS для базового PWs в домене VPLS.

  • LSM VPLS поддерживается в Выпуске 5.1.0 Cisco IOS XR и позже.

Ограничения LSM VPLS

  • Выпуск 5.1.0 Cisco IOS XR функциональность LSM VPLS поддерживает только деревья TE P2MP Регулирования трафика MLPS, установленные с TE RSVP.

  • P2MP PW может быть сообщен с протоколом BGP только в Выпуске 5.1.0 Cisco IOS XR. В этой первой фазе удаленные PE, которые участвуют в домене VPLS, автообнаружены с Автоматическим обнаружением BGP (AD BGP).

  • Статическая сигнализация LDP не поддерживается в Выпуске 5.1.0 Cisco IOS XR.

Обучение управления доступом к среде Media Access Control (MAC)

Изучение MAC на PE Листа для кадра, который поступает в P2MP PW, сделано, как будто кадр принят на P2P приводящий PW к Корневому PE для того P2MP PW. В этом образе сделано Изучение MAC на PE2 для кадров, которые поступают в P2MP LSP PW, базированный в PE-1, как будто кадр поступил в P2P PW между PE-1 и PE2. Уровень управления L2VPN ответственен за программирование информации о расположении VPLS с P2P информация о PW для Изучения MAC на расположении LSP P2MP.

Протокол управления группами Интернет, snooping (IGMPSN) поддержка

Протокол IGMP, Snooping (IGMPSN), поддерживается на обоих Смещение первого (head) и последнего (tail) элемента очереди P-дерева P2MP в домене моста, который участвует в LSM VPLS. Это позволяет многоадресному трафику IGMPSN по действительному экземпляру VRF (VFI) PWs извлекать выгоду из оптимизации ресурсов, предоставленной LSP P2MP. Если IGMPSN включен в домене моста с одним или более VFI PWs участвующий в LSM VPLS, всем уровне, два многоадресных трафика (L2) передаются по Головке P-дерева P2MP, привязанной к домену моста. Многоадресные маршруты L2 используются, чтобы передать трафик к локальным приемникам, Точки Потока Ethernet (EFPs), обратиться к PWs и VFI PWs, которые не участвуют в LSM VPLS.

Когда IGMPSN включен в домене моста, который является хвостом LSP P2MP, оптимизированное расположение многоадресного трафика L2, полученного на LSP P2MP, сделано для локальных приемников (т.е. Порты моста Присоединяемого канала (AC) (BP) и доступ BP PW).

Примечание: Snooping Протокол распределения меток групповой адресации (MLDP) не поддерживается в Выпуске 5.1.0 Cisco IOS XR.

Поддерживаемый масштаб

Выпуск 5.1.0 Cisco IOS XR поддерживает максимум 1000 Туннелей P2MP или 1000 P2MP PWs на Главный/Хвостовой маршрутизатор.

Конфигурация LSM VPLS

P2MP автоматическая конфигурация туннеля

mpls traffic-eng
 interface GigabitEthernet0/1/1/0
 !
 interface GigabitEthernet0/1/1/1
 !
 auto-tunnel p2mp
 tunnel-id min 100 max 200

MPLS TE Fast ReRoute (FRR) конфигурацию

mpls traffic-eng
 interface GigabitEthernet0/1/1/0
 auto-tunnel backup
  nhop-only
 !
 !
 interface GigabitEthernet0/1/1/1
 auto-tunnel backup
  nhop-only
 !
 !
 auto-tunnel p2mp
 tunnel-id min 100 max 200
 !
 auto-tunnel backup
 tunnel-id min 1000 max 1500
 !
 attribute-set p2mp-te set1
 bandwidth 10000
 fast-reroute
 record-route
 !

Конфигурация L2VPN

l2vpn
 bridge group bg1
 bridge-domain bg1_bd1
  interface GigabitEthernet0/1/1/10.1
  !
  vfi bg1_bd1_vfi
   vpn-id 1
   autodiscovery bgp
    rd auto
    route-target 209.165.201.1:1
    signaling-protocol bgp
     ve-id 100
    !
   !
   multicast p2mp
    signaling-protocol bgp
    !
    transport rsvp-te
     attribute-set p2mp-te set1
    !

Sample Topology и Configuation

Туннели P2MP автообнаружены туннели. Статические туннели P2MP не поддерживаются.

Статические конфигурации туннеля не используются. Автоматическая конфигурация туннеля P2MP должна быть включена на всех Периферийных маршрутизаторах и также на маршрутизаторе P, если она действует как узел зародыша. Узел зародыша является средней точкой и маршрутизатором окончания в то же время.

Пример топологии с конфигурацией показывают здесь. В этой топологии P2MP PWs созданы между этими тремя PE и маршрутизатором P, который действует как узел зародыша. Все три Периферийных маршрутизатора действуют как Головка (для входного трафика) и Хвост (для выходного трафика).

Конфигурация PE1

RP/0/RSP0/CPU0:PE1#show run
hostname PE1
!
ipv4 unnumbered mpls traffic-eng Loopback0
!
interface Loopback0
 ipv4 address 209.165.200.225 255.255.255.255
!
interface GigabitEthernet0/1/1/0
 description connected P router
 ipv4 address 209.165.201.1 255.255.255.224
!
interface GigabitEthernet0/1/1/1
 description connected to P router
 ipv4 address 209.165.201.151 255.255.255.224
 transceiver permit pid all
!
interface GigabitEthernet0/1/1/10
 transceiver permit pid all
!
interface GigabitEthernet0/1/1/10.1 l2transport
 encapsulation dot1q 1
!
router ospf 100
 router-id 209.165.200.225
 area 0
 mpls traffic-eng
 interface Loopback0
 !
 interface GigabitEthernet0/1/1/0
 !
 interface GigabitEthernet0/1/1/1
 !
 !
 mpls traffic-eng router-id 209.165.200.225
!
router bgp 100
 nsr
 bgp router-id 209.165.200.225
 bgp graceful-restart
 address-family l2vpn vpls-vpws
 !
 neighbor 209.165.200.226
 remote-as 100
 update-source Loopback0
 address-family l2vpn vpls-vpws
 !
 !
 neighbor 209.165.200.227
 remote-as 100
 update-source Loopback0
 address-family l2vpn vpls-vpws
 !
 !
 neighbor 209.165.200.228
 remote-as 100
 update-source Loopback0
 address-family l2vpn vpls-vpws
 !
 !
!
l2vpn
 bridge group bg1
 bridge-domain bg1_bd1
  interface GigabitEthernet0/1/1/10.1
  !
  vfi bg1_bd1_vfi
   vpn-id 1
   autodiscovery bgp
    rd auto
    route-target 209.165.201.1:1
    signaling-protocol bgp
     ve-id 100
    !
   !
   multicast p2mp
    signaling-protocol bgp
    !
    transport rsvp-te
     attribute-set p2mp-te set1
    !
   !
  !
 !
 !
!
rsvp
 interface GigabitEthernet0/1/1/0
 bandwidth 100000
 !
 interface GigabitEthernet0/1/1/1
 bandwidth 100000
 !
!
mpls traffic-eng
 interface GigabitEthernet0/1/1/0
 auto-tunnel backup
  nhop-only
 !
 !
 interface GigabitEthernet0/1/1/1
 auto-tunnel backup
  nhop-only
 !
 !
 auto-tunnel p2mp
 tunnel-id min 100 max 200
 !
 auto-tunnel backup
 tunnel-id min 1000 max 1500
 !
 attribute-set p2mp-te set1
 bandwidth 10000
 fast-reroute
 record-route
 !
!
mpls ldp
 nsr
 graceful-restart
 router-id 209.165.200.225
 interface GigabitEthernet0/1/1/0
 !
 interface GigabitEthernet0/1/1/1
 !
!
end
 
RP/0/RSP0/CPU0:PE1#

P конфигурация

RP/0/RSP0/CPU0:P#show run
hostname P
ipv4 unnumbered mpls traffic-eng Loopback0
interface Loopback0
 ipv4 address 209.165.200.226 255.255.255.255
!
interface GigabitEthernet0/1/1/0
 description connected to PE1 router
 ipv4 address 209.165.201.2 255.255.255.224
 transceiver permit pid all
!
interface GigabitEthernet0/1/1/1
 description connected to PE1 router
 ipv4 address 209.165.201.152 255.255.255.224
 transceiver permit pid all
!
interface GigabitEthernet0/1/1/3
 description connected to PE2 router
 ipv4 address 209.165.201.61 255.255.255.224
!
interface GigabitEthernet0/1/1/4
 transceiver permit pid all
!
interface GigabitEthernet0/1/1/4.1 l2transport
 encapsulation dot1q 1
!
interface GigabitEthernet0/1/1/8
 description connected to PE3 router
 ipv4 address 209.165.201.101 255.255.255.224
!
router ospf 100
 nsr
 nsf cisco
 area 0
 mpls traffic-eng
 interface Loopback0
 !
 interface GigabitEthernet0/1/1/0
 !
 interface GigabitEthernet0/1/1/1
 !
 interface GigabitEthernet0/1/1/3
 !
 interface GigabitEthernet0/1/1/8
 !
 !
 mpls traffic-eng router-id 209.165.200.226
!
router bgp 100
 nsr
 bgp router-id 209.165.200.226
 bgp graceful-restart
 address-family l2vpn vpls-vpws
 !
 neighbor 209.165.200.225
 remote-as 100
 update-source Loopback0
 address-family l2vpn vpls-vpws
 !
 !
 neighbor 209.165.200.227
 remote-as 100
 update-source Loopback0
 address-family l2vpn vpls-vpws
 !
 !
 neighbor 209.165.200.228
 remote-as 100
 update-source Loopback0
 address-family l2vpn vpls-vpws
 !
 !
!
l2vpn
 bridge group bg1
 bridge-domain bg1_bd1
  interface GigabitEthernet0/1/1/4.1
  !
  vfi bg1_bd1_vfi
   vpn-id 1
   autodiscovery bgp
    rd auto
    route-target 209.165.201.1:1
    signaling-protocol bgp
     ve-id 200
    !
   !
   multicast p2mp
    signaling-protocol bgp
    !
    transport rsvp-te
     attribute-set p2mp-te set1
    !
   !
  !
 !
 !
!
rsvp
 interface GigabitEthernet0/1/1/0
 bandwidth 100000
 !
 interface GigabitEthernet0/1/1/1
 bandwidth 100000
 !
 interface GigabitEthernet0/1/1/3
 bandwidth 100000
 !
 interface GigabitEthernet0/1/1/8
 bandwidth 100000
 !
!
mpls traffic-eng
 interface GigabitEthernet0/1/1/0
 auto-tunnel backup
  nhop-only
 !
 !
 interface GigabitEthernet0/1/1/1
 auto-tunnel backup
  nhop-only
 !
 !
 interface GigabitEthernet0/1/1/3
 !
 interface GigabitEthernet0/1/1/8
 !
 auto-tunnel p2mp
 tunnel-id min 100 max 200
 !
 auto-tunnel backup
 tunnel-id min 1000 max 1500
 !
 attribute-set p2mp-te set1
 bandwidth 10000
 fast-reroute
 record-route
 !
!
mpls ldp
 nsr
 graceful-restart
 router-id 209.165.200.226
 interface GigabitEthernet0/1/1/0
 !
 interface GigabitEthernet0/1/1/1
 !
 interface GigabitEthernet0/1/1/3
 !
 interface GigabitEthernet0/1/1/8
 !
!
end
 
RP/0/RSP0/CPU0:P#

Конфигурация PE2

RP/0/RSP0/CPU0:PE2#show run
hostname PE2
ipv4 unnumbered mpls traffic-eng Loopback0
interface Loopback0
 ipv4 address 209.165.200.227 255.255.255.255
!
interface GigabitEthernet0/3/0/2.1 l2transport
 encapsulation dot1q 1
!
interface GigabitEthernet0/3/0/3
 description connected to P router
 ipv4 address 209.165.201.62 255.255.255.224
 transceiver permit pid all
!
router ospf 100
 nsr
 router-id 209.165.200.227
 nsf cisco
 area 0
 mpls traffic-eng
 interface Loopback0
 !
 interface GigabitEthernet0/3/0/3
 !
 !
 mpls traffic-eng router-id 209.165.200.227
!
router bgp 100
 nsr
 bgp router-id 209.165.200.227
 bgp graceful-restart
 address-family l2vpn vpls-vpws
 !
 neighbor 209.165.200.225
 remote-as 100
 update-source Loopback0
 address-family l2vpn vpls-vpws
 !
 !
 neighbor 209.165.200.226
 remote-as 100
 update-source Loopback0
 address-family l2vpn vpls-vpws
 !
 !
 neighbor 209.165.200.228
 remote-as 100
 update-source Loopback0
 address-family l2vpn vpls-vpws
 !
 !
!
l2vpn
 bridge group bg1
 bridge-domain bg1_bd1
  interface GigabitEthernet0/3/0/2.1
  !
  vfi bg1_bd1_vfi
   vpn-id 1
   autodiscovery bgp
    rd auto
    route-target 209.165.201.1:1
    signaling-protocol bgp
     ve-id 300
    !
   !
   multicast p2mp
    signaling-protocol bgp
    !
    transport rsvp-te
     attribute-set p2mp-te set1
    !
   !
  !
 !
 !
!
rsvp
 interface GigabitEthernet0/3/0/3
 bandwidth 100000
 !
!
mpls traffic-eng
 interface GigabitEthernet0/3/0/3
 !
 auto-tunnel p2mp
 tunnel-id min 100 max 200
 !
 auto-tunnel backup
 tunnel-id min 1000 max 1500
 !
 attribute-set p2mp-te set1
 bandwidth 10000
 fast-reroute
 record-route
 !
!
mpls ldp
 nsr
 graceful-restart
 router-id 209.165.200.227
 interface GigabitEthernet0/3/0/3
 !
!
end
 
RP/0/RSP0/CPU0:PE2#

Конфигурация PE3

RP/0/RSP0/CPU0:PE3#show run
hostname PE3
ipv4 unnumbered mpls traffic-eng Loopback0

interface Loopback0
 ipv4 address 209.165.200.228 255.255.255.255
!
interface GigabitEthernet0/2/1/8
 description connected to P router
 ipv4 address 209.165.201.102 255.255.255.224
 transceiver permit pid all
!
interface GigabitEthernet0/2/1/11
 transceiver permit pid all
!
interface GigabitEthernet0/2/1/11.1 l2transport
 encapsulation dot1q 1
!
router ospf 100
 nsr
 router-id 209.165.200.228
 nsf cisco
 area 0
 mpls traffic-eng
 interface Loopback0
 !
 interface GigabitEthernet0/2/1/8
 !
 !
 mpls traffic-eng router-id 209.165.200.228
!
router bgp 100
 nsr
 bgp router-id 209.165.200.228
 bgp graceful-restart
 address-family l2vpn vpls-vpws
 !
 neighbor 209.165.200.225
 remote-as 100
 update-source Loopback0
 address-family l2vpn vpls-vpws
 !
 !
 neighbor 209.165.200.226
 remote-as 100
 update-source Loopback0
 address-family l2vpn vpls-vpws
 !
 !
 neighbor 209.165.200.227
 remote-as 100
 update-source Loopback0
 address-family l2vpn vpls-vpws
 !
 !
!
l2vpn
 bridge group bg1
 bridge-domain bg1_bd1
  interface GigabitEthernet0/2/1/11.1
  !
  vfi bg1_bd1_vfi
   vpn-id 1
   autodiscovery bgp
    rd auto
    route-target 209.165.201.1:1
    signaling-protocol bgp
     ve-id 400
    !
   !
   multicast p2mp
    signaling-protocol bgp
    !
    transport rsvp-te
     attribute-set p2mp-te set1
    !
   !
  !
 !
 !
!
rsvp
 interface GigabitEthernet0/2/1/8
 bandwidth 1000000
 !
!
mpls traffic-eng
 interface GigabitEthernet0/2/1/8
 !
 auto-tunnel p2mp
 tunnel-id min 100 max 200
 !
 auto-tunnel backup
 tunnel-id min 1000 max 1500
 !
 attribute-set p2mp-te set1
 bandwidth 10000
 fast-reroute
 record-route
 !
!
mpls ldp
 nsr
 graceful-restart
 router-id 209.165.200.228
 interface GigabitEthernet0/2/1/8
 !
!
end
 
RP/0/RSP0/CPU0:PE3#  

Проверка (команды show)

Эти команды показа полезны, чтобы отладить и проверить статус P2MP PW и туннели MPLS TE P2MP.

  • покажите bridge-domain l2vpn
  • покажите подробность bridge-domain l2vpn
  • show mpls traffic-eng tunnels p2mp
  • метки show mpls forwarding <метка> подробность
  • show mpls traffic-eng tunnels p2mp табличный

Приведем несколько примеров:

 show l2vpn bridge-domain

RP/0/RSP0/CPU0:PE1#show l2vpn bridge-domain
Legend: pp = Partially Programmed.
Bridge group: bg1, bridge-domain: bg1_bd1, id: 0, state: up, ShgId: 0, MSTi: 0
 Aging: 300 s, MAC limit: 4000, Action: none, Notification: syslog
 Filter MAC addresses: 0
 ACs: 1 (1 up), VFIs: 1, PWs: 3 (3 up), PBBs: 0 (0 up)
 List of ACs:
   GigabitEthernet0/1/1/10.1, state: up, Static MAC addresses: 0
 List of Access PWs:
 List of VFIs:
   VFI bg1_bd1_vfi (up)
     P2MP: RSVP-TE, BGP, 1, Tunnel Up
     Neighbor 209.165.200.226 pw-id 1, state: up, Static MAC addresses: 0
     Neighbor 209.165.200.227 pw-id 1, state: up, Static MAC addresses: 0
     Neighbor 209.165.200.228 pw-id 1, state: up, Static MAC addresses: 0
RP/0/RSP0/CPU0:PE1#


show l2vpn bridge-domain detail
 
RP/0/RSP0/CPU0:PE1#show l2vpn bridge-domain detail
Legend: pp = Partially Programmed.
Bridge group: bg1, bridge-domain: bg1_bd1, id: 0, state: up, ShgId: 0, MSTi: 0
 Coupled state: disabled
 MAC learning: enabled
 MAC withdraw: enabled
   MAC withdraw for Access PW: enabled
   MAC withdraw sent on: bridge port up
   MAC withdraw relaying (access to access): disabled
 Flooding:
   Broadcast & Multicast: enabled
   Unknown unicast: enabled
 MAC aging time: 300 s, Type: inactivity
 MAC limit: 4000, Action: none, Notification: syslog
 MAC limit reached: no
 MAC port down flush: enabled
 MAC Secure: disabled, Logging: disabled
 Split Horizon Group: none
 Dynamic ARP Inspection: disabled, Logging: disabled
 IP Source Guard: disabled, Logging: disabled
 DHCPv4 snooping: disabled
 IGMP Snooping: enabled
  IGMP Snooping profile: none
 MLD Snooping profile: none
 Storm Control: disabled
 Bridge MTU: 1500
 MIB cvplsConfigIndex: 1
 Filter MAC addresses:
 P2MP PW: enabled
 Create time: 18/02/2014 03:47:59 (00:41:54 ago)
 No status change since creation
 ACs: 1 (1 up), VFIs: 1, PWs: 3 (3 up), PBBs: 0 (0 up)
 List of ACs:
   AC: GigabitEthernet0/1/1/10.1, state is up
     Type VLAN; Num Ranges: 1
     VLAN ranges: [1, 1]
     MTU 1504; XC ID 0x8802a7; interworking none
     MAC learning: enabled
     Flooding:
       Broadcast & Multicast: enabled
       Unknown unicast: enabled
     MAC aging time: 300 s, Type: inactivity
     MAC limit: 4000, Action: none, Notification: syslog
     MAC limit reached: no
     MAC port down flush: enabled
     MAC Secure: disabled, Logging: disabled
     Split Horizon Group: none
     Dynamic ARP Inspection: disabled, Logging: disabled
     IP Source Guard: disabled, Logging: disabled
     DHCPv4 snooping: disabled
     IGMP Snooping: enabled
     IGMP Snooping profile: none
     MLD Snooping profile: none
     Storm Control: disabled
     Static MAC addresses:
     Statistics:
       packets: received 0, sent 0
       bytes: received 0, sent 0
     Storm control drop counters:
       packets: broadcast 0, multicast 0, unknown unicast 0
       bytes: broadcast 0, multicast 0, unknown unicast 0
     Dynamic ARP inspection drop counters:
       packets: 0, bytes: 0
     IP source guard drop counters:
       packets: 0, bytes: 0
 List of Access PWs:
 List of VFIs:
   VFI bg1_bd1_vfi (up)
     P2MP:
       Type RSVP-TE, BGP signaling, PTree ID 1
       P2MP Status: Tunnel Up
       P2MP-TE attribute-set: set1
       Tunnel tunnel-mte100, Local Label: 289994
     VPN-ID: 1, Auto Discovery: BGP, state is Provisioned (Service Connected)
Route Distinguisher: (auto)
209.165.200.225:32768
     Import Route Targets:
       209.165.201.1:1
     Export Route Targets:
       209.165.201.1:1
     Signaling protocol: BGP
     Local VE-ID: 100 , Advertised Local VE-ID : 100
     VE-Range: 10
     PW: neighbor 209.165.200.226, PW ID 1, state is up ( established )
       PW class not set, XC ID 0xc0000001
       Encapsulation MPLS, Auto-discovered (BGP), protocol BGP
       Source address 209.165.200.225
       PW type VPLS, control word disabled, interworking none
       Sequencing not set
 
         MPLS        Local                         Remote                       
         ------------ ------------------------------ -------------------------
         Label       289959                        16030                        
         MTU         1500                          1500                         
         Control word disabled                      disabled                     
         PW type     VPLS                          VPLS                         
         VE-ID       100                           200                          
         ------------ ------------------------------ -------------------------
       MIB cpwVcIndex: 3221225473
       Create time: 18/02/2014 03:58:31 (00:31:23 ago)
       Last time status changed: 18/02/2014 03:58:31 (00:31:23 ago)
       MAC withdraw messages: sent 0, received 0
       Static MAC addresses:
       Statistics:
         packets: received 0, sent 0
         bytes: received 0, sent 0
       Storm control drop counters:
         packets: broadcast 0, multicast 0, unknown unicast 0
         bytes: broadcast 0, multicast 0, unknown unicast 0
     DHCPv4 snooping: disabled
     IGMP Snooping profile: none
     MLD Snooping profile: none
       P2MP-PW:
           FEC           Local                        Remote                      
           -------------- ----------------------------- ----------------------
           Label         NULL (inclusive tree)        NULL (inclusive tree)       
           P2MP ID       100                          100                         
           Flags         0x00                         0x00                        
           PTree Type    RSVP-TE                      RSVP-TE                     
           Tunnel ID     100                          100                         
           Ext. Tunnel ID 209.165.200.225              209.165.200.226             
         Statistics:
           packets: received 0
           bytes: received 0
     PW: neighbor 209.165.200.227, PW ID 1, state is up ( established )
       PW class not set, XC ID 0xc0000002
       Encapsulation MPLS, Auto-discovered (BGP), protocol BGP
       Source address 209.165.200.225
       PW type VPLS, control word disabled, interworking none
       Sequencing not set
 
         MPLS        Local                         Remote                       
         ------------ ------------------------------ -------------------------
         Label       289944                        16030                        
         MTU         1500                          1500                         
         Control word disabled                      disabled                     
         PW type     VPLS                          VPLS                         
         VE-ID       100                           300                          
         ------------ ------------------------------ -------------------------
       MIB cpwVcIndex: 3221225474
       Create time: 18/02/2014 04:05:25 (00:24:29 ago)
       Last time status changed: 18/02/2014 04:05:25 (00:24:29 ago)
       MAC withdraw messages: sent 0, received 0
       Static MAC addresses:
       Statistics:
         packets: received 0, sent 0
         bytes: received 0, sent 0
       Storm control drop counters:
         packets: broadcast 0, multicast 0, unknown unicast 0
         bytes: broadcast 0, multicast 0, unknown unicast 0
     DHCPv4 snooping: disabled
     IGMP Snooping profile: none
     MLD Snooping profile: none
       P2MP-PW:
           FEC           Local                        Remote                      
           -------------- ----------------------------- ----------------------
           Label         NULL (inclusive tree)        NULL (inclusive tree)       
           P2MP ID       100                          100                         
           Flags         0x00                         0x00                        
           PTree Type    RSVP-TE                      RSVP-TE                     
           Tunnel ID     100                          100                         
           Ext. Tunnel ID 209.165.200.225              209.165.200.227             
         Statistics:
           packets: received 0
           bytes: received 0
     PW: neighbor 209.165.200.228, PW ID 1, state is up ( established )
       PW class not set, XC ID 0xc0000003
       Encapsulation MPLS, Auto-discovered (BGP), protocol BGP
       Source address 209.165.200.225
       PW type VPLS, control word disabled, interworking none
       Sequencing not set
 
         MPLS        Local                         Remote                       
         ------------ ------------------------------ -------------------------
         Label       289929                        16045                        
         MTU         1500                          1500                         
         Control word disabled                      disabled                     
         PW type     VPLS                          VPLS                         
         VE-ID       100                           400                          
         ------------ ------------------------------ -------------------------
       MIB cpwVcIndex: 3221225475
       Create time: 18/02/2014 04:08:11 (00:21:43 ago)
       Last time status changed: 18/02/2014 04:08:11 (00:21:43 ago)
       MAC withdraw messages: sent 0, received 0
       Static MAC addresses:
       Statistics:
         packets: received 0, sent 0
         bytes: received 0, sent 0
       Storm control drop counters:
         packets: broadcast 0, multicast 0, unknown unicast 0
         bytes: broadcast 0, multicast 0, unknown unicast 0
     DHCPv4 snooping: disabled
     IGMP Snooping profile: none
     MLD Snooping profile: none
       P2MP-PW:
           FEC           Local                        Remote                      
           -------------- ----------------------------- ----------------------
           Label         NULL (inclusive tree)        NULL (inclusive tree)       
           P2MP ID       100                          100                         
           Flags         0x00                         0x00                        
           PTree Type    RSVP-TE                      RSVP-TE                     
           Tunnel ID     100                          100                         
           Ext. Tunnel ID 209.165.200.225              209.165.200.228             
         Statistics:
           packets: received 0
           bytes: received 0
     VFI Statistics:
       drops: illegal VLAN 0, illegal length 0
RP/0/RSP0/CPU0:PE1#


show mpls traffic-eng tunnels p2mp
 
RP/0/RSP0/CPU0:PE1#show mpls traffic-eng tunnels p2mp
 
 
Name: tunnel-mte100 (auto-tunnel for VPLS (l2vpn))
  Signalled-Name: auto_PE1_mt100
  Status:
    Admin: up Oper: up (Up for 00:32:35)
 
    Config Parameters:
     Bandwidth: 0 kbps (CT0) Priority: 7 7 Affinity: 0x0/0xffff
     Interface Bandwidth: 10000 kbps
     Metric Type: TE (default)
     Fast Reroute: Enabled, Protection Desired: Any
     Record Route: Enabled
     Reoptimization after affinity failure: Enabled
 
     Attribute-set: set1 (type p2mp-te)
     Destination summary: (3 up, 0 down, 0 disabled) Affinity: 0x0/0xffff
     Auto-bw: disabled
     Destination: 209.165.200.226
       State: Up for 00:32:35
       Path options:
         path-option 10 dynamic    [active]
     Destination: 209.165.200.227
       State: Up for 00:25:41
       Path options:
         path-option 10 dynamic    [active]
     Destination: 209.165.200.228
       State: Up for 00:22:55
       Path options:
         path-option 10 dynamic    [active]
 
   Current LSP:
     lsp-id: 10004 p2mp-id: 100 tun-id: 100 src: 209.165.200.225 extid:
209.165.200.225
     LSP up for: 00:32:35 (since Tue Feb 18 03:58:31 UTC 2014)
     Reroute Pending: No
     Inuse Bandwidth: 0 kbps (CT0)
     Number of S2Ls: 3 connected, 0 signaling proceeding, 0 down
 
     S2L Sub LSP: Destination 209.165.200.226 Signaling Status: connected
       S2L up for: 00:32:35 (since Tue Feb 18 03:58:31 UTC 2014)
       Sub Group ID: 1 Sub Group Originator ID: 209.165.200.225
       Path option path-option 10 dynamic   (path weight 1)
       Path info (OSPF 100 area 0)
         209.165.201.2
         209.165.200.226
 
     S2L Sub LSP: Destination 209.165.200.227 Signaling Status: connected
       S2L up for: 00:25:41 (since Tue Feb 18 04:05:25 UTC 2014)
       Sub Group ID: 2 Sub Group Originator ID: 209.165.200.225
       Path option path-option 10 dynamic   (path weight 2)
       Path info (OSPF 100 area 0)
         209.165.201.2
         209.165.201.61
         209.165.201.62
         209.165.200.227
 
     S2L Sub LSP: Destination 209.165.200.228 Signaling Status: connected
       S2L up for: 00:22:55 (since Tue Feb 18 04:08:11 UTC 2014)
       Sub Group ID: 4 Sub Group Originator ID: 209.165.200.225
       Path option path-option 10 dynamic   (path weight 2)
       Path info (OSPF 100 area 0)
         209.165.201.2
         209.165.201.101
         209.165.201.102
         209.165.200.228
 
   Reoptimized LSP (Install Timer Remaining 0 Seconds):
     None
   Cleaned LSP (Cleanup Timer Remaining 0 Seconds):
     None
 
LSP Tunnel 209.165.200.226 100 [10005] is signalled, connection is up
 Tunnel Name: auto_P_mt100 Tunnel Role: Tail
 InLabel: GigabitEthernet0/1/1/0, 289995
 Signalling Info:
   Src 209.165.200.226 Dst 209.165.200.225, Tun ID 100, Tun Inst 10005, Ext ID
209.165.200.226
   Router-IDs: upstream  209.165.200.226
               local     209.165.200.225
   Bandwidth: 0 kbps (CT0) Priority: 7 7 DSTE-class: 0
   Soft Preemption: None
   Path Info:
     Incoming Address: 209.165.201.1
     Incoming:
     Explicit Route:
       Strict, 209.165.201.1
       Strict, 209.165.200.225
     Record Route:
       IPv4 209.165.201.2, flags 0x0
     Tspec: avg rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
     Session Attributes: Local Prot: Set, Node Prot: Not Set, BW Prot: Not Set
                         Soft Preemption Desired: Not Set
   Resv Info: None
     Record Route: Empty
     Resv Info:
       Record Route: Empty
       Fspec: avg rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
 
LSP Tunnel 209.165.200.227 100 [10003] is signalled, connection is up
 Tunnel Name: auto_PE2_mt100 Tunnel Role: Tail
 InLabel: GigabitEthernet0/1/1/0, 289998
 Signalling Info:
   Src 209.165.200.227 Dst 209.165.200.225, Tun ID 100, Tun Inst 10003, Ext ID
209.165.200.227
   Router-IDs: upstream  209.165.200.226
               local     209.165.200.225
   Bandwidth: 0 kbps (CT0) Priority: 7 7 DSTE-class: 0
   Soft Preemption: None
   Path Info:
     Incoming Address: 209.165.201.1
     Incoming:
     Explicit Route:
       Strict, 209.165.201.1
       Strict, 209.165.200.225
     Record Route:
       IPv4 209.165.201.2, flags 0x0
       IPv4 209.165.201.62, flags 0x0
     Tspec: avg rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
     Session Attributes: Local Prot: Set, Node Prot: Not Set, BW Prot: Not Set
                         Soft Preemption Desired: Not Set
   Resv Info: None
     Record Route: Empty
     Resv Info:
       Record Route: Empty
       Fspec: avg rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
 
LSP Tunnel 209.165.200.228 100 [10004] is signalled, connection is up
 Tunnel Name: auto_PE3_mt100 Tunnel Role: Tail
 InLabel: GigabitEthernet0/1/1/0, 289970
 Signalling Info:
   Src 209.165.200.228 Dst 209.165.200.225, Tun ID 100, Tun Inst 10004, Ext ID
209.165.200.228
   Router-IDs: upstream  209.165.200.226
               local     209.165.200.225
   Bandwidth: 0 kbps (CT0) Priority: 7 7 DSTE-class: 0
   Soft Preemption: None
   Path Info:
     Incoming Address: 209.165.201.1
     Incoming:
     Explicit Route:
       Strict, 209.165.201.1
       Strict, 209.165.200.225
     Record Route:
       IPv4 209.165.201.2, flags 0x0
       IPv4 209.165.201.102, flags 0x0
     Tspec: avg rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
     Session Attributes: Local Prot: Set, Node Prot: Not Set, BW Prot: Not Set
                         Soft Preemption Desired: Not Set
   Resv Info: None
     Record Route: Empty
     Resv Info:
       Record Route: Empty
       Fspec: avg rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
Displayed 1 (of 2) heads, 0 (of 0) midpoints, 3 (of 4) tails
Displayed 1 up, 0 down, 0 recovering, 0 recovered heads
RP/0/RSP0/CPU0:PE1#


show mpls forwarding labels <label> detail


RP/0/RSP0/CPU0:PE1#show mpls forwarding labels 289994 detail
Local Outgoing   Prefix            Outgoing    Next Hop       Bytes      
Label Label      or ID             Interface                   Switched   
------ ----------- ------------------ ------------ --------------- ------------
289994            P2MP TE: 100
      Updated Feb 18 03:58:32.360
      TE Tunnel Head, tunnel ID: 100, tunnel ifh: 0x8000e20
      IPv4 Tableid: 0xe0000000, IPv6 Tableid: 0xe0800000
      Flags:IP Lookup:not-set, Expnullv4:not-set, Expnullv6:set
            Payload Type v4:set, Payload Type v6:not-set, l2vpn:set
            Head:set, Tail:not-set, Bud:not-set, Peek:not-set, inclusive:set
            Ingress Drop:not-set, Egress Drop:not-set
      Platform Data&colon;{0x2000000, 0x2000000, 0x0, 0x0}, RPF-ID:0x80003
      VPLS Disposition: Bridge ID: 0, SHG ID: 0, PW Xconnect ID: 0x0
 
      mpls paths: 1, local mpls paths: 0, protected mpls paths: 1
 
      16005      P2MP TE: 100      Gi0/1/1/0   209.165.201.2  0          
        Updated Feb 18 03:58:32.360
        My Nodeid:65, Interface Nodeid:2065, Backup Interface Nodeid:2065
Packets Switched: 0
 
RP/0/RSP0/CPU0:PE1#


show mpls traffic-eng tunnels p2mp tabular
 
RP/0/RSP0/CPU0:PE1#show mpls traffic-eng tunnels p2mp tabular
 
          Tunnel  LSP    Destination         Source          FRR LSP Path
            Name   ID        Address        Address State State Role Prot
----------------- ----- --------------- --------------- ------ ------ ---- -----
  ^tunnel-mte100 10004 209.165.200.226 209.165.200.225    up Ready Head     
  ^tunnel-mte100 10004 209.165.200.227 209.165.200.225    up Ready Head     
  ^tunnel-mte100 10004 209.165.200.228 209.165.200.225    up Ready Head     
    auto_P_mt100 10005 209.165.200.225 209.165.200.226    up Inact Tail     
  auto_PE2_mt100 10003 209.165.200.225 209.165.200.227    up Inact Tail     
  auto_PE3_mt100 10004 209.165.200.225 209.165.200.228    up Inact Tail     
* = automatically created backup tunnel
^ = automatically created P2MP tunnel
RP/0/RSP0/CPU0:PE1#

Устраните неполадки LSM VPLS

Проблемы обычной конфигурации

Наиболее распространенные причины для проблем P2MP в L2VPN показывают здесь.

  • BGP - конфигурация для LSM является точно тем же как этим для AD BGP. Удостоверьтесь, что экспортировали/импортировали l2vpn vpls-vpws маршруты семейства адресов путем настройки address-family l2vpn vpls-vpws для Соседних BGP узел.

  • Существует конфигурация MPLS и ошибки конфигурирования многоадресной передачи.

    Регулирование трафика MLPS должно быть включено на интерфейсах, где проходит P2MP PWs.

    mpls traffic-eng
    interface gigabit <>

    auto-tunnel p2mp
     tunnel-id min 100 max 200

    Enable multicast-routing for interfaces.

    multicast-routing
    address-family ipv4
    interface all enable


  • Конфигурация L2VPN для LSM в Выпуске 5.1.0 Cisco IOS XR требует что вы:

    • Настройте конфигурацию VPN ID для VFI
    • Настройте P2MP групповой адресации для VFI. Confgure транспортный протокол и протокол сигнализации, как в конфигурации данного примера:
    l2vpn
    bridge group bg
     bridge-domain bd1   
      vfi vf1    
       vpn-id 1    
       autodiscovery bgp    
        rd auto
        route-target 209.165.201.7:1
        signaling-protocol bgp
          ve-id 1
      multicast p2mp
        signaling-protocol bgp
        transport rsvp-te


  • Головка/Хвост LSM должна быть установлена должным образом. В Выпуске 5.1.0 Cisco IOS XR каждым хвостом LSM является также Головка LSM и наоборот. Поскольку нет никакого явного обмена возможности LSM среди маршрутизаторов, все маршрутизаторы во включенном домене моста LSM должны участвовать в LSM.

L2VPN и команды показа L2FIB и устранение неполадок

  • Процесс менеджера L2VPN (l2vpn_mgr) передает с Регулированием трафика MLPS (TE) процесс управления (te_control) и запрашивает создание туннеля. Гарантируйте, что te_control и процессы l2vpn_mgr находятся в активном состоянии с этими командами:
    • покажите процесс l2vpn_mgr
    • покажите процесс te_control


  • Проверьте, что процесс l2vpn_mgr запросил создание туннеля. Запись для туннеля должна быть в этой команде показа:

    RP/0/RSP0/CPU0:PE1#show l2vpn atom-db preferred-path
    Tunnel              BW Tot/Avail/Resv   Peer ID           VC ID
    ----------------------------------------------------------------------
    tunnel-mte1 0/0/0                        209.165.200.226   1
                               209.165.200.227   1
                               209.165.200.228   1


  • L2VPN должен получить сведения о туннеле от процесса te_control. Проверьте, что эта команда показа имеет ненулевые подробные данные, такие как туннельный идентификатор, Ext.tunnel-идентификатор, туннель-ifh и p2mp-идентификатор:

    RP/0/RSP0/CPU0:PE1#show l2vpn atom-db preferred-path private
    Tunnel tunnel-mte1 0/0/0:
     Peer ID: 209.165.200.226, VC-ID 1
     Peer ID: 209.165.200.227, VC-ID 1
     Peer ID: 209.165.200.228, VC-ID 1
     MTE details:
         tunnel-ifh: 0x08000e20
        local-label: 289994
            p2mp-id: 100
          tunnel-id: 100
      Ext.tunnel-id: 209.165.200.225


  • L2VPN должен объявить Экземпляр сервиса групповой адресации поставщика (PMSI) ко всем другим Периферийным маршрутизаторам. Проверьте, что l2vpn_mgr передал PMSI за настроенным VFI. Событие LSM Head: передайте PMSI, должен присутствовать в конечном счете история для VFI.

    RP/0/0/CPU0:one#show l2vpn bridge-domain p2mp private
    [...]
      Object: VFI
      Base info: version=0x0, flags=0x0, type=0, reserved=0
      VFI event trace history [Num events: 5]
      ----------------------------------------------------------------------------
        Time               Event                        Flags     Flags
        ====               =====                        =====     =====
        Dec 3 08:52:37.504 LSM Head: P2MP Provision     00000001, 00000000 - -
        Dec 3 08:52:37.504 BD VPN Add                   00000000, 00000000 M -
        Dec 3 08:55:56.672 LSM Head: MTE updated        00000001, 00000000 - -
        Dec 3 08:55:56.672 LSM Head: send PMSI          00000480, 00002710 - -
      ----------------------------------------------------------------------------
    [...]


  • L2VPN на других маршрутизаторах должен получить PMSI, который был просто передан. Гарантируйте что Хвост LSM: полученный PMSI показывают в конечном счете историю на получающей стороне:

    RP/0/0/CPU0:two#show l2vpn bridge-domain p2mp private
    [...]
      VFI event trace history [Num events: 7]
      ----------------------------------------------------------------------------
        Time               Event                        Flags     Flags
        ====               =====                        =====     =====
        Dec 3 08:42:49.216 LSM Head: P2MP Provision     00000001, 00000000 - -
        Dec 3 08:42:50.240 LSM Head: MTE updated        00000001, 00000070 - -
        Dec 3 08:42:50.240 LSM Head: send PMSI          00000480, 00002710 - -
        Dec 3 08:43:51.680 BD VPN Add                   00000000, 00000000 - -
        Dec 3 08:44:59.776 LSM Tail: PMSI received      0100a8c0, 00002710 - -
        Dec 3 08:45:00.288 LSM Head: MTE updated        00000001, 00000000 - -
      ----------------------------------------------------------------------------
    [...]


  • Каждый маршрутизатор является оба Смещением первого (head) и последнего (tail) элемента очереди LSM и должен передать PMSI и получить PMSIs от каждого из других маршрутизаторов. Первый проверенный маршрутизатор должен получить PMSIs от каждого из других узлов.

  • Уровень Две Базы данных переадресации (L2FIB) должны получить ГЛАВНУЮ информацию от L2VPN и должны загрузить их к линейной плате.

    RP/0/RSP0/CPU0:PE1#show l2vpn forwarding bridge-domain detail location 0/1/CPU0

    Bridge-domain name: bg1:bg1_bd1, id: 0, state: up
     MAC learning: enabled
    MAC port down flush: enabled
    Flooding:
      Broadcast & Multicast: enabled
      Unknown unicast: enabled
     MAC aging time: 300 s, Type: inactivity
     MAC limit: 4000, Action: none, Notification: syslog
    MAC limit reached: no
     MAC Secure: disabled, Logging: disabled
    DHCPv4 snooping: profile not known on this node
     Dynamic ARP Inspection: disabled, Logging: disabled
     IP Source Guard: disabled, Logging: disabled
    IGMP snooping: disabled, flooding: enabled
     MLD snooping: disabled, flooding: disabled
     Storm control: disabled
     P2MP PW: enabled
     Ptree type: RSVP-TE, TE i/f: tunnel-mte100,
    nhop valid: TRUE, Status: Bound, Label: 289994
     Bridge MTU: 1500 bytes
     Number of bridge ports: 4
     Number of MAC addresses: 0
     Multi-spanning tree instance: 0


  • L2FIB должен получить ХВОСТОВУЮ информацию от L2VPN для каждого PW и должен загрузить их к платформе.

    RP/0/RSP0/CPU0:PE1#show l2vpn forwarding bridge-domain hardware ingress detail
    location 0/1/CPU0


    Bridge-domain name: bg1:bg1_bd1, id: 0, state: up
     MAC learning: enabled
     MAC port down flush: enabled
     Flooding:
      Broadcast & Multicast: enabled
      Unknown unicast: enabled
     MAC aging time: 300 s, Type: inactivity
     MAC limit: 4000, Action: none, Notification: syslog
     MAC limit reached: no
     MAC Secure: disabled, Logging: disabled
     DHCPv4 snooping: profile not known on this node
     Dynamic ARP Inspection: disabled, Logging: disabled
     IP Source Guard: disabled, Logging: disabled
     IGMP snooping: disabled, flooding: enabled
     MLD snooping: disabled, flooding: disabled
     Storm control: disabled
     P2MP PW: enabled
     Ptree type: RSVP-TE, TE i/f: tunnel-mte100,
                nhop valid: TRUE, Status: Bound, Label: 289994
     Bridge MTU: 1500 bytes
     Number of bridge ports: 4
     Number of MAC addresses: 0
     Multi-spanning tree instance: 0
     
     Platform Bridge context:
       Last notification sent at: 02/18/2014 21:58:55
       Ingress Bridge Domain: 0, State: Created
       static MACs: 0, port level static MACs: 0, MAC limit: 4000, current MAC limit:
    4000,   MTU: 1500, MAC limit action: 0
       Rack 0 FGIDs:shg0: 0x00000000, shg1: 0x00000002, shg2: 0x00000002
       Rack 1 FGIDs:shg0: 0x00000000, shg1: 0x00000000, shg2: 0x00000000
         Flags: Virtual Table ID Disable, P2MP Enable, CorePW Attach
         P2MP Head-end Info: Head end bound
         Tunnel ifhandle: 0x08000e20, Internal Label: 289994, Local LC NP mask: 0x0,
           Head-end Local LC NP mask: 0x0, All L2 Mcast routes local LC NP mask: 0x0
       Rack: 0, Physical slot: 1, shg 0 members: 1, shg 1 members: 0, shg 2 members: 0
     
     
     Platform Bridge HAL context:
       Number of NPs: 4, NP mask: 0x0008, mgid index: 513, learn key: 0
       NP: 3, shg 0 members: 1, shg 1 members: 0, shg 2 members: 0
       MAC limit counter index: 0x00ec1e60
       
       Platform Bridge Domain Hardware Information:
         Bridge Domain: 0 NP 0
           Flags: Virtual Table, Learn Enable, P2MP Tree Enabled
           Head-end P-Tree Int Label: 289994
           Num Members: 0, Learn Key: 0x00, Half Age: 5
           fgid shg0: 0x0000, fgid shg1: 0x0002, fgid shg2: 0x0002, mgid index: 513
           BD learn cntr: 0x00ec1e60
         Bridge Domain: 0 NP 1
           Flags: Virtual Table, Learn Enable, P2MP Tree Enabled
           Head-end P-Tree Int Label: 289994
           Num Members: 0, Learn Key: 0x00, Half Age: 5
           fgid shg0: 0x0000, fgid shg1: 0x0002, fgid shg2: 0x0002, mgid index: 513
           BD learn cntr: 0x00ec1e60
         Bridge Domain: 0 NP 2
           Flags: Virtual Table, Learn Enable, P2MP Tree Enabled
           Head-end P-Tree Int Label: 289994
           Num Members: 0, Learn Key: 0x00, Half Age: 5
           fgid shg0: 0x0000, fgid shg1: 0x0002, fgid shg2: 0x0002, mgid index: 513
           BD learn cntr: 0x00ec1e60
         Bridge Domain: 0 NP 3
           Flags: Virtual Table, Learn Enable, P2MP Tree Enabled
           Head-end P-Tree Int Label: 289994
           Num Members: 1, Learn Key: 0x00, Half Age: 5
           fgid shg0: 0x0000, fgid shg1: 0x0002, fgid shg2: 0x0002, mgid index: 513
           BD learn cntr: 0x00ec1e60
           Bridge Member 0, copy 0
             Flags: Active, XID: 0x06c002a7
           Bridge Member 0, copy 1
             Flags: Active, XID: 0x06c002a7
         
     
     GigabitEthernet0/1/1/10.1, state: oper up
       Number of MAC: 0
       Statistics:
         packets: received 0, sent 0
         bytes: received 0, sent 0
       Storm control drop counters:
         packets: broadcast 0, multicast 0, unknown unicast 0
         bytes: broadcast 0, multicast 0, unknown unicast 0
       Dynamic arp inspection drop counters:
         packets: 0, bytes: 0
       IP source guard drop counters:
         packets: 0, bytes: 0
     Platform Bridge Port context:
     Last notification sent at: 02/18/2014 21:58:56
     Ingress State: Bound
       Flags: None
       
     Platform AC context:
     Ingress AC: VPLS, State: Bound
       Flags: Port Level MAC Limit
     XID: 0x06c002a7, SHG: None
     uIDB: 0x001a, NP: 3, Port Learn Key: 0
     Slot flood mask rack 0: 0x200000 rack 1: 0x0 NP flood mask: 0x0008
     NP3
       Ingress uIDB:
         Flags: L2, Status, Racetrack Eligible, VPLS
         Stats Ptr: 0x5302c9, uIDB index: 0x001a, Wire Exp Tag: 1
         BVI Bridge Domain: 0, BVI Source XID: 0x00000000
         VLAN1: 0, VLAN1 etype: 0x0000, VLAN2: 0, VLAN2 etype: 0x0000
         L2 ACL Format: 0, L2 ACL ID: 0, IPV4 ACL ID: 0, IPV6 ACL ID: 0
         QOS ID: 0, QOS Format ID: 0
         Local Switch dest XID: 0x06c002a7
         UIDB IF Handle: 0x02001042, Source Port: 0, Num VLANs: 0
       Xconnect ID: 0x06c002a7, NP: 3
         Type: AC
         Flags: Learn enable, VPLS
         uIDB Index: 0x001a
         Bridge Domain ID: 0, Stats Pointer: 0xec1e62
         Split Horizon Group: None
       Bridge Port    : Bridge 0 Port 0
         Flags: Active Member
         XID: 0x06c002a7
       Bridge Port Virt: Bridge 0 Port 0
         Flags: Active Member
         XID: 0x06c002a7
       Storm Control not enabled
     
     Nbor 209.165.200.226 pw-id 1
       Number of MAC: 0
       Statistics:
         packets: received 0, sent 2
         bytes: received 0, sent 192
       Storm control drop counters:
         packets: broadcast 2, multicast 0, unknown unicast 0
         bytes: broadcast 192, multicast 0, unknown unicast 0
       Dynamic arp inspection drop counters:
         packets: 0, bytes: 0
       IP source guard drop counters:
         packets: 0, bytes: 0
       Statistics P2MP:
         packets: received 0
         bytes: received 0
     
     Platform Bridge Port context:
     Last notification sent at: 02/18/2014 21:58:55
     Ingress State: Bound
       Flags: None
       P2MP PW enabled, P2MP Role: tail
     Platform PW context:
     Ingress PW: VPLS, State: Bound
     XID: 0xc0008000, bridge: 0, MAC limit: 4000, l2vpn ldi index: 0x0001, vc label:
    16030, nr_ldi_hash: 0xab, r_ldi_hash: 0xbd, lag_hash: 0x17, SHG: VFI Enabled
       Flags: MAC Limit Port Level
     Port Learn Key: 0
     Trident Layer Flags: None
     Slot flood mask rack 0: 0x0 rack 1: 0x0 NP flood mask: 0x0000
     Primary L3 path: ifhandle: 0x02000100, sfp_or_lagid: 0x00d2
     Backup L3 path: Not set
     NP0
       Xconnect ID: 0xc0008000, NP: 0
         Type: Pseudowire (no control word)
         Flags: Learn enable, Type 5, Local replication, VPLS
         VC label hash, nR-LDI Hash: 0xab, R-LDI Hash: 0xb7, LAG Hash: 0x17,
         VC output label: 0x03e9e (16030), LDI: 0x0001, stats ptr: 0x00530258
         Bridge Domain ID: 0, Stats Pointer: 0xec1e62
         Split Horizon Group: VFI Enabled
     NP1
       Xconnect ID: 0xc0008000, NP: 1
         Type: Pseudowire (no control word)
         Flags: Learn enable, Type 5, Local replication, VPLS
         VC label hash, nR-LDI Hash: 0xab, R-LDI Hash: 0xb7, LAG Hash: 0x17,
         VC output label: 0x03e9e (16030), LDI: 0x0001, stats ptr: 0x00530258
         Bridge Domain ID: 0, Stats Pointer: 0xec1e62
         Split Horizon Group: VFI Enabled
     NP2
       Xconnect ID: 0xc0008000, NP: 2
         Type: Pseudowire (no control word)
         Flags: Learn enable, Type 5, Local replication, VPLS
         VC label hash, nR-LDI Hash: 0xab, R-LDI Hash: 0xb7, LAG Hash: 0x17,
         VC output label: 0x03e9e (16030), LDI: 0x0001, stats ptr: 0x00530300
         Bridge Domain ID: 0, Stats Pointer: 0xec1e62
         Split Horizon Group: VFI Enabled
     NP3
       Xconnect ID: 0xc0008000, NP: 3
         Type: Pseudowire (no control word)
         Flags: Learn enable, Type 5, Local replication, VPLS
         VC label hash, nR-LDI Hash: 0xab, R-LDI Hash: 0xb7, LAG Hash: 0x17,
         VC output label: 0x03e9e (16030), LDI: 0x0001, stats ptr: 0x00530488
         Bridge Domain ID: 0, Stats Pointer: 0xec1e64
         Split Horizon Group: VFI Enabled
     
     Nbor 209.165.200.227 pw-id 1
       Number of MAC: 0
       Statistics:
         packets: received 0, sent 1
         bytes: received 0, sent 96
       Storm control drop counters:
         packets: broadcast 0, multicast 0, unknown unicast 0
         bytes: broadcast 0, multicast 0, unknown unicast 0
       Dynamic arp inspection drop counters:
         packets: 0, bytes: 0
       IP source guard drop counters:
         packets: 0, bytes: 0
       Statistics P2MP:
         packets: received 0
         bytes: received 0
     
     Platform Bridge Port context:
     Last notification sent at: 02/18/2014 21:58:55
     Ingress State: Bound
       Flags: None
       P2MP PW enabled, P2MP Role: tail
     Platform PW context:
     Ingress PW: VPLS, State: Bound
     XID: 0xc0008001, bridge: 0, MAC limit: 4000, l2vpn ldi index: 0x0002, vc label:
    16030, nr_ldi_hash: 0xab, r_ldi_hash: 0xbd, lag_hash: 0x17, SHG: VFI Enabled
       Flags: MAC Limit Port Level
     Port Learn Key: 0
     Trident Layer Flags: None
     Slot flood mask rack 0: 0x0 rack 1: 0x0 NP flood mask: 0x0000
     Primary L3 path: ifhandle: 0x02000100, sfp_or_lagid: 0x00d2
     Backup L3 path: Not set
     NP0
       Xconnect ID: 0xc0008001, NP: 0
         Type: Pseudowire (no control word)
         Flags: Learn enable, Type 5, Local replication, VPLS
         VC label hash, nR-LDI Hash: 0xab, R-LDI Hash: 0xb7, LAG Hash: 0x17,
         VC output label: 0x03e9e (16030), LDI: 0x0002, stats ptr: 0x0053025e
         Bridge Domain ID: 0, Stats Pointer: 0xec1e64
         Split Horizon Group: VFI Enabled
     NP1
       Xconnect ID: 0xc0008001, NP: 1
         Type: Pseudowire (no control word)
         Flags: Learn enable, Type 5, Local replication, VPLS
         VC label hash, nR-LDI Hash: 0xab, R-LDI Hash: 0xb7, LAG Hash: 0x17,
         VC output label: 0x03e9e (16030), LDI: 0x0002, stats ptr: 0x0053025e
         Bridge Domain ID: 0, Stats Pointer: 0xec1e64
         Split Horizon Group: VFI Enabled
     NP2
       Xconnect ID: 0xc0008001, NP: 2
         Type: Pseudowire (no control word)
         Flags: Learn enable, Type 5, Local replication, VPLS
         VC label hash, nR-LDI Hash: 0xab, R-LDI Hash: 0xb7, LAG Hash: 0x17,
         VC output label: 0x03e9e (16030), LDI: 0x0002, stats ptr: 0x00530306
         Bridge Domain ID: 0, Stats Pointer: 0xec1e64
         Split Horizon Group: VFI Enabled
     NP3
       Xconnect ID: 0xc0008001, NP: 3
         Type: Pseudowire (no control word)
         Flags: Learn enable, Type 5, Local replication, VPLS
         VC label hash, nR-LDI Hash: 0xab, R-LDI Hash: 0xb7, LAG Hash: 0x17,
         VC output label: 0x03e9e (16030), LDI: 0x0002, stats ptr: 0x0053048e
         Bridge Domain ID: 0, Stats Pointer: 0xec1e66
         Split Horizon Group: VFI Enabled
     
     Nbor 209.165.200.228 pw-id 1
       Number of MAC: 0
       Statistics:
         packets: received 0, sent 0
         bytes: received 0, sent 0
       Storm control drop counters:
         packets: broadcast 0, multicast 0, unknown unicast 0
         bytes: broadcast 0, multicast 0, unknown unicast 0
       Dynamic arp inspection drop counters:
         packets: 0, bytes: 0
       IP source guard drop counters:
         packets: 0, bytes: 0
       Statistics P2MP:
         packets: received 0
         bytes: received 0
     
     Platform Bridge Port context:
     Last notification sent at: 02/18/2014 21:58:55
     Ingress State: Bound
       Flags: None
       P2MP PW enabled, P2MP Role: tail
     Platform PW context:
     Ingress PW: VPLS, State: Bound
     XID: 0xc0008002, bridge: 0, MAC limit: 4000, l2vpn ldi index: 0x0003, vc label:
    16045, nr_ldi_hash: 0x7b, r_ldi_hash: 0xb3, lag_hash: 0xa8, SHG: VFI Enabled
       Flags: MAC Limit Port Level
     Port Learn Key: 0
     Trident Layer Flags: None
     Slot flood mask rack 0: 0x0 rack 1: 0x0 NP flood mask: 0x0000
     Primary L3 path: ifhandle: 0x02000100, sfp_or_lagid: 0x00d2
     Backup L3 path: Not set
     NP0
       Xconnect ID: 0xc0008002, NP: 0
         Type: Pseudowire (no control word)
         Flags: Learn enable, Type 5, Local replication, VPLS
         VC label hash, nR-LDI Hash: 0x7b, R-LDI Hash: 0xd6, LAG Hash: 0xa8,
         VC output label: 0x03ead (16045), LDI: 0x0003, stats ptr: 0x00530264
         Bridge Domain ID: 0, Stats Pointer: 0xec1e66
         Split Horizon Group: VFI Enabled
     NP1
       Xconnect ID: 0xc0008002, NP: 1
         Type: Pseudowire (no control word)
         Flags: Learn enable, Type 5, Local replication, VPLS
         VC label hash, nR-LDI Hash: 0x7b, R-LDI Hash: 0xd6, LAG Hash: 0xa8,
         VC output label: 0x03ead (16045), LDI: 0x0003, stats ptr: 0x00530264
         Bridge Domain ID: 0, Stats Pointer: 0xec1e66
         Split Horizon Group: VFI Enabled
     NP2
       Xconnect ID: 0xc0008002, NP: 2
         Type: Pseudowire (no control word)
         Flags: Learn enable, Type 5, Local replication, VPLS
         VC label hash, nR-LDI Hash: 0x7b, R-LDI Hash: 0xd6, LAG Hash: 0xa8,
         VC output label: 0x03ead (16045), LDI: 0x0003, stats ptr: 0x0053030c
         Bridge Domain ID: 0, Stats Pointer: 0xec1e66
         Split Horizon Group: VFI Enabled
     NP3
       Xconnect ID: 0xc0008002, NP: 3
         Type: Pseudowire (no control word)
         Flags: Learn enable, Type 5, Local replication, VPLS
         VC label hash, nR-LDI Hash: 0x7b, R-LDI Hash: 0xd6, LAG Hash: 0xa8,
         VC output label: 0x03ead (16045), LDI: 0x0003, stats ptr: 0x00530494
         Bridge Domain ID: 0, Stats Pointer: 0xec1e68
         Split Horizon Group: VFI Enabled
     
    RP/0/RSP0/CPU0:PE1#

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.