Коммутаторы : коммутаторы Cisco Nexus серии 1000V

Nexus примеры конфигурации канала порта коммутаторов серии 1000V

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв

Введение

Этот документ описывает оптимальные методы для использования при развертывании каналов порта на коммутаторе Cisco Nexus 1000V (N1KV). N1KV требует каналов порта для профилей порта, которые содержат несколько интерфейсов на хост.

Внесенный Карлосом Лопесом и Метью Вронковским, специалистами службы технической поддержки Cisco.

Предварительные условия

Требования

Компания Cisco рекомендует предварительно ознакомиться со следующими предметами:

  • N1KV
  • Система Cisco UCS (UCS)
  • Cisco Nexus и коммутаторы серии Catalyst

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • N1KV
  • UCS

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Настройка

Этот раздел содержит эти конфигурации:

N1KV на UCS серверы серии B в режиме конечного узла

UCS Cisco использует два разнообразных пути между блейдом и восходящей сетью. В настоящее время Центральные устройства не делают Протокола управления Агрегации канала поддержки (LACP)/виртуальный Port Channel (vPC), движущийся на юг к блейдам. Это означает, что должен использоваться канал статического порта с точки зрения N1KV. Прикрепление MAC требуется, так как восходящие коммутаторы не поддерживают EtherChannel мультишасси.

# VSM configuration
port-profile type ethernet system-uplink
vmware port-group
switchport mode trunk
switchport trunk allowed vlan 100, 101, 102, 103, 200 - 300
channel-group auto mode on mac-pinning
no shutdown
system vlan 100,101,102,103
state enabled

# Upstream switch configuration
-None required

N1KV на UCS Серверы Cерии C или Стоечные серверы, Связанные к Nexus 5000/7000 Коммутаторы с vPC

В этой топологии каждый сервер стойки физически связан с двумя другими коммутаторами Nexus - один кабель к каждому коммутатору. LACP является Предпочтительным режимом, потому что это позволяет лучшее распределение трафика и добавление/вычитание неразрушительного ссылок. Предполагается то, что восходящим коммутаторам Nexus уже настроили одноранговый канал vPC.

# VSM configuration
feature lacp
lacp offload
port-channel load-balance ethernet source-mac
port-profile type ethernet system-uplink
vmware port-group
switchport mode trunk
switchport trunk allowed vlan 100, 101, 102, 103, 200 - 300
channel-group auto mode active
no shutdown
system vlan 100,101,102,103
state enabled

# Nexus 5k/7k switches #1 & #2 configuration
interface port-channel1000
switchport mode trunk
vpc 1000
switchport trunk allowed vlan 100-103,200-300
spanning-tree port type edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable

no lacp suspend-individual <- Nexus 7k only!!!
!
interface Ethernet1/11
description ESX-Host1
switchport mode trunk
switchport trunk allowed vlan 100-103,200-300
spanning-tree port type edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable
channel-group 1000 mode active

N1KV на UCS Серверы Cерии C или Стоечные серверы, Связанные к Коммутаторам без vPC

В этой топологии каждый сервер стойки физически связан с двумя другими коммутаторами, но vPC не доступен. Единственная поддерживаемая конфигурация является Прикреплением MAC. Эта конфигурация идентична используемому на UCS серверы Серии B. Канал статического порта (режим на) не поддерживается, так как восходящие коммутаторы не поддерживают Технологию Ethernet-канала мультишасси.

# VSM configuration
port-profile type ethernet system-uplink
vmware port-group
switchport mode trunk
switchport trunk allowed vlan 100, 101, 102, 103, 200 - 300
channel-group auto mode on mac-pinning
no shutdown
system vlan 100,101,102,103
state enabled

# Upstream switch configuration
-None required

N1KV на UCS серверы cерии C или стоечные серверы, связанные к 6500 VSS или складывающим коммутаторам

В этой топологии восходящие коммутаторы действуют как отдельное шасси. Это позволяет N1KV соединяться с LACP.

# VSM configuration
feature lacp
lacp offload
port-profile type ethernet system-uplink
vmware port-group
switchport mode trunk
switchport trunk allowed vlan 100, 101, 102, 103, 200 - 300
channel-group auto mode active
no shutdown
system vlan 100,101,102,103
state enabled

# 6500 VSS configuration
interface Port-channel1000
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100-103,200-300
switchport mode trunk
spanning-tree portfast edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable
!
interface GigabitEthernet1/1/1
description ESX-Host1 adapter 1
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100-103,200-300
switchport mode trunk
spanning-tree portfast edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable
channel-group 1000 mode active
!
interface GigabitEthernet2/1/1
description ESX-Host1 adapter 2
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 100-103,200-300
switchport mode trunk
spanning-tree portfast edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable
channel-group 1000 mode active

N1KV на UCS серверы cерии C или стоечные серверы, связанные к одиночному восходящему коммутатору с каналом статического порта

В этой топологии серверы являются одноканальными к восходящему коммутатору. Эта топология не обеспечивает избыточности коммутатора и не является оптимальным методом.

# VSM configuration
port-profile type ethernet system-uplink
vmware port-group
switchport mode trunk
switchport trunk allowed vlan 100, 101, 102, 103, 200 - 300
channel-group auto mode on
no shutdown
system vlan 100,101,102,103
state enabled

# Upstream Nexus switch
interface port-channel 1000
switchport mode trunk
switchport trunk allowed vlan 100-103,200-300
spanning-tree port type edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable
!
interface Ethernet1/11
description ESX-Host1
switchport mode trunk
switchport trunk allowed vlan 100-103,200-300
spanning-tree port type edge trunk
spanning-tree bpduguard enable
spanning-tree bpdufilter enable
channel-group 1000 mode on

Проверка.

Воспользуйтесь данным разделом для проверки правильности функционирования вашей конфигурации.

show run interface po{X} membership
show port-channel summary

Устранение неполадок

Этот раздел обеспечивает информацию, которую вы можете использовать для того, чтобы устранить неисправность в вашей конфигурации.

show port-channel summary
show port-channel internal event-history [all|errors]debug lacp all

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Document ID: 116739