Беспроводные сети / Мобильные решения : "Беспроводные сети, LAN (WLAN)"

WDS на JA версии 15.2 (4) автономных точек доступа Cisco с примером конфигурации локального сервера RADIUS

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв

Введение

Этот документ описывает, как настроить Беспроводные доменные сервисы (WDS) на автономной точке доступа (AP) настройка с локальным сервером RADIUS. Документ фокусируется на конфигурациях через новый GUI, но также и предоставляет конфигурации интерфейса командной строки (CLI).

Внесенный Maithri B и BG Surendra, специалистами службы технической поддержки Cisco.

Предварительные условия

Требования

Cisco рекомендует ознакомиться с основным GUI и конфигурацией интерфейса командой строки на автономных AP.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного обеспечения и оборудования:

  • Точка доступа серии Cisco 3602e на Автономном программном обеспечении AP IOS®, Выпуске 15.2 (4) JA1; это устройство будет действовать как AP WDS и локальный сервер RADIUS.
  • Точка доступа серии Cisco 2602i на Автономном программном обеспечении IOS AP, Выпуске 15.2 (4) JA1; это устройство будет действовать как Точка доступа клиента WDS.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Настройка

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Конфигурации GUI

Создайте SSID

Эта процедура описывает, как создать новые идентификаторы наборов сервисов (SSID).

  1. Перейдите к Безопасности> Диспетчер SSID и нажмите NEW для создания нового SSID.

    116597-config-wds-radius-01.png

  2. Настройте SSID для аутентификации Протокола EAP.

    116597-config-wds-radius-02.png

  3. Установите желаемый уровень шифрования. В данном примере используйте Защищенный доступ по протоколу Wi-Fi 2 (WPA2).

    116597-config-wds-radius-03.png

  4. Чтобы сохранить изменения, нажмите Apply.

  5. Перейдите к Безопасности> Диспетчер шифрования и выберите требуемый метод шифрования шифрования.

    116597-config-wds-radius-04.png

Конфигурация локального сервера RADIUS на AP WDS

Эта процедура описывает, как настроить локальный сервер RADIUS на AP WDS:

  1. Перейдите к Безопасности> Диспетчер серверов, добавьте IP Виртуального интерфейса моста (BVI) AP WDS как локальный RADIUS и добавьте общий секретный ключ.

    116597-config-wds-radius-05.png

  2. Перейдите к Безопасности> Локальный сервер RADIUS> вкладка General Set-Up. Определите протоколы EAP, которые вы хотите использовать. В данном примере включите аутентификацию Светового расширяемого протокола аутентификации (LEAP).

    116597-config-wds-radius-06.png

  3. Можно также добавить IPs Сервера доступа к сети (NAS) и клиентское имя пользователя / пароли учетных данных на той же странице. Конфигурация локального RADIUS на AP WDS завершена.

    116597-config-wds-radius-07.png

Конфигурация локального сервера RADIUS на точке доступа клиента WDS

Эти данные показывают, как настроить IP-адрес AP WDS как сервер RADIUS:

116597-config-wds-radius-08.png

Оба AP теперь настроены с SSIDs для Аутентификации LEAP и действий сервера WDS как локальный RADIUS. Используйте те же шаги для внешнего RADIUS; только IP сервера RADIUS изменится.

Включите WDS на AP WDS

Эта процедура описывает, как включить WDS на AP WDS:

  1. Перейдите к вкладке Wireless> WDS> General Set-Up и включите флажку Use этот AP как Беспроводные доменные сервисы. Это включает сервис WDS на AP.

  2. В сети со множественными AP WDS используйте Параметр приоритета Беспроводных доменных сервисов для определения основного WDS и резервного WDS. Диапазоны значений от 1-255, где 255 наивысший приоритет.

    116597-config-wds-radius-09.png

  3. Перейдите к вкладке Server Groups на той же странице. Создайте список группы серверов инфраструктуры, на котором аутентифицируются все AP клиента WDS. Можно использовать локальный сервер RADIUS на AP WDS для этой цели. Так как это было уже добавлено, это появляется в выпадающем списке.

    116597-config-wds-radius-10.png

  4. Включите кнопку с зависимой фиксацией Use Group For: Аутентификация инфраструктуры, и нажимает Apply для сохранения настроек.

  5. Имя пользователя AP WDS и пароли могут быть добавлены к списку локального сервера RADIUS.

Включите WDS на точке доступа клиента WDS

Эта процедура описывает, как включить WDS на Точке доступа клиента WDS:

  1. Navigatge к беспроводным сетям> AP, и включает флажок для, Участвуют в Инфраструктуре SWAN. SWAN обозначает Структурированную Беспроводную локальную сеть.

    116597-config-wds-radius-11.png

  2. AP клиента WDS могут автоматический обнаруживать AP WDS. Или, можно вручную ввести IP-адрес AP WDS для клиентской регистрации в Указанном текстовом поле Обнаружения.

    Можно также добавить клиентское имя пользователя WDS и пароль для аутентификации против локального сервера RADIUS, настроенного на AP WDS.

Конфигурации интерфейса командой строки

WDS_AP#

Это - пример конфигурации для AP WDS:

Current configuration : 2832 bytes
!
! Last configuration change at 05:54:08 UTC Fri Apr 26 2013
version 15.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname MAIB-WDS-AP
!
!
logging rate-limit console 9
enable secret 5 $1$EdDD$dG47yIKn86GCqmKjFf1Sy0
!
aaa new-model
!
!
aaa group server radius rad_eap
server name Local-Radius
!
aaa group server radius Infrastructure
server name Local-Radius
!
aaa authentication login eap_methods group rad_eap
aaa authentication login method_Infrastructure group Infrastructure
aaa authorization exec default local
!
!
!
!
!
aaa session-id common
no ip routing
no ip cef
!
!
!
!
dot11 syslog
!
dot11 ssid WDS-EAP
authentication open eap eap_methods
authentication network-eap eap_methods
authentication key-management wpa version 2
guest-mode
!
!
dot11 guest
!
!
!
username Cisco password 7 13261E010803
username My3602 privilege 15 password 7 10430810111F00025D56797F65
!
!
bridge irb
!
!
!
interface Dot11Radio0
no ip address
no ip route-cache
!
encryption mode ciphers aes-ccm
!
ssid WDS-EAP
!
antenna gain 0
stbc
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Dot11Radio1
no ip address
no ip route-cache
!
encryption mode ciphers aes-ccm
!
ssid WDS-EAP
!
antenna gain 0
peakdetect
dfs band 3 block
stbc
channel dfs
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface GigabitEthernet0
no ip address
no ip route-cache
duplex auto
speed auto
bridge-group 1
bridge-group 1 spanning-disabled
no bridge-group 1 source-learning
!
interface BVI1
ip address 10.106.54.146 255.255.255.192
no ip route-cache
ipv6 address dhcp
ipv6 address autoconfig
ipv6 enable
!
ip forward-protocol nd
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
ip radius source-interface BVI1
!
!
radius-server local
no authentication eapfast
no authentication mac
nas 10.106.54.146 key 7 045802150C2E1D1C5A
user WDSClient1 nthash 7
072E776E682F4D5D35345B5A227E78050D6413004A57452024017B0803712B224A
!
radius-server attribute 32 include-in-access-req format %h
radius-server vsa send accounting
!
radius server Local-Radius
address ipv4 10.106.54.146 auth-port 1812 acct-port 1813
key 7 060506324F41584B56
!
bridge 1 route ip
!
!
wlccp authentication-server infrastructure method_Infrastructure
wlccp wds priority 254 interface BVI1
!
line con 0
line vty 0 4
transport input all
!
end

Точка доступа клиента WDS

Это - пример конфигурации для Точки доступа клиента WDS:

Current configuration : 2512 bytes
!
! Last configuration change at 00:33:17 UTC Wed May 22 2013
version 15.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname MAIB-WDS-Client
!
!
logging rate-limit console 9
enable secret 5 $1$vx/M$qP6DY30TGiXmjvUDvKKjk/
!
aaa new-model
!
!
aaa group server radius rad_eap
server name WDS-Radius
!
aaa authentication login eap_methods group rad_eap
aaa authorization exec default local
!
!
!
!
!
aaa session-id common
no ip routing
no ip cef
!
!
!
!
dot11 syslog
!
dot11 ssid WDS-EAP
authentication open eap eap_methods
authentication network-eap eap_methods
authentication key-management wpa version 2
guest-mode
!
!
dot11 guest
!
eap profile WDS-AP
method leap
!
!
!
username Cisco password 7 062506324F41
username My2602 privilege 15 password 7 09414F000D0D051B5A5E577E6A
!
!
bridge irb
!
!
!
interface Dot11Radio0
no ip address
no ip route-cache
!
encryption mode ciphers aes-ccm
!
ssid WDS-EAP
!
antenna gain 0
stbc
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Dot11Radio1
no ip address
no ip route-cache
!
encryption mode ciphers aes-ccm
!
ssid WDS-EAP
!
antenna gain 0
peakdetect
dfs band 3 block
stbc
channel dfs
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface GigabitEthernet0
no ip address
no ip route-cache
duplex auto
speed auto
bridge-group 1
bridge-group 1 spanning-disabled
no bridge-group 1 source-learning
!
interface BVI1
ip address 10.106.54.136 255.255.255.192
no ip route-cache
ipv6 address dhcp
ipv6 address autoconfig
ipv6 enable
!
ip forward-protocol nd
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
ip radius source-interface BVI1
!
!
radius-server attribute 32 include-in-access-req format %h
radius-server vsa send accounting
!
radius server WDS-Radius
address ipv4 10.106.54.146 auth-port 1812 acct-port 1813
key 7 110A1016141D5A5E57
!
bridge 1 route ip
!
!
wlccp ap username WDSClient1 password 7 070C285F4D06485744
wlccp ap wds ip address 10.106.54.146
!
line con 0
line vty 0 4
transport input all
!
end

Проверка

Этот раздел позволяет убедиться, что конфигурация работает правильно. Как только настройка завершена, Точка доступа клиента WDS должна быть в состоянии зарегистрироваться к AP WDS.

На AP WDS статус WDS показывают как Зарегистрированный.

116597-config-wds-radius-12.png

На Точке доступа клиента WDS статусом WDS является Инфраструктура.

116597-config-wds-radius-13.png

Примечание: Средство интерпретации выходных данных (только зарегистрированные клиенты) поддерживает некоторые команды show. Используйте Средство интерпретации выходных данных, чтобы просмотреть анализ выходных данных команды show.

Выходные данные проверки CLI на AP WDS

Эта процедура показывает, как проверить конфигурацию точки доступа WDS:

MAIB-WDS-AP#sh wlccp wds ap

HOSTNAME MAC-ADDR IP-ADDR IPV6-ADDR STATE
MAIB-WDS-Client f872.ea24.40e6 10.106.54.136 :: REGISTERED

MAIB-WDS-AP#sh wlccp wds statistics

WDS Statistics for last 10:34:13:
Current AP count: 1
Current MN count: 0
AAA Auth Attempt count: 2
AAA Auth Success count: 2
AAA Auth Failure count: 0
MAC Spoofing Block count: 0
Roaming without AAA Auth count: 0
Roaming with full AAA Auth count:0
Fast Secured Roaming count: 0
MSC Failure count: 0
KSC Failure count: 0
MIC Failure count: 0
RN Mismatch count: 0

Выходные данные проверки CLI на точке доступа клиента WDS

Эта процедура показывает, как проверить конфигурацию Точки доступа клиента WDS:

MAIB-WDS-Client#sh wlccp ap

WDS = bc16.6516.62c4, IP: 10.106.54.146 , IPV6: ::
state = wlccp_ap_st_registered
IN Authenticator = IP: 10.106.54.146 IPV6: ::
MN Authenticator = IP: 10.106.54.146 IPv6::

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.



Document ID: 116597