Голосовая связь и система унифицированных коммуникаций : Cisco Unity Connection

Плохое качество звука CUC с VMware

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв

Введение

Этот документ описывает процесс, чтобы определить, являются ли проблемы качества звука сетевой проблемой или проблемой с виртуализированным приложением.

Внесенный специалистами службы технической поддержки Cisco.

Проблема

Поскольку больше приложений передачи голосовых данных в реальном времени виртуализировано, это становится намного более сложным для решения проблем качества звука. Используйте Unity Connection в качестве предмета для этого "приложения передачи голосовых данных в реальном времени".

Соберите информацию

  1. Первый шаг должен определить, искажены ли приглашения при отъезде Unity Connection. Для сбора пакета перехватите "размер файла capture1 eth0 перехвата сети utils все количество 100000".

    Примечание: Приглашения Объединенных коммуникаций Cisco (CUC) являются хорошей базовой линией для определения нежелательного качества. Не используйте зарегистрированные поздравления пользователя, поскольку они могут быть ненадежным сроком.

          
  2. Проанализируйте захват пакета: Wireshark, А-закон G.711 поддержек или мю-закон G.711.
  3. Проверьте качество исходящего потока Протокола таблицы маршрутизации (RTP) с Wireshark:
    1. Декодируйте с настройками по умолчанию.
    2. Декодируйте с опцией "метку времени RTP использования" в Wireshark.

Возможные причины

Если оба декодируемых потока испытывают проблемы качества голосовой связи, проблема могла бы быть с приглашением (файл WAV) или Unity Connection.

Если запись по умолчанию искажена, но использование меток времени RTP прекрасно, проблема могла бы быть с ресурсами/VMware.

Если качество приемлемо при слушании потока RTP с помощью декодирования по умолчанию проблема могла бы быть с сетевым подключением между CUC и телефоном.

Примечание: Предложение является взятием захват пакета от коммутатора, где сервер ESXi связан и проверка по качеству. Если это плохо, вероятно, что драйверы проверены на самом хосте ESXi.

Решение

Если проблема указывает, что проблема с Unity Connection или файлом WAV, сначала проверьте качество записи:

  1. Проверьте протокол NTP.
    1. Если клиенту настроили множественный NTPs, гарантируйте, что CUC часто не переключается между двумя.
    2. Проверьте, чтобы видеть, имеют ли серверы NTP NTPv4 (захват пакета): "статус ntp utils".
  2. Используйте веб-GUI для проверки качества.
  3. Гарантируйте, что на CUC нет никаких дампов памяти. Ищите известную ошибку: "список активных пользователей ядра utils".
  4. Используйте Резервного Редактора Кобры для проверки качества.

Если проблема указывает, что проблема с VMware, проверяют, выполняют эти действия:

  1. Проверьте, что надлежащее Резервирование сделано на Виртуальных машинах Unity Connection: проверьте ЦП и резервирование ОЗУ как в Поддерживаемых платформах.
  2. Гарантируйте, что Большой получают, разгружаются (LRO) выключен для хоста ESXi (не проблема с ESXi 5.1 +). Посмотрите Отключают LRO на Установках приложений UCS/UC для получения дополнительной информации.
  3. Возьмите снимок VM CUC. Посмотрите Снимки VMware для получения дополнительной информации.

    Примечание: Снимки VM Unity Connection не поддерживаются и могли бы вызвать проблемы с качеством голосовой связи.

  4. Гарантируйте, что установлены Программные средства VMware. Посмотрите Программные средства VMware для получения дополнительной информации.

    Примечание: Программные средства VMware устанавливают драйверы сетевой интерфейсной платы (NIC) на VM для улучшения производительности сети.

  5. Гарантируйте, что не проверен Синхронизирующий VM с хостом. Эта опция синхронизирует время виртуальной машины с хостом ESXi. В клиенте Сферы перейдите, чтобы Выбрать виртуальную машину и щелкнуть правой кнопкой мыши параметры настройки Редактирования виртуальной машины. От вкладки Options выберите программные средства VMware> Усовершенствованный. Гарантируйте, что неконтролируемо Синхронизировать гостевое время с флажком host.


Document ID: 116578