Беспроводные сети / Мобильные решения : "Беспроводные сети, LAN (WLAN)"

Пример конфигурации беспроводной сети ISR

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв

Введение

Этот документ описывает, как сказать различие между традиционным синтаксисом Cisco и Маршрутизаторами ISR Следующего поколения (ISR) и предоставляет сведения о том, как настроить их.

Внесенный BG Surendra, специалистом службы технической поддержки Cisco.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Общие сведения

Существуют различные типы ISR Cisco, и только несколько из них интегрированы с Cisco IOS® для маршрутизаторов. Например, с Наследством 851 Вт, 857 Вт, 871 Вт, и ISR на 877 Вт, необходимо обратиться к маршрутизатору через Telnet/Secure Shell (SSH) или использовать программу Security Device Manager (SDM) для доступа к конфигурациям беспроводной сети. В сравнении, некоторых ISR Следующего поколения, таких как 861 Вт, 881 Вт, 891 Вт, 1941 Вт, 819 Вт, идет с Точками беспроводного доступа (AP), уже интегрированные, и может быть обращен отдельно с интерфейсом Виртуального интерфейса моста (BVI) AP (или с GUI или с Telnet/SSH).

Определите ISR устаревшего и следующего поколения

Для определения ISR введите команду show ip interface brief в маршрутизатор.

Если интерфейсный AP WLAN 0 и Интерфейсный Концерт WLAN 0 присутствуют на списке интерфейсов, то это означает, что это - маршрутизатор Следующего поколения и имеет Интегрированный беспроводный AP в маршрутизаторе. Можно обратиться к этому через CLI с Telnet/SSH или от GUI.

Примечание: Если вы не видите интерфейсный AP WLAN 0 на списке интерфейсов для 861 Вт, 881 Вт, 891 Вт или 1941 Вт, то это означает, что маршрутизатор не поддерживает радио.

Для Устаревших маршрутизаторов это - то, что появляется, когда вы вводите укороченную команду интервала show ip:

Как показано, для Устаревших маршрутизаторов, вы видите только Радиоинтерфейс непосредственно на IOS. 

Настройка

Существуют другие методы, используемые для настройки ISR. Для настройки Устаревших маршрутизаторов, где радио поддержек IOS маршрутизатора, необходимо настроить маршрутизатор через интерфейс BVI для каждой VLAN. Кроме того, необходимо соединить трафик с Радиоинтерфейсом и мостом интерфейса виртуальной локальной сети (VLAN) через BVI. При использовании Идентификаторы Набора множественного обслуживания (SSIDs), то каждый SSID должен быть сопоставлен с каждой VLAN, и каждая VLAN должна быть сопоставлена с уникальной Группой мостов (BG) через отдельный интерфейс BVI.

С другой стороны, при настройке ISR Следующего поколения тогда конфигурация менее сложна. Необходимо установить соединение между маршрутизатором и AP, и настроить AP так же, как любой другой автономный AP. Будет одиночный интерфейс BVI со множественными подчиненными интерфейсами, который помогает связываться между множественным SSIDs и VLAN.

ISR Следующего поколения могут синхронизироваться с архитектурой Менеджера унифицированной беспроводной связи Cisco (CUWM) также. Модуль AP в маршрутизаторе может быть преобразован в Протокол точки доступа легкого веса (LWAPP) / Контроль и Инициализация Точек беспроводного доступа (CAPWAP) режим, который зарегистрирован к Контроллеру беспроводной локальной сети (WLC). В этом разделе описывается преобразовать модуль AP из Автономного и LWAPP.

Примечание: 861 Вт не поддерживает режим LWAPP.

Устаревший Пример конфигурации ISR

Этот пример конфигурации использует два VLAN (VLAN 1 и VLAN 2), которые каждый сопоставлены с другим SSID с ЗАЩИЩЕННЫМ ДОСТУПОМ ПО ПРОТОКОЛУ WI-FI - Пред Общий ключ (WPA-PSK) безопасность:

en
conf t

vlan 2 mapped to GUESTRITS SSID..Use the vlan
  as per the network configuration


dot11 ssid GUESTRITS
vlan 2
mbssid
authentication open
authentication key-management wpa
wpa-psk ascii 0 cisco123


dot11 ssid INTERNAL
vlan 1                               >> vlan 1 mapped to INTERNAL SSID
authentication open
mbssid
authentication key-management wpa
wpa-psk ascii 0 cisco123
!

!
bridge irb                         <<< Enables IRB. Allows bridging of
                                        traffic

!

interface Dot11Radio0
no ip address
mbssid
!
encryption vlan 1 mode ciphers tkip  << Encryption           
!
encryption vlan 2 mode ciphers tkip
!
ssid GUESTRITS
!
ssid INTERNAL
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0
  basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
!
interface Dot11Radio0.1             <<< Corresponding Sub Interface
encapsulation dot1Q 1 native            configuration for Radio
bridge-group 1                      <<< Bridging between VLAN 1 and
bridge-group 1 subscriber-loop-control  Dot11 0.1
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!


interface Dot11Radio0.2              <<< Corresponding Sub Interface
encapsulation dot1Q 2                     configuration for Radio
bridge-group 2                        <<< Bridging between VLAN 2 and
bridge-group 2 subscriber-loop-control    Dot11 0/2  
bridge-group 2 spanning-disabled
bridge-group 2 block-unknown-source
no bridge-group 2 source-learning
no bridge-group 2 unicast-flooding
!


interface Vlan1
no ip address
bridge-group 1                        <<< Bridging between VLAN 1 and
                                          Dot11 0/1

 

interface Vlan2
no ip address
bridge-group 2                        <<< Bridging between VLAN 2 and
!                                        Dot11 0.2


interface BVI1                         << BVI 1 for VLAN 1
ip address 10.0.0.2 255.255.255.0              
!
interface BVI2                         << BVI 2 for VLAN 2
ip address 192.168.1.1 255.255.255.0
!

!
bridge 1 protocol ieee                <<< Mandatory Bridging commands
bridge 1 route ip
bridge 2 protocol ieee
bridge 2 route ip
!

Пример конфигурации ISR следующего поколения

Выполните эти шаги для настройки маршрутизаторов Следующего поколения:

  1. Установите подключение между маршрутизатором и AP с обратным интерфейсом консоли, который доступен на маршрутизаторе (Интерфейсный AP WLAN 0). Используйте IP-адрес для этого интерфейса (можно назначить IP-адрес или использовать IP ненумерованную команду VLAN X) для присвоения IP.

    Вот пример, где используется IP ненумерованная команда VLAN:

    en
    conf t
    int wlan-ap 0
    ip unnumbered vlan 1
    no shut

    Это появляется при вводе  команды br интервала show ip:



    Это помогает вам входить к модулю AP.

  2. Введите сервисный модуль AP WLAN 0 команд сеанса для регистрации к AP.



    Придерживайтесь того же процесса, используемого для настройки автономного AP. Для примеров дополнительной настройки посмотрите страницу индекса Примеров конфигурации и технических примечаний.

    Если развертывания состоят из несколько интерфейсов VLAN или SSIDs, необходимо установить GIG WLAN 0 интерфейсов как магистральный порт, который позволяет требуемые VLAN на маршрутизаторе.


Обновите AP ISR от легкого веса к автономному

Когда интегрированный AP выполняет образ LWAPP, такой как AP801-RCVK9W8-M, AP801-RCVK9 "W8"-M (указывает, что LWAPP), или W7 (указывает на автономный образ), команда Config t не работает; AP должен использовать автономный образ для выполнения команд. Для решения этого вопроса необходимо обновить AP ISR от легкого веса к автономному.

Введите эти команды:

Router>en
Router#config t
Router(config t)#service-module wlan-ap0 bootimage autonomous

С этими командами можно изменить Режим AP. Если вы хотите, чтобы AP загрузил и выполнил автономный образ, используйте Автономный в предыдущей команде. Если вы хотите, чтобы AP загрузился и загрузился с образом LWAPP, то введите Унифицированный и повторно загрузите AP этой командой:

Router(config t)#service-module wlan-ap 0 reload

Это устанавливает AP в автономный. Процессуальные работы для большинства случаев. Однако при обнаружении с проблемами можно использовать ручной процесс:

  1. TFTPD32 загрузок на портативного ПК и установку это. Загрузите последний Образ IOS для Серии AP801:

    1. Перейдите к Cisco.com.
    2. Нажмите вкладку Support около вершины экрана.
    3. Нажмите Download Software.
    4. Выберите Wireless, и затем выберите Интегрированные маршрутизаторы и коммутаторы от выпадающего списка продукта.
    5. Выберите модель маршрутизатора.
    6. Выберите соответствующий Образ IOS: 12.4 (21a) Ян (или позже, как требуется).
  2. Войдите к модулю AP от маршрутизатора и введите эти команды:

    • AP> en
    • Cli консоли AP#debug capwap debug lwapp console cli OR
    • AP#config t (эта команда настройки теперь работает),
    • AP (config t) #int GIG 0 или международный FA 0
    • AP (config - интервал) #ip addresss <mask> <address> (гарантируют, что у вас есть подключение к IP-адресу портативного ПК, и что они находятся оба в той же подсети),
    • AP (config - интервал) #no закрывался
    • AP (config - интервал) #end
  3. Введите команды archive download для обновления AP к автономному:

    • AP#archive, коротковолновый загрузками/force-reload/overwrite tftp://<IP-адрес TFTP (IP портативных ПК)> / <Автономный image.tar>
    • AP#archive коротковолновый загрузками/overwrite/force-reload tftp://10.0.0.4/ap801-k9w7-tar.124-21a. JY.tar

    Это завершает процесс настройки вручную.

    Примечание: Если AP находится в автономном режиме, и вы хотите преобразовать его в LWAPP, использовать архивные команды загрузок и выбрать LWAPP Recovery image вместо Автономной операционной системы межсетевого взаимодействия Cisco IOS (AIOS) образ.

Проверка.  

В настоящее время для этой конфигурации нет процедуры проверки.

Устранение неполадок 

Для этой конфигурации в настоящее время нет сведений об устранении проблем. 

Дополнительные сведения


Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Document ID: 116579