Маршрутизаторы : Маршрутизаторы агрегации Cisco ASR серии 9000

Конфигурация коммутации L2 к процессу перехода конфигурации L2VPN XR

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв

Введение

Этот документ описывает, как преобразовать конфигурацию Cisco IOS® Layer 2 switching в конфигурацию Виртуальной частной сети уровня 2 (L2VPN) Cisco IOS XR.

Внесенный Мануэлем Иризарри, полномочиями Дэвида, и Сэмюэлем Милстидом, специалистами службы технической поддержки Cisco.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Этот документ не ограничен определенным программным обеспечением, но ограничен Объединенным маршрутизатором услуг (ASR) серии 9000 связанные версии аппаратного обеспечения, которые используют модель Виртуального канала Ethernet (EVC) для настройки L2VPN. Маршрутизаторы ASR серии 9000 используют модель EVC, в то время как маршрутизаторы системы маршрутизации Cisco операторского класса, которые выполняют Cisco IOS XR, не делают.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Общие сведения

ASR маршрутизатор серии 9000 не придерживается модели IEEE Уровня 2 (L2) конфигурация, прежде всего 802.1Q и 802.1AD. Вместо этого это использует модель EVC. Модель EVC позволяет Cisco IOS XR усиливать текущие теги VLAN 802.1Q по-новому. Традиционно, тег VLAN определяет классификацию, VLAN, передачу, и какую таблицу ассоциативно-запоминающего устройства (CAM) использовать для выполнения поиска MAC-адреса. С моделью EVC это понятие разъединено для разрешения большей гибкости и более высокого масштаба. Модель EVC устраняет ограничение Cisco IOS 4,096 максимумов VLAN.

EVC использует эти составляющий компоненты:

  • Точка потока Ethernet (EFP) - EFP является локальным подчиненным интерфейс L2, который используется для классификации трафика под медосмотром или групповым интерфейсом.

  • EVC - EVC является сквозным представлением единственного экземпляра L2. EFP определен как оконечная точка EVC в узле. Поскольку множественный EVCs может пройти через один физический интерфейс, основная цель конфигурации EFP должна распознать трафик, который принадлежит определенному EVC на том интерфейсе и применять поведение при перенаправлении и функции, определенные для этого EVC.

  • Домен моста (BD) - BD является широковещательным доменом Ethernet, внутренним к устройству. BD позволяет вам разъединить VLAN от широковещательного домена. BD имеет сопоставления один ко многим с EFPs: все EFPs в узле для определенного EVC сгруппированы с использованием BD. Если EFPs принадлежат тому же BD и имеют тот же номер BD, то EFPs получают трафик, даже если у них есть другие номера виртуальной локальной сети (VLAN).

Проблема

Cisco IOS XR на ASR маршрутизаторы серии 9000 использует модель Виртуального канала Ethernet (EVC). Модель EVC не имеет понятия транков, интерфейсов виртуальной локальной сети (VLAN) или коммутируемого виртуального интерфейса (SVI). Транки, Интерфейсы виртуальной локальной сети (VLAN) и SVI от Cisco IOS должны быть преобразованы в конфигурации Cisco IOS XR через подчиненные интерфейсы, BD L2VPN и Виртуальные интерфейсы моста (BVI). Модель EVC могла бы быть в новинку для некоторых пользователей Cisco IOS, когда они сначала мигрируют на Cisco IOS XR.

Решение

Конфигурация на Cisco IOS XR состоит из трех шагов:

  1. Создайте EFP через конфигурацию интерфейса или подчиненного интерфейса с опцией l2transport, которая представляет VLAN.

  2. Создайте BD для группировки EFPs.

  3. Когда Уровень 3 (L3), SVI необходимы, настройте через interface BVI в Cisco IOS XR, вместо interface vlan в Cisco IOS, для обеспечения основных функций L3 для интерфейсов L2, которые принадлежат BD.

Примечание: Интерфейсы BVI не поддерживают теги VLAN; таким образом для BVI для обработки входного трафика на EFP тег VLAN должен быть вытолкан на входе и прибавлен выход. Это завершено с командой перезаписи.

Преобразуйте конфигурацию

Данный пример иллюстрирует, как преобразовать конфигурацию от Cisco IOS до Cisco IOS XR.

Конфигурация IOS

interface GigabitEthernet3/13
switchport
switchport access vlan 4
speed 1000
duplex full
!
interface GigabitEthernet3/14
switchport
switchport access vlan 130
speed 1000
duplex full
!
interface GigabitEthernet3/15
switchport
switchport access vlan 133
speed 1000
duplex full
!
interface TenGigabitEthernet13/3
description IOS Trunk
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 1*,4,130,133
switchport mode trunk
no ip address
!
interface Vlan 4
ip address 10.10.4.1 255.255.255.0

interface Vlan 130
ip address 10.10.130.1 255.255.255.0
!

*Vlan 1 is the native vlan

Создайте интерфейс EFP. Cisco IOS XR внедряет структурированный CLI для EFP и конфигурации EVC. Для настройки EFP используйте эти команды настройки интерфейса:

  • команда l2transport - Эта команда определяет подинтерфейс, физический порт или интерфейс родителя порта связки (bundle) как EFP.

  • команда encapsulation - Эта команда используется для определения критериев соответствия VLAN.

  • команда перезаписи - Эта команда используется для определения критериев перезаписи тега VLAN.

Конфигурация ASR 9000 для межсудьбы (магистральный порт) TenGigabitEhternet 13/3

interface GigabitEthernet 0/0/0/1
!
interface GigabitEthernet 0/0/0/1.1 l2transport
encapsulation dot1q untagged **
!

interface GigabitEthernet 0/0/0/1.4 l2transport
encapsulation dot1q 4
rewrite ingress tag pop 1 symmetric

interface GigabitEthernet 0/0/0/2
!
interface GigabitEthernet 0/0/0/2.130 l2transport
encapsulation dot1q 130
rewrite ingress tag pop 1 symmetric
!
interface GigabitEthernet 0/0/0/3
!
interface GigabitEthernet 0/0/0/3.133 l2transport
encapsulation dot1q 133
rewrite ingress tag pop 1 symmetric
!
interface tengig0/0/0/0
!
interface tengig0/0/0/0.4 l2transport
no ip address
encapsulation dot1q 4
rewrite ingress tag pop 1 symmetric
!
interface tengig0/0/0/0.130 l2transport
no ip address
encapsulation dot1q 130
rewrite ingress tag pop 1 symmetric
!
interface tengig0/0/0/0.133 l2transport
no ip address
encapsulation dot1q 133
rewrite ingress tag pop 1 symmetric
!

Для добавления собственного VLAN 1, не помечают трафик, и для создания подчиненного интерфейса l2transport с dot1q без меток инкапсуляция. Используйте encapsulation dot1q без меток команда под интерфейсом l2transport или подчиненным интерфейсом, если порт связан с портом, настраивают для доступа к порту коммутатора в устройстве IOS.

Например:

IOS:

interface Gigabitethernet 1/1
switchport
switchport access vlan 3

IOSXR:

interfage GigabitEthernet 0/1/1/1.1 l2transport
encapsulation dot1q untagged

После того, как EFP создан, интерфейс BVI может быть создан и добавлен к BD. Интерфейс BVI используется для размещения interface VLAN в Cisco IOS.

interface BVI4
ipv4 address 10.10.4.1 255.255.0.0
!
interface BVI130
ipv4 address 10.130.1.1 255.255.0.0
!

Номер интерфейса BVI должен не обязательно совпасть с идентификатором VLAN. То же истинно для количества подинтерфейса транспортных интерфейсов L2. Однако для ясности в данном примере, номер BVI совпадает с меткой dot1q, а также номером подинтерфейса EFP.

В данном примере BD L2VPN создан для мостового соединения EFPs и BVI вместе:

l2vpn
bridge group VLAN4
bridge-domain VLAN4
interface ten0/0/0/0.4
!
interface GigabitEthernet 0/0/0/1.4
!
routed interface bvi4
!
!
bridge-domain VLAN130
interface ten0/0/0/0.130
!
interface GigabitEthernet 0/0/0/2.130
!
routed interface bvi130
!
!
bridge-domain VLAN133
interface ten0/0/0/0.133
!
interface GigabitEthernet 0/0/0/3.133
!
!
!
!

Группа мостов (BG) является нефункциональной иерархией конфигурации, которая связывает несколько BD в части той же функциональной группы. Это функционирует как создание множественных отдельных групп с их доменами, делает, в противоположность одной группе с составными доменами.

Аналогичные команды

Эта таблица приводит другие команды, доступные в Cisco IOS и аналогичных командах в Cisco IOS XR, настроенном под BD:

IOSIOS XR
switchport block unicast}затопление одноадресного одноадресного отключает
switchport port-security maximumпредельный максимум Mac (располагаются 5-512000),
switchport port-security violationпредельное действие Mac (лавинная рассылка, без лавинных рассылок, завершение) предельное уведомление Mac (оба, ни один, trap-сообщение)
перемещение Mac mac address-table notificationПотребность настроить придерживающееся: Mac безопасное действие ни один Mac безопасная регистрация
switchport port-security mac-addressвзаимодействуйте x предел Mac Max. y H.H.H статического MAC - адреса

Дополнительные сведения



Document ID: 116500