Протокол IP : Протокол L2TP

Мостовое соединение L2 через пример конфигурации сети L3

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв

Введение

Этот документ описывает, как соединить сеть (L2) Уровня 2 через сеть (L3) Уровня 3.

Внесенный Атри Basu, Джей Янг Тейлор, и Мани Гэнесан, специалисты службы технической поддержки Cisco.

Предварительные условия

Требования

Компания Cisco рекомендует предварительно ознакомиться со следующими предметами:

  • Версия 3 (L2TPv3) протокола туннелирования уровня 2
  • Generic Routing Encapsulation (GRE)

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Общие сведения

Во многих ситуациях вы требуете решения для агрегации трафика WiFi от хот-спотов до центрального места расположения. В таких случаях решение должно позволить устройствам оборудования в помещении заказчика (CPE) соединять Трафик ethernet от конечного хоста и инкапсулировать пакеты посредством Трафика ethernet к оконечной точке.

При использовании Маршрутизаторов агрегации (ASR) простой способ, чтобы сделать, это должно использовать Ethernet по мягкому GRE. Однако для маршрутизаторов Интегрированного сервиса (ISR) и все другие устройства CPE, это не опция. В более старых версиях Cisco IOS® было возможно туннелировать L2 по GRE путем мостового соединения физического интерфейса с Туннельным интерфейсом GRE. Несмотря на то, что регулярное использование мостов разделяет заголовок VLAN от входящих пакетов, использование Integrated routing and bridging (IRB) на маршрутизаторе может направить и соединить тот же протокол сетевого уровня на том же интерфейсе и все еще позволить маршрутизатору поддерживать заголовок VLAN от одного интерфейса до другого.

Примечание: При настройке bridge-group на Туннельном интерфейсе на более старых версиях Cisco IOS IOS сообщает, что команда является невыпущенной и неподдерживаемой, но это все еще принимает команду. В более свежих версиях эта команда является абсолютно устаревшей, и показы сообщения об ошибках.

Предыдущее решение не поддерживается Cisco. Поддерживаемое решение для мостового соединения сети L2 должно использовать L2TPv3, как описано в этом документе. L2TPv3 оказывает поддержку для транспорта различных протоколов L2 как Ethernet, 802.1q (VLAN), Frame Relay, High-Level Data Link Control (HDLC) и Протокол PPP. Фокусом этого документа является расширение Ethernet.

Настройка

Эта настройка является очень простой. В то время как r100 и r202 имеют один L3 интерфейс и один интерфейс L2, маршрутизаторы r101 и r201 служат хостами в той же сети. Цель состоит в том, чтобы установить соединение L2TPv3, таким образом, что r101 и r201 в состоянии пропинговать друг друга без требования любых маршрутов.

Схема сети

Конфигурация туннеля

Конфигурация туннеля L2TP включает три шага:

  1. Настройте (дополнительного) L2TP-class

    Этот класс используется для определения некоторой аутентификации и параметров управления для туннеля L2TP. Если это используется, два конца должны отразить друг друга.
    l2tp-class test
    hostname stanford
    password 7 082E5C4B071F091805

  2. Настройте Pseudowire-class

    Как название предполагает, этот раздел используется для настройки фактического туннеля или "pseudowire" между этими двумя оконечными точками. Определите шаблон, который содержит инкапсуляцию pseudowire, оконечную точку и протокол управляющего канал.
    pseudowire-class test
    encapsulation l2tpv3
    ip local interface Loopback0
    ip pmtu

  3. Используйте Xconnect для обеспечения назначения туннеля

    Свяжите pseudowire L2TP с прикрепляемым каналом (интерфейс к локальной стороне L2) и определите ее назначение. 

Моменты, которые необходимо отметить:

  • Самому прикрепляемому каналу настроили no IP address.
  • Точка начала туннеля, настроенная с IP local interface, находится в разделе pseudowire-class.
  • Назначение туннеля определено с командой xconnect.

Факторы

  • Как с решением для Туннелирования GRE, использование маршрутизатора, на котором можно завершить туннель L2 все еще, не позволяет сообщениям Протокольного блока данных (PDU) L2 быть переданными через туннель. Без надлежащего туннелирования протокола L2, которое не поддерживается на этом устройстве, эти сообщения использованы интерфейсом L2.

  • Поддержка туннелирования протокола L2 (протокол обнаружения Cisco, Протокол STP, Протокол магистральных каналов VLAN и Протокол обнаружения Уровня соединения) требует, чтобы устройство было коммутатором. Этот коммутатор должен быть L3, знающим, чтобы быть в состоянии к туннельному трафику и ограничить возможные выборы.

  • L3, туннелирующий, инкапсуляция зависит от устройства, которое делает туннелирование:
    1. Cisco 7301 поддерживает инкапсуляцию L2TPv3.
    2. Cisco 65xx не поддерживает расширение L2 с туннелем L2TPv3. Однако L2 может быть расширен через ядро MLPS с опцией Any Transport over MPLS (AToM).
    3. Туннель L2TP не поддерживается на коммутаторах Cisco 4500.

  • Только одиночный туннельный интерфейс xconnect может быть настроен на физическом интерфейсе или подчиненном интерфейсе. Отдельный интерфейс необходим для каждой оконечной точки pseudowire. Вы не можете настроить несколько интерфейсов с xconnect с тем же pw-классом и тем же L2TP ID.

  • Максимальный размер Максимального размера передаваемого блока данных информационного наполнения для туннеля L2TP обычно - 1460 байтов для трафика, который перемещается по стандартному Ethernet. В случае L2TP по Протоколу UDP издержки являются результатом IP - заголовка (20 байтов), заголовок UDP (8 байтов) и заголовок L2TP (12 байтов).

Пример конфигурации

Конфигурация маршрутизатора r101

interface Ethernet0/0
ip address 172.16.1.100 255.255.255.0

Конфигурация маршрутизатора r100

pseudowire-class test
encapsulation l2tpv3
protocol none
ip local interface fast 0/0
!
interface FastEthernet0/0
description WAN
ip address 198.51.100.100 255.255.255.0
!
interface FastEthernet0/1
description LAN
no ip address
speed 100
full-duplex
xconnect 203.0.113.102 1 encapsulation l2tpv3 manual pw-class test
l2tp id 1 2
!
ip route 0.0.0.0 0.0.0.0 198.51.100.1

Конфигурация маршрутизатора r202

pseudowire-class test
encapsulation l2tpv3
protocol none
ip local interface fast 0/0
!
interface FastEthernet0/0
description WAN
ip address 203.0.113.102 255.255.255.255

interface FastEthernet0/1
no ip address
duplex auto
speed auto
xconnect 198.51.100.100 1 encapsulation l2tpv3 manual pw-class test
l2tp id 2 1

Конфигурация маршрутизатора r201

interface Ethernet0/0
ip address 172.16.1.201 255.255.255.0

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Проверка

Для отображения подробных сведений об управляющих канал L2TP, которые установлены к другим поддерживающим L2TP устройствам для всех Сеансов l2tp на маршрутизаторе, используют команду show l2tun tunnel all.

Чтобы проверить, что инкапсуляция L2TPv3 работает должным образом, пропингуйте хост на удаленном узле, который, как предполагается, находится на той же VLAN. Если эхо-запрос успешен, можно использовать эту команду, чтобы подтвердить, что конфигурация работает должным образом. Средство интерпретации выходных данных (только зарегистрированные клиенты) поддерживает некоторые команды show. Используйте Средство интерпретации выходных данных, чтобы просмотреть анализ выходных данных команды show.

  • Команда show arp отображает кэш Протокола ARP.

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.



Document ID: 116266