Унифицированные вычисления : Cisco UCS Manager

Пример конфигурации UCS FCoE канала от абонента к оператору

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв

Введение

Этот документ описывает, как настроить каналы связи Fibre Channel по Ethernet (FCoE). В системе Cisco UCS (UCS) Версия 2.1 и более поздние Версии, была представлена поддержка Fibre Channel по Ethernet (FCoE) мультиперехода. Эта поддержка позволяет соединительную консолидацию от двух отдельных ссылок до одиночного канала связи, который несет и Fibre Channel (FC) и Ethernet.

Примечание: Унифицированные каналы связи отличаются от унифицированных портов. Любое центральное устройство (FI), которое включает поколение 1, могло объединить каналы связи. Однако только поколение 2 FIs объединило порты.

Внесенный Кристофером Брауном, специалистом службы технической поддержки Cisco.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения в этом документе основываются на Менеджере UCS (UCSM) Версия 2.1. Необходимо выполнить, по крайней мере, Версию 2.1 (1a) для использования этого документа.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Настройка

Поддерживаемые конфигурации

Во всех этих конфигурациях можно заменить любую ссылку port-channel того же типа. Например, если конфигурация показывает одну ссылку, она может быть настроена с одним port-channel вместо этого. Однако у вас не может быть Ethernet и Унифицированного порта в том же port-channel.

Канал от абонента к оператору FCoE с технологией Virtual PortChannel (vPC)

Эта конфигурация не содержит унифицированных ссылок, но это - самый легкий способ интегрировать каналы связи FCoE в вашу текущую среду. Эта конфигурация избавляет от необходимости пересекать матрицы FC.

С перекрестным подключением с прикреплением

В этой конфигурации Коммутаторы Cisco Nexus серии 5000 (N5ks) и FIs с перекрестным подключением, но не направлены портом вместе. Это позволяет вам иметь некоторые унифицированные каналы связи, но вы все еще поддерживаете известную организацию сети.

Все унифицированные каналы от абонента к оператору

Эта конфигурация предоставляет большую часть консолидации. Помните, что эти ссылки могут также быть port-channel, но все ссылки должны быть объединенными каналами связи. Это, вероятно, будет наиболее распространенной реализацией.

Конфигурация на UCS

Существует три шага для настройки UCS:

  1. Настройте виртуальную сеть устройств хранения данных (VSAN).
  2. Настройте унифицированные каналы от абонента к оператору.
  3. Настройте (дополнительные) port-channel.

Настройте VSAN

В этой конфигурации VSAN 500 вне Матрицы A, и VSAN 600 вне Матрицы B. Это - одинаковая конфигурация, которую вы использовали бы для создания VSAN для обычного FC.

Настройте унифицированные каналы от абонента к оператору

Унифицированный канал связи скрыт в GUI. Для создания унифицированного порта необходимо сначала настроить его как канал связи или канал связи FCoE. Затем можно настроить его как унифицированный порт. Эта конфигурация не удаляет первую роль. Вместо этого это создает интерфейс, который имеет обоих.

Удостоверьтесь, что установили свой VSAN на этом этапе.

На этом этапе ваш UCS настроен для унифицированного трафика. Данный пример не использует port-channel. Однако можно настроить port-channel обычно на этом этапе. Удостоверьтесь, что установили VSAN под вкладкой VSAN для port-channel.

Конфигурация на N5k

Конфигурация на N5k состоит из 3 шагов:

  1. Включите FCoE и параметры настройки Качества обслуживания (QoS) по умолчанию. Создайте FCoE VLAN и свяжите VSAN с ним.
  2. Настройте Интерфейс Ethernet (или port-channel).
  3. Создайте Действительный Fibre Channel (vFC) и свяжите его с Интерфейсом Ethernet.

Примечание: UCS является коммутатором N порта виртуализации (NPV) по умолчанию, таким образом, восходящий коммутатор должен быть в режиме N порта Identifer Virtulization (NPIV) (введите функцию npiv команда для включения). Посмотрите Настройку N порт Виртуализация для получения дополнительной информации об этой функции.

Включите FCoE и параметры настройки QoS по умолчанию

Если N5k уже настроен для FCoE, можно пропустить этот шаг. Если N5k не настроен для FCoE, обратитесь к Приложение A в конце этого документа для инструкции.

Настройте интерфейсы Ethernet (или port-channel)

Это - конфигурация для интерфейса, который обычно соединяется с UCS. Удостоверьтесь, что позволили FCoE VLAN.

f340-31-15-5596-1(config)# interface ethernet 1/32
f340-31-15-5596-1(config-if)# switchport mode trunk
f340-31-15-5596-1(config-if)# switchport trunk allowed vlan all

Это - пример очень простой конфигурации магистрали. Заметьте, что нет никакой конфигурации FCoE на этом интерфейсе.

Настройте VFC

Это - конфигурация для VFC, который обрабатывает весь трафик FCoE от UCS:

f340-31-15-5596-1(config-if)# int vfc 25
f340-31-15-5596-1(config-if)# switchport trunk allowed vsan 500
f340-31-15-5596-1(config-if)# no shut
f340-31-15-5596-1(config-if)# bind interface ethernet 1/32
f340-31-15-5596-1(config-if)#

Существует несколько точек для замечания в данном примере:

  • Номер VFC не имеет значения. Это может быть что-либо, пока это уже не используется.
  • Это - порт Магистральной матрицы (TF), поэтому удостоверьтесь, что позволили свой VSAN.
  • Свяжите это с интерфейсом, который стоит перед UCS. Это - физический интерфейс, на котором передается/получается трафик FCoE. Это передается на VLAN, привязанной к VSAN.

На этом этапе вам настроили все полностью. Введите show interface vfc команда хх, чтобы гарантировать, что подходит VSAN.

f340-31-15-5596-1(config-if)# show interface vfc 25
vfc25 is trunking
Bound interface is Ethernet1/32
Hardware is Ethernet
Port WWN is 20:18:54:7f:ee:d3:f8:bf
Admin port mode is F, trunk mode is on
snmp link state traps are enabled
Port mode is TF
Port vsan is 500
Trunk vsans (admin allowed and active) (500)
Trunk vsans (up) (500)
Trunk vsans (isolated) ()
Trunk vsans (initializing) ()
1 minute input rate 4448 bits/sec, 556 bytes/sec, 1 frames/sec
1 minute output rate 610448 bits/sec, 76306 bytes/sec, 27 frames/sec
27347 frames input, 45743308 bytes
0 discards, 0 errors
114710 frames output, 218235936 bytes
0 discards, 0 errors
last clearing of "show interface" counters Thu May 9 13:37:42 2013

Interface last changed at Thu May 9 14:03:44 2013

Если VSAN не подключен, проверьте свою конфигурацию и свои соединения. Если это все еще не работает, машите Портом Ethernet на N5k.

На этом этапе вы применяете свою обычную конфигурацию FC (политика загрузки, зонируя).

f340-31-15-5596-1(config-if)# show flogi database
--------------------------------------------------------------------------------
INTERFACE VSAN FCID PORT NAME NODE NAME
--------------------------------------------------------------------------------
fc2/3 500 0xd80000 20:42:00:0d:ec:b1:34:c0 21:f4:00:0d:ec:b1:34:c1
fc2/3 500 0xd80001 20:00:00:25:b5:12:dc:5f 20:00:00:25:b5:13:dc:2f
[svinfra-esxi-1]
fc2/3 500 0xd80003 20:00:00:25:b5:12:dc:3f 20:00:00:25:b5:13:dc:0f
[svinfra-esxi-2]
vfc7 500 0xd80060 25:f6:00:0d:ec:cc:d3:ff 21:f4:00:0d:ec:cc:d3:c1
vfc7 500 0xd80061 20:00:00:25:b5:19:70:28 20:00:00:25:b5:19:70:18
vfc25 500 0xd80042 20:00:00:25:b5:ab:1a:01 20:00:00:25:b5:00:00:8f
vfc25 500 0xd80043 20:00:00:25:b5:ab:1a:02 20:00:00:25:b5:00:00:9f
vfc25 500 0xd80044 20:00:00:25:b5:00:3a:08 20:00:00:25:b5:00:00:5f
vfc25 500 0xd80045 20:00:00:25:b5:00:3a:09 20:00:00:25:b5:00:00:4f
vfc25 500 0xd80048 2d:9a:00:05:73:c2:c6:3f 21:f4:00:05:73:c2:c6:01

Проверка

В настоящее время для этой конфигурации нет процедуры проверки.

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.

Приложение A - N5k основная Конфигурация FCoE

Для настройки N5k для FCoE войдите:

feature fcoe
system qos
service-policy type network-qos fcoe-default-nq-policy
service-policy type queuing input fcoe-default-in-policy
service-policy type queuing output fcoe-default-out-policy
service-policy type qos input fcoe-default-in-policy

Эти команды сначала включают FCoE, и затем включают политики QoS по умолчанию, которые необходимы для FCoE. Если у вас есть пользовательские параметры настройки QoS, используйте тех в качестве ядра. Вот конфигурации по умолчанию:

  policy-map type qos fcoe-default-in-policy
class type qos class-fcoe
set qos-group 1
class type qos class-default
set qos-group 0

policy-map type queuing fcoe-default-in-policy
class type queuing class-fcoe
bandwidth percent 50
class type queuing class-default
bandwidth percent 50
policy-map type queuing fcoe-default-out-policy
class type queuing class-fcoe
bandwidth percent 50
class type queuing class-default
bandwidth percent 50

policy-map type network-qos fcoe-default-nq-policy
class type network-qos class-fcoe

pause no-drop
mtu 2158
class type network-qos class-default

mtu 1500
multicast-optimize

Как вы можете видеть эта политика создает класс трафика FCoE, отмечает его для без отбрасываний, и дает ему выделенную полосу пропускания. Можно модифицировать их, поскольку вам нужно (например, для добавления Кадров большого размера).

Затем, необходимо связать VSAN с VLAN:

f340-31-15-5596-1(config)# vlan 500
f340-31-15-5596-1(config-vlan)# name VNX_500
f340-31-15-5596-1(config-vlan)# fcoe vsan 500
f340-31-15-5596-1(config-vlan)#

Это говорит N5k, что VLAN 500 является FCoE VLAN и что любой трафик, который входит, должен быть коммутирован к VSAN 500.

На этом этапе ваш N5k настроен для FCoE и готовый к соединению UCS.



Document ID: 116188