Унифицированные вычисления : Cisco UCS Manager

Пример конфигурации канала входного порта UCS

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв

Введение

Этот документ описывает, как настроить канал входного порта на Серверах UCS Cisco.

Внесенный Джо Леблэнком и Эндрю Келли, специалистами службы технической поддержки Cisco.

Предварительные условия

Требования

Cisco рекомендует ознакомиться с каналами порта перед попыткой этой конфигурации.

Используемые компоненты

Сведения в этом документе основываются на системах Cisco UCS (UCS).

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Настройка

Конфигурация канала порта UCS статически установлена в активный режим Протокола управления агрегацией каналов (LACP). Эта конфигурация не может модифицироваться; поэтому, все восходящие конфигурации порт-канал должны придерживаться режима LACP, активного также. Также можно настроить восходящий switchports для пассивного режима LACP.

Конфигурация интерфейса командой строки CLI

Вот выборка конфигурации интерфейса UCS, которая не может модифицироваться:

UCS1-B(nxos)# show run interface eth1/19

!Command: show running-config interface Ethernet1/19
!Time: Fri Oct 12 20:25:59 2012

version 5.0(3)N2(2.11)

interface Ethernet1/19
description U: Uplink
pinning border
switchport mode trunk
switchport trunk allowed vlan 1,107,110-111,115,119,
168,175,179,183,200-201,279,283,379,383,555-556
channel-group 100 mode active
no shutdown

Вот конфигурация интерфейса порт-канала:

UCS1-B(nxos)# show run interface po100

!Command: show running-config interface port-channel100
!Time: Fri Oct 12 20:21:19 2012

version 5.0(3)N2(2.11)

interface port-channel100
description U: Uplink
switchport mode trunk
pinning border
switchport trunk allowed vlan 1,107,110-111,115,119,
168,175,179,183,200-201,279,283,379,383,555-556
speed 10000

Можно всем заправлять интерфейсная команда на канале порта, чтобы показать участникам port-channel:

UCS1-B(nxos)# show interface po100
port-channel100 is up
Hardware: Port-Channel, address: 000d.eccd.665a (bia 000d.eccd.665a)
Description: U: Uplink
MTU 1500 bytes, BW 20000000 Kbit, DLY 10 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA
Port mode is trunk
full-duplex, 10 Gb/s
Beacon is turned off
Input flow-control is off, output flow-control is off
Switchport monitor is off
EtherType is 0x8100
Members in this channel: Eth1/19, Eth1/20

Канал входного порта должен быть LACP для соответствия с конфигурацией UCS. Другие конфигурации могут присутствовать, но (как минимум) необходимо видеть эту конфигурацию:

5k# show run int eth1/3

!Command: show running-config interface Ethernet1/3
!Time: Sat Oct 13 00:30:51 2012

version 5.1(3)N2(1)

interface Ethernet1/3
switchport mode trunk
spanning-tree port type edge trunk
channel-group 100 mode active

Заметьте транк spanning-tree port type edge на устройствах NXOS. Эта конфигурация гарантирует, что, если ссылка колеблется, порт сразу возвращается. В ситуации сбоя важно, чтобы восходящие порты коммутатора не перемещались через состояния STP, которые продлевают время простоя. Для получения дополнительной информации об этой команде обратитесь к spanning-tree port type edge.

Cisco IOS, эквивалентная из этой команды, является spanning-tree portfast trunk.

Дополнительные сведения см. в следующих документах:

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Конфигурация графического интерфейса пользователя (GUI )

  1. Создайте Интерфейс порт-канал.

    116095-configure-ucs-upstream-port-channel-01.jpg

  2. Выберите порты и нажмите двойную стрелку для добавления их к Port Channel.

  3. В то время как LACP выполняет согласование с восходящим коммутатором, после нажатия Finish канал порта появляется как вниз.

    116095-configure-ucs-upstream-port-channel-02.jpg

Если восходящий коммутатор настроен должным образом, общее состояние перемещается в Работоспособное состояние.

Устранение неполадок

  • Если скорость будет другой с обеих сторон, канал порта не подойдет. Это является распространенной неправильной настройкой.
  • Вы, возможно, должны были бы перевести все ссылки в рабочее состояние индивидуально сначала и проверить соседние порты. Используйте соседний узел show cdp для проверки соседних портов.


Document ID: 116095