Интерфейсы и модули Cisco : Cisco Unified SIP Proxy

Как настроить аварийное переключение для Cisco унифицированный прокси SIP

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (21 апреля 2016) | Отзыв

Введение

Этот документ обсуждает две опции для использования для настройки резервирования (аварийное переключение) для Cisco Унифицированный прокси SIP.

Внесенный Рэнди Юань Ву, специалистом службы технической поддержки Cisco.

Предварительные условия

Требования

Компания Cisco рекомендует предварительно ознакомиться со следующими предметами:

  • Протокол маршрутизатора горячего резервирования (HSRP)
  • DNS
  • Унифицированный прокси-сервер Cisco SIP (CUSP)

Компоненты

Сведения в этом документе основываются на CUSP.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Создайте стойкий к отказу шлюз по умолчанию

Способность создать стойкий к отказу шлюз по умолчанию является ключевой характеристикой, которую предоставляет унифицированный прокси-сервер Cisco SIP (CUSP). Существует две опции, которые можно использовать для достижения резервирования для CUSP. Нужно использовать SRV DNS Сервера Системы доменных имен; другой должен создать виртуальный сервер. Протокол HSRP является механизмом, которым может быть создан виртуальный сервер. Первая часть этого документа кратко описывает, как внедрить SRV DNS. Остальные и большинство этого документа описывают как HSRP? s функции может быть внедрен для обнаружения проблем или на шасси Маршрутизатора ISR (ISR) или на самом service-module CUSP.

Параметр номер один — SRV DNS

В этой опции настройте восходящий элемент (какой бы ни элемент переводит вызовы к CUSP) использовать DNS. Если попытка достигнуть сбоев cusp1, восходящий элемент делает запрос для следующей записи в SRV DNS и попыток использовать cusp2. DNS должен быть настроен должным образом для этого для работы.

  1. Во-первых, два SRV DNS (сервисные) записи должны быть созданы, один для каждого острого выступа. Запись, которая указывает к cusp1, имеет более высокий приоритет.

  2. Во-вторых, два DNS (имя хоста), записи должны быть созданы так, чтобы могли быть решены назначения в SRV-записях в DNS. Данный пример показывает то, что сервер DNS должен содержать в его записях.

116015-configure-failover-cusp-01.png

Опция два — HSRP

Эта схема предоставляет базовую архитектуру того, как настроить CUSP для HSRP. Левая часть является восходящим элементом SIP, и правая часть является нисходящим элементом SIP. Промежуточный эти элементы один виртуальный маршрутизатор с IP-адресом 192.168.20.7. Оба входящие и исходящие элементы ведут трафик SIP к IP-адресу виртуального маршрутизатора. В виртуальном маршрутизаторе два действительных маршрутизатора: основной и вторичное устройство. Эти два маршрутизатора совместно используют этот тот же виртуальный IP - адрес, и их конфигурации идентичны за двумя исключениями. Поэтому конфигурации, данные в этом документе, являются тем же для обоих маршрутизаторов.

Примечание: Конфигурация HSRP для двух CUSPs в одиночном маршрутизаторе не была протестирована. Могло бы быть возможно взять это решение и развернуть его для множественного CUSPs, но это не поддерживается в это время.

116015-configure-failover-cusp-02.png

Основное подключение настройки

Во-первых, установите подключение между маршрутизатором и блейдом. Несмотря на то, что это охвачено в других документах, это избыточно обсуждено в этом документе также. В данном примере основной маршрутизатор имеет адрес 192.168.20.80, и его CUSP имеет адрес 192.168.20.81.

interface GigabitEthernet0/1
ip address 192.168.20.80 255.255.252.0
!!
interface Integrated-Service-Engine1/0
ip unnumbered GigabitEthernet0/1
service-module ip address 192.168.20.81 255.255.252.0
service-module ip default-gateway 192.168.20.80
!!
ip route 192.168.20.81 255.255.255.255 Integrated-Service-Engine1/0

Дополнительный маршрутизатор имеет адрес 192.168.20.90, и его CUSP имеет адрес 192.168.20.81.

interface GigabitEthernet0/1
ip address 192.168.20.90 255.255.252.0
!!
interface Integrated-Service-Engine1/0
ip unnumbered GigabitEthernet0/1
service-module ip address 192.168.20.81 255.255.252.0
service-module ip default-gateway 192.168.20.90
!!
ip route 192.168.20.81 255.255.255.255 Integrated-Service-Engine1/0

Установите аварийное переключение уровня маршрутизатора

Затем, аварийное переключение уровня маршрутизатора должно быть настроено. Это включает обозначение одного из маршрутизаторов как основной и другой как вторичное устройство. Существует небольшое различие в конфигурации этих двух маршрутизаторов.

Вот конфигурация для Основного маршрутизатора:

interface GigabitEthernet0/1
standby 0 ip 192.168.20.7
standby 0 priority 100

Вот конфигурация для Дополнительного маршрутизатора:

interface GigabitEthernet0/1
standby 0 ip 192.168.20.7
standby 0 priority 90

Обоим маршрутизаторам установили их резервные IP - адреса в виртуальный маршрутизатор; однако, основной маршрутизатор имеет более высокий приоритет, чем вторичный. Это означает, в то время как все другие вещи идентичны, основной маршрутизатор считают активным, и весь трафик SIP проходит основной маршрутизатор и затем к CUSP на том маршрутизаторе. Если основной маршрутизатор выключается по какой-либо причине, такой как перебой в питании, дополнительный маршрутизатор находится в резерве и только вступает во владение.

Отследите интерфейсы

HSRP также должен быть настройкой для обнаружения сбоя уровня CUSP. Что происходит, если CUSP в основном маршрутизаторе умирает за кого-то, обосновывают, но сам маршрутизатор является незатронутым? Трафик SIP продолжает передаваться CUSP в основном маршрутизаторе. Приоритет маршрутизатора должен быть изменен на основе состояния CUSP, расположенного в каждом маршрутизаторе.

Способ сделать это должно установить эхо - запрос ICMP к CUSP от каждого маршрутизатора. В этом случае эхо передается каждые две (2) секунды с одним (1) вторым таймаутом. Ниже эти значения, тогда более быстрое, маршрутизатор может обнаружить, что CUSP не работает. Однако, если эхо - запрос ICMP установлено слишком низко, это могло бы привести к ошибочным допускам. Последняя строка настройки в данном примере начинает эхо и заставляет его происходить навсегда.

Примечание: Эхо - запрос ICMP не могут отследить состояние порта SIP. Если проблема на уровне порта, аварийное переключение HSRP не может инициироваться. Повторить; если маршрутизатор отказывает, другой маршрутизатор вступает во владение; если эхо-запросы для соглашений об Уровне IP-сервиса (SLA) сбой, другой маршрутизатор вступает во владение; если порт SIP отказывает, это не обнаружено.

ip sla 1
icmp-echo 192.168.20.81
timeout 1000
frequency 2
!!
ip sla schedule 1 life forever start-time now

Объект должен быть настройкой для отслеживания состояния того эха. Объектный номер равняется 100 в этом случае. Если статус этого объекта не работает, интерфейс должен собираться постепенно уменьшить приоритет маршрутизатора 20. Это означает, идет ли CUSP на основном маршрутизаторе неактивный по некоторым причинам, его приоритет понизится с 100 до 80. Его приоритет является тогда меньше, чем то из вторичного устройства, которое имеет приоритет 90. Если резерв 0 вытесняет, установлен, он вызывает дополнительный маршрутизатор к поглощению для основного, и затем трафик SIP переходит к вторичному CUSP.

track 100 ip sla 1 reachability
!!
interface GigabitEthernet0/1
standby 0 track 100 decrement 20
standby 0 preempt

Конфигурация HSRP основного маршрутизатора

ip sla 1
icmp-echo 192.168.20.81
timeout 1000
frequency 2
!!
ip sla schedule 1 life forever start-time now
!!
track 100 ip sla 1 reachability
!!
interface GigabitEthernet0/1
ip address 192.168.20.80 255.255.252.0
standby 0 ip 192.168.20.7
standby 0 priority 100
standby 0 preempt
standby 0 track 100 decrement 20
!!
interface Integrated-Service-Engine1/0
ip unnumbered GigabitEthernet0/1
service-module ip address 192.168.20.81 255.255.252.0
service-module ip default-gateway 192.168.20.80
!!
ip route 192.168.20.81 255.255.255.255 Integrated-Service-Engine1/0

Конфигурация HSRP дополнительного маршрутизатора

ip sla 1
icmp-echo 192.168.20.81
timeout 1000
frequency 2
!!
ip sla schedule 1 life forever start-time now
!!
track 100 ip sla 1 reachability
!!
interface GigabitEthernet0/1
ip address 192.168.20.90 255.255.252.0
standby 0 ip 192.168.20.7
standby 0 priority 90
standby 0 preempt
standby 0 track 100 decrement 20
!!
interface Integrated-Service-Engine1/0
ip unnumbered GigabitEthernet0/1
service-module ip address 192.168.20.81 255.255.252.0
service-module ip default-gateway 192.168.20.90
!!
ip route 192.168.20.81 255.255.255.255 Integrated-Service-Engine1/0

Дополнительные сведения



Document ID: 116015