Интерфейсы и модули Cisco : Модуль Cisco Wireless LAN Controller

Сетка и пример конфигурации поддержки несколько интерфейсов VLAN WGB

21 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ предоставляет пример конфигурации для поддержки несколько интерфейсов VLAN Сетки и Моста рабочей группы (WGB) с открытой аутентификацией (Откройте Аутентификацию), и с Легковесным расширяемым протоколом аутентификации (LEAP).

Примечание: Внесенный BG Surendra, специалистом службы технической поддержки Cisco.

Другие Документы в этой Серии

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Более подробную информацию о применяемых в документе обозначениях см. в описании условных обозначений, используемых в технической документации Cisco.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Используйте инструмент Command Lookup (только для зарегистрированных пользователей) для того, чтобы получить более подробную информацию о командах, использованных в этом разделе.

Схема сети

Этот документ использует эту сетевую установку, которая показывает, как достигнуть поддержки несколько интерфейсов VLAN на коммутаторе позади WGB с Открытым Подлинным LEAP, добавлен в конце.

Топология:

Сервер DHCP — Коммутатор — Контроллер беспроводной локальной сети (WLC) — Точка доступа к корневому каталогу (RAP) (Сетка))))) (((((WGB — Коммутатор

http://www.cisco.com/c/dam/en/us/support/docs/interfaces-modules/wireless-lan-controller-module/115752-mesh-wgb-01.gif

  • Сервер протокола динамической конфигурации узла (DHCP) настроен для VLAN 50 и 100.

  • WLC создали динамические интерфейсы для VLAN 50 и 100.

  • WGB имеет подчиненные интерфейсы для требуемых VLAN — 50 и 100.

  • Коммутатор позади WGB потребовал VLAN — 50 и 100.

В лабораторной установке VLAN 40 для управления WLC, VLAN 40 на RAP Сетки и VLAN 50 на WGB. Клиенты позади коммутатора WGB получают IP-адрес от VLAN 50 и VLAN 100 по воздуху через WGB и RAP Сетки.

Примечание: Та же настройка в силе для точки доступа (AP) Автономного режима также.

Конфигурации

Эти конфигурации используются в данном документе:

  • WGB WLC

  • Коммутатор

  • LEAP

WGB WLC

На интерфейсе командной строки (CLI) WLC введите команду config wgb vlan enable.

http://www.cisco.com/c/dam/en/us/support/docs/interfaces-modules/wireless-lan-controller-module/115752-mesh-wgb-02.gif

На CLI WGB введите команду workgroup-bridge unified-vlan-client.

workgroup-bridge unified-vlan-client
dot11 ssid WGB_LWAPP
   vlan 50
   authentication open
   guest-mode
   infrastructure-ssid
end

interface Dot11Radio0
 no ip address
 no ip route-cache
 ssid WGB_LWAPP
 station-role workgroup-bridge
 
interface Dot11Radio0.50
 encapsulation dot1Q 50 native
 no ip route-cache
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface Dot11Radio0.100
 encapsulation dot1Q 100
 no ip route-cache
 bridge-group 100
 
interface FastEthernet0.50
 encapsulation dot1Q 50 native
 no ip route-cache
 bridge-group 1
 bridge-group 1 spanning-disabled
!
interface FastEthernet0.100
 encapsulation dot1Q 100
 no ip route-cache
 bridge-group 100

interface BVI1

!--- Grab the IP address from VLAN 50 which is across wireless
 
 ip address dhcp  
 no ip route-cache

Коммутатор

Конфигурация для коммутатора:

Switch#sh cdp neighbors
Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge
                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone
 
Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID
BGL14-TACLAB-ASW-S8
                 Fas 0/2           150          R S I     WS-C3550- Fas 0/27
SURBG-AP         Fas 0/1           130           T I      AIR-AP124 Fas 0
Switch#
Switch#sh run int fa 0/1
Building configuration...

Current configuration : 127 bytes
!
interface FastEthernet0/1
 switchport trunk encapsulation dot1q
 switchport trunk native vlan 50
 switchport mode trunk
end

Switch#sh vlan br
VLAN Name                             Status    Ports
---- -------------------------------- --------- -------------------------------
1    default                         
12   VLAN0012                         active
40   VLAN0040                         active
50   VLAN0050                         active
100  VLAN0100                         active
Switch#sh run int vlan 50
Building configuration...
Current configuration : 41 bytes
!
interface Vlan50
 ip address dhcp
end

Switch#sh run int vlan 100
Building configuration...
 
Current configuration : 42 bytes
!
interface Vlan100
 ip address dhcp
end

Switch#sh ip int br | i up
Vlan12                 unassigned      YES DHCP    up                    up
Vlan50                 172.16.1.7      YES DHCP    up                    up
Vlan100                100.0.0.21      YES DHCP    up                    up

В заключение VLAN 50 и 100 интерфейсов получают IP-адрес из сервера DHCP, который находится позади коммутатора на центральном узле через радио через RAP Сетки и WGB.

На WLC корректная VLAN сопоставлена с корректными интерфейсами.

VLAN 100 захватывает IP-адрес и ту запись на WLC.

http://www.cisco.com/c/dam/en/us/support/docs/interfaces-modules/wireless-lan-controller-module/115752-mesh-wgb-03.gif

VLAN 50 захватывает IP-адрес и ту запись на WLC.

http://www.cisco.com/c/dam/en/us/support/docs/interfaces-modules/wireless-lan-controller-module/115752-mesh-wgb-04.gif

LEAP

Настройте WLAN для WPA2 - 802.1X локальный eap profile.

http://www.cisco.com/c/dam/en/us/support/docs/interfaces-modules/wireless-lan-controller-module/115752-mesh-wgb-05.gif

http://www.cisco.com/c/dam/en/us/support/docs/interfaces-modules/wireless-lan-controller-module/115752-mesh-wgb-06.gif

http://www.cisco.com/c/dam/en/us/support/docs/interfaces-modules/wireless-lan-controller-module/115752-mesh-wgb-07.gif

Гарантируйте приоритет аутентификации на локальных точках Протокола EAP к Базе локальных пользователей.

http://www.cisco.com/c/dam/en/us/support/docs/interfaces-modules/wireless-lan-controller-module/115752-mesh-wgb-08.gif

AP WGP

dot11 ssid WGB_LWAPP
   vlan 50
   authentication open eap eap
   authentication network-eap eap
   authentication key-management wpa version 2
   dot1x credentials wgb
   dot1x eap profile eapfast
   infrastructure-ssid
   no ids mfp client
!

!--- Profile configured -- LEAP

eap profile eapfast                
 method leap
!
!
!

!--- Credentials used by this WGB AP to get auth with WLC (Local net users)

dot1x credentials wgb         
 username cisco123
 password 7 0822455D0A16544541
 

interface Dot11Radio0
 no ip address
 no ip route-cache
 !
 encryption mode ciphers aes-ccm
 !
 encryption vlan 50 mode ciphers aes-ccm
 !
 ssid WGB_LWAPP
 !
 packet retries 128
 station-role workgroup-bridge
!
interface Dot11Radio0.50
 encapsulation dot1Q 50 native
 no ip route-cache
 bridge-group 1
!
interface Dot11Radio0.100
 encapsulation dot1Q 100
 no ip route-cache
 bridge-group 100
 bridge-group 100 spanning-disabled

Клиент находится в состоянии выполнения с безопасностью LEAP.

http://www.cisco.com/c/dam/en/us/support/docs/interfaces-modules/wireless-lan-controller-module/115752-mesh-wgb-09.gif

Проверка

В настоящее время для этой конфигурации нет процедуры проверки.

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.


Дополнительные сведения


Document ID: 115752