Безопасность и VPN : Terminal Access Controller Access Control System (TACACS+)

IOS на TACACS VRF + устранение проблем

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

TACACS + в большой степени используется в качестве протокола аутентификации для аутентификации пользователей к сетевым устройствам. Все больше администраторов выделяет свой трафик управления с помощью VPN Routing и Forwarding (VRF). По умолчанию AAA на IOS использует таблицу маршрутизации по умолчанию для передавания пакеты. Этот документ описывает, как настроить и устранить неполадки TACACS +, когда сервер находится в VRF.

Примечание: Внесенный Джесси Дюбуа, специалистом службы технической поддержки Cisco.

Предварительные условия

Требования

Компания Cisco рекомендует предварительно ознакомиться со следующими предметами:

  • TACACS +

  • VRF

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Информация о функциональной возможности

По существу VRF является таблицей виртуальной маршрутизации на устройстве. Когда IOS делает решение о маршрутизации, если функция или интерфейс используют VRF, решения о маршрутизации сделаны против той таблицы маршрутизации VRF. В противном случае функция использует таблицу глобальной маршрутизации. С этим в памяти, вот то, как вы настраиваете TACACS + для использования VRF (соответствующая конфигурация полужирным):

version 15.2
service config
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname vrfAAA
!
boot-start-marker
boot-end-marker
!
aaa new-model
!
aaa group server tacacs+ management
 server-private 192.0.2.4 key cisco
 server-private 192.0.2.5 key cisco
 ip vrf forwarding blue
 ip tacacs source-interface GigabitEthernet0/0
!
aaa authentication login default group management local
aaa authorization exec default group management if-authenticated 
aaa accounting exec default start-stop group management
!
aaa session-id common
!
no ipv6 cef
!
ip vrf blue
!
no ip domain lookup
ip cef
!
interface GigabitEthernet0/0
 ip vrf forwarding blue
 ip address 203.0.113.2 255.255.255.0
 duplex auto
 speed auto
!
interface GigabitEthernet0/1
 no ip address
 shutdown
 duplex auto
 speed auto
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route vrf blue 0.0.0.0 0.0.0.0 203.0.113.1
!
line con 0
line aux 0
line vty 0 4
 transport input all

Как вы можете видеть нет никаких глобально определенных TACACS + серверы. При миграции серверов на VRF можно безопасно удалить глобально настроенный TACACS + серверы.

Методика устранения проблем

  1. Удостоверьтесь, что у вас есть надлежащее определение ip vrf forwarding под aaa group server, а также исходным интерфейсом для TACACS + трафик.

  2. Проверьте таблицу маршрутизации VRF и удостоверьтесь, что существует маршрут к TACACS + сервер. Приведенный выше пример используется для показа таблицы маршрутизации VRF:

    vrfAAA#show ip route vrf blue
    
    Routing Table: blue
    Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
           D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area 
           N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
           E1 - OSPF external type 1, E2 - OSPF external type 2
           i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
           ia - IS-IS inter area, * - candidate default, U - per-user static route
           o - ODR, P - periodic downloaded static route, H - NHRP, l - LISP
           + - replicated route, % - next hop override
    
    Gateway of last resort is 203.0.113.1 to network 0.0.0.0
    
    S*    0.0.0.0/0 [1/0] via 203.0.113.1
          203.0.0.0/24 is variably subnetted, 2 subnets, 2 masks
    C        203.0.113.0/24 is directly connected, GigabitEthernet0/0
    L        203.0.113.2/32 is directly connected, GigabitEthernet0/0
  3. Можно ли пропинговать TACACS + сервер? Помните, что это должно быть VRF, определенным также:

    vrfAAA#ping vrf blue 192.0.2.4
    Type escape sequence to abort.
    Sending 5, 100-byte ICMP Echos to 102.0.2.4, timeout is 2 seconds:
    !!!!!
    Success rate is 100 percent (5/5), round-trip min/avg/max = 1/1/4 ms
  4. Можно использовать команду test aaa для подтверждения подключения (необходимо использовать опцию нового кода в конце, наследство не работает):

    vrfAAA#test aaa group management cisco Cisco123 new-code 
    Sending password
    User successfully authenticated
    
    USER ATTRIBUTES
    
    username             "cisco"
    reply-message        "password: "

Если маршруты существуют, и вы не видите соответствий на TACACS + сервер, удостоверьтесь, что ACL позволяют порту TCP 49 достигать сервера от маршрутизатора или коммутатора. Если вы получаете TACACS устранения неполадок ошибки проверки подлинности + как обычный, функция VRF только для маршрутизации пакета.

Анализ данных

Если всему выше корректных взглядов, aaa и отладки tacacs можно позволить решить проблему. Запустите с этих отладок:

  • debug tacacs

  • debug aaa authentication

Вот пример отладки, где что-то не настроено должным образом, такой как, но не ограничено:

  • Недостающий TACACS + исходный интерфейс

  • Недостающие команды ip vrf forwarding под исходным интерфейсом или под aaa group server

  • Никакой маршрут к TACACS + сервер в таблице маршрутизации VRF

Jul 30 20:23:16.399: TPLUS: Queuing AAA Authentication request 0 for processing
Jul 30 20:23:16.399: TPLUS: processing authentication start request id 0
Jul 30 20:23:16.399: TPLUS: Authentication start packet created for 0(cisco)
Jul 30 20:23:16.399: TPLUS: Using server 192.0.2.4
Jul 30 20:23:16.399: TPLUS(00000000)/0: Connect Error No route to host
Jul 30 20:23:16.399: TPLUS: Choosing next server 192.0.2.5
Jul 30 20:23:16.399: TPLUS(00000000)/0: Connect Error No route to host

Вот успешное подключение:

Jul 30 20:54:29.091: AAA/AUTHEN/LOGIN (00000000): Pick method list 'default' 
Jul 30 20:54:29.091: TPLUS: Queuing AAA Authentication request 0 for processing
Jul 30 20:54:29.091: TPLUS: processing authentication start request id 0
Jul 30 20:54:29.091: TPLUS: Authentication start packet created for 0(cisco)
Jul 30 20:54:29.091: TPLUS: Using server 192.0.2.4
Jul 30 20:54:29.091: TPLUS(00000000)/0/NB_WAIT/2B2DC1AC: Started 5 sec timeout
Jul 30 20:54:29.095: TPLUS(00000000)/0/NB_WAIT: socket event 2
Jul 30 20:54:29.095: TPLUS(00000000)/0/NB_WAIT: wrote entire 25 bytes request
Jul 30 20:54:29.095: TPLUS(00000000)/0/READ: socket event 1
Jul 30 20:54:29.095: TPLUS(00000000)/0/READ: Would block while reading
Jul 30 20:54:29.099: TPLUS(00000000)/0/READ: socket event 1
Jul 30 20:54:29.099: TPLUS(00000000)/0/READ: read entire 12 header bytes (expect 16 bytes data)
Jul 30 20:54:29.099: TPLUS(00000000)/0/READ: socket event 1
Jul 30 20:54:29.099: TPLUS(00000000)/0/READ: read entire 28 bytes response
Jul 30 20:54:29.099: TPLUS(00000000)/0/2B2DC1AC: Processing the reply packet
Jul 30 20:54:29.099: TPLUS: Received authen response status GET_PASSWORD (8)
Jul 30 20:54:29.099: TPLUS: Queuing AAA Authentication request 0 for processing
Jul 30 20:54:29.099: TPLUS: processing authentication continue request id 0
Jul 30 20:54:29.099: TPLUS: Authentication continue packet generated for 0
Jul 30 20:54:29.099: TPLUS(00000000)/0/WRITE/2B2DC1AC: Started 5 sec timeout
Jul 30 20:54:29.099: TPLUS(00000000)/0/WRITE: wrote entire 25 bytes request
Jul 30 20:54:29.103: TPLUS(00000000)/0/READ: socket event 1
Jul 30 20:54:29.103: TPLUS(00000000)/0/READ: read entire 12 header bytes (expect 6 bytes data)
Jul 30 20:54:29.103: TPLUS(00000000)/0/READ: socket event 1
Jul 30 20:54:29.103: TPLUS(00000000)/0/READ: read entire 18 bytes response
Jul 30 20:54:29.103: TPLUS(00000000)/0/2B2DC1AC: Processing the reply packet
Jul 30 20:54:29.103: TPLUS: Received authen response status PASS (2)

Типичные неполадки

Самая обычная проблема является конфигурацией. Много раз admin вставляет aaa group server, но не обновляет линии aaa для обращения к группе серверов. Вместо:

aaa authentication login default group management local
aaa authorization exec default group management if-authenticated 
aaa accounting exec default start-stop group management

Admin вставит:

aaa authentication login default grout tacacs+ local
aaa authorization exec default group tacacs+ if-authenticated 
aaa accounting exec default start-stop group tacacs+

Просто обновите конфигурацию с корректной группой серверов.

Вторая типичная проблема является пользователем, получает эту ошибку при попытке добавить ip vrf forwarding под группой серверов:

% Unknown command or computer name, or unable to find computer address

Это означает, что не была найдена команда. Если это происходит, удостоверяются, что версия IOS поддерживает TACACS на VRF +. Вот некоторые общие минимальные номера версии:

  • 12.3 (7) T

  • 12.2 (33) SRA1

  • 12.2(33)SXI

  • 12.2 (33) SXH4

  • 12.2 (54) SG

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 113667