Протокол IP : Протокол BGP

Реализация BGP Использование 32-разрядного примера конфигурации номера AS

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ описывает, как настроить протокол BGP с использованием 32-разрядного номера AS. В BGP каждый домен маршрутизации является одиночным административным доменом, имеет уникальный назначенный номер AS на него и контролируется стандартным набором политик маршрутизации. Он также поддерживает междоменную маршрутизацию.

В этом документе BGP, взаимодействующий, настроен между 16-разрядными и 32-разрядными говорящими маршрутизаторами под управлением BGP. Новый 32-разрядный режим AS совместим с the16-разрядным режимом AS. Одноранговые соединения по протоколу BGP, которые могут работать в 32-разрядном режиме, положительно отвечают на новую возможность, и тот сеанс работает в новом режиме. С другой стороны, 32-разрядные Одноранговые соединения по протоколу BGP при передаче с 16-разрядными динамиками BGP, 16-разрядные участвующие в обмене данными маршрутизатор игнорируют эту новую возможность и управляют их сеансом BGP в 16-разрядном режиме.

Предварительные условия

Требования

Cisco рекомендует иметь базовые знания о BGP.

Версии аппаратного и программного обеспечения

Конфигурации в этом документе основываются на маршрутизаторе Cisco серии 7200 с Cisco Выпуск ПО IOS� 15.0 (1).

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Настройка

В данном примере маршрутизаторы R1 и R3 настроены, чтобы быть в AS 100, формирующем отношение iBGP с помощью 16-разрядного режима AS. Маршрутизаторы R2 и R4 настроены в AS 10.1 и одноранговом телефонном соединении IBGP формы с помощью 32-разрядного режима AS. Маршрутизаторы R1 и R2 работают и протокол IGP в OSPF данного примера друг между другом, и также формирует eBGP, граничащий между ними.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

В этом документе использованы параметры данной сети:

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/113593-config-bgp-using-32bit-ASN-01.gif

Конфигурации

Эти конфигурации используются в данном документе:

Маршрутизатор М1
R1#show run
Building configuration...
!
version 15.0
!
hostname R1
!
ip cef
!
interface Loopback0
ip address 1.1.1.1 255.255.255.255
!
interface Loopback10
ip address 192.168.100.1 255.255.255.0
!
interface Loopback20
ip address 192.168.200.1 255.255.255.0
!
interface FastEthernet1/0
ip address 192.168.10.1 255.255.255.0
duplex auto
 speed auto
!
interface Serial2/0
 ip address 10.10.100.1 255.255.255.0
 serial restart-delay 0
!
router ospf 1
 log-adjacency-changes
 network 1.1.1.1 0.0.0.0 area 0
 network 10.10.100.0 0.0.0.255 area 0
!
router bgp 100

!--- BGP is configured using 16-bit AS number

 no synchronization
 bgp router-id 10.10.10.10
 bgp asnotation dot

!--- This command change the default asplain notation
to dot notation.


!--- Note that without this command the AS number will 
treated as asplain notation i.e. 10.1 will 
be displayed as 655361


 bgp log-neighbor-changes
 network 192.168.100.0
 network 192.168.200.0
 neighbor 2.2.2.2 remote-as 10.1

!--- The AS number of the eBGP peer in 32-bit

 neighbor 2.2.2.2 ebgp-multihop 255
 neighbor 2.2.2.2 update-source Loopback0
 neighbor 192.168.10.2 remote-as 100
 neighbor 192.168.10.2 next-hop-self
 no auto-summary
!
end

Маршрутизатор М2
R2#show run
!
version 15.0
!
hostname R2
!
ip cef
!
interface Loopback0
ip address 2.2.2.2 255.255.255.0
!
interface Loopback10
ip address 10.1.1.1 255.255.255.255
!
interface Loopback20
ip address 20.1.1.1 255.255.255.255
!
interface FastEthernet1/0
ip address 172.16.10.1 255.255.255.0
duplex auto
speed auto
!
interface Serial2/0
ip address 10.10.100.2 255.255.255.0
serial restart-delay 0
!
!
router ospf 1
 log-adjacency-changes
 network 2.2.2.2 0.0.0.0 area 0
 network 10.10.100.0 0.0.0.255 area 0
!
router bgp 10.1

!--- BGP is configured using 32-bit AS number

 no synchronization
 bgp router-id 20.20.20.20
 bgp asnotation dot
 bgp log-neighbor-changes
 network 10.1.1.1 mask 255.255.255.255
 network 20.1.1.1 mask 255.255.255.255
 neighbor 1.1.1.1 remote-as 100
 neighbor 1.1.1.1 ebgp-multihop 255
 neighbor 1.1.1.1 update-source Loopback0
 neighbor 172.16.10.2 remote-as 10.1
 neighbor 172.16.10.2 next-hop-self
 no auto-summary
!
end

Маршрутизатор R3
R3#show run
Building configuration...
!
version 15.0
ip cef
!
interface Loopback0
 ip address 30.30.30.30 255.255.255.255
!
interface FastEthernet1/0
 ip address 192.168.10.2 255.255.255.0
 duplex auto
 speed auto
!
router bgp 100
 no synchronization
 bgp router-id 3.3.3.3
 bgp log-neighbor-changes
 network 30.30.30.30 mask 255.255.255.255
 neighbor 192.168.10.1 remote-as 100
 neighbor 192.168.10.1 next-hop-self
 no auto-summary

!--- iBGP peering is formed between routers R1 and R3
using 16-bit AS number.

!
end

Маршрутизатор R4
R4#show run
Building configuration...
!
version 15.0
ip cef
!
interface Loopback0
 ip address 40.40.40.40 255.255.255.255
!
interface FastEthernet1/0
 ip address 172.16.10.2 255.255.255.0
 duplex auto
 speed auto
!
router bgp 10.1
 no synchronization
 bgp router-id 4.4.4.4
 bgp asnotation dot
 bgp log-neighbor-changes
 network 40.40.40.40 mask 255.255.255.255
 neighbor 172.16.10.1 remote-as 10.1
 no auto-summary
!
end

!--- iBGP peering is formed between routers 
R2 and R4 using 32-bit AS number.

Проверка.

Воспользуйтесь данным разделом для проверки правильности функционирования вашей конфигурации.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Используйте OIT для просмотра анализа выходных данных команды show.

Команды "show"

Чтобы проверить, что BGP может поддержать 32-разрядный ASN, используйте команду show ip bgp neighbor.

show ip bgp neighbor
В маршрутизаторе R1
R1#show ip bgp neighbor 2.2.2.2
BGP neighbor is 2.2.2.2,  remote AS 10.1, external link
  BGP version 4, remote router ID 20.20.20.20
  BGP state = Established, up for 03:28:22
  Last read 00:00:41, last write 00:00:29, hold time is 180, keepalive interval is 60 seconds
  Neighbor sessions:
    1 active, is multisession capable
  Neighbor capabilities:
    Route refresh: advertised and received(new)
    Four-octets ASN Capability: advertised and received
    Address family IPv4 Unicast: advertised and received
    Multisession Capability: advertised and received
  Message statistics, state Established:
    InQ depth is 0
    OutQ depth is 0

                         Sent       Rcvd
    Opens:                  1          1
    Notifications:          0          0
    Updates:                3          3
    Keepalives:           229        230
    Route Refresh:          0          0
    Total:                233        234


!--- Output omitted---!

Для показа записей в таблице маршрутизации BGP используйте команду show ip bgp .

show ip bgp
В маршрутизаторе R1
R1#sh ip bgp
BGP table version is 13, local router ID is 10.10.10.10
Status codes: s suppressed, d damped, h history, * valid, > best, I - internal,
              r RIB-failure, S Stale
Origin codes: I - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*> 10.1.1.1/32      2.2.2.2                  0             0 10.1 I
*> 20.1.1.1/32      2.2.2.2                  0             0 10.1 I
*>i30.30.30.30/32   192.168.10.2             0    100      0 I
*> 40.40.40.40/32   2.2.2.2                                0 10.1 I
*> 192.168.100.0    0.0.0.0                  0         32768 I
*> 192.168.200.0    0.0.0.0                  0         32768 I


!--- Note that the routes highlighted are received from the eBGP peer 
router R2 which is in 32-bit AS 10.1.


In router R3
R3#sh ip bgp
BGP table version is 11, local router ID is 3.3.3.3
Status codes: s suppressed, d damped, h history, * valid, > best, I - internal,
              r RIB-failure, S Stale
Origin codes: I - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i10.1.1.1/32      192.168.10.1             0    100      0 655361 I
*>i20.1.1.1/32      192.168.10.1             0    100      0 655361 I
*> 30.30.30.30/32   0.0.0.0                  0         32768 I
*>i40.40.40.40/32   192.168.10.1             0    100      0 655361 I
*>i192.168.100.0    192.168.10.1             0    100      0 I
*>i192.168.200.0    192.168.10.1             0    100      0 I


!--- The router R3 does not have bgp asnotation dot
configured in it. Therefore, the route received from the router in 32-bit AS AS 10.1 
is displayed as 655361.


In router R4
R4#sh ip bgp
BGP table version is 7, local router ID is 4.4.4.4
Status codes: s suppressed, d damped, h history, * valid, > best, I - internal,
              r RIB-failure, S Stale
Origin codes: I - IGP, e - EGP, ? - incomplete

   Network          Next Hop            Metric LocPrf Weight Path
*>i10.1.1.1/32      172.16.10.1              0    100      0 I
*>i20.1.1.1/32      172.16.10.1              0    100      0 I
*>i30.30.30.30/32   172.16.10.1              0    100      0 100 I
*> 40.40.40.40/32   0.0.0.0                  0         32768 I
*>i192.168.100.0    172.16.10.1              0    100      0 100 I
*>i192.168.200.0    172.16.10.1              0    100      0 100 I


!--- The above output shows the entries in BGP routing table of router R4.

Для подтверждения достижимости между маршрутизаторами используйте команду ping.

ping
От маршрутизатора R3
R3#ping 40.40.40.40

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 40.40.40.40, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 68/101/148 ms
От маршрутизатора R4
R4#ping 30.30.30.30

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 30.30.30.30, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/89/112 ms

!--- The above output shows that End to End connectivity is established between R3 and R4,
where R3 is AS 100(16-bit AS) and router R4 is in AS 10.1(32-bit AS).

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 113593