Коммутаторы : Коммутаторы Cisco Catalyst серии 6500

Коммутаторы серии Catalyst 6500 Использование примера конфигурации VPLS

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (19 декабря 2015) | Отзыв


Содержание


Введение

Этот документ предоставляет пример конфигурации для службы виртуальной локальной частной сети (VPLS) на коммутаторах Cisco Catalyst серии 6500, чтобы к позволяет предприятиям соединить их на основе Ethernet LAN от множественных узлов до их поставщиком услуг.

Предварительные условия

Требования

Убедитесь, что вы обеспечили выполнение следующих требований, прежде чем попробовать эту конфигурацию:

  • Базовые знания о конфигурации на коммутаторах Cisco Catalyst серии 6500

  • Имейте базовые знания о VPLS

Используемые компоненты

Сведения в этом документе основываются на коммутаторе Cisco Catalyst серии 6500.

VPLS поддерживается на Коммутаторе Catalyst 6500 с SIP-600/SUP3B или позже с Cisco Выпуск ПО IOS� 12.2 (33) SXH или позже. Коммутатор требует, чтобы использование карт SIP выполнило функциональность VPLS.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Более подробную информацию о применяемых в документе обозначениях см. в описании условных обозначений, используемых в технической документации Cisco.

Общие сведения

С точки зрения предприятия VPLS использует открытую сеть поставщика услуг как одна гигантская Локальная сеть Ethernet, которая подключает множественные устройства CE узлов, который, кажется, соединяется с логическим мостом, которым управляют по сети IP/MPLS.

VPLS упрощает границу LAN/WAN и представляет как интерфейс Ethernet, который, кажется, находится на той же LAN, независимо от местоположения.

Сначала создайте действительный экземпляр VRF (VFI) на каждом Коммутаторе Catalyst 6500 для устанавливания VPLS. VFI задает VPN ID домена VPLS, адреса другого устройства в домене и тип туннельной сигнализации и механизма инкапсуляции для каждого однорангового устройства. Набор VFIs, сформированного соединением устройств, называют экземпляром VPLS, который формирует логический мост по Packet Switched Network.

Решение о пересылке пакетов сделано при поиске действительного экземпляра VRF (VFI) Уровня 2. Во избежание проблемы пакетного цикличного выполнения в ядре поставщика устройства принуждают принцип разделения горизонта для эмулированных VC.

Прежде чем вы настроите VPLS, настроите MPLS в ядре так, чтобы путь коммутации меток (LSP) существовал между устройствами.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Используйте инструмент Command Lookup (только для зарегистрированных пользователей) для того, чтобы получить более подробную информацию о командах, использованных в этом разделе.

Схема сети

В настоящем документе используется следующая схема сети:

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-6500-series-switches/113563-vpls-6500-config-01.gif

Конфигурации

Эти конфигурации используются в данном документе:

Коммутатор Catalyst 6500 1
switch6500_1#configure terminal


!--- Enable the Layer 2 VFI manual configuration mode.

switch6500_1(config)#l2 vfi VPLS-A manual

!--- Configure a VPN ID for a VPLS domain.

switch6500_1(config-vfi)#vpn id 500

!--- Specify the remote peering router ID 
!--- and the tunnel encapsulation type or the pseudo-wire 
!--- property to be used to set up the emulated VC.

switch6500_1(config-vfi)#neighbor 10.7.1.3 encapsulation mpls
switch6500_1(config-vfi)#exit

switch6500_1(config)#interface Loopback 0
switch6500_1(config-if)#ip address 10.7.1.2 255.255.255.255

switch6500_1(config)#interface GigabitEthernet 6/3
switch6500_1(config-if)#switchport

!--- Set the interface as an 802.1Q tunnel port. 

switch6500_1(config-if)#switchport mode dot1qtunnel

!--- Set the VLAN when the interface is in Access mode.

switch6500_1(config-if)#switchport access vlan 500


!--- Create a dynamic switched virtual interface (SVI).

switch6500_1(config)#interface Vlan 500

!--- Disable IP processing.

switch6500_1(config-if)#no ip address

!--- Specify the Layer 2 VFI that you are binding to the VLAN port.

switch6500_1(config-if)#xconnect vfi VPLS-A
switch6500_1(config-if)#exit

switch6500_1(config)#vlan 500
switch6500_1(config-vlan)#state active
switch6500_1(config-vlan)#exit


!--- Save the configurations in the device.

switch6500_1(config)#copy running-config startup-config
switch6500_1(config)#exit

Коммутатор Catalyst 6500 2
switch6500_2#configure terminal

switch6500_2(config)#l2 vfi VPLS-B manual
switch6500_2(config-vfi)#vpn id 500
switch6500_2(config-vfi)#neighbor 10.7.1.2 encapsulation mpls
switch6500_2(config-vfi)#exit

switch6500_2(config)#interface Loopback 0
switch6500_2(config-if)#ip address 10.7.1.3 255.255.255.255

switch6500_2(config)#interface GigabitEthernet 3/3
switch6500_2(config-if)#switchport
switch6500_2(config-if)#switchport mode dot1qtunnel
switch6500_2(config-if)#switchport access vlan 500

switch6500_2(config)#interface Vlan 500
switch6500_2(config-if)#no ip address
switch6500_2(config-if)#xconnect vfi VPLS-B
switch6500_2(config-if)#exit

switch6500_2(config)#interface vlan 500
switch6500_2(config-vlan)#state active
switch6500_2(config-vlan)#exit


!--- Save the configurations in the device.

switch6500_2(config)#copy running-config startup-config
switch6500_2(config)#exit

Проверка

Этот раздел позволяет убедиться, что конфигурация работает правильно.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.


Дополнительные сведения


Document ID: 113563