Протокол IP : Протокол HSRP

Опция дорожки в примере конфигурации HSRPv2

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ описывает, как настроить резервный Протокол HSRP для IPv6 (HSRPv2) группа, чтобы отследить объект и изменить Приоритет HSRP на основе объектного состояния.

Каждый отслеживаемый объект имеет уникальный номер, который задан на интерфейсе командной строки (CLI) отслеживания. HSRPv2 использует этот номер для отслеживания конкретного объекта. Процесс отслеживания периодически опрашивает отслеживаемый объект для значения, изменяет и передает любые изменения (как или вниз оценивает) к HSRPv2, или сразу или после указанной задержки. Этот документ использует команду track interface для настройки интерфейса, который будет отслежен.

Предварительные условия

Требования

Убедитесь, что вы обеспечили выполнение следующих требований, прежде чем попробовать эту конфигурацию:

  • Знание настройки HSRP; обратитесь к HSRP Настройки для получения дополнительной информации.

  • Базовые знания о реализации адресации IPv6 и основного подключения; обратитесь к Реализации Адресации IPv6 и Основного подключения для получения дополнительной информации.

  • Базовые знания о Расширенном Отслеживании объектов

  • HSRPv2 должен быть включен на интерфейсе, прежде чем сможет быть настроен IPv6 HSRP.

  • Одноадресная маршрутизация IPv6 должна быть позволена на устройстве для IPv6 HSRP быть настроенной.

Используемые компоненты

Конфигурации в этом документе основываются на series маршрутизаторе Cisco7200, который выполняет Cisco Выпуск ПО IOS� 15.0 (1).

Условные обозначения

Сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Настройка

R2 и маршрутизаторы R3 связаны с R1 через последовательный интерфейс. Интерфейсы Fast Ethernet R2 и R3 настроены с IPv6 HSRP таким способом, которым R2 действует как активный маршрутизатор и действия R3 как резервный маршрутизатор. В маршрутизаторе R2 процесс отслеживания настроен для отслеживания состояния протокола интерфейсной линии последовательного интерфейса 1/0: В случае, если S1/0 последовательного интерфейса R2 выключается, маршрутизатор R3 изменяет свое состояние от Резерва до Активного.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

В настоящем документе используется следующая схема сети:

http://www.cisco.com/c/dam/en/us/support/docs/ip/hot-standby-router-protocol-hsrp/113553-to-hsrpv2-config-01.gif

Конфигурации

Эти конфигурации используются в данном документе:

Конфигурация маршрутизатора R1
!
version 15.0
!
hostname R1
!
ipv6 unicast-routing
ipv6 cef
!
!
interface Serial1/0
 no ip address
 ipv6 address 2010:10:10:10::1/64
 serial restart-delay 0
!
!
interface Serial1/1
 no ip address
 ipv6 address 2011:11:11:11::1/64
 serial restart-delay 0
 !
end

Конфигурация маршрутизатора R2
!
version 15.0
!
hostname R2
!
ipv6 unicast-routing
ipv6 cef
!
track 1 interface Serial1/0 line-protocol

!--- Tracking process 1 is configured in the router
!--- to track state of the interface line protocol
!--- of serial interface 1/0

!
interface Serial1/0
 no ip address
 ipv6 address 2010:10:10:10::2/64
 serial restart-delay 0
!
!
interface FastEthernet2/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 1010:1:1:1::10/64
 standby version 2
 standby 10 ipv6 autoconfig

!--- Assigns a standby group and standby IP address.

 standby 10 preempt delay minimum 45

!--- The preempt command allows the router to become the 
!--- active router when it has the priority higher than all the other
!--- HSRP-configured routers. Without this command, even if a router has higher 
!--- priority value, it will not become an active router.
!--- The delay minimum value causes the local router to postpone
!--- taking over the active role for a minimum of 45 seconds.

 standby 10 track 1 decrement 10

!--- Configures HSRP to track an object and change the Hot Standby
!--- priority on the basis of the state of the object.



!--- In this example,the HSRP tracks the interface s1/0 mentioned
!--- in the track process 1.


!--- Decrement value specified the amount by which the Hot Standby 
!--- priority for the router is decremented (or incremented) when the tracked object 
!--- goes down (or comes back up). The range is from 1 to 255. The default is 10. 

!
end

Конфигурация маршрутизатора R3
!
version 15.0
!
hostname R3
!
ipv6 unicast-routing
ipv6 cef
!
interface Serial1/0
 no ip address
 ipv6 address 2011:11:11:11::2/64
 serial restart-delay 0
!
interface FastEthernet2/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 1010:1:1:1::11/64
 standby version 2
 standby 10 ipv6 autoconfig
 standby 10 priority 95
 standby 10 preempt delay minimum 45
!
end

Проверка

Используйте команду show standby на R2 и маршрутизаторах R3 для проверки конфигурации.

Маршрутизатор М2
R2#show standby
FastEthernet2/0 - Group 10 (version 2)
  State is Active
    5 state changes, last state change 00:26:03
  Virtual IP address is FE80::5:73FF:FEA0:A
  Active virtual MAC address is 0005.73a0.000a
    Local virtual MAC address is 0005.73a0.000a (v2 IPv6 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 1.872 secs
  Preemption enabled, delay min 45 secs
  Active router is local
  Standby router is FE80::C802:AFF:FE10:38, priority 95 (expires in 8.048 sec)
  Priority 100 (default 100)
    Track object 1 state Up decrement 10
  Group name is "hsrp-Fa2/0-10" (default)

Маршрутизатор R3
R3#show standby
FastEthernet2/0 - Group 10 (version 2)
  State is Standby
    4 state changes, last state change 00:26:25
  Virtual IP address is FE80::5:73FF:FEA0:A
  Active virtual MAC address is 0005.73a0.000a
    Local virtual MAC address is 0005.73a0.000a (v2 IPv6 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 0.176 secs
  Preemption enabled, delay min 45 secs
  Active router is FE80::C801:14FF:FEF4:38, priority 100 (expires in 9.888 sec)
    MAC address is ca01.14f4.0038
  Standby router is local
  Priority 95 (configured 95)
  Group name is "hsrp-Fa2/0-10" (default)

Для отображения данных слежения используйте команду show track в маршрутизаторе R2.

Маршрутизатор М2
R2#show track 1
Track 1
  Interface Serial1/0 line-protocol
  Line protocol is Up
    3 changes, last change 00:28:39
  Tracked by:
    HSRP FastEthernet2/0 10

!--- Displays the information about the objects that 
!--- are tracked by tracking process 1.

R2#show track int brief
Track   Object                           Parameter        Value Last Change
1       interface   Serial1/0            line-protocol    Up    00:31:19

!--- Displays the information about the tracked interface.

В случае, если активный маршрутизатор (R2 в данном примере) выключается, резервный маршрутизатор сразу изменяет свое состояние на Активный как показано в этой таблице:

Когда выключается активный маршрутизатор (R2)...
Маршрутизатор М2
R2(config)#interface s1/0
R2(config-if)#shut
R2(config-if)#
*May 21 20:56:54.223: %TRACKING-5-STATE: 1 interface Se1/0 line-protocol Up->Down
R2(config-if)#
*May 21 20:56:56.203: %LINK-5-CHANGED: Interface Serial1/0, changed state to administratively down
*May 21 20:56:57.203: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0, changed state to down
R2(config-if)#
*May 21 20:57:43.087: %HSRP-5-STATECHANGE: FastEthernet2/0 Grp 10 state Active -> Speak
R2(config-if)#
*May 21 20:57:54.479: %HSRP-5-STATECHANGE: FastEthernet2/0 Grp 10 state Speak -> Standby


!--- When the interface goes down, the active router changes 
!--- its state to Standby.

Маршрутизатор R3
R3#
*May 21 20:56:53.419: %HSRP-5-STATECHANGE: FastEthernet2/0 Grp 10 state Standby-> Active


!--- The standby router is now the active router.
 

R3#show standby
FastEthernet2/0 - Group 10 (version 2)
  State is Active
    5 state changes, last state change 00:02:32
  Virtual IP address is FE80::5:73FF:FEA0:A
  Active virtual MAC address is 0005.73a0.000a
    Local virtual MAC address is 0005.73a0.000a (v2 IPv6 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 0.080 secs
  Preemption enabled, delay min 45 secs
  Active router is local
  Standby router is FE80::C801:14FF:FEF4:38, priority 90 (expires in 9.664 sec)
  Priority 95 (configured 95)
  Group name is "hsrp-Fa2/0-10" (default)

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.


Дополнительные сведения


Document ID: 113553