Протокол IP : Протокол BGP

Обоюдное перераспределение между EIGRP и примером BGP - конфигурации

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

В этом документе описана настройка двустороннего перераспределения между протоколами EIGRP и BGP.

Предварительные условия

  • Базовые знания о EIGRP

  • Базовые знания о BGP

Версии аппаратного и программного обеспечения

Конфигурации в этом документе основываются на маршрутизаторе Cisco серии 7200 с Cisco Выпуск ПО IOS� 15.0 (1).

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Настройка

В данном примере маршрутизаторы R1 и R2 связываются друг с другом использующим EIGRP. Маршрутизаторы R2 и R3 используют eBGP. Для взаимного перераспределения маршрутов eBGP в к EIGRP используйте команду redistribute bgp с Метриками EIGRP. Точно так же для перераспределения маршрутов EIGRP в к BGP, используйте перераспределять команду номера AS eigrp.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

В настоящем документе используется следующая схема сети:

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/113506-failover-eigrp-bgp-01.gif

Конфигурации

Эти конфигурации используются в данном документе:

Маршрутизатор М1
!
hostname R1
!
ip cef
!
!
interface Loopback0
 ip address 30.30.30.30 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.1.101 255.255.255.0
 duplex auto
 speed auto

!
router eigrp 100
 network 30.0.0.0
 network 192.168.1.0
 no auto-summary
!
end

Маршрутизатор М2
!
hostname R2
!
ip cef
!
!
interface Loopback0
 ip address 10.10.10.10 255.255.255.255
!
interface Loopback1
 ip address 20.20.20.20 255.255.255.255
!
interface FastEthernet0/0
 ip address 192.168.1.100 255.255.255.0
 duplex auto
 speed auto
!
interface Serial0/0
 ip address 172.16.100.50 255.255.255.0
 serial restart-delay 0
 clock rate 2000000

!
router eigrp 100
 redistribute static
 redistribute bgp 1000 metric 100 1 255 1 1500
 network 10.0.0.0
 network 192.168.1.0
 no auto-summary
!
router bgp 1000
 no synchronization
 bgp log-neighbor-changes
 network 20.20.20.20 mask 255.255.255.255
 redistribute connected
 redistribute static
 redistribute eigrp 100
 neighbor 172.16.100.51 remote-as 2000
 neighbor 172.16.100.51 next-hop-self

 
 no auto-summary
!
end

Маршрутизатор R3
!
hostname R3
!
ip cef
!
interface Loopback0
 ip address 22.22.22.22 255.255.255.255

!
interface Serial0/0
 ip address 172.16.100.51 255.255.255.0
 serial restart-delay 0
 clock rate 2000000
!
router bgp 2000
 no synchronization
 bgp log-neighbor-changes
 network 22.22.22.22 mask 255.255.255.255
 network 172.16.100.0 mask 255.255.255.0
 neighbor 172.16.100.50 remote-as 1000
 neighbor 172.16.100.50 default-originate
 default-information originate

!--- Default route is configured!


 no auto-summary

!
end

Проверка

Воспользуйтесь данным разделом для проверки правильности функционирования вашей конфигурации.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Используйте OIT для просмотра анализа выходных данных команды show.

Команды "show"

Чтобы проверить, что EIGRP получает перераспределенные маршруты, используйте команду show ip route eigrp.

show ip route eigrp
В маршрутизаторе R1
R1#show ip route eigrp
20.0.0.0/32 is subnetted, 1 subnets
D EX    20.20.20.20
           [170/25625856] via 192.168.1.100, 01:00:33, FastEthernet0/0
     22.0.0.0/32 is subnetted, 1 subnets
D EX    22.22.22.22
           [170/25625856] via 192.168.1.100, 00:59:49, FastEthernet0/0
     10.0.0.0/32 is subnetted, 1 subnets
D       10.10.10.10 [90/409600] via 192.168.1.100, 00:55:17, FastEthernet0/0
D*EX 0.0.0.0/0 [170/25625856] via 192.168.1.100, 00:46:24, FastEthernet0/0


!--- Shows the default route from router R3.



!--- EX indicates that the routes are EIGRP external routes.



Чтобы проверить, что маршруты EIGRP перераспределены в BGP должным образом, используйте команду bgp show ip route в маршрутизаторе R3.

bgp show ip route
В маршрутизаторе R3
R3#show ip route bgp
show ip route bgp
     20.0.0.0/32 is subnetted, 1 subnets
B       20.20.20.20 [20/0] via 172.16.100.50, 01:03:02
     10.0.0.0/32 is subnetted, 1 subnets
B       10.10.10.10 [20/0] via 172.16.100.50, 01:03:02
B    192.168.1.0/24 [20/0] via 172.16.100.50, 01:03:02
     30.0.0.0/32 is subnetted, 1 subnets
B       30.30.30.30 [20/409600] via 172.16.100.50, 00:59:06

!--- The output indicates that the EIGRP routes are
!--- redistributed in BGP.



Дополнительные сведения


Document ID: 113506