Коммутаторы : Коммутаторы Cisco Nexus серии 7000

Коммутатор Cisco Nexus серии 7000 Пример конфигурации ERSPAN

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ описывает, как настроить инкапсулированный удаленный коммутируемый анализатор для портов (ERSPAN) сеанс на Коммутаторе Cisco Nexus серии 7000, который контролирует трафик между Портами Ethernet на двух других Коммутаторах Cisco Nexus серии 7000.

Предварительные условия

Требования

Удостоверьтесь в соответствии этим требованиям перед попыткой применения этой конфигурации:

  • Имейте базовые знания о конфигурации на Коммутаторах Cisco Nexus серии 7000

  • Имейте базовые знания о ERSPAN

Используемые компоненты

Сведения в этом документе основываются на Nexus Коммутатор серии 7018 на Выпуске 5.1 (3) программного обеспечения Cisco NX-OS.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Более подробную информацию о применяемых в документе обозначениях см. в описании условных обозначений, используемых в технической документации Cisco.

Общие сведения

О ERSPAN

  • ERSPAN включает удалeнный мониторинг нескольк блоков коммутаторов по сети.

  • ERSPAN транспортирует зеркальный трафик от исходных портов других коммутаторов в порт назначения, где соединился анализатор сети.

  • Трафик инкапсулируется в исходном коммутаторе и передан конечному коммутатору, где пакет декапсулирован и затем передан к порту назначения.

  • ERSPAN состоит из исходного сеанса ERSPAN, маршрутизуемой универсальной инкапсуляции маршрутизации (GRE) ERSPAN - инкапсулированный трафик и целевой сеанс ERSPAN.

  • Можно настроить исходные сеансы ERSPAN и целевые сеансы на других коммутаторах отдельно.

  • ERSPAN не контролирует пакетов, которые генерируются супервизором, независимо от их источника.

Источники ERSPAN

  • Интерфейсы, от которых может быть проверен трафик, называют источниками ERSPAN.

  • Можно контролировать все пакеты для исходного порта, который получен (вход), передал (выход), или двунаправленный (оба).

  • Источники ERSPAN включают исходные порты, исходные VLAN или исходные vsan. Когда VLAN задана как источник ERSPAN, все поддерживаемые интерфейсы в VLAN являются источниками ERSPAN.

Назначения ERSPAN

  • Порты назначения получают скопированный трафик от источников ERSPAN.

  • Порт назначения является портом, который был связан с устройством, таким как Устройство SwitchProbe или другой зонд Удалeнного мониторинга (RMON) или устройство безопасности, которое может получить и проанализировать скопированные пакеты от порта несколька источников или одиночного.

  • Порты назначения не участвуют ни в каком экземпляре связующего дерева или любых протоколах Уровня 3.

Настройка

Этот пример конфигурации использует исходный порт на Коммутаторе Cisco Nexus серии 7000 1 и порт назначения на другом Коммутаторе Nexus 7000, где соединился анализатор сети. Существует Соединение Ethernet между обоими коммутаторы, как показано в схеме.

Примечание: Используйте инструмент Command Lookup (только для зарегистрированных пользователей) для того, чтобы получить более подробную информацию о командах, использованных в этом разделе.

Схема сети

В этом документе использованы параметры данной сети:

http://www.cisco.com/c/dam/en/us/support/docs/switches/nexus-7000-series-switches/113480-erspan-nexus-7k-01.gif

Конфигурации

Эти конфигурации используются в данном документе:

Коммутатор Nexus 7000 1
switch_1#configure terminal


!--- Configures an ERSPAN source session.

switch_1(config)#monitor session 48 type erspan-source

!--- Configure the sources and traffic direction.

switch_1(config-erspan-src)#source interface Ethernet2/10 both

!--- Configure the destination IP address in the ERSPAN session.

switch_1(config-erspan-src)#destination ip 10.11.11.3

!--- Configure the ERSPAN ID.

switch_1(config-erspan-src)#erspan-id 902

!--- Configure the VRF.

switch_1(config-erspan-src)#vrf default

!--- Enable the ERSPAN source session (by default the session is 
!--- in shutdown state).

switch_1(config-erspan-src)#no shut
switch_1(config-erspan-src)#exit


!--- Configure the ERSPAN global origin IP address.

switch_1(config)#monitor erspan origin ip-address 10.254.254.21 global



!--- Configure the IP address for loopback interface, which is used
!--- as source of the ERSPAN traffic.

switch_1(config)#interface loopback1
switch_1(config-if)#ip address 10.254.254.21/32
switch_1(config-if)#exit

switch_1(config)#interface Ethernet1/1
switch_1(config-if)#switchport
switch_1(config-if)#switchport mode trunk
switch_1(config-if)#no shutdown
switch_1(config-if)#exit

switch_1(config)#feature interface-vlan
switch_1(config)#interface Vlan 11
switch_1(config-if)#ip address 10.11.11.2/29
switch_1(config-if)#no ip redirects
switch_1(config-if)#no shutdown
switch_1(config-if)#exit


!--- Save the configurations in the device.

switch_1(config)#copy running-config startup-config
Switch_1(config)#exit

Коммутатор Nexus 7000 2
switch_2#configure terminal


!--- Configures an ERSPAN destination session.

switch_2(config)#monitor session 47 type erspan-destination

!--- Configures the source IP address.

switch_2(config-erspan-src)#source ip 10.11.11.3

!--- Configures a destination for copied source packets.

switch_2(config-erspan-src)#destination interface Ethernet2/34

!--- Configure the ERSPAN ID.

switch_2(config-erspan-src)#erspan-id 902

!--- Configure the VRF.

switch_2(config-erspan-src)#vrf default

!--- Enable the ERSPAN destination session (by default the session is 
!--- in shutdown state).

switch_2(config-erspan-src)#no shut
switch_2(config-erspan-src)#exit

switch_2(config)#interface Ethernet2/34
switch_2(config-if)#switchport monitor
switch_2(config-if)#exit

switch_2(config)#feature interface-vlan
switch_2(config)#interface Vlan 11
switch_2(config-if)#ip address 10.11.11.3/29
switch_2(config-if)#no ip redirects
switch_2(config-if)#no shutdown
switch_2(config-if)#exit

switch_2(config)#interface Ethernet1/2
switch_2(config-if)#switchport
switch_2(config-if)#switchport mode trunk
switch_2(config-if)#no shutdown
switch_2(config-if)#exit


!--- Save the configurations in the device.

switch_2(config)#copy running-config startup-config
Switch_2(config)#exit

Проверка.

Воспользуйтесь данным разделом для проверки правильности функционирования вашей конфигурации.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Это некоторые команды проверки ERSPAN:

  • Используйте команду show monitor для показа статуса сеансов ERSPAN:

    switch_1# show monitor
    Session  State        Reason                  Description
    -------  -----------  ----------------------  --------------------------------
    4        up           The session is up
  • Используйте show monitor session [открывают сеанс session_number] команда для показа конфигурации сеанса ERSPAN:

    switch_1# show monitor session 48
       session 48
    ---------------
    type              : erspan-source
    state             : up
    erspan-id         : 902
    vrf-name          : default
    acl-name          : acl-name not specified
    ip-ttl            : 255
    ip-dscp           : 0
    destination-ip    : 10.11.11.3
    origin-ip         : 10.254.254.21 (global)
    source intf       :
        rx            : Eth2/10
        tx            : Eth2/10
        both          : Eth2/10
    source VLANs      :
        rx            :
        tx            :
        both          :
    filter VLANs      : filter not specified
  • Используйте show monitor session вся команда для показа, весь ERSPAN открывает сеанс конфигурацию в устройстве.

  • Используйте команду контроля config покажите выполнение для показа выполнения конфигурация ERSPAN:

    switch_1# show running-config monitor
    
    !Command: show running-config monitor
    !Time: Thu Apr 19 10:15:33 2012
    
    version 5.1(3)
    monitor session 48 type erspan-source
      erspan-id 902
      vrf default
      destination ip 10.11.11.3
      source interface Ethernet2/10 both
      no shut
    
    monitor erspan origin ip-address 10.254.254.21 global
  • Используйте команду контроля show startup-config для показа загрузочной конфигурации ERSPAN.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 113480