Протокол IP : IP версии 6 (IPv6)

Перераспределите маршруты OSPFv3 в примере BGP - конфигурации

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ предоставляет пример перераспределения маршрутов Открытого кратчайшего пути первой версии 3 (OSPFv3) в к Многопротокольному BGP для IPv6. OSPFv3 подробно останавливается на версии 2 OSPF для оказания поддержки для префиксов маршрутизации IPv6 и адресов IPv6 большего размера. Многопротокольный BGP является расширенным BGP, который несет сведения о маршрутизации для несколько сетей семейств адресов протокола уровня, такой как, семейство адреса IPv6 и для маршрутов групповой IP-адресации.

Предварительные условия

Предварительные условия

Удостоверьтесь в соответствии этим требованиям перед попыткой применения этой конфигурации:

Версии аппаратного и программного обеспечения

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Конфигурации в этом документе основываются на Маршрутизаторе серии Cisco 3700 с Cisco Выпуск ПО IOS� 12.4 (15) T1.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Настройка

В данном примере маршрутизаторы R2 и R3 связаны через последовательный интерфейс и настроены с Многопротокольным BGP. Маршрутизаторы R2 и R3 передают с их локальными маршрутизаторами R1 и R4 с помощью OSPFv3. Адреса обратной связи созданы в маршрутизаторах для генерации сетей. Маршрутизаторы R2 и R3, которые выполняют и BGP и OSPFv3, используют перераспределять команду для перераспределения маршрутов OSPFv3 в к BGP. Все маршрутизаторы настроены с адресами IPv6.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

В настоящем документе используется следующая схема сети:

http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6-ipv6/113453-redis-ospfv3-bgp-01.gif

Конфигурации

Эти конфигурации используются в данном документе:

Маршрутизатор М1
!
version 12.4
!
hostname R1
!
ip cef
!
ipv6 unicast-routing

!--- Enables the forwarding of IPv6 packets.

!
interface Loopback0
 no ip address
 ipv6 address 2222::1/128
 ipv6 ospf 1 area 0

!--- Enables OSPFv3 on the interface and associates
!--- the interface loopback0 to area 0.

!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 1010:1:1:1::1/64
 ipv6 ospf 1 area 0

!--- Associates the Interface Fa0/0 to area 0.

!
ipv6 router ospf 1
 router-id 1.1.1.1

!--- Router R1 uses 1.1.1.1 as router ID.

 log-adjacency-changes
!
end

Маршрутизатор М2
!
version 12.4
!
hostname R2
!
ip cef
!
ipv6 unicast-routing
!
interface Loopback0
 no ip address
 ipv6 address 2010::1/128
 ipv6 ospf 1 area 1
!
interface Loopback1
 no ip address
 ipv6 address 2011::1/128
 ipv6 ospf 1 area 1
!
interface Loopback99
 no ip address
 ipv6 address 5050:55:55:55::55/128
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 1010:1:1:1::2/64
 ipv6 ospf 1 area 0
!
interface Serial0/0
 no ip address
 ipv6 address 3030:1:1:1::10/64
 clock rate 2000000
!
router bgp 65000
 bgp router-id 1.1.1.1
 no bgp default ipv4-unicast

!--- Without configuring "no bgp default ipv4-unicast" only 
!--- IPv4 will be advertised.

 bgp log-neighbor-changes
 neighbor 3030:1:1:1::11 remote-as 65000
 neighbor 3030:1:1:1::11 update-source Serial0/0
 !
 address-family ipv6
  neighbor 3030:1:1:1::11 activate
  network 5050:55:55:55::55/128
  redistribute connected
  redistribute ospf 1 match internal external 1 external 2

!--- This redistributes all OSPF routes into BGP.

  no synchronization
 exit-address-family
!
ipv6 router ospf 1
 router-id 2.2.2.2
 log-adjacency-changes
!
end

Маршрутизатор R3
!
version 12.4
!
hostname R3
!
ip cef
!
ipv6 unicast-routing
!
interface Loopback0
 no ip address
 ipv6 address 1111::1/128
 ipv6 ospf 1 area 1
!
interface Loopback1
 no ip address
 ipv6 address 1112::1/128
 ipv6 ospf 1 area 1
!
interface Loopback99
 no ip address
 ipv6 address 6060:66:66:66::66/128
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2020:1:1:1::2/64
 ipv6 ospf 1 area 0
!
interface Serial0/0
 no ip address
 ipv6 address 3030:1:1:1::11/64
 clock rate 2000000
!
router bgp 65000
 bgp router-id 2.2.2.2
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 3030:1:1:1::10 remote-as 65000
 neighbor 3030:1:1:1::10 update-source Serial0/0
 !
 address-family ipv6
  neighbor 3030:1:1:1::10 activate
  network 6060:66:66:66::66/128
  redistribute connected
  redistribute ospf 1 match internal external 1 external 2
  no synchronization
 exit-address-family
!
ipv6 router ospf 1
 router-id 3.3.3.3
 log-adjacency-changes
!
end

Маршрутизатор R4
!
version 12.4
!
hostname R4
!
ip cef
!
ipv6 unicast-routing
!
interface Loopback0
 no ip address
 ipv6 address 3333::1/128
 ipv6 ospf 1 area 0
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2020:1:1:1::1/64
 ipv6 ospf 1 area 0
!
ipv6 router ospf 1
 router-id 5.5.5.5
 log-adjacency-changes
!
end

Проверка

Воспользуйтесь данным разделом для проверки правильности функционирования вашей конфигурации.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Эти команды показа используются для проверки конфигурации:

Проверьте конфигурацию OSPFv3

Чтобы проверить, что OSPFv3 настроен должным образом, используйте команду настройки OSPF show ipv6 route в маршрутизаторах R1 и R4.

ospf show ipv6 route
В маршрутизаторе R1
R1#show ipv6 route ospf
IPv6 Routing Table - 6 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
OI  2010::1/128 [110/10]
     via FE80::C001:16FF:FEDC:0, FastEthernet0/0
OI  2011::1/128 [110/10]
     via FE80::C001:16FF:FEDC:0, FastEthernet0/0
В маршрутизаторе R4
R4#show ipv6 route ospf
IPv6 Routing Table - 6 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
OI  1111::1/128 [110/10]
     via FE80::C002:16FF:FEDC:0, FastEthernet0/0
OI  1112::1/128 [110/10]
     via FE80::C002:16FF:FEDC:0, FastEthernet0/0

Проверьте BGP - конфигурацию

Чтобы проверить, перераспределены ли маршруты OSPFv3 в к BGP, используйте команду show ipv6 route bgp в маршрутизаторах R2 и R3.

show ipv6 route bgp
В маршрутизаторе R2
R2#show ipv6 route bgp
IPv6 Routing Table - 14 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
B   1111::1/128 [200/0]
     via 3030:1:1:1::11
B   1112::1/128 [200/0]
     via 3030:1:1:1::11
B   2020:1:1:1::/64 [200/0]
     via 3030:1:1:1::11
B   3333::1/128 [200/10]
     via 3030:1:1:1::11

!--- The above routes are OSPFv3 routes
!--- that are redistributed in to BGP.

B   6060:66:66:66::66/128 [200/0]
     via 3030:1:1:1::11
В маршрутизаторе R3
R3#show ipv6 route bgp
IPv6 Routing Table - 14 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
B   1010:1:1:1::/64 [200/0]
     via 3030:1:1:1::10
B   2010::1/128 [200/0]
     via 3030:1:1:1::10
B   2011::1/128 [200/0]
     via 3030:1:1:1::10
B   2222::1/128 [200/10]
     via 3030:1:1:1::10

!--- The above routes are OSPFv3 routes
!--- that are redistributed in to BGP.

B   5050:55:55:55::55/128 [200/0]
     via 3030:1:1:1::10


Дополнительные сведения


Document ID: 113453