Беспроводные сети : Контроллеры беспроводной локальной сети Cisco серии 5500

Беспроводная локальная сеть решение для ограничения скорости для каждого пользователя

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Отзыв


Содержание


Введение

http://www.cisco.com/c/dam/en/us/support/docs/wireless/5500-series-wireless-controllers/113435-wlan-user-rls-01.gif

Ограничение скорости нисходящего трафика для каждого пользователя для беспроводной сети может быть реализовано средствами контроллеров Cisco WLAN. В то же время, дооснащение решения функциями контроля микропотоков IOS обеспечивает более детальный механизм ограничения скорости как во входящем, так и в исходящем направлении. Мотивация для осуществления диапазонов ограничения скорости для каждого пользователя от защиты “пожирателя ресурсов” пропускной способности должна внедрить разделенные на уровни модели пропускной способности для доступа сети заказчика, и в некоторых случаях, конкретные ресурсы белого списка, которые освобождены от пропускной способности, определяющей политику как требование. В дополнение к удушению трафика IPv4 текущего поколения решение способно к ограничению скорости IPv6 для каждого пользователя. Это предоставляет защиту инвестиций.

Предварительные условия

Требования

Управление микропотоком требует использования модуля управления Supervisor 720 или позже который выполняет версию Cisco Выпуск ПО IOS� 12.2 (14) SX или позже.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Контроллеры беспроводных LAN

  • Точки доступа (AP)

  • Модуль управления Supervisor 720 Cisco Catalyst или позже

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Конфигурация Catalyst 6500

Конфигурация управления микропотоком

Выполните следующие действия:

  1. Использование Управления микропотоком сначала требует, чтобы список контроля доступа (ACL) был создан для определения трафика для применения политики удушения.

    Примечание: Этот пример конфигурации использует 192.168.30.x/24 подсеть для беспроводных клиентов.

    ip access-list extended acl-wireless-downstream
    permit ip any 192.168.30.0 0.0.0.255
    ip access-list extended acl-wireless-upstream
    permit ip 192.168.30.0 0.0.0.255 any
  2. Создайте class-map для соответствия на предыдущем ACL.

    class-map match-all class-wireless-downstream
    match access-group name acl-wireless-downstream
    class-map match-all class-wireless-upstream
    match access-group name acl-wireless-upstream
  3. Создание policy-map свяжет ранее созданный ACL и class-map к отдельному действию для применения к трафику. В этом случае трафик душат к 1 Мбит/с в обоих направлениях. Исходная маска потока используется в восходящем направлении (клиент к AP), и целевая маска потока используется в нижележащем направлении (AP клиенту).

    policy-map police-wireless-upstream
    class class-wireless-upstream
    police flow mask src-only 1m 187500 conform-action transmit exceed-action drop
    policy-map police-wireless-downstream
    class class-wireless-downstream
    police flow mask dest-only 1m 187500 conform-action transmit exceed-action drop

Для получения дополнительной информации о настройке Управления микропотоком обратитесь к Основанному на пользователе Ограничению скорости в Cisco Catalyst 6500.

Регулировка политика ограничения скорости пропускной способности

Программное заявление в policy-map - то, где настроена реальная пропускная способность (настроенный в битах) и Размер пакета (настроенный в байтах) параметры.

Хорошее эмпирическое правило для размера пакета:

Burst = (Bandwidth / 8) * 1.5

Пример:

Это использования линии скорость 1 Мбит/с (биты):

police flow mask dest-only 1m 187500 conform-action transmit exceed-action drop

Это использования линии скорость 5 Мбит/с (биты):

police flow mask dest-only 5mc 937500 conform-action transmit exceed-action drop

Ресурсы белого списка от применения политик пропускной способности

В некоторых случаях определенные, некоторый сетевые ресурсы должны быть освобождены от пропускной способности, определяющей политику, такой как сервер Windows Update или устройство исправления положения. В дополнение к хостам белый список может также использоваться для освобождения всех подсетей от применения политик пропускной способности.

Пример:

Данный пример исключает хост 192.168.20.22 из любого ограничения пропускной способности при передаче с 192.168.30.0/24 сетью.

ip access-list extended acl-wireless-downstream
deny ip host 192.168.20.22 192.168.30.0 0.0.0.255
permit ip any 192.168.30.0 0.0.0.255
ip access-list extended acl-wireless-upstream
deny ip 192.168.30.0 0.0.0.255 host 192.168.20.22
permit ip 192.168.30.0 0.0.0.255 any

Управление микропотоком IPv6

http://www.cisco.com/c/dam/en/us/support/docs/wireless/5500-series-wireless-controllers/113435-wlan-user-rls-02.gif

Выполните следующие действия:

  1. Добавьте другой список доступа на Catalyst 6500 для определения трафика IPv6, который задушат.

    ipv6 access-list aclv6-wireless-downstream
    permit ipv6 any 2001:DB8:0:30::/64
    !
    ipv6 access-list aclv6-wireless-upstream
    permit ipv6 2001:DB8:0:30::/64 any
    
  2. Модифицируйте class-map для включения ACL IPv6.

    class-map match-any class-wireless-downstream
    match access-group name aclv6-wireless-downstream
    match access-group name acl-wireless-downstream
    class-map match-any class-wireless-upstream
    match access-group name aclv6-wireless-upstream
    match access-group name acl-wireless-upstream

Основанный на устройстве (2500, 4400, 5500) конфигурация контроллера

Для обеспечения Управления микропотоком основанным на устройстве контроллером, такой как серии 5508, конфигурация упрощенна. В то время как политика обслуживания Catalyst 6500 применена к интерфейсу контроллера, интерфейс контроллера настроен подобный любой другой VLAN.

http://www.cisco.com/c/dam/en/us/support/docs/wireless/5500-series-wireless-controllers/113435-wlan-user-rls-03.gif

Выполните следующие действия:

  1. Примените police-wireless-upstream на входящий порт от контроллера.

    interface GigabitEthernet4/13
    description WLC
    switchport
    switchport trunk allowed vlan 30
    switchport mode trunk
    service-policy input police-wireless-upstream
    end
    
  2. Примените policy-wireless-downstream на соединительные порты LAN/WAN.

    interface GigabitEthernet4/20
    description WAN
    switchport
    switchport access vlan 20
    switchport mode access
    service-policy input police-wireless-downstream
    end

Основанный на модуле (WiSM, WiSM2) конфигурация контроллера

Для усиления Управления микропотоком на Catalyst 6500 с Беспроводным сервисом Module2 (WiSM2) конфигурация должна быть отрегулирована для использования Качества обслуживания (QoS) на основе VLAN. Это означает, что политика Управления микропотоком не применена непосредственно к интерфейсу порта (например, Gi1/0/1), но применена на интерфейс виртуальной локальной сети (VLAN).

http://www.cisco.com/c/dam/en/us/support/docs/wireless/5500-series-wireless-controllers/113435-wlan-user-rls-04.gif

Выполните следующие действия:

  1. Настройте WiSM для QoS на основе VLAN:

    wism service-vlan 800
    wism module 1 controller 1 allowed-vlan 30
    wism module 1 controller 1 qos vlan-based
  2. Примените policy-wireless-upstream на клиентский SVI VLAN:

    interface Vlan30
    description Client-Limited
    ip address 192.168.30.1 255.255.255.0
    ipv6 address 2001:DB8:0:30::1/64
    ipv6 enable
    service-policy input police-wireless-upstream
    end
  3. Примените policy-wireless-downstream на соединительные порты LAN/WAN.

    interface GigabitEthernet4/20
    description WAN
    switchport
    switchport access vlan 20
    switchport mode access
    service-policy input police-wireless-downstream
    end

Проверка решения

Одно из основных требований ограничения скорости для каждого пользователя является возможностью ограничить все потоки, прибывающие из и предназначенный индивидуальному пользователю. Чтобы проверить, что решение для Управления микропотоком удовлетворяет это требование, IxChariot используется для моделирования четырех одновременных сеансов загрузки и четырех одновременных сеансов загрузки для индивидуального пользователя. Это может представлять кого-то запускающего сеанс FTP, просматривая веб-сайты и наблюдая видеопоток при отправке электронного письма с большим присоединением, и т.д.

В этом тесте IxChariot настроен со сценарием “Throughput.scr” с помощью Трафика TCP для измерения скорости ссылки с помощью задушенного трафика. Решение для Управления микропотоком в состоянии задушить, все течет к в общей сложности 1 Мбит/с нисходящий и 1 Мбит/с в восходящем направлении для пользователя. Кроме того, все потоки используют примерно 25% доступной пропускной способности (например, 250 Кбит/с за поток x 4 = 1 Мбит/с).

http://www.cisco.com/c/dam/en/us/support/docs/wireless/5500-series-wireless-controllers/113435-wlan-user-rls-05.gif

Примечание: Поскольку действие Управления микропотоком происходит на Уровне 3, конечный результат для пропускной способности Трафика TCP может быть меньше, чем настроенная скорость из-за служебной информации протокола.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения