Протокол IP : Протокол BGP

Пример конфигурации отражателя маршрута BGP IPv6

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ предоставляет пример конфигурации с помощью IPv6, который помогает вам понимать функцию Рефлектора маршрута (RR) в Протоколе BGP. По умолчанию маршруты, полученные от равноправного объекта IBGP, не передаются другому равноправному объекту IBGP, пока конфигурация полной сетки не сформирована между всеми маршрутизаторами под управлением BGP в AS. Это приводит к проблемам масштабирования. Использование отражателей маршрута BGP приводит к намного более высоким уровням масштабируемости.

Рефлектор маршрута Настройки позволяет маршрутизатору объявлять или отражать маршруты полученный с помощью протокола iBGP другим динамикам iBGP. Маршрутизатором, как говорят, является Рефлектор маршрута, когда настроено с командой neighbor route-reflector-client и соседними узлами, в которых точки команды являются клиентами того RR.

Предварительные условия

Требования

Удостоверьтесь в соответствии этим требованиям перед попыткой применения этой конфигурации:

  • Имейте понимание протокола маршрутизации BGP и его операции

  • Имейте понимание Схемы адресации IPv6

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Конфигурации в этом документе основываются на Маршрутизаторе серии Cisco 3700 с Cisco Выпуск ПО IOS� 12.4 (15) T1.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Настройка

В данном примере Маршрутизатор A настроен как RR, и маршрутизаторы RRClient1 и RRClient2 являются клиентами Маршрутизатора A. Все маршрутизаторы настроены, чтобы быть в AS 100, невзирая на то, что маршрутизаторы не имеют конфигурации полной сетки. Вместо этого это использует функцию RR BGP для передачи друг с другом.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

В этом документе использованы параметры данной сети:

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/113419-ipv6-bgp-rr-01.gif

Примеры конфигураций

Эти конфигурации используются в данном документе:

Маршрутизатор А
hostname Router-A
!
ip cef
!
ipv6 unicast-routing
!
interface Loopback0
 no ip address
 ipv6 address 2011:11:11:11::11/128
 ipv6 ospf 10 area 0
!
interface Serial0/0
 no ip address
 ipv6 address 2011:12:12:12::1/64
 ipv6 ospf 10 area 0
 clock rate 2000000
!
interface Serial0/1
 no ip address
 ipv6 address 2011:13:13:13::1/64
 ipv6 ospf 10 area 0
 clock rate 2000000
!
router bgp 100
 bgp router-id 1.1.1.1
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 2011:22:22:22::22 remote-as 100
 neighbor 2011:22:22:22::22 update-source Loopback0
 neighbor 2011:33:33:33::33 remote-as 100
 neighbor 2011:33:33:33::33 update-source Loopback0
 !
 address-family ipv6
  neighbor 2011:22:22:22::22 activate
  neighbor 2011:22:22:22::22 route-reflector-client

!--- Configures the router RRClient1
as route reflector client!


  neighbor 2011:33:33:33::33 activate
  neighbor 2011:33:33:33::33 route-reflector-client

!--- Configures the router RRClient2
as route reflector client!

 exit-address-family
!
ip forward-protocol nd
!
ipv6 router ospf 10
 router-id 1.1.1.1

!--- Router ID of the route reflector router A!

 log-adjacency-changes
!
end

RRClient1
hostname RR-Client1
!
ip cef
!
ipv6 unicast-routing
!
interface Loopback0
 no ip address
 ipv6 address 2011:22:22:22::22/128
 ipv6 ospf 10 area 0
!
interface Loopback10
 no ip address
 ipv6 address 1010:10:10:10::10/128
!
interface Serial0/0
 no ip address
 ipv6 address 2011:12:12:12::2/64
 ipv6 ospf 10 area 0
 clock rate 2000000
!
router bgp 100
 bgp router-id 2.2.2.2

!--- Router ID of the RRClient1

 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 2011:11:11:11::11 remote-as 100
 neighbor 2011:11:11:11::11 update-source Loopback0
 !
 address-family ipv6
  neighbor 2011:11:11:11::11 activate
  network 1010:10:10:10::10/128
 exit-address-family
!
!
ip forward-protocol nd
!
ipv6 router ospf 10
 router-id 2.2.2.2
 log-adjacency-changes
!
!
end

RRClient2
hostname RR-Client2
!
ip cef
!
no ip domain lookup
ipv6 unicast-routing
!
!
interface Loopback0
 no ip address
 ipv6 address 2011:33:33:33::33/128
 ipv6 ospf 10 area 0
!
interface Loopback20
 no ip address
 ipv6 address 2020:20:20:20::20/128
!
interface Serial0/0
 no ip address
 ipv6 address 2011:13:13:13::2/64
 ipv6 ospf 10 area 0
 clock rate 2000000
!
router bgp 100
 bgp router-id 3.3.3.3

!--- Router ID of the RRClient2

 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 2011:11:11:11::11 remote-as 100
 neighbor 2011:11:11:11::11 update-source Loopback0
 !
 address-family ipv6
  neighbor 2011:11:11:11::11 activate
  network 2020:20:20:20::20/128
 exit-address-family
!
ip forward-protocol nd
!
ipv6 router ospf 10
 router-id 3.3.3.3
 log-adjacency-changes
!
end

Проверка.

Этот раздел позволяет убедиться, что конфигурация работает правильно.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Эти команды показа используются для подтверждения конфигурации:

В клиентах RR:

show ipv6 route bgp
В RRClient1
RRClient1#sh ipv6 route bgp
IPv6 Routing Table - 9 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
B   2020:20:20:20::20/128 [200/0]
     via 2011:33:33:33::33

!--- The iBGP route from RRClient2 is reflected


RRClient1#ping 2011:33:33:33::33
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2011:33:33:33::33, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 16/24/32 ms

!--- Ping to the RRClient2 from RRClient1 is successful

В RRClient2
RRCLlient2#sh ipv6 route bgp
IPv6 Routing Table - 9 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
B   1010:10:10:10::10/128 [200/0]
     via 2011:22:22:22::22

!--- The iBGP route from RRClient1 is reflected

RRCLlient2#ping 1010:10:10:10::10

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 1010:10:10:10::10, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 40/50/76 ms

!--- Ping to the RRClient1 from RRClient2 is successful

В маршрутизаторе A:

show bgp ipv6 одноадресно передал префикс IPv6
RouterA#sh bgp ipv6 unicast 1010:10:10:10::10/128
BGP routing table entry for 1010:10:10:10::10/128, version 3
Paths: (1 available, best #1, table Global-IPv6-Table)
  Advertised to update-groups:
        1
  Local, (Received from a RR-client)

!--- Indicates that the route was received from a route-reflector
 client router RRClient1

    2011:22:22:22::22 (metric 64) from 2011:22:22:22::22 (2.2.2.2)
      Origin IGP, metric 0, localpref 100, valid, internal, best
RouterA#show bgp ipv6 unicast 2020:20:20:20::20/128
BGP routing table entry for 2020:20:20:20::20/128, version 2
Paths: (1 available, best #1, table Global-IPv6-Table)
  Advertised to update-groups:
        1
  Local, (Received from a RR-client)

!--- Indicates that the route was received from a route-reflector
client router RRClient2

    2011:33:33:33::33 (metric 64) from 2011:33:33:33::33 (3.3.3.3)
      Origin IGP, metric 0, localpref 100, valid, internal, best

В клиентах RR:

Каждый раз, когда маршрут IBGP отражен (т.е. распространившийся к другому равноправному объекту IBGP), маршрутизатор, внедряющий рефлектор маршрута (в нашем случае, Маршрутизаторе A), добавляет 2 нетранзитивных атрибута:

  • Удержание VAD:

    Это - непереходный дополнительный атрибут BGP. Отраженный маршрут IBGP будет иметь идентификатор маршрутизатора равноправного объекта IBGP, от которого маршрут был получен как его удержание VAD. В нашем примере, маршруте 2020:20:20:20:: 20/128, который является от RRClient 2, отражен Маршрутизатором A (RR) к RRClient1. В результате этот маршрут будет иметь Идентификатор маршрутизатора RRClient2 (Идентификатор маршрутизатора: 3.3.3.3) как его Удержание VAD.

  • Кластерный ID:

    Это - непереходный дополнительный атрибут BGP. Если кластерное значение идентификатора не будет настроено, отраженный маршрут IBGP будет иметь идентификатор маршрутизатора RR как его Кластерный ID. В нашем примере, маршруте 2020:20:20:20:: 20/128 не настраивали кластерный идентификатор и поэтому Идентификатор маршрутизатора (Идентификатор маршрутизатора: 1.1.1.1) Маршрутизатора A (RR) будет Кластерный ID.

ipv6-префикс индивидуальной рассылки show bgp ipv6
В RRClient1
show bgp ipv6 unicast 2020:20:20:20::20/128
BGP routing table entry for 2020:20:20:20::20/128, version 3
Paths: (1 available, best #1, table Global-IPv6-Table)
  Not advertised to any peer
  Local
    2011:33:33:33::33 (metric 128) from 2011:11:11:11::11 (1.1.1.1)
      Origin IGP, metric 0, localpref 100, valid, internal, best
      Originator: 3.3.3.3, Cluster list: 1.1.1.1

!--- Originator ID 3.3.3.3 is the router id of the RRClient2 from
which the route is received!


!--- Similarly, Cluster ID 1.1.1.1 is the router ID of the
router reflector Router A!

В RRClient2
show bgp ipv6 unicast 1010:10:10:10::10/128
BGP routing table entry for 1010:10:10:10::10/128, version 3
Paths: (1 available, best #1, table Global-IPv6-Table)
  Not advertised to any peer
  Local
    2011:22:22:22::22 (metric 128) from 2011:11:11:11::11 (1.1.1.1)
      Origin IGP, metric 0, localpref 100, valid, internal, best
      Originator: 2.2.2.2, Cluster list: 1.1.1.1

!--- Originator ID 2.2.2.2 is the router ID of the RRClient1 from 
which the route is received!


!--- Similarly, Cluster ID 1.1.1.1 is the router ID of the
router reflector Router A!

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 113419