Протокол IP : IP версии 6 (IPv6)

Статические маршруты внедрения для Примера конфигурации IPv6

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ описывает, как настроить статические маршруты для IPv6. Статические маршруты являются вручную сконфигурированными маршрутами, который определяет явный путь между двумя устройствами. В случае изменения топологии в сети статические маршруты автоматически не обновлены как этот динамические протоколы и должны быть вручную реконфигурированы. Статические маршруты полезны для небольших сетей, который имеет только один путь к внешним сетям.

Основной недостаток использования статических маршрутов является отсутствием автоматической конфигурации в случае изменений топологии. Статические маршруты также внедрены для обеспечения безопасности для определенные типы трафиков к другим сетям, которые требуют большего контроля. Ограничения, которые рассматривают в использовании статических маршрутов, являются отсутствием резервирования, и в больших сетях ручная повторная настройка маршрутов может стать большой административной служебной информацией.

Используйте команду ipv6 route для настройки статичной маршрутизации. Обратите внимание на то, что перед настройкой маршрутизатора со статическим IPv6 route необходимо включить передачу пакетов IPv6 с командой ipv6 unicast-routing в режиме глобальной конфигурации.

Предварительные условия

Рассматриваемая процедура настройки предполагает выполнение следующих условий:

  • Знание статичной маршрутизации IPv4

  • Знание схемы адресации IPv6

Используемые компоненты

Сведения в этом документе основываются на Маршрутизаторе серии Cisco 3700 на Cisco Выпуск ПО IOS� 12.4 (15) T 13.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

В этом документе использованы параметры данной сети:

http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6-ipv6/113361-ipv6-static-routes-01.gif

Конфигурации

Эти конфигурации используются в данном документе:

Вот ссылка на видео, доступное на Сообществе Cisco Support leavingcisco.com, которое демонстрирует, как настроить статические маршруты для сети IPv6 в маршрутизаторах Cisco IOS:

Конфигурация статических маршрутов для IPv6 в Cisco IOS leavingcisco.com

http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6-ipv6/113361-ipv6-static-routes-02.gif

Маршрутизатор М1
version 12.4
!
hostname R1
!
ip cef
!
ipv6 unicast-routing

!--- Enables the forwarding of IPv6 packets.

!
interface Loopback1
 no ip address
 ipv6 address 1010::1/128
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2000::1/126
!
ip forward-protocol nd
!
ipv6 route 2001::/126 2000::2
ipv6 route 2020::1/128 2000::2
ipv6 route 3030::1/128 2000::2

!--- Static routes are configured in router R1, 
!--- to reach the networks in router R2 and R3.
!--- This is done when you specify 
!--- the next-hop address, which in this case is
!--- 2000::2 from which the output interface 
!--- is automatically derived.


!
end

Маршрутизатор М2
version 12.4
!
hostname R2
!
ip cef
!
ipv6 unicast-routing
!
interface Loopback2
 no ip address
 ipv6 address 2020::1/128
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2000::2/126
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address 2001::1/126
!
ip forward-protocol nd
!
ipv6 route 1010::1/128 2000::1
ipv6 route 3030::1/128 2001::2

!--- Static routes are configured to reach
!--- routers R1 and R3 loopback address when you 
!--- specify the corresponding interface address.

!
end

Маршрутизатор R3
version 12.4
!
hostname R3
!
ip cef
!
ipv6 unicast-routing
!
interface Loopback3
 no ip address
 ipv6 address 3030::1/128
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2001::2/126
!
ip forward-protocol nd
!
ipv6 route 1010::1/128 2001::1
ipv6 route 2000::/126 2001::1
ipv6 route 2020::1/128 2001::1

!--- For router 3, to reach R1 and R2, 
!--- static routes are configured when you 
!--- mention 2001::1 as the next-hop address.

!
end

Проверка.

Этот раздел позволяет убедиться, что конфигурация работает правильно.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Используйте show ipv6 route статическая команда для показа содержания таблицы маршрутизации IPv6, и выходные данные являются показом ниже:

статичный show ipv6 route
В маршрутизаторе R1
R1#show ipv6 route static
IPv6 Routing Table - 7 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
S   2001::/126 [1/0]
     via 2000::2
S   2020::1/128 [1/0]
     via 2000::2
S   3030::1/128 [1/0]
     via 2000::2

!--- Displays the static routes learnt by router R1 through 2000::2.

В маршрутизаторе R3
R3#show ipv6 route static
IPv6 Routing Table - 7 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
S   1010::1/128 [1/0]
     via 2001::1
S   2000::/126 [1/0]
     via 2001::1
S   2020::1/128 [1/0]
     via 2001::1

!--- Displays the static routes learnt by router R3 through 2001::1.

Маршрутизатор R1 имеет маршруты к маршрутизатору R2 и R3, поэтому, маршрутизатор R1 должен быть в состоянии пропинговать адрес обратной связи маршрутизатора R2's и маршрутизатор R3. Используйте команду ping для подтверждения того же.

В маршрутизаторе R1
Прозванивание адреса обратной связи маршрутизатора R2's
R1#ping 2020::1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2020::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 0/36/104 ms

!--- Router R1 is successfully able to ping 
!--- router R2's loopback address.

Прозванивание маршрутизатора R3
R1#ping 2001::2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001::2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/40/116 ms

R1#ping 3030::1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 3030::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/32/84 ms

!--- Similarly R1 is also able to reach R3,
!--- for example, ping to R3's interface address
!--- and loopback address from router R1 is successful.

Примечание: Так же маршрутизатор R3 может также достигнуть адреса Fa0/0 R1 маршрутизаторов 2000:: 1 и его адрес обратной связи 1010:: 1.

Используйте команду show ipv6 static , чтобы отобразить текущее содержание таблицы маршрутизации и использовать подробный синтаксис для показа более полезных сведений, которые обсуждены в данном примере:

show ipv6 static
В маршрутизаторе R1
R1#show ipv6 static
IPv6 Static routes
Code: * - installed in RIB
* 2001::/126 via nexthop 2000::2, distance 1
* 2020::1/128 via nexthop 2000::2, distance 1
* 3030::1/128 via nexthop 2000::2, distance 1

!--- Displays the routes that are installed in 
!--- the IPv6 Routing Information Base(RIB) marked with *!

Когда подробное ключевое слово задано, дополнительные сведения отображены. Это - выборка выходных данных:

подробность show ipv6 static
В маршрутизаторе R2
R2#show ipv6 static detail
IPv6 Static routes
Code: * - installed in RIB
* 1010::1/128 via nexthop 2000::1, distance 1
     Resolves to 1 paths (max depth 1)

!--- Displays the output path set, and maximum 
!--- resolution depth, which in this case is 1.

     via FastEthernet0/0
* 3030::1/128 via nexthop 2001::2, distance 1
     Resolves to 1 paths (max depth 1)
     via FastEthernet0/1

!--- Displays that the route is received through 
!--- the next-hop 2000::1 through interface fa0/0.

Примечание: В случае недопустимых маршрутов отображена эта информация:

  • Для недопустимых рекурсивных маршрутов, причина, почему маршрут не допустим.

  • Для прямого недопустимого или полностью указанные маршруты, причина, почему маршрут не допустим.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 113361