Протокол IP : Протокол OSPF

Перераспределите связанные сети в OSPF с ключевым словом подсети

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ описывает поведение перераспределения связанных маршрутов в Протокол OSPF. Существует два способов поведения, которые зависят от того, дано ли ключевое слово подсети или не при перераспределении связанных сетей. В общем случае при использовании команды redistribute для перераспределения маршрутов в домене OSPF, маршрутизатор автоматически становится граничным маршрутизатором автономной системы (ASBR) . По умолчанию, когда маршруты из протоколов перераспределены в к OSPF со связанным ключевым словом, эти маршруты становятся перераспределенными как внешними к AS и только маршрутам, которые не разделены на подсети, перераспределены. При включении ключевого слова подсетей OSPF перераспределяет маршруты, которые разделены на подсети. Процесс использует 20 в качестве метрики по умолчанию. Когда никакая метрика не задана при помощи ключевого слова типа метрики, это происходит.

Предварительные условия

Требования

Рассматриваемая процедура настройки предполагает выполнение следующих условий:

  • Знание маршрутизации общего IP

  • Знание понятий протокола маршрутизации OSPF и сроков

Используемые компоненты

Конфигурации в этом документе основываются на Маршрутизаторе серии Cisco 3700 на Cisco программное обеспечение Выпуска ПО IOS� 12.4 (15) T 13.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Маршрутизаторы R1, R2 и R3 связаны через последовательный интерфейс друг с другом и настроены с IP-адресом. Существуют некоторые адреса обратной связи, созданные и на R1 и на R3 для генерации сетей. В то время как R3 связывается с R1 с помощью OSPF, EIGRP работает на маршрутизаторах R1 и R2. Маршрутизатор R2, который выполняет и EIGRP и OSPF, использует перераспределять команду для перераспределения маршрутов EIGRP в к OSPF.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

В этом документе использованы параметры данной сети:

http://www.cisco.com/c/dam/en/us/support/docs/ip/open-shortest-path-first-ospf/113339-ospf-connected-net-01.gif

Конфигурации

Эти конфигурации используются в данном документе:

Маршрутизатор М1
version 12.4
!
hostname R1
!
ip cef
!
interface Loopback0
 ip address 10.10.10.10 255.255.255.240
!
interface Loopback1
 ip address 20.20.20.20 255.255.255.240
!
interface Loopback2
 ip address 30.30.30.30 255.255.255.240
!
interface Serial0/0
 ip address 172.16.10.1 255.255.248.0
 clock rate 2000000
!
router eigrp 100
 network 10.10.10.0 0.0.0.15
 network 20.20.20.16 0.0.0.15
 network 30.30.30.16 0.0.0.15
 network 172.16.8.0 0.0.7.255
 no auto-summary

!--- Auto-summary is disabled so that 
!--- the networks are summarized with subnets.

!
end

Маршрутизатор М2
version 12.4
!
hostname R2
!
ip cef
!
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
!
interface Loopback1
 ip address 2.2.2.2 255.255.255.255
!
interface Loopback2
 ip address 3.3.3.3 255.255.255.255
!
interface Serial0/0
 ip address 172.16.10.2 255.255.248.0
 clock rate 2000000
!
interface Serial0/1
 ip address 172.16.64.1 255.255.255.0
 clock rate 2000000
!
router eigrp 100
 network 1.0.0.0
 network 3.0.0.0
 network 172.16.8.0 0.0.7.255
 auto-summary
!
router ospf 100
 log-adjacency-changes
 redistribute eigrp 100 
 redistribute connected
 network 2.2.2.2 0.0.0.0 area 0
 network 172.16.64.0 0.0.0.255 area 0
!
end

Маршрутизатор R3
version 12.4
!
hostname R3
!
ip cef
!
interface Loopback0
 ip address 11.1.1.1 255.255.255.255
!
interface Loopback1
 ip address 12.1.1.1 255.255.255.255
!
interface Loopback2
 ip address 13.1.1.1 255.255.255.255
!
interface Serial0/0
 ip address 172.16.64.2 255.255.255.0
 clock rate 2000000
!
router ospf 100
 log-adjacency-changes
 network 11.1.1.1 0.0.0.0 area 0
 network 12.1.1.1 0.0.0.0 area 0
 network 13.1.1.1 0.0.0.0 area 0
 network 172.16.64.0 0.0.0.255 area 0
!
end

Проверка.

Проверьте перераспределение связанных сетей в OSPF

Воспользуйтесь данным разделом для проверки правильности функционирования вашей конфигурации.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Используйте команду show ip route ospf , чтобы проверить, что маршрутизатор R3 получил перераспределенные маршруты.

show ip route ospf
Когда связанные маршруты перераспределены с перераспределением связанного в маршрутизаторе R2: В маршрутизаторе R3
R3#show ip route ospf
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/65] via 172.16.64.1, 06:14:14, Serial0/0

!--- Only the classful routes are shown without actual subnets.

Когда перераспределено со спецификацией ключевого слова подсетей в перераспределять связанных подсетях в маршрутизаторе R2: В маршрутизаторе R3
R3#show ip route ospf
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/65] via 172.16.64.1, 06:14:14, Serial0/0
R3#sh ip route ospf
     1.0.0.0/32 is subnetted, 1 subnets
O E2    1.1.1.1 [110/20] via 172.16.64.1, 00:00:02, Serial0/0

!--- When routes are redistributed in to OSPF, 
!--- OSPF uses 20 as the default metric if 
!--- the metric-type keyword is not mentioned
!--- and the routes are redistributed as External Type 2(E2) routes.

     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/65] via 172.16.64.1, 06:36:58, Serial0/0
     3.0.0.0/32 is subnetted, 1 subnets
O E2    3.3.3.3 [110/20] via 172.16.64.1, 00:00:02, Serial0/0
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
O E2    172.16.8.0/21 [110/20] via 172.16.64.1, 00:00:02, Serial0/0

!--- On specifying the keyword subnets, 
!--- the routes are reflected along with the subnets.



!--- Only the classful routes are shown without actual subnets.

Проверьте Перераспределение маршрутов EIGRP в OSPF

Когда маршруты EIGRP перераспределены в к OSPF с перераспределять идентификатором <process eigrp> команда, маршруты перераспределены, поскольку E2 направляет с метрикой по умолчанию 20, когда не задано никакое ключевое слово типа метрики.

show ip route ospf
Когда EIGRP перераспределен с командой redistribute eigrp 100 в маршрутизаторе R2: В маршрутизаторе R3
R3#show ip route ospf
O E2 1.0.0.0/8 [110/20] via 172.16.64.1, 00:00:09, Serial0/0
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/65] via 172.16.64.1, 07:03:16, Serial0/0
O E2 3.0.0.0/8 [110/20] via 172.16.64.1, 00:00:09, Serial0/0
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
O E2    172.16.0.0/16 [110/20] via 172.16.64.1, 00:00:09, Serial0/0

!--- Only classful networks are redistributed by default.

Когда вы задаете ключевое слово подсети в команде redistribute eigrp 100 subnets в маршрутизаторе R2: В маршрутизаторе R3
R3#sh ip route ospf
O E2 1.0.0.0/8 [110/20] via 172.16.64.1, 00:06:19, Serial0/0
     2.0.0.0/32 is subnetted, 1 subnets
O       2.2.2.2 [110/65] via 172.16.64.1, 07:09:26, Serial0/0
O E2 3.0.0.0/8 [110/20] via 172.16.64.1, 00:06:19, Serial0/0
     20.0.0.0/28 is subnetted, 1 subnets
O E2    20.20.20.16 [110/20] via 172.16.64.1, 00:00:06, Serial0/0
     172.16.0.0/16 is variably subnetted, 2 subnets, 2 masks
O E2    172.16.0.0/16 [110/20] via 172.16.64.1, 00:06:19, Serial0/0
     10.0.0.0/28 is subnetted, 1 subnets
O E2    10.10.10.0 [110/20] via 172.16.64.1, 00:00:06, Serial0/0
     30.0.0.0/28 is subnetted, 1 subnets
O E2    30.30.30.16 [110/20] via 172.16.64.1, 00:00:06, Serial0/0

!--- On specifying the keyword subnets, 
!--- the subnetted routes are reflected along
!--- with their subnet mask.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 113339