5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Трансляция сетевых адресов - Трансляция портов (NAT-PT) является IPv6 к механизму трансляции IPv4, который позволяет устройствам только для IPv6 связываться с устройствами только для IPv4 и наоборот. NAT-PT разработан, чтобы быть развернутым для разрешения прямого соединения между сетями только для IPv6 и сетями только для IPv4 прозрачно, которые используют одиночный адрес V4.

Этот документ объясняет, как внедрить Статический NAT-PT, который использует пример конфигурации, куда узлы сети IPv6 связываются с узлами сети IPv4, которые используют сопоставление IPv6 IPv4 address, настроенного на маршрутизаторе NAT-PT.

Предварительные условия

Требования

Рассматриваемая процедура настройки предполагает выполнение следующих условий:

Примечание: NAT-PT считали осуждаемым IETF из-за его плотного соединения с Системой доменных имен (DNS) и его общих ограничений в трансляции, и это, оказалось, как технология было слишком сложно для поддержания масштабируемых переводных сервисов. С осуждением NAT-PT и увеличивающегося перехода IPv6 среди пользователей привел к введению NAT64. Сошлитесь на эти документы для получения дополнительной информации о NAT64:

Используемые компоненты

Конфигурации в этом документе основываются на Маршрутизаторе серии Cisco 3700 на Cisco Выпуск ПО IOS� 12.4 (15) T 13.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Настройка

В данном примере три маршрутизатора R1, R2 и R3 связаны через последовательный интерфейс, где R1 действует как маршрутизатор NAT-PT, который соединяется с маршрутизатором R2 с помощью IPv4 address и с R3 с помощью IPv6 address.

Примечание: NAT-PT не поддерживается в технологии CEF и должен быть отключен.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

Данный пример использует эту сетевую установку:

http://www.cisco.com/c/dam/en/us/support/docs/ip/network-address-translation-nat/113275-nat-ptv6-01.gif

Конфигурации

Данный пример использует их конфигурация:

Конфигурация R1
hostname R1
ipv6 unicast-routing
!
interface Serial0/0
 ip address 192.168.30.10 255.255.255.0
 duplex auto
 speed auto
 ipv6 nat
!
interface Serial0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address 2001:DB8:3002::9/64
 ipv6 enable
!
ipv6 route ::/0 2001:DB8:3002::10
ipv6 nat v4v6 source 192.168.30.9 2000::960B:202

!--- Translates the ipv4 add of R2 fa0/0 to ipv6 address.
          
ipv6 nat v6v4 source 3001:11:0:1::1 150.11.3.1

!--- Translates the ipv6 add of loop0 of R3 to ipv4 address.
              
ipv6 nat prefix 2000::/96

!--- The destination prefixes that matches 2000::/96 
!--- are translated by NAT-PT.
                            
!
end

Конфигурация R2
hostname R2
!
interface Serial0/0
 ip address 192.168.30.9 255.255.255.0
 duplex auto
 speed auto
!
ip route 0.0.0.0 0.0.0.0 192.168.30.10
!

!
end

Конфигурация R3
hostname R3
ipv6 unicast-routing
!
interface Loopback0
 no ip address
 ipv6 address 3001:11:0:1::1/64
!
interface Serial0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2001:DB8:3002::10/64
!
ipv6 route ::/0 2001:DB8:3002::9
!

Проверка.

Воспользуйтесь данным разделом для проверки правильности функционирования вашей конфигурации.

В маршрутизаторе R3

Теперь любой пакет от IPv6 address Loopback0 R3 должен быть в состоянии достигнуть fa0/0 IPv4 address R2 с помощью IPv6 address 2000:: 960B:202 как показано здесь:

Ping
R3#ping 2000::960b:202 sou lo 0

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2000::960B:202, timeout is 2 seconds:
Packet sent with a source address of 3001:11:0:1::1
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 8/60/124 ms

!--- This shows that the router R3 is able to reach 
!--- the router R2 through lo address 3001:11:0:1::1.

В маршрутизаторе R2

Ping
R2#ping 150.11.3.1

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 150.11.3.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 24/68/120 ms

!--- The successful ping response shows that the router R2
!--- is able to reach the IPv6 network.

В маршрутизаторе R1

show ipv6 nat translations

show ipv6 nat translations
R1#show ipv6 nat translations
Prot  IPv4 source              IPv6 source
      IPv4 destination         IPv6 destination
---   ---                      ---
      192.168.30.9             2000::960B:202

---   150.11.3.1               3001:11:0:1::1
      ---                      ---

R1#show ipv6 nat translations
Prot  IPv4 source              IPv6 source
      IPv4 destination         IPv6 destination
---   ---                      ---
      192.168.30.9             2000::960B:202

---   150.11.3.1               3001:11:0:1::1
      ---                      ---

!--- This command displays the active NAT-PT translations in the router.

debug ipv6 nat детализирован

debug ipv6 nat детализирован
R1#debug ipv6 nat detailed
R1#
*Mar  1 09:12:41.877: IPv6 NAT: Found prefix 2000::/96
*Mar  1 09:12:41.881: IPv6 NAT: IPv4->IPv6:
                 src (192.168.30.9 -> 2000::960B:202)
                 dst (0.0.0.0 -> ::)
                 ref_count = 1, usecount = 0, flags = 513,
                 rt_flags = 0, more_flags = 0

*Mar  1 09:12:41.881: IPv6 NAT: IPv4->IPv6:
                 src (0.0.0.0 -> ::)
                 dst (150.11.3.1 -> 3001:11:0:1::1)
                 ref_count = 1, usecount = 0, flags = 257,
                 rt_flags = 0, more_flags = 0

*Mar  1 09:12:41.925: IPv6 NAT: IPv6->IPv4:
                 src (3001:11:0:1::1 -> 150.11.3.1)
                 dst (2000::960B:202 -> 192.168.30.9)
                 ref_count = 1, usecount = 0, flags = 2,
                 rt_flags = 0, more_flags = 0

*Mar  1 09:12:41.925: IPv6 NAT: icmp src (3001:11:0:1::1) -> (150.11.3.1), 
                 dst (2000::960B:202) -> (192.168.30.9)
*Mar  1 09:12:41.965: IPv6 NAT: Found prefix 2000::/96
*Mar  1 09:12:41.965: IPv6 NAT: IPv4->IPv6:
                 src (192.168.30.9 -> 2000::960B:202)
                 dst (150.11.3.1 -> 3001:11:0:1::1)
                 ref_count = 1, usecount = 0, flags = 2,
                 rt_flags = 0,


!--- This command displays detailed information about NAT-PT events.

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 113275