Протокол IP : Протокол EIGRP

Пример конфигурации IPv6 EIGRP

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ описывает, как настроить протокол EIGRP для IPv6. EIGRP является расширенной версией IGRP, разработанного Cisco. Это - усовершенствованный протокол маршрутизации по методу вектора расстояния, который полагается на Diffused Update Algorithm (DUAL) для вычисления кратчайшего пути назначению в сети. EIGRP для IPv6 работает таким же образом как IPv4 EIGRP, где они могут настраиваться и управляться отдельно.

Предварительные условия

  • Базовые знания о EIGRPv4

  • Базовые знания об адресации IPv6

Ограничения

EIGRP Настройки для IPv6 имеет некоторые ограничения; они упомянуты ниже:

  • Интерфейсы могут быть непосредственно настроены с EIGRP для IPv6 без использования глобального IPv6 address. Нет никакой инструкции сети в EIGRP для IPv6.

  • Идентификатор маршрутизатора должен быть настроен для экземпляра протокола EIGRPv6, прежде чем он сможет работать.

  • EIGRP для IPv6 имеет функцию завершения. Гарантируйте, что процесс маршрутизации находится в режиме "нета закрытого", чтобы начать выполнять протокол.

Используемые компоненты

Конфигурации в этом документе основываются на Маршрутизаторе серии Cisco 3700 на программном обеспечении Cisco IOS версии 12.4(15)T 13.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Настройка

В данном примере два маршрутизатора (R1 и R2) настроены с IPv6 address. Адреса обратной связи назначены в обоих маршрутизаторах, и они настроены, чтобы быть в EIGRP1. EIGRPv6 включен на уровень интерфейса с помощью этой команды: поскольку-количество ipv6 eigrp

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

Данный пример использует эту сетевую установку:

http://www.cisco.com/c/dam/en/us/support/docs/ip/enhanced-interior-gateway-routing-protocol-eigrp/113267-eigrp-ipv6-01.gif

Конфигурации

Данный пример использует их конфигурация:

Конфигурация R1
hostname R1
!
ipv6 unicast-routing
!
interface Loopback0
 no ip address
 ipv6 address 1010:AB8::/64 eui-64
 ipv6 enable
 ipv6 eigrp 1
!
interface Loopback1
 no ip address
 ipv6 address 2020:AB8::/64 eui-64
 ipv6 enable
 ipv6 eigrp 1
!
interface Loopback2
 no ip address
 ipv6 address 3030:AB8::/64 eui-64
 ipv6 enable
 ipv6 eigrp 1
!
interface Serial0/0
 no ip address
 ipv6 address FE80::1 link-local
 ipv6 address 2010:AB8::1/64
 ipv6 enable
 ipv6 eigrp 1
 clock rate 2000000
!
ipv6 router eigrp 1
 router-id 2.2.2.2
 no shutdown
!
end

Конфигурация R2
hostname R2
!
ipv6 unicast-routing
!
interface Loopback0
 no ip address
 ipv6 address 1000:AB8::/64 eui-64
 ipv6 enable
 ipv6 eigrp 1
!
interface Loopback1
 no ip address
 ipv6 address 2000:AB8::/64 eui-64
 ipv6 enable
 ipv6 eigrp 1
!
interface Loopback2
 no ip address
 ipv6 address 3000:AB8::/64 eui-64
 ipv6 enable
 ipv6 eigrp 1
!
interface Serial0/0
 no ip address
 ipv6 address FE80::2 link-local
 ipv6 address 2010:AB8::2/64
 ipv6 enable
 ipv6 eigrp 1
 clock rate 2000000
!
ipv6 router eigrp 1
 router-id 1.1.1.1
 no shutdown
!
end

Проверка.

Этот раздел позволяет убедиться, что конфигурация работает правильно.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

Команды "show"

Команда show ipv6 eigrp neighbors отображает соседние узлы, обнаруженные EIGRPv6.

Show ipv6 eigrp neighbors
Маршрутизатор М1
IPv6-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq 
                                            (sec)         (ms)       Cnt Num
0   Link-local address:     Se0/0             13 15:17:58   44   264  0  12
    FE80::2

!--- Shows the link local address of router R2. 

Маршрутизатор М2
IPv6-EIGRP neighbors for process 1
H   Address                 Interface       Hold Uptime   SRTT   RTO  Q  Seq 
                                            (sec)         (ms)       Cnt Num
0   Link-local address:     Se0/0             14 16:32:05   30   300  0  12
    FE80::1

!--- Shows the link local address of router R1. 

Команда EIGRP show ipv6 route показывает содержание таблицы маршрутизации IPv6, которая включает маршруты, определенные для EIGRP.

eigrp show ipv6 route
Маршрутизатор М1
R1#show ipv6 route eigrp
IPv6 Routing Table - 12 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
D   1000:AB8::/64 [90/2297856]
     via FE80::2, Serial0/0
D   2000:AB8::/64 [90/2297856]
     via FE80::2, Serial0/0
D   3000:AB8::/64 [90/2297856]
     via FE80::2, Serial0/0

!--- This command shows IPv6-specific EIGRP routes.

Маршрутизатор М2
R2#show ipv6 route eigrp
IPv6 Routing Table - 12 entries
Codes: C - Connected, L - Local, S - Static, R - RIP, B - BGP
       U - Per-user Static route, M - MIPv6
       I1 - ISIS L1, I2 - ISIS L2, IA - ISIS interarea, IS - ISIS summary
       O - OSPF intra, OI - OSPF inter, OE1 - OSPF ext 1, OE2 - OSPF ext 2
       ON1 - OSPF NSSA ext 1, ON2 - OSPF NSSA ext 2
       D - EIGRP, EX - EIGRP external
D   1010:AB8::/64 [90/2297856]
     via FE80::1, Serial0/0
D   2020:AB8::/64 [90/2297856]
     via FE80::1, Serial0/0
D   3030:AB8::/64 [90/2297856]
     via FE80::1, Serial0/0

Команда show ipv6 eigrp interfaces отображает информацию об интерфейсах, которые настроены для EIGRP.

show ipv6 eigrp interfaces
Маршрутизатор М1
R1#show ipv6 eigrp 1 interface
IPv6-EIGRP interfaces for process 1

                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Se0/0              1        0/0        44       0/15         199           0
Lo0                0        0/0         0       0/1            0           0
Lo1                0        0/0         0       0/1            0           0
Lo2                0        0/0         0       0/1            0           0

!--- This command determines which interface EIGRP is active.

Маршрутизатор М2
R2#show ipv6 eigrp 1 interface
IPv6-EIGRP interfaces for process 1

                        Xmit Queue   Mean   Pacing Time   Multicast    Pending
Interface        Peers  Un/Reliable  SRTT   Un/Reliable   Flow Timer   Routes
Se0/0              1        0/0        30       0/15         135           0
Lo0                0        0/0         0       0/1            0           0
Lo1                0        0/0         0       0/1            0           0
Lo2                0        0/0         0       0/1            0           0

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 113267