Коммутаторы : Коммутаторы Cisco Catalyst серии 2960

Catalyst 2960/2950 Серия Переключает Использование Примера конфигурации Голосового VLAN

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Отзыв


Содержание


Введение

В этом документе приведен пример конфигурации сети VLAN для голосовой связи на коммутаторах Cisco Catalyst серии 2960/2950. В частности этот документ показывает, как настроить функцию VLAN для голосовой связи в коммутаторах Cisco Catalyst 2950.

Предварительные условия

Требования

Удостоверьтесь в соответствии этим требованиям перед попыткой применения этой конфигурации:

  • Имейте базовые знания о конфигурации на Cisco Catalyst 2960/2950 Коммутаторы Серии.

  • Имейте основное понимание голосового VLAN.

Используемые компоненты

Сведения в этом документе основываются на Cisco Catalyst 2950 Коммутаторов.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Более подробную информацию о применяемых в документе обозначениях см. в описании условных обозначений, используемых в технической документации Cisco.

Обзор голосового VLAN

Функция голосового VLAN разрешает портам коммутатора переносить голосовой трафик с IP precedence Уровня 3 и значениями класса обслуживания (CoS) Уровня 2 от IP-телефона. На основе CoS IEEE 802.1p, качество обслуживания (QoS) поддержки коммутаторов, которое использует классификацию и планирующий для передачи сетевого трафика от коммутатора. Можно настроить Cisco IP Phone, чтобы передать трафик с приоритетом IEEE 802.1p и настроить коммутатор, чтобы доверять или отвергнуть приоритет трафика, назначенный IP-телефоном.

Можно настроить порт коммутатора, который связан с IP-телефоном, для использования одной VLAN для голосового трафика и другой VLAN для трафика данных от устройства, подключенного к порту доступа IP-телефона. Можно настроить порты доступа на коммутаторе для передавания пакетов протокола CDP, чтобы дать подключенному IP-телефону команду передавать голосовой трафик к коммутатору любым из этих методов:

  • В голосовом VLAN, помеченном со значением приоритета CoS Уровня 2

  • В VLAN доступа, помеченной со значением приоритета CoS Уровня 2

  • В VLAN доступа, без меток (никакое значение приоритета CoS Уровня 2)

Коммутатор может обработать трафик данных, который прибывает из устройства, подключенного к порту доступа на IP-телефоне. Можно настроить порты коммутатора, которые передают пакеты CDP, которые дают подключенному IP-телефону команду настраивать режим (доверял или недоверяемый режим) для порта доступа по телефону.

В доверяемом режиме порт доступа на IP-телефоне передает трафик от ПК без любого изменения. В недоверяемом режиме порт доступа на IP-телефоне получает весь трафик в кадрах IEEE 802.1Q, которые содержат настроенное значение CoS Уровня 2. Значение CoS Уровня 2 по умолчанию 0. Недоверяемый режим является по умолчанию.

Настройка

В этом разделе вам предоставляют информацию по настройке функции голосового VLAN, описанные в этом документе.

В коммутаторе опция голосового VLAN отключена по умолчанию. При включении голосового VLAN на порту весь немаркированный трафик передается согласно приоритету CoS по умолчанию. Прежде чем вы включите голосовой VLAN, включите QoS на коммутаторе путем запуска команды глобальной кофигурации mls qos и настроите режим доверия порта для доверия путем запуска mls qos trust потому что команда настройки интерфейса.

По умолчанию порт коммутатора отбрасывает любые помеченные кадры в аппаратных средствах. Для принятия помеченных кадров на порту коммутатора одна из этих команд должна быть настроена на порту:

  • dot1p switchport voice vlan

  • switchport voice vlan V_VLAN_ID

  • !-- switchport mode trunk

Используйте команду dot1p switchport voice vlan, чтобы дать порту коммутатора команду использовать приоритетное тегирование IEEE 802.1p для передачи всего голосового трафика с более высоким приоритетом через собственный компонент (доступ) VLAN.

Используйте команду V_VLAN_ID switchport voice vlan для настройки указанного голосового VLAN, таким образом, IP-телефон может передать голосовой трафик в кадрах IEEE 802.1Q со значением CoS Уровня 2. Cisco IP Phone может также передать непомеченный речевой трафик, или это может использовать свою собственную конфигурацию для передачи голосового трафика к VLAN доступа коммутатора.

Используйте команду switchport priority extend trust для расширения режима доверия до устройства (ПК), связанный с IP-телефоном. Путем выдачи этой команды коммутатор сообщит телефону о том, как обработать пакеты данных от устройства, подключенного к порту доступа на Cisco IP Phone. Пакеты, генерируемые ПК, используют назначенное значение CoS в 802.1q заголовок. Телефон не должен изменяться (доверяют) приоритету кадров, поступающих в порт для телефона от ПК.

Необходимо включить CDP на порту коммутатора, с которым связан IP-телефон. По умолчанию CDP включен глобально на интерфейсах коммутатора. CDP является механизмом, используемым между коммутатором и Cisco IP Phone для настройки Cisco IP Phone для связи с портом коммутатора. CDP является составляющим собственность Cisco Systems, и телефоны других изготовителей могут не быть в состоянии использовать этот метод для настройки IP-телефона для соответствия с конфигурацией порта коммутатора.

Примечание: Используйте инструмент Command Lookup (только для зарегистрированных пользователей) для того, чтобы получить более подробную информацию о командах, использованных в этом разделе.

Схема сети

В этом документе использованы параметры данной сети:

http://www.cisco.com/c/dam/en/us/support/docs/switches/catalyst-2950-series-switches/113260-voice-vlan-01.gif

Эта схема является примером конфигурации голосового VLAN на Cisco Catalyst 2950 Коммутаторов. FastEthernet портов коммутатора 0/6 и 0/8 связан с Cisco IP Phone и портом доступа на обоих, которые IP-телефоны связаны с ПК.

Конфигурации

Эти конфигурации используются в данном документе:

На основе доверяемого значения CoS

В этих 2950 коммутаторах FastEthernet 0/6 порт имеет настроенную VLAN 10 для голосового VLAN с dot1p для использования приоритетного тегирования IEEE 802.1p для голосового трафика и настроил трастовый режим для трафика данных от ПК, который связан с портом доступа Cisco IP Phone. Здесь, Cisco IP Phone доверяет портативному ПК или ПК через CoS, и трафик данных использует собственный VLAN. Эта конфигурация, как правило, используется для рабочих станций управления, высокоприоритетных пользователей или высокого приложения значения CoS.

Когда Телефон Cisco делает CDP с коммутатором, граница надежности всегда расширяется на IP-телефон. Т.е. пакеты IP-телефона никогда не изменяются от CoS 5 до по умолчанию CoS. Именно поэтому команда switchport priority extend trust используется для портативного ПК или ПК. Это передается через CDP, чтобы сказать IP-телефону не переписывать пакеты с высоким приоритетом.

FastEthernet 0/8 порт настроен с отдельными VLAN для трафика речевых пакетов и пакетов данных. В данном примере VLAN 10 используется для голосового трафика, и VLAN 20 используется для трафика данных. Эта конфигурация используется для типичных Cisco IP Phone, не доверяя портативному ПК или ПК. Трафик использует тип фрейма IEEE 802.1Q.

С командой mls qos trust cos порт Коммутатора Catalyst посмотрел на значение CoS на Заголовке ethernet для классификации входного трафика и доверяет значению CoS маркированного тегами пакета, происходящему из Cisco IP Phone. По умолчанию Порт Ethernet становится недоверяемым, таким образом, не будут доверять трафику, прибывающему из голосового VLAN и VLAN для передачи данных.

Используйте команду priority-queue out для высказывания пакетных привилегий заголовка очереди при попытке выйти из порта, предотвращающего дрожание. Команда portfast связующего дерева удаляет интерфейс из протокола STP, и команда bpduguard защищает сеть, должен кто-то пытаться подключить новый коммутатор с ним после отключения IP-телефона. Если бы коммутатор должен был быть включен, порт перешел бы к err-disable. Они, как правило, добавляются к портам для телефона.

Cisco Catalyst 2950 коммутаторов
Switch#configure terminal
Switch(config)#mls qos
Switch(config)#interface fastethernet 0/6


!--- Set the interface to classify incoming traffic packets by
 using the packet CoS value.

Switch(config-if)#mls qos trust cos


!--- Configure the phone to use IEEE 802.1p priority tagging for
 voice traffic.

Switch(config-if)#switchport voice vlan dot1p
Switch(config-if)#switchport voice vlan 10


!--- Trust the CoS value the PC sends in on the data VLAN.

Switch(config-if)#switchport priority extend trust
Switch(config-if)#priority-queue out
Switch(config-if)#spanning-tree portfast
Switch(config-if)#spanning-tree bpduguard enable
Switch(config-if)#exit


Switch(config)#interface gigabitethernet0/8
Switch(config-if)#mls qos trust cos


!--- Configure specified VLANs for voice and data traffic.

Switch(config-if)#switchport voice vlan 10
Switch(config-if)#switchport access vlan 20

Switch(config-if)#priority-queue out
Switch(config-if)#spanning-tree portfast
Switch(config-if)#spanning-tree bpduguard enable
Switch(config-if)#exit

При использовании IP-телефона не от компании Cisco

При использовании IP-телефон не от компании Cisco, который не распознает Cisco составляющий собственность CDP и автоматически устанавливает магистральный порт, необходимо будет настроить транк вручную. В этом примере конфигурации мы ограничиваем VLAN 10 и 20 и блокируем собственный VLAN по умолчанию 1 или VLAN 0. VLAN 10 используется для голосового трафика, и VLAN 20 используется для трафика данных. IP-телефон не от компании Cisco изучает корректную VLAN для своих маркированных тегами пакетов через настройку вручную, или через файл TFTP это загружает во время, загружаются. Данный пример использует эту конфигурацию:

Cisco Catalyst 2950 коммутаторов
Switch#configure terminal
Switch(config)#interface fastethernet 0/6


!---Trusts tagged packets CoS value; all untagged packets reset DSCP 
value in IP header to 0.

Switch(config-if)#mls qos trust cos


!--- Turn off DTP (dynamic trunking protocol).

Switch(config-if)#switchport nonegotiate


!--- Forces the port into trunking mode.

Switch(config-if)#switchport mode trunk
Switch(config-if)#switchport trunk native vlan 20


!--- Restricts the VLANs.

Switch(config-if)#switchport trunk allowed vlans 10,20
Switch(config-if)#priority-queue out
Switch(config-if)#spanning-tree portfast trunk
Switch(config-if)#spanning-tree bpduguard enable
Switch(config-if)#exit

На основе доверяемого DSCP-значения в IP - заголовке

Здесь, мы используем доверяемый DiffService Кодовые точки (DSCP) значение вместо значения CoS, потому что CoS предлагает способ понять важность пакета только путем рассмотрения его заголовка L2. DSCP является 6-разрядным полем в пакете IP. Используйте команду mls qos trust DSCP для доверия DSCP-значению IP - заголовку. В этом случае IP-телефон устанавливает свой DSCP правильно в его пакетах, и портативный ПК установил бы свой DSCP правильно. Данный пример использует эту конфигурацию:

Cisco Catalyst 2950 коммутаторов
Switch#configure terminal
Switch(config)#interface fastethernet 0/6


!---Trust the DSCP value in the IP header.

Switch(config-if)#mls qos trust DSCP


!--- IP phone VLAN

Switch(config-if)#switchport voice vlan 10
Switch(config-if)#switchport access vlan 20


!--- Trust the DSCP value the PC sends in on the data VLAN.

Switch(config-if)#switchport priority extend trust
Switch(config-if)#priority-queue out
Switch(config-if)#spanning-tree portfast
Switch(config-if)#spanning-tree bpduguard enable
Switch(config-if)#exit

Проверка.

Этот раздел позволяет убедиться, что конфигурация работает правильно.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

  • Используйте команду switchport interface-id show interfaces для подтверждения конфигурации голосового VLAN.

    Например: :

    Switch#show interfaces FastEthernet 0/6 switchport
    Name: Fa0/6
    Switchport: Enabled
    Administrative Mode: dynamic desirable
    Operational Mode: static access
    Administrative Trunking Encapsulation: dot1q
    Operational Trunking Encapsulation: native
    Negotiation of Trunking: On
    Access Mode VLAN: 1 (default)
    Trunking Native Mode VLAN: 1 (default)
    Voice VLAN: dot1p
    Administrative private-vlan host-association: none 
    Administrative private-vlan mapping: none 
    Administrative private-vlan trunk native VLAN: none
    Administrative private-vlan trunk encapsulation: dot1q
    Administrative private-vlan trunk normal VLANs: none
    Administrative private-vlan trunk private VLANs: none
    Operational private-vlan: none
    Trunking VLANs Enabled: ALL
    Pruning VLANs Enabled: 2-1001
    Capture Mode Disabled
    Capture VLANs Allowed: ALL
    Protected: false
    Unknown unicast blocked: disabled
    Unknown multicast blocked: disabled
    Appliance trust: trusted
    
  • Используйте команду interface-id show running-config interface для подтверждения записей голосового VLAN для определенного интерфейса.

    Например: :

    Switch#show running-config interface fastEthernet 0/6
    Building configuration...
    
    Current configuration : 139 bytes
    !
    interface FastEthernet0/6
     switchport voice vlan dot1p
     switchport voice vlan 10
     switchport priority extend trust
     mls qos trust cos
     priority-queue out
     spanning-tree portfast
     spanning-tree bpduguard enable
    end
    
    Switch#show running-config interface fastEthernet 0/8
    Building configuration...
    
    Current configuration : 137 bytes
    !
    interface FastEthernet0/8
     switchport voice vlan 10
     switchport access vlan 20
     mls qos trust cos
     priority-queue out
     spanning-tree portfast
     spanning-tree bpduguard enable
    end

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения