Протокол IP : Протокол HSRP

Пример конфигурации HSRP IPv6

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ описывает, как настроить протокол маршрутизации с горячим резервированием (HSRP) для IPv6. HSRP используется в группе маршрутизаторов для выбора активного маршрутизатора и резервного маршрутизатора. В группе интерфейсов маршрутизатора активный маршрутизатор является предпочтительным маршрутизатором для пакетов маршрутизации; резервный маршрутизатор является маршрутизатором, который вступает во владение, когда активный маршрутизатор отказывает или когда соблюдают заданные условия. HSRP разработан для обеспечения только действительного первого перехода для Ipv6 host.

У группы IPv6 HSRP есть виртуальный MAC - адрес, который получен из номера группы HSRP и действительного IPv6 локальный для канала адрес т.е. по умолчанию, полученный из Виртуального MAC - адреса hsrp. Когда группа HSRP активна, периодические объявления маршрутизатора (RAs) передаются за HSRP действительный IPv6 локальный для канала адрес. Эти RAs останавливаются после того, как заключительный RA передается, когда группа оставляет активное состояние.

HSRP использует механизм приоритета для определения, какой настроенный маршрутизатор HSRP должен быть активным маршрутизатором по умолчанию. Для настройки маршрутизатора как активного маршрутизатора необходимо назначить его приоритет, который выше, чем приоритет всех других настроенных маршрутизаторов HSRP. Приоритет по умолчанию равняется 100; поэтому при настройке всего одного маршрутизатора для имения более высокого приоритета, тот маршрутизатор будет активным маршрутизатором по умолчанию. Версия 2 HSRP использует новый адрес групповой IP-адресации 224.0.0.102 для передачи пакетов приветствия вместо адреса групповой адресации 224.0.0.2, который используется версией 1.

Предварительные условия

Требования

Убедитесь, что вы обеспечили выполнение следующих требований, прежде чем попробовать эту конфигурацию:

  • Знание настройки HSRP; обратитесь к HSRP Настройки для получения дополнительной информации.

  • Базовые знания о реализации адресации IPv6 и основного подключения; обратитесь к Реализации Адресации IPv6 и Основного подключения для получения дополнительной информации.

  • Версия 2 HSRP должна быть включена на интерфейсе, прежде чем сможет быть настроен IPv6 HSRP.

  • Одноадресная маршрутизация IPv6 должна быть позволена на устройстве для IPv6 HSRP быть настроенной

Используемые компоненты

Конфигурации в этом документе основываются на Маршрутизаторе серии Cisco 3700 на программном обеспечении Cisco IOS Software Release 12.4 (15) T 13.

Примечание: Проверьте лицензионные сведения для команд IPv6.

Условные обозначения

Сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Настройка

Маршрутизаторы R1 и R2 связаны с R3 через последовательный интерфейс. Интерфейсы Fast Ethernet R1 и R2 настроены с IPv6 HSRP таким способом, которым R1 действует как активный маршрутизатор и действия R2 как резервный маршрутизатор. В случае, если последовательный интерфейс, S0/0 R1 выключается, маршрутизатор R2, изменяет свое состояние от Резерва до Активного.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

В настоящем документе используется следующая схема сети:

http://www.cisco.com/c/dam/en/us/support/docs/ip/hot-standby-router-protocol-hsrp/113216-ipv6-hsrp-01.gif

Конфигурации

Эти конфигурации используются в данном документе:

Вот ссылка на видео (доступный на Сообществе Cisco Support leavingcisco.com), который демонстрирует, как настроить HSRP для IPv6 в маршрутизаторах Cisco IOS:

HSRP Настройки для IPv6 leavingcisco.com

http://www.cisco.com/c/dam/en/us/support/docs/ip/hot-standby-router-protocol-hsrp/113216-ipv6-hsrp-02.gif

Конфигурация маршрутизатора R1
R1#show run
Building configuration...
!
hostname R1
!
ip cef
!
ipv6 unicast-routing
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address 2020:AB8:2001::1010/64
 ipv6 enable
 standby version 2
 standby 1 ipv6 autoconfig

!--- Assigns a standby group and standby IP address.


 standby 1 priority 120


!--- R1 is configured as the active router.
!--- This is done by assigning a priority value 
!--- (in this case 120) to the router's Fa0/0 interface.
!--- The default priority value is 100.


 standby 1 preempt delay minimum 30


!--- The preempt command allows the router to become the 
!--- active router when it has the priority higher than 
!--- all the other HSRP-configured routers. 
!---- Without this command, even if a router has higher 
!--- priority value, it will not become an active router.
!--- The delay minimum value causes the local router to postpone
!--- taking over the active role for a minimum of 30 seconds.


 standby 1 track Serial0/0 90


!--- Indicates that HSRP tracks serial0/0.
!--- The interface priority is configured (in this case 90) which 
!--- indicates that if the tracked interface goes down the router 
!--- priority value is to be decremented by 90. 
!--- Default decrement value is 10.

!
interface Serial0/0
 no ip address
 ipv6 enable
 ipv6 address 2010:AB8:2001::1010/64
 clock rate 2000000
!
end

Конфигурация маршрутизатора R2
R2#show run
Building configuration...
!
hostname R2
!
ip cef
!
ipv6 unicast-routing
!
interface FastEthernet0/0

!--- R2 is configured as a standby router
!--- with a default priority value of 100.

 no ip address
 duplex auto
 speed auto
 ipv6 address 2020:AB8:2001::1011/64
 ipv6 enable
 standby version 2
 standby 1 ipv6 autoconfig
 standby 1 preempt delay minimum 30
 standby 1 track Serial0/0
!
interface Serial0/0
 no ip address
 ipv6 address 2010:AB8:2010::1020/64
 ipv6 enable
 clock rate 2000000
!
end

Конфигурация маршрутизатора R3
R3#show run
Building configuration...
!
hostname R3
!
ip cef
!
ipv6 unicast-routing
!
interface Serial0/0
 no ip address
 ipv6 address 2010:AB8:2001::1011/64
 ipv6 enable
 clock rate 2000000
!
interface Serial0/1
 no ip address
 ipv6 address 2010:AB8:2010::1021/64
 clock rate 2000000
!
end

Проверка

Используйте команду show standby на R1 и маршрутизаторах R2 для проверки конфигурации.

Маршрутизатор М1
R1#show standby
FastEthernet0/0 - Group 1 (version 2)
  State is Active 
!--- R1 router is in Active state.

    4 state changes, last state change 02:51:30
  Virtual IP address is FE80::5:73FF:FEA0:1
  Active virtual MAC address is 0005.73a0.0001
    Local virtual MAC address is 0005.73a0.0001 (v2 IPv6 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 2.480 secs
  Preemption enabled, delay min 30 secs
  Active router is local
  Standby router is FE80::C010:21FF:FE78:0, priority 100 (expires in 7.036 sec)
  Priority 120 (configured 120)
    Track interface Serial0/0 state Up decrement 10
  Group name is "hsrp-Fa0/0-1" (default)

Маршрутизатор М2
R2#show standby
FastEthernet0/0 - Group 1 (version 2)
  State is Standby
!--- R2 router is in Standby state.

    4 state changes, last state change 02:51:43
  Virtual IP address is FE80::5:73FF:FEA0:1
  Active virtual MAC address is 0005.73a0.0001
    Local virtual MAC address is 0005.73a0.0001 (v2 IPv6 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 0.900 secs
  Preemption enabled, delay min 30 secs
  Active router is FE80::C00F:21FF:FE78:0, priority 120 (expires in 9.928 sec)
    MAC address is c20f.2178.0000
  Standby router is local
  Priority 100 (default 100)
    Track interface Serial0/0 state Up decrement 10
  Group name is "hsrp-Fa0/0-1" (default)

В случае, если активный маршрутизатор (R1 в данном примере) выключается, резервный маршрутизатор сразу изменяет свое состояние на Активный как показано в этой таблице:

Когда выключается активный маршрутизатор (R1)...
Маршрутизатор М1
R1(config)#interface s0/0
R1(config-if)#shut
R1(config-if)#exit
*Mar  1 00:01:34.879: %LINK-5-CHANGED: Interface Serial0/0, changed state to 
      administratively down
*Mar  1 00:01:35.879: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial0/0, 
      changed state to down
R1#
*Mar  1 00:04:06.691: %SYS-5-CONFIG_I: Configured from console by console
R1#
*Mar  1 00:04:36.175: %HSRP-5-STATECHANGE: FastEthernet0/0 Grp 1 state Active -> Speak
R1#
*Mar  1 00:04:46.175: %HSRP-5-STATECHANGE: FastEthernet0/0 Grp 1 state Speak -> Standby

!--- When the interface goes down, the active router changes its state to Standby.

Маршрутизатор М2
*Mar  1 00:04:35.631: %HSRP-5-STATECHANGE: FastEthernet0/0 Grp 1 state Standby ->Active


!--- The standby router is now the active router.
 

R2#show standby
FastEthernet0/0 - Group 1 (version 2)
  State is Active
    2 state changes, last state change 00:10:39
  Virtual IP address is FE80::5:73FF:FEA0:1
  Active virtual MAC address is 0005.73a0.0001
    Local virtual MAC address is 0005.73a0.0001 (v2 IPv6 default)
  Hello time 3 sec, hold time 10 sec
    Next hello sent in 2.532 secs
  Preemption enabled, delay min 30 secs
  Active router is local
  Standby router is FE80::C00F:21FF:FE78:0, priority 30 (expires in 7.524 sec)
  Priority 100 (default 100)
    Track interface Serial0/0 state Up decrement 10
  Group name is "hsrp-Fa0/0-1" (default)

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.


Дополнительные сведения


Document ID: 113216