Протокол IP : Протокол OSPF

Пример конфигурации виртуальных каналов OSPFv3

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ предоставляет пример при настройке виртуальных соединений в Открытом Кратчайшем пути, Первая Версия 3 (OSPFv3). OSPFv3 подробно останавливается на версии 2 OSPF для оказания поддержки для префиксов маршрутизации IPv6 и большего размера адресов IPv6.

Для каждого виртуального соединения основной блок данных сведений о безопасности создан для виртуального соединения. Поскольку защищенный сокет должен быть открыт на каждом интерфейсе, будет соответствующий блок данных сведений о безопасности для каждого интерфейса в транзитной области. Состояние защищенного сокета сохранено в блоке данных сведений о безопасности интерфейса. Поле состояния в основном блоке данных сведений о безопасности отражает статус всех защищенных сокетов, открытых для виртуального соединения. Если все защищенные сокеты будут подключены UP, то состояние защиты для виртуального соединения будет установлено в UP.

Пакеты, переданные на виртуальном соединении с IPsec, должны использовать предопределенные адреса источника и назначения. Первый адрес локальной области, найденный во внутри-областном префиксном LSA маршрутизатора для области, используется в качестве адреса источника. Этот адрес источника сохраняется в структуре данных области и используется, когда защищенные сокеты открыты, и пакеты переданы по виртуальному соединению. Виртуальное соединение не перейдет к состоянию "точка-точка", пока не будет выбран адрес источника. Кроме того, когда адрес источника или назначения изменяется, предыдущие защищенные сокеты должны быть закрыты, и открыты новые защищенные сокеты.

Этот пример конфигурации использует команду area virtual-link для определения виртуального канала OSPF в режиме конфигурации маршрутизатора.

Примечание: Каждый сосед на виртуальном канале должен включать ID транзитной области и соответствующий идентификатор маршрутизатора соседа на виртуальном канале для виртуального соединения, которое будет должным образом настроено. Используйте команду EXEC show ip ospf для наблюдения идентификатора маршрутизатора.

Предварительные условия

Требования

Убедитесь, что вы обеспечили выполнение следующих требований, прежде чем попробовать эту конфигурацию:

  • Завершите стратегию сети OSPF и планирующий вашу сеть IPv6.

  • Включите одноадресную маршрутизацию IPv6.

  • Включите IPv6 на интерфейсе.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования.

Конфигурации в этом документе основываются на Маршрутизаторе серии Cisco 3700 на программном обеспечении Cisco IOS₩½ Software Release 12.4 (15) T 13.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

В настоящем документе используется следующая схема сети:

http://www.cisco.com/c/dam/en/us/support/docs/ip/open-shortest-path-first-ospf/113204-ospfv3-vlink-config-01.gif

Конфигурации

Эти конфигурации используются в данном документе:

  • Маршрутизатор М1

  • Маршрутизатор М2

  • Маршрутизатор R3

  • Маршрутизатор R4

Маршрутизатор М1
hostname R1
! 
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
 no ip address
 ipv6 address FE01:1::1/64
 ipv6 enable
 ipv6 ospf 10 area 0
 !
interface Ethernet1/0
 no ip address
 ipv6 address 2011:8:8:1::1/64
 ipv6 enable
 ipv6 ospf 10 area 0
 !
ipv6 router ospf 10
 router-id 1.1.1.1
 log-adjacency-changes

Маршрутизатор М2
hostname R2
!
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
 no ip address
 ipv6 address FE01:2::2/64
 ipv6 enable
 ipv6 ospf 10 area 0
 !
interface Ethernet1/0
 no ip address
 ipv6 address 2011:8:8:1::2/64
 ipv6 enable
 ipv6 ospf 10 area 0
!
interface Serial2/0
 no ip address
 ipv6 address 2011:8:8:2::2/64
 ipv6 enable
 ipv6 ospf 10 area 23
 serial restart-delay 0
 clock rate 64000
 !
ipv6 router ospf 10
 router-id 2.2.2.2
 log-adjacency-changes
 area 23 virtual-link 3.3.3.3
!

Маршрутизатор R3
hostname R3
!
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
 no ip address
 ipv6 address FE01:3::3/64
 ipv6 enable
 ipv6 ospf 10 area 23
 !

interface Ethernet1/0
 no ip address
 ipv6 address 2011:8:8:3::3/64
 ipv6 enable
 ipv6 ospf 10 area 34
 !
interface Serial2/0
 no ip address
 ipv6 address 2011:8:8:2::3/64
 ipv6 enable
 ipv6 ospf 10 area 23
 serial restart-delay 0
 !
ipv6 router ospf 10
 router-id 3.3.3.3
 log-adjacency-changes
 area 23 virtual-link 2.2.2.2
!

Маршрутизатор R4
hostname R4
!
ipv6 unicast-routing
ipv6 cef
!
interface Loopback0
 no ip address
 ipv6 address FE01:4::4/64
 ipv6 enable
 ipv6 ospf 10 area 34
 !
interface Ethernet1/0
 no ip address
 ipv6 address 2011:8:8:3::4/64
 ipv6 enable
 ipv6 ospf 10 area 34
 !
ipv6 router ospf 10
 router-id 4.4.4.4
 log-adjacency-changes
!

Проверка

Используйте эти команды для проверки конфигурации:

В маршрутизаторе R1

Выходные данные ясно показывают, что маршрутизатор R1 может пропинговать успешно адрес обратной связи маршрутизатора R4.

ping ipv6
R1#ping ipv6
Target IPv6 address: fe01:4::4

Ping Loopback 0 interface of R4
   	
Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands? [no]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FE01:4::4, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 48/72/96 ms

В маршрутизаторе R2

Команда show ipv6 ospf neighbor предоставляет сведения о соседях на на интерфейсное основание.

show ipv6 ospf neighbor
R2# show ipv6 ospf neighbor

Neighbor ID     Pri   State           Dead Time   Interface ID    Interface
3.3.3.3                 0   FULL/  -                -                22        OSPFv3_VL0   

Virtual Link Between R2 & R3
       
1.1.1.1                 1   FULL/DR         00:00:35         4                 Ethernet1/0
3.3.3.3                 0   FULL/  -           00:00:31      12                Serial2/0

В маршрутизаторе R4

Выходные данные ясно показывают, что маршрутизатор R4 может пропинговать успешно петлевой интерфейс маршрутизатора R1.

ping ipv6
R4#ping ipv6
Target IPv6 address: fe01:1::1				

Ping Loopback 0 interface of R1

Repeat count [5]:
Datagram size [100]:
Timeout in seconds [2]:
Extended commands? [no]:
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to FE01:1::1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 56/100/224 ms

Устранение неполадок

Для этой конфигурации в настоящее время нет сведений об устранении проблем.


Дополнительные сведения


Document ID: 113204