Голосовая связь : Протокол MGCP

Поддержка MGCP на примере конфигурации включенного маршрутизатора VRF

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ описывает, как настроить Сообщение протокол управление шлюзами (MGCP) на Маршрутизации голосовых данных и Передаче (VRF) включенный маршрутизатор.

Существует два основных элемента, которые необходимо понять относительно MGCP:

  • Оконечные точки

  • Агенты вызовов

Оконечные точки являются любым из голосовых портов на определяемом шлюзе. Эти голосовые порты предоставляют подключение и аналоговым портам, таким как Отделение междугородной телефонной связи (FXO) / Станция внешнего обмена (FXS), и цифровым магистралям, таким как T1 или E1, к PSTN. Шлюзы могут иметь зависимость от нескольких оконечных точек на количестве портов, которые это содержит.

Агенты вызовов являются внешними управляющими устройствами в системе голосовой связи. Сisco CallManager является агентом вызовов, на которого ссылаются в этом документе. В MGCP агент вызовов является устройством, которое имеет полный контроль над шлюзом. Это очень эффективная система, поскольку все администрирование выполнено агентом вызовов. Существует очень мало настройки, требуемой на конце шлюза, поскольку все шаблоны маршрута и планы соединений настроены на Сisco CallManager.

Важно помнить, что этот протокол используется для целей управления только. Никакие голосовые данные не переданы через сам протокол MGCP. Вся передача голосовых данных происходит непосредственно между телефоном и шлюзом. Этот рисунок изображает отношения соединений MGCP:

http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/113180-mgcp-support-vrf-enabled-01.gif

Cisco IP Phone в данном примере используют Протокол SCCP для передачи с Сisco CallManager. Фактические голосовые данные переданы через Протокол RTP непосредственно между этими двумя устройствами. MGCP используется Сisco CallManager только для управления шлюзом.

Предварительные условия

Требования

Для этого документа отсутствуют особые требования.

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного обеспечения и оборудования:

  • Версия программного обеспечения Cisco IOS 12.4 (24) T 4

  • Cisco маршрутизатор серии 2800

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Более подробную информацию о применяемых в документе обозначениях см. в описании условных обозначений, используемых в технической документации Cisco.

MGCP и облегченный VRF

Логические функции маршрутизации VRF не существуют в протоколе MGCP.

Так как MGCP не является "осведомленным о VRF” протоколом, вы не можете настроить Голосовой шлюз IOS для помещения трафика MGCP в voice VRF. Трафик MGCP будет только использовать таблицу маршрутизации по умолчанию маршрутизатора независимо от конфигураций VRF.

Существует два решения поддержать MGCP в типичных развертываниях VRF. См. этот типичный Сетевой сценарий VRF:

http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/113180-mgcp-support-vrf-enabled-02.gif

Использование двух маршрутизаторов, которые можно установить один, т.е. со шлюзом MGCP, действующим как основной маршрутизатор (никакие VRF) обеспечение Трафика ethernet к второму маршрутизатору, который делает маршрутизацию VRF MPLS. Можно тогда направить трафик MGCP по маршрутизатору VRF, поскольку это - просто способ маршрутизации, и MGCP не сознает.

http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/113180-mgcp-support-vrf-enabled-03.gif

Другое аналогичное решение должно использовать одиночный маршрутизатор VRF и использовать второй доступный интерфейс к прямому трафику MGCP к голосовой сети.

http://www.cisco.com/c/dam/en/us/support/docs/voice/media-gateway-control-protocol-mgcp/113180-mgcp-support-vrf-enabled-04.gif

Соединение интерфейса к голосовому VLAN на коммутируемой сети позволяет протоколам MGCP маршрутизироваться назад в маршрутизатор через интерфейс VRF и в конечном счете CallManager.

Глобальному маршруту маршрутизатора VRF только нужно дать IP и статический маршрут, указывающий на IP интерфейса VRF или адреса DHCP от голосового VLAN. Посмотрите эти элементы конфигурации:

hostname VRF_MGCP_rtr
!
ip DATA
rd 65232:1
route-target export 65232:1
route-target import 65232:1
!
ip VOICE
rd 65232:3
route-target export 65232:3
route-target import 65232:3
!
interface GigabitEthernet0/0
 description MGCP interface
 ip address dhcp 
!-- USE DHCP or Static IP address from VOICE VLAN

!
interface GigabitEthernet0/1
 no ip address
 duplex full
 speed auto
 no keepalive
!
interface GigabitEthernet0/1.100
description DATA VLAN
encapsulation dot1Q 1 native
ip forwarding DATA
ip address 10.1.232.1 255.255.255.0
ntp broadcast
!
Interface GigabitEthernet0/1.300
Description VOICE VLAN
encapsulation dot1Q 2
ip forwarding VOICE
ip address 10.2.20.129 255.255.255.128
!
Interface Serial0/0/0
no ip address
no encapsulation ppp
encapsulation frame-relay IETF
!
interface Serial0/0/0.100 point-to-point
description DATA PVC
ip forwarding DATA
ip address 10.1.52.198 255.255.255.252
frame-relay interface-dlci 100 IETF
!
interface Serial0/0/0.300 point-to-point
description VOICE PVC
ip forwarding VOICE
ip address 10.2.54.198 255.255.255.252
frame-relay interface-dlci 300 IETF
!
mgcp
mgcp call-agent 10.1.255.241 2427 service-type mgcp version 0.1
mgcp bind control source-interface GigabitEthernet0/0 
!-- Bind to MGCP Interface

mgcp bind media source-interface GigabitEthernet0/0
mgcp bind media source-interface GigabitEthernet0/0
!
mgcp profile default
!

Проверка

В настоящее время для этой конфигурации нет процедуры проверки.


Дополнительные сведения


Document ID: 113180