Протокол IP : Протоколы IP-маршрутизации

Отрегулируйте административное расстояние для выбора маршрута в Примере конфигурации маршрутизаторов Cisco IOS

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ описывает, как изменить значение расстояния администрирования протокола маршрутизации для влияния на выбор маршрута в маршрутизаторах Cisco.

Административное расстояние - это функция, используемая маршрутизаторами для выбора оптимального маршрута при наличии двух и более различных маршрутов до одной цели по различным протоколам маршрутизации. Административное расстояние определяет надежность протокола маршрутизации. Чем меньший значение расстояния администрирования, тем более надежный протокол.

Примечание: При изменении расстояний по умолчанию это может привести к циклам маршрутизации в сети. Измените административное расстояние с осторожностью и только после того, как вы продумали то, чего вы хотите достигнуть.

Предварительные условия

Требования

Для данного документа отсутствуют предварительные условия.

Используемые компоненты

Конфигурации в этом документе основываются на Маршрутизаторе серии Cisco 3700 на программном обеспечении Cisco IOS версии 12.4(15)T 13.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Настройка

В этом разделе содержатся сведения о настройке функций, описанных в этом документе.

Примечание: Чтобы получить подробные сведения о командах в данном документе, используйте Средство поиска команд (только для зарегистрированных клиентов).

Схема сети

Здесь маршрутизатор R1 и R2 связан через параллельные линии последовательной передачи. Маршрутизаторы R1 и R2 настроены с BGP и OSPF. Административное расстояние по умолчанию OSPF равняется 110, в то время как тот из eBGP равняется 20. С расстоянием команды мы изменили AD значение BGP к 190. До этой команды маршрутизатор R2 предпочел маршруты BGP по OSPF, так как у них были AD настроенные значения по умолчанию. После того, как AD значение BGP изменилось, маршруты OSPF берет приоритеты.

http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-routed-protocols/113153-adjust-ad-01.gif

Конфигурации

Этот документ использует их конфигурация

Конфигурация R1
interface Loopback0
 ip address 1.1.1.1 255.255.255.255
 !
!
interface Loopback10
 ip address 10.10.10.10 255.255.255.255
 !
!
interface Loopback20
 ip address 20.20.20.20 255.255.255.255
 !
!
interface Loopback30
 ip address 30.30.30.30 255.255.255.255
 !
!
interface Serial1/0
 ip address 100.100.100.1 255.255.255.0
 serial restart-delay 0
 clock rate 64000
 !
!
interface Serial1/1
 ip address 192.168.12.1 255.255.255.0
 serial restart-delay 0
 clock rate 64000
 !
!
router ospf 10
 router-id 1.1.1.1
 log-adjacency-changes
 network 1.1.1.1 0.0.0.0 area 0
 network 10.10.10.10 0.0.0.0 area 0
 network 20.20.20.20 0.0.0.0 area 0
 network 100.100.100.1 0.0.0.0 area 0
!
router bgp 123
 no synchronization
 bgp router-id 1.1.1.1
 bgp log-neighbor-changes
 network 10.10.10.10 mask 255.255.255.255
 network 20.20.20.20 mask 255.255.255.255
 network 30.30.30.30 mask 255.255.255.255
 neighbor 2.2.2.2 remote-as 100
 neighbor 2.2.2.2 ebgp-multihop 5
 neighbor 2.2.2.2 update-source Loopback0
 no auto-summary
!

Конфигурация R2
interface Loopback0
 ip address 2.2.2.2 255.255.255.255
 !
!
interface Serial1/0
 ip address 100.100.100.2 255.255.255.0
 serial restart-delay 0
 clock rate 64000
 !
!
interface Serial1/1
 ip address 192.168.12.2 255.255.255.0
 serial restart-delay 0
 clock rate 64000
 !

!
router ospf 10
 router-id 2.2.2.2
 log-adjacency-changes
 network 2.2.2.2 0.0.0.0 area 0
 network 100.100.100.2 0.0.0.0 area 0
!
router bgp 100
 no synchronization
 bgp router-id 2.2.2.2
 bgp log-neighbor-changes
 neighbor 1.1.1.1 remote-as 123
 neighbor 1.1.1.1 ebgp-multihop 5
 neighbor 1.1.1.1 update-source Loopback0
 distance 190 1.1.1.1 0.0.0.0 

Changed the AD value of BGP as 190!

 no auto-summary
!

Проверка.

Используйте команды, описанные в этом разделе для подтверждения конфигурации.

Средство Output Interpreter (OIT) (только для зарегистрированных клиентов) поддерживает определенные команды show. Посредством OIT можно анализировать выходные данные команд show.

На маршрутизаторе R2

Когда команда расстояния не применена на Маршрутизатор R2

Show ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       I - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
O        1.1.1.1 [110/65] via 100.100.100.1, 00:00:03, Serial1/0
      2.0.0.0/32 is subnetted, 1 subnets
C        2.2.2.2 is directly connected, Loopback0
      10.0.0.0/32 is subnetted, 1 subnets
B        10.10.10.10 [20/0] via 1.1.1.1, 00:00:03        

 BGP Router Preffered Over OSPF

      20.0.0.0/32 is subnetted, 1 subnets
B        20.20.20.20 [20/0] via 1.1.1.1, 00:00:03
 
 BGP Router Preffered Over OSPF

      30.0.0.0/32 is subnetted, 1 subnets
B        30.30.30.30 [20/0] via 1.1.1.1, 00:00:03
      100.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        100.100.100.0/24 is directly connected, Serial1/0
L        100.100.100.2/32 is directly connected, Serial1/0
      192.168.12.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.12.0/24 is directly connected, Serial1/1
L        192.168.12.2/32 is directly connected, Serial1/1

Когда команда расстояния применена на Маршрутизатор R2

Show ip route
R2#sh ip route
Codes: L - local, C - connected, S - static, R - RIP, M - mobile, B - BGP
       D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
       N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
       E1 - OSPF external type 1, E2 - OSPF external type 2
       I - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
       ia - IS-IS inter area, * - candidate default, U - per-user static route
       o - ODR, P - periodic downloaded static route, + - replicated route

Gateway of last resort is not set

      1.0.0.0/32 is subnetted, 1 subnets
O        1.1.1.1 [110/65] via 100.100.100.1, 00:00:03, Serial1/0
      2.0.0.0/32 is subnetted, 1 subnets
C        2.2.2.2 is directly connected, Loopback0
      10.0.0.0/32 is subnetted, 1 subnets
O        10.10.10.10 [110/65] via 100.100.100.1, 00:00:03, Serial1/0
           
By increasing the AD of External BGP, OSPF takes precedence

      20.0.0.0/32 is subnetted, 1 subnets
O        20.20.20.20 [110/65] via 100.100.100.1, 00:00:03, Serial1/0
           
By increasing the AD of External BGP, OSPF takes precedence

      30.0.0.0/32 is subnetted, 1 subnets
B        30.30.30.30 [190/0] via 1.1.1.1, 00:00:03
      100.0.0.0/8 is variably subnetted, 2 subnets, 2 masks
C        100.100.100.0/24 is directly connected, Serial1/0
L        100.100.100.2/32 is directly connected, Serial1/0
      192.168.12.0/24 is variably subnetted, 2 subnets, 2 masks
C        192.168.12.0/24 is directly connected, Serial1/1
L        192.168.12.2/32 is directly connected, Serial1/1

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 113153