Протокол IP : IP версии 6 (IPv6)

PPP CHAP / АУТЕНТИФИКАЦИЯ PAP по Примеру Конфигурирования последовательных каналов IPv6

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ предоставляет пример конфигурации для Протокола аутентификации по квитированию вызова (CHAP) Протокола PPP / Аутентификация Протокола аутентификации пароля (PAP) по Последовательному соединению IPv6.

Когда или PAP или CHAP включены, локальный маршрутизатор требует, чтобы удаленное устройство удостоверило свою личность прежде, чем позволить трафику данных течь. Аутентификация PAP требует, чтобы удаленное устройство передало название и пароль, который проверен против соответствующей записи в базе данных локального имени пользователя или в удаленной базе данных сервера безопасности. Аутентификация CHAP передает Challenge - сообщение к удаленному устройству. Удаленное устройство шифрует значение проблемы с общим секретным ключом и возвращает зашифрованное значение и его название к локальному маршрутизатору в Ответном сообщении. Локальный маршрутизатор пытается совпасть с названием удаленного устройства с cвязанной тайной, сохраненной в локальном имени пользователя или удаленной базе данных сервера безопасности. Это использует сохраненную тайну, чтобы зашифровать исходную проблему и проверить, что совпадают зашифрованные значения.

Предварительные условия

Требования

Удостоверьтесь в соответствии этим требованиям перед попыткой применения этой конфигурации:

  • Поймите процесс проверки подлинности PAP/CHAP

  • Поймите основной IPv6

Используемые компоненты

Сведения, содержащиеся в данном документе, касаются следующих версий программного и аппаратного обеспечения:

  • Cisco IOS Software Release 12.4, набор функций IP-сервисов усовершенствования

  • CISCO 3700 SERIES MULTISERVICE ACCESS ROUTERS

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Общие сведения

В примере маршрутизаторы R1 и R2 настроены с Аутентификацией "PPP". В маршрутизаторе R1 интерфейсный S1/0 является IPv6, включил и имеет IPv6 address 2011:2706:ABC::/64 eui-64 путем осуществления EUI-64. Расширенный уникальный идентификатор (EUI) позволяет хосту автоматически назначить себя уникальный 64-разрядный идентификатор интерфейса IPv6 без потребности в настройке вручную или DHCP. Это выполнено на Интерфейсах Ethernet путем ссылки на уже уникальный 48-разрядный MAC-адрес и переформатирования того значения для соответствия со спецификацией EUI-64. Точно так же интерфейс S1/0 на маршрутизаторе R2 включен с 2011:2706:ABC::/64 eui-64.

Настройка

Маршрутизаторы R1 и R2 настроены с основной аутентификацией PPP/CHAP.

Схема сети

http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6-ipv6/113073-ppp-chap-ipv6-01.gif

Конфигурации

Эти конфигурации используются в данном документе:

Конфигурация R1
hostname R1
!
aaa new-model
!
aaa authentication ppp default local
!
username R2 password 0 cisco

interface Serial1/0
 no ip address
 encapsulation ppp
 ipv6 address 2011:2706:ABC::/64 eui-64
 ipv6 enable
 no fair-queue
 ppp authentication chap callin
!

Конфигурация R2
interface Serial1/1
 no ip address
 encapsulation ppp
 ipv6 address 2011:2706:ABC::/64 eui-64
 ipv6 enable
 clock rate 64000
 ppp chap hostname R2
 ppp chap password 0 cisco

Проверка.

В данном разделе содержатся сведения для проверки работы текущей конфигурации.

На маршрутизаторе R1 выполните эти команды:

  1. debug ppp negotiation

    debug ppp negotiation
    
    
    *Jun 27 08:34:56:357: Se1/0 PPP: Outbound cdp packet dropped
    *Jun 27 08:34:56:845: %SYS-5-CONFIG_|: Configured from console by console
    *Jun 27 08:34:58:357: %LINK-3-UPDOWN: Interface Serial1/0, changed state to up
    *Jun 27 08:34:58:357: Se1/0 PPP: Using default call direction
    *Jun 27 08:34:58:357: Se1/0 PPP: Treating connection as a dedicated line
    *Jun 27 08:34:58:357: Se1/0 PPP: Session handle[470002F8] Session id[29]
    *Jun 27 08:34:58:357: Se1/0 PPP: Phase is ESTABLISHING, Active Open
    *Jun 27 08:34:58:357: Se1/0 LCP: O CONFREQ [Closed] id 72 len 15
    *Jun 27 08:34:58:357: Se1/0 LCP:  AuthProto CHAP (0x0305C22305)
    *Jun 27 08:34:58:357: Se1/0 LCP:  MagicNumber 0x35B44C0F (0x050635B44C0F)
    *Jun 27 08:34:58:361: Se1/0 LCP: I CONFREQ {REQsent] id 59 len 10
    *Jun 27 08:34:58:361: Se1/0 LCP:  MagicNumber 0x1FEDF9A2 (0x05061FEDF9A2)
    *Jun 27 08:34:58:361: Se1/0 LCP: O CONFACK {REQsent] id 59 len 10
    *Jun 27 08:34:58:361: Se1/0 LCP:  MagicNumber 0x1FEDF9A2 (0x05061FEDF9A2)
    *Jun 27 08:34:58:365: Se1/0 LCP: I CONFACK {ACKsent] id 72 len 15
    *Jun 27 08:34:58:365: Se1/0 LCP:  AuthProto CHAP (0x0305C22305)
    *Jun 27 08:34:58.365: Se1/0 LCP:    MagicNumber 0x35B44C0F (0x050635B44C0F)
    *Jun 27 08:34:58.365: Se1/0 LCP: State is Open
    *Jun 27 08:34:58.365: Se1/0 PPP: Phase is AUTHENTICATING, by this end
    *Jun 27 08:34:58.365: Se1/0 CHAP: O CHALLENGE id 5 len 23 from "R1"
    *Jun 27 08:34:58.377: Se1/0 CHAP: I RESPONSE id 5 len 23 from "R2"
    *Jun 27 08:34:58.377: Se1/0 PPP: Phase is FORWARDING, Attempting Forward
    *Jun 27 08:34:58.377: Se1/0 PPP: Phase is AUTHENTICATING, Unauthenticated User
    *Jun 27 08:34:58.381: Se1/0 PPP: Phase is FORWARDING, Attempting Forward
    *Jun 27 08:34:58.381: Se1/0 PPP: Phase is AUTHENTICATING, Authenticated User
    *Jun 27 08:34:58.381: Se1/0 CHAP: O SUCCESS id 5 len 4
    *Jun 27 08:34:58.381: Se1/0 PPP: Phase is UP
    *Jun 27 08:34:58.381: Se1/0 CDPCP: O CONFREQ [Closed] id 1 len 4
    *Jun 27 08:34:58.381: Se1/0 IPV6CP: O CONFREQ [Closed] id 1 len 14
    *Jun 27 08:34:58.381: Se1/0 IPV6CP:    Interface-Id 021B:54FF:FEA9:24B0 
        (0x010A021B54FFFEA924B0)
    *Jun 27 08:34:58.381: Se1/0 PPP: Process pending ncp packets
    *Jun 27 08:34:58.389: Se1/0 CDPCP: I CONFREQ [REQsent] id 1 len 4
    *Jun 27 08:34:58.389: Se1/0 CDPCP: O CONFACK [REQsent] id 1 len 4
    *Jun 27 08:34:58.389: Se1/0 IPV6CP: I CONFREQ [REQsent] id 1 len 14
    *Jun 27 08:34:58.389: Se1/0 IPV6CP:    Interface-Id 021F:CAFF:FE04:F918 
        (0x010A021FCAFFFE04F918)
    *Jun 27 08:34:58.389: Se1/0 IPV6CP: O CONFACK [REQsent] id 1 len 14
    *Jun 27 08:34:58.389: Se1/0 IPV6CP:    Interface-Id 021F:CAFF:FE04:F918 
        (0x010A021FCAFFFE04F918)
    *Jun 27 08:34:58.393: Se1/0 CDPCP: I CONFACK [ACKsent] id 1 len 4
    *Jun 27 08:34:58.393: Se1/0 CDPCP: State is Open
    *Jun 27 08:34:58.393: Se1/0 IPV6CP: I CONFACK [ACKsent] id 1 len 14
    *Jun 27 08:34:58.393: Se1/0 IPV6CP:    Interface-Id 021B:54FF:FEA9:24B0 
        (0x010A021B54FFFEA924B0)
    *Jun 27 08:34:58.393: Se1/0 IPV6CP: State is Open
    *Jun 27 08:34:59.381: %LINEPROTO-5-UPDOWN: Line protocol on Interface Serial1/0,
        changed state to up
    
  2. debug ppp authenticaion

    *Jun 27 08:37:46.045: Se1/0 PPP: Using default call direction
    *Jun 27 08:37:46.045: Se1/0 PPP: Treating connection as a dedicated line
    *Jun 27 08:37:46.045: Se1/0 PPP: Session handle[C40002F9] Session id[30]
    *Jun 27 08:37:46.045: Se1/0 PPP: Authorization NOT required
    *Jun 27 08:37:46.053: Se1/0 CHAP: O CHALLENGE id 6 len 23 from "R1"
    *Jun 27 08:37:46.065: Se1/0 CHAP: I RESPONSE id 6 len 23 from "R2"
    *Jun 27 08:37:46.065: Se1/0 PPP: Sent CHAP LOGIN Request
    *Jun 27 08:37:46.065: Se1/0 PPP: Received LOGIN Response PASS
    *Jun 27 08:37:46.069: Se1/0 CHAP: O SUCCESS id 6 len 4
    
    

На маршрутизаторе R2 выполните эту команду:

  • debug ppp authenticaion

    debug ppp authentication 
    
    *Feb 28 05:18:39.439: Se1/1 PPP: Using default call direction
    *Feb 28 05:18:39.439: Se1/1 PPP: Treating connection as a dedicated line
    *Feb 28 05:18:39.439: Se1/1 PPP: Session handle[E300000B] Session id[35]
    *Feb 28 05:18:39.439: Se1/1 PPP: Authorization required
    *Feb 28 05:18:39.451: Se1/1 PPP: No authorization without authentication
    *Feb 28 05:18:39.455: Se1/1 CHAP: I CHALLENGE id 7 len 23 from "R1"
    *Feb 28 05:18:39.459: Se1/1 CHAP: Using hostname from interface CHAP
    *Feb 28 05:18:39.459: Se1/1 CHAP: Using password from interface CHAP
    *Feb 28 05:18:39.459: Se1/1 CHAP: O RESPONSE id 7 len 23 from "R2"
    *Feb 28 05:18:39.467: Se1/1 CHAP: I SUCCESS id 7 len 4
    

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 113073