Протокол IP : IPv6

Настройте функцию локального параметра BGP IPv6

5 апреля 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ объясняет функцию Local-Preference Протокола BGP IPv6. Локальное предпочтение указывает на AS, которая является предпочтительной для выхода из AS в целях достижения определенной сети. Путь с более высоким локальным параметром предпочтен больше. Значение по умолчанию предпочтения равняется 100.

Предварительные условия

Требования

Рассматриваемая процедура настройки предполагает выполнение следующих условий:

  • Понимание протокола маршрутизации BGP и его операции

  • Понимание Схемы адресации IPv6

Используемые компоненты

Сведения в этом документе протестированы на этих версиях программного и аппаратного обеспечения

  • Cisco IOS Software Release 12.4, набор функций IP-сервисов усовершенствования

  • CISCO 3700 SERIES MULTISERVICE ACCESS ROUTERS

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Общие сведения

В примере Маршрутизатор R1, R2 и R3 является частью Номера автономной системы BGP 123. R4 является частью Автономной системы 101 и частью R5 Автономной системы 100.

Эти три маршрутизатора (R1, R2 и R3) настроены с OSPFv3 для подключения IGP. Префикс IPv6 Lo петлевого интерфейса 0 (1111:111:111:A::/64 eui-64, 2222:222:222:A::/64 eui-64 И 3333:333:333:A::/64 eui-64) всех трех маршрутизаторов объявлен в области 0 из протокола маршрутизации OSPFv3.

Одноранговое телефонное соединение IBGP сформировано между маршрутизаторами R1, R2 и R3 через изученные петлевые префиксы. Маршрутизатор R1 и R4 связан по каналу WAN (последовательное подключение), и формирует Равноправный информационный обмен eBGP. Так же маршрутизатор R3 и R5 формирует Равноправный информационный обмен eBGP по каналу WAN.

Маршрутизатор R4 и R5 вводит те же префиксы IPv6:

  1. сеть BC01:BC1:10:A::/64

  2. сеть BC02:BC1:11:A::/64

  3. сеть BC03:BC1:12:A::/64

Поскольку эти два Маршрутизатора R4 и R5 вводят те же префиксы IPv6, выбор пути основывается на BGP известные Атрибуты. В данном примере выбран Локальный параметр. Значение Локального параметра BGP 500 установлено для префиксного BC01:BC1:10:A::/64 на маршрутизаторе R3 через route-map. Это приводит к R3 как точка выхода для этого префикса и R1 точка выхода для оставления двумя префиксами.

Настройка

Интерфейсы Fast Ethernet (F0/0 И F0/1) маршрутизаторов R1, R2 И R3 являются IPv6, включенным с IPv6 address формата eui-64.

Схема сети

В этом документе использованы параметры данной сети:

http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6/113035-ipv6-bgp-local-preference-config-01.gif

Конфигурации

Эти конфигурации используются в данном документе:

Примечание: Все маршрутизаторы включены с передачей пакетов IPv6 при помощи команды ipv6 unicast-routing .

_________________________ М1
interface Loopback0
 no ip address
 ipv6 address 1111:111:111:A::/64 eui-64
 ipv6 enable
 ipv6 ospf 10 area 0

!--- Enables OSPFv3 on the interface and associates
!--- the interface loopback0 to area 0.

!
interface FastEthernet0/0
 description CONNECTED TO Rtr2
 no ip address
 duplex auto
 speed auto
 ipv6 address AB01:CD1:123:A::/64 eui-64
 ipv6 enable
 ipv6 ospf 10 area 0
!
interface Serial0/0
 no ip address
 ipv6 address AB01:CD1:123:C::/64 eui-64
 ipv6 enable
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address AB01:CD1:123:B::/64 eui-64
 ipv6 enable
 ipv6 ospf 10 area 0
!
ipv6 router ospf 10
 router-id 1.1.1.1
 log-adjacency-changes
 redistribute connected route-map CONNECTED
!
route-map CONNECTED permit 10
 match interface Serial0/0
!
router bgp 123
 bgp router-id 1.1.1.1
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor 2222:222:222:A:C602:3FF:FEF0:0 remote-as 123
 neighbor 2222:222:222:A:C602:3FF:FEF0:0 update-source Loopback0
 neighbor 3333:333:333:A:C603:3FF:FEF0:0 remote-as 123
 neighbor 3333:333:333:A:C603:3FF:FEF0:0 update-source Loopback0
 neighbor AB01:CD1:123:C:C604:16FF:FE98:0 remote-as 101
 neighbor AB01:CD1:123:C:C604:16FF:FE98:0 ebgp-multihop 5
 !
 address-family ipv6
  neighbor 2222:222:222:A:C602:3FF:FEF0:0 activate
  neighbor 2222:222:222:A:C602:3FF:FEF0:0 next-hop-self
  neighbor 3333:333:333:A:C603:3FF:FEF0:0 activate
  neighbor 3333:333:333:A:C603:3FF:FEF0:0 next-hop-self
  neighbor AB01:CD1:123:C:C604:16FF:FE98:0 activate
 exit-address-family

_________________________ М2
interface Loopback0
 no ip address
 ipv6 address 2222:222:222:A::/64 eui-64
 ipv6 enable
 ipv6 ospf 10 area 0
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address AB01:CD1:123:A::/64 eui-64
 ipv6 ospf 10 area 0
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address AB01:CD1:123:D::/64 eui-64
 ipv6 enable
 ipv6 ospf 10 area 0
!
ipv6 router ospf 10
 router-id 2.2.2.2
 log-adjacency-changes
!
router bgp 123
 no synchronization
 bgp router-id 2.2.2.2
 bgp log-neighbor-changes
 neighbor 1111:111:111:A:C601:3FF:FEF0:0 remote-as 123
 neighbor 1111:111:111:A:C601:3FF:FEF0:0 update-source Loopback0
 neighbor 3333:333:333:A:C603:3FF:FEF0:0 remote-as 123
 neighbor 3333:333:333:A:C603:3FF:FEF0:0 update-source Loopback0
 no auto-summary
 !
 address-family ipv6
  neighbor 1111:111:111:A:C601:3FF:FEF0:0 activate
  neighbor 3333:333:333:A:C603:3FF:FEF0:0 activate
 exit-address-family

R3
interface Loopback0
 no ip address
 ipv6 address 3333:333:333:A::/64 eui-64
 ipv6 enable
 ipv6 ospf 10 area 0
!
interface FastEthernet0/0
 no ip address
 duplex auto
 speed auto
 ipv6 address AB01:CD1:123:B::/64 eui-64
 ipv6 enable
 ipv6 ospf 10 area 0
!
interface Serial0/0
 no ip address
 ipv6 address AB01:CD1:123:E::/64 eui-64
 ipv6 enable
 clock rate 2000000
!
interface FastEthernet0/1
 no ip address
 duplex auto
 speed auto
 ipv6 address AB01:CD1:123:D::/64 eui-64
 ipv6 ospf 10 area 0
!
ipv6 router ospf 10
 router-id 3.3.3.3
 log-adjacency-changes
 redistribute connected route-map CONNECTED
!
router bgp 123
 no synchronization
 bgp router-id 3.3.3.3
 bgp log-neighbor-changes
 neighbor 1111:111:111:A:C601:3FF:FEF0:0 remote-as 123
 neighbor 1111:111:111:A:C601:3FF:FEF0:0 update-source Loopback0
 neighbor 2222:222:222:A:C602:3FF:FEF0:0 remote-as 123
 neighbor 2222:222:222:A:C602:3FF:FEF0:0 update-source Loopback0
 neighbor AB01:CD1:123:E:C605:16FF:FE98:0 remote-as 202
 neighbor AB01:CD1:123:E:C605:16FF:FE98:0 ebgp-multihop 5
 no auto-summary
 !
 address-family ipv6
  neighbor 1111:111:111:A:C601:3FF:FEF0:0 activate
  neighbor 1111:111:111:A:C601:3FF:FEF0:0 next-hop-self
  neighbor 1111:111:111:A:C601:3FF:FEF0:0 route-map LOCAL_PREF out
  neighbor 2222:222:222:A:C602:3FF:FEF0:0 activate
  neighbor 2222:222:222:A:C602:3FF:FEF0:0 next-hop-self
  neighbor 2222:222:222:A:C602:3FF:FEF0:0 route-map LOCAL_PREF out
  neighbor AB01:CD1:123:E:C605:16FF:FE98:0 activate
 exit-address-family

!
ipv6 prefix-list 10 seq 5 permit BC01:BC1:10:A::/64
!
route-map LOCAL_PREF permit 10
 match ipv6 address prefix-list 10
 set local-preference 500
!
route-map LOCAL_PREF permit 20
!
route-map CONNECTED permit 10
 match interface Serial0/0

R4
interface Serial0/0
 no ip address
 ipv6 address AB01:CD1:123:C::/64 eui-64
 ipv6 enable
 clock rate 2000000
!
interface Loopback10
 no ip address
 ipv6 address BC01:BC1:10:A::/64 eui-64
 ipv6 enable
!
interface Loopback11
 no ip address
 ipv6 address BC02:BC1:11:A::/64 eui-64
 ipv6 enable
!
interface Loopback12
 no ip address
 ipv6 address BC03:BC1:12:A::/64 eui-64
 ipv6 enable

router bgp 101
 bgp router-id 4.4.4.4
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor AB01:CD1:123:C:C601:3FF:FEF0:0 remote-as 123
 neighbor AB01:CD1:123:C:C601:3FF:FEF0:0 ebgp-multihop 5
 !
 address-family ipv6
  neighbor AB01:CD1:123:C:C601:3FF:FEF0:0 activate
  network BC01:BC1:10:A::/64
  network BC02:BC1:11:A::/64
  network BC03:BC1:12:A::/64
 exit-address-family

R5
interface Serial0/0
 no ip address
 ipv6 address AB01:CD1:123:E::/64 eui-64
 ipv6 enable
 clock rate 2000000
!
interface Loopback10
 no ip address
 ipv6 address BC01:BC1:10:A::/64 eui-64
 ipv6 enable
!
interface Loopback11
 no ip address
 ipv6 address BC02:BC1:11:A::/64 eui-64
 ipv6 enable
!
interface Loopback12
 no ip address
 ipv6 address BC03:BC1:12:A::/64 eui-64
 ipv6 enable
!
router bgp 202
 bgp router-id 5.5.5.5
 no bgp default ipv4-unicast
 bgp log-neighbor-changes
 neighbor AB01:CD1:123:E:C603:3FF:FEF0:0 remote-as 123
 neighbor AB01:CD1:123:E:C603:3FF:FEF0:0 ebgp-multihop 5
 !
 address-family ipv6
  neighbor AB01:CD1:123:E:C603:3FF:FEF0:0 activate
  network BC01:BC1:10:A::/64
  network BC02:BC1:11:A::/64
  network BC03:BC1:12:A::/64
 exit-address-family

Проверка.

Этот раздел предоставляет сведения, можно использовать, чтобы подтвердить, что должным образом работает конфигурация.

На маршрутизаторе R1

  1. show ipv6 interface brief

    http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6/113035-ipv6-bgp-local-preference-config-02.gif

  2. show bgp ipv6 одноадресно передал сводку

    http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6/113035-ipv6-bgp-local-preference-config-03.gif

На маршрутизаторе R2

  1. show ipv6 interface brief

    http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6/113035-ipv6-bgp-local-preference-config-04.gif

  2. show bgp ipv6 unicast

    Примечание: Когда Локальный параметр не настроен, маршрутизатор R2 (Rtr2) имеет маршрутизатор R1 (Rtr1) как свой следующий переход для всего изученного Ipv6 address. http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6/113035-ipv6-bgp-local-preference-config-05.gif

  3. show bgp ipv6 unicast

    После Локального параметра Настройки 500 для префиксного BC01:BC1:10:A::/64, R2 имеет другой выход только для этого префикса.

    http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6/113035-ipv6-bgp-local-preference-config-06.gif

    Примечание: Префиксный BC01:BC1:10:A::/64 берет выходной путь Маршрутизатора R3, поскольку Локальный параметр установлен выше.

На маршрутизаторе R3

  1. show ipv6 interface brief

    http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6/113035-ipv6-bgp-local-preference-config-07.gif

  2. show bgp ipv6 одноадресно передал сводку

    http://www.cisco.com/c/dam/en/us/support/docs/ip/ip-version-6/113035-ipv6-bgp-local-preference-config-08.gif

Устранение неполадок

Используйте эти команды для устранения проблем

  1. debug bgp ipv6 updates
  2. clear bgp ipv6 {индивидуальная рассылка | групповая адресация}

Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 113035