Протокол IP : Протокол BGP

Понимание атрибута MED BGP

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Цель этого документа состоит в том, чтобы предоставить лучше понимание Атрибута Multi Exit Discriminator (MED) Протокола BGP при пересечении границы автономной системы (AS) путем реализации его в других сценариях.

Когда существуют точки несколька точек входа для того AS, MED предоставляет динамический способ для влияния на другой AS в способе достигнуть определенного маршрута. BGP придерживается систематической процедуры для выбора оптимального пути. Существуют другие Важные атрибуты, такие как вес, локальный параметр, инициируют маршрут и путь AS, которые приняты для учета прежде, чем рассмотреть атрибут MED. Так, если какое-либо из этих соответствий критериев, не рассмотрят атрибут MED.

Примечание: Когда все другие факторы равны, точка выхода с самым низким MED предпочтена.

Предварительные условия

Требования

Cisco рекомендует иметь базовые знания о BGP.

Используемые компоненты

Настоящий документ не имеет жесткой привязки к каким-либо конкретным версиям программного обеспечения и оборудования. Сценарии, обсужденные в этом документе, используют эти версии программного и аппаратного обеспечения:

  • Сценарий 1: Маршрутизаторы Cisco 2600 на Cisco Выпуск ПО IOS� 12.4 или позже

  • Сценарий 2: Маршрутизаторы Cisco 2600 на Cisco IOS Software Release 12.4 или позже

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Примеры практического применения

Сценарий 1

Когда динамик BGP изучает маршрут из узла, MED маршрута передают к другому внутреннему BGP (iBGP) узлы, но не к внешнему BGP (eBGP) узлы.

Рассмотрите эту сетевую установку:

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/112965-bgpmed-attr-01.gif

Здесь, маршрутизатор R1 и маршрутизатор R2 рассматривают в том же AS, например AS#100, и маршрутизатор R3 принадлежит AS#101. Для легкого соглашения используются IP-адреса в блоке/24.

Маршрутизаторы R1 и R2 настроены следующим образом:

Маршрутизатор 1
(Config)#interface Loopback10
(Config-if)#ip address 10.10.10.10 255.255.255.255
(Config-if)#interface FastEthernet0/0
(Config-if)#ip address 192.1.12.1 255.255.255.0
(Config)#router bgp 100
(Config-router)#no synchronization
(Config-router)#bgp router-id 10.10.10.10
(Config-router)#bgp log-neighbor-changes
(Config-router)#network 10.10.10.10 mask 255.255.255.255 route-map ATTACH_MED
(Config-router)#neighbor 192.1.12.2 remote-as 100
(Config-router)#no auto-summary
(Config)#access-list 10 permit 10.10.10.10
(Config)#route-map ATTACH_MED permit 10
(Config)#match ip address 10
(Config)#set metric 100

Router-2
(Config)#interface FastEthernet0/0
(Config-if)#ip address 192.1.12.2 255.255.255.0
(Config-if)#interface Serial1/0
(Config-if)#ip address 192.1.23.2 255.255.255.0
(Config-if)#encapsulation frame-relay IETF
(Config-if)#no fair-queue
(Config-if)#frame-relay map ip 192.1.23.3 203 broadcast
(Config-if)#no frame-relay inverse-arp
(Config-if)#frame-relay lmi-type ansi
(Config)#router bgp 100
(Config-router)#no synchronization
(Config-router)#bgp router-id 22.22.22.22
(Config-router)#bgp log-neighbor-changes
(Config-router)#neighbor 192.1.12.1 remote-as 100
(Config-router)#neighbor 192.1.23.3 remote-as 101
(Config-router)#neighbor 192.1.23.3 ebgp-multihop 3
(Config-router)#no auto-summary

Конфигурация маршрутизатора R3 дана здесь:

Маршрутизатор 3
(Config)#interface Serial1/0
(Config-if)#ip address 192.1.23.3 255.255.255.0
(Config-if)#encapsulation frame-relay IETF
(Config-if)#no fair-queue
(Config-if)#frame-relay map ip 192.1.23.2 302 broadcast
(Config-if)#no frame-relay inverse-arp
(Config-if)#frame-relay lmi-type ansi
(Config)#router bgp 101
(Config-router)#no synchronization
(Config-router)#bgp log-neighbor-changes
(Config-router)#neighbor 192.1.23.2 remote-as 100
(Config-router)#neighbor 192.1.23.2 ebgp-multihop 3
(Config-router)#no auto-summary

В этой настройке R1 и R2 имеют выполнение iBGP. Поэтому, когда обновление вводит AS с определенной метрикой, та метрика используется для создания решений в AS. Команда show ip bgp , когда проверено от R2 показывает вам значение метрики для 10.10.10.10, который наклонен через соседа iBGP 192.1.12.1 и будет иметь Значение MED 100.

Выходные данные от R2 показывают здесь:

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/112965-bgpmed-attr-02.gif

eBGP выполняется между R2 и R3, потому что они находятся в другом AS. Когда те же проходы обновления в третий AS, например AS#101, та метрика возвращается к 0. Команде show ip bgp , когда проверено от R3 удалят ее метрику, потому что 10.10.10.10 пересечений граница AS (101).

Выходные данные от R3 показывают здесь:

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/112965-bgpmed-attr-03.gif

Из этого сценария очевидно, что атрибут MED может влиять на входящий трафик от соседних автономных систем. Атрибут MED не может влиять на решения о маршрутизации более - удаленные автономные системы. Когда динамик BGP изучает маршрут из узла, это может передать MED маршрута к любым равноправным объектам IBGP, но не к узлам eBGP. В результате MED имеет уместность только между соседними автономными системами.

Сценарий 2

Если маршрут, введенный в BGP (или использование сети или перераспределяют команду), прибывает из IGP (RIP или EIGRP или OSPF), MED получен из метрики IGP, и маршрут объявлен к соседу по протоколу EBGP с этим MED.

Этот сценарий использует эту сетевую установку:

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/112965-bgpmed-attr-04.gif

В этой сети R1 настроен для выполнения в сети RIP. Маршрутизаторы R2 и R3 выполняют BGP, где R2 настроен с AS 100, в то время как R3 с AS 101.

Маршрутизатор R1 настроен следующим образом:

Маршрутизатор М1
(Config)#interface Loopback10
(Config-if)#ip address 10.10.10.10 255.255.255.255
(Config-if)#interface FastEthernet0/0
(Config-if)#ip address 192.1.12.1 255.255.255.0
(Config)#router rip
(Config-router)#network 10.0.0.0
(Config-router)#network 192.1.12.0
(Config-router)#no auto-summary

Маршрутизаторы R2 и R3 настроены для BGP, где перераспределение сделано в R2 для введения сетей RIP к BGP.

Маршрутизатор М2
(Config)#interface FastEthernet0/0
(Config-if)#ip address 192.1.12.2 255.255.255.0
(Config-if)#interface Serial1/0
(Config-if)#ip address 192.1.23.2 255.255.255.0
(Config-if)#encapsulation frame-relay IETF
(Config-if)#no fair-queue
(Config-if)#frame-relay map ip 192.1.23.3 203 broadcast
(Config-if)#no frame-relay inverse-arp
(Config-if)#frame-relay lmi-type ansi
(Config)#router rip
(Config-router)# network 192.1.12.0
(Config-router)#no auto-summary
(Config-router)#router bgp 100
(Config-router)#no synchronization
(Config-router)#bgp router-id 22.22.22.22
(Config-router)#bgp log-neighbor-changes
(Config-router)#neighbor 192.1.23.3 remote-as 101
(Config-router)#neighbor 192.1.23.3 ebgp-multihop 3
(Config-router)#redistribute rip metric 1
 Config-router)#no auto-summary

Маршрутизатор R3
(Config)#interface Serial1/0
(Config-if)#ip address 192.1.23.3 255.255.255.0
(Config-if)#encapsulation frame-relay IETF
(Config-if)#no fair-queue
(Config-if)#frame-relay map ip 192.1.23.2 302 broadcast
(Config-if)#no frame-relay inverse-arp
(Config-if)#frame-relay lmi-type ansi
(Config)#router bgp 101
(Config-router)# no synchronization
(Config-router)#bgp router-id 33.33.33.33
(Config-router)#bgp log-neighbor-changes
(Config-router)#neighbor 192.1.23.2 remote-as 100
(Config-router)#neighbor 192.1.23.2 ebgp-multihop 3
(Config-router)#no auto-summary

И RIP и BGP работают на R2. При проверке использования команды show ip bgp вы видите, что префикс, который 10.0.0.0 сети показывают с метрикой 1, который получен из RIP.

Выходные данные от R2 показывают здесь:

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/112965-bgpmed-attr-05.gif

Однако в R3, который работает на eBGP, сеть объявлена путем считания Значения MED полученным из IGP. В этом случае это - RIP. Префикс 10.0.0.0 объявлен со Значением MED IGP, которое является метрикой RIP 1.

Это может замеченный в этих выходных данных:

http://www.cisco.com/c/dam/en/us/support/docs/ip/border-gateway-protocol-bgp/112965-bgpmed-attr-06.gif

Из этого сценария поведение MED, в случае сетей, вводимых к маршрутизатору под управлением BGP через сеть или, перераспределяет команду, ясно замечен, где фактическое Значение MED заменяется той из метрики IGP. Теперь, учитывая что этот атрибут является подсказкой к внешним соседям о предпочтениях пути в AS. Как сообщили ранее, не всегда считается, существует ли другое больше Важных атрибутов для определения лучшего маршрута. Чтобы иметь тот же эффект с более детерминированным атрибутом, используйте команду set as-path prepend в соответствии с Картой маршрутизации. При подготовке пути AS для определенных маршрутов он продолжит быть замеченным другим AS. Для получения дополнительной информации об использовании As-path prepend обратитесь к Использованию Набора-aspath, предварительно ожидают Команду.


Дополнительные сведения


Document ID: 112965