Коммутаторы : ??????????? ??????? ?????????? 1440 ?? ???? ???????????? Cisco Catalyst 6500

Миграция автономного коммутатора Cisco Catalyst 6500 к виртуальной системе коммутации Cisco Catalyst 6500

10 февраля 2011 - Перевод, выполненный профессиональным переводчиком
Другие версии: PDF-версия:pdf | Машинный перевод (28 июля 2013) | Английский (25 февраля 2009) | Отзыв

Содержание

Введение
Предварительные условия
      Требования
      Используемые компоненты
      Условные обозначения
Общие сведения
Процесс переноса
      Поддержка оборудования и ПО
      Пути переноса
      Обзор схемы переноса
      Пошаговый процесс переноса
Связанные обсуждения сообщества поддержки Cisco
Дополнительные сведения

Введение

В этом документе описана процедура переноса автономного коммутатора Cisco Catalyst серии 6500 в систему виртуальной коммутации Cisco Catalyst 6500.

Примечание. В этом документе указаны только общие шаги, необходимые для переноса. Непосредственный порядок действий зависит от текущей конфигурации коммутатора и может незначительно отличаться от описываемой процедуры.

Предварительные условия

Требования

Компания Cisco рекомендует ознакомиться со следующими темами:

Используемые компоненты

Сведения, содержащиеся в этом документе, касаются коммутаторов Cisco Catalyst серии 6500 с супервизором VS-S720-10G-3C/XL под управлением ПО Cisco IOS® Software Release 12.2(33)SXH1 или более позднего выпуска.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. При работе в действующей сети необходимо понимать последствия выполнения любой команды.

Условные обозначения

Подробные сведения об условных обозначениях см. в документе Условное обозначение технических терминов Cisco.

Общие сведения

Система виртуальной коммутации (VSS) — новая оригинальная функция коммутаторов Cisco Catalyst 6500, фактически позволяющая представить два физических шасси как единый логический элемент. Такая технология несет в себе обширный потенциал модернизации корпоративных офисных комплексов и центров обработки данных, включая режим высокой доступности, обеспечение масштабируемости и производительности, а также управление и техническое обслуживание.

Текущая реализация VSS позволяет объединить два физических коммутатора Cisco Catalyst серии 6500 в один логически управляемый объект. Этот принцип проиллюстрирован на рисунке: включив VSS, можно управлять двумя шасси 6509 как одним шасси с 18 слотами.

/image/gif/paws/109573/vss-migration1.gif

Процесс переноса

Поддержка оборудования и программного обеспечения

VSS — программная функция, доступная только в коммутаторах Cisco Catalyst серии 6500. Для ее включения и использования требуются следующие компоненты:

Оборудование. VS-S720-10G-3C/XL

/image/gif/paws/109573/vss-migration2.gif

Программное обеспечение. ПО Cisco IOS, выпуск 12.2(33)SXH1 или выше.

Пути переноса

В следующей таблице перечислен ряд возможных путей переноса в систему VSS: Эта конфигурация носит ориентировочный характер и не является исчерпывающей.

Первоначальная конфигурация. Требуемое обновление. Итоговая конфигурация.
Два коммутатора Cisco Catalyst серии 6500 с супервизорами WS-SUP720-3B.

/image/gif/paws/109573/vss-migration3.gif

Модернизация оборудования — супервизоры VS-S720-10G-3C/XL. Обновление ПО — Cisco IOS 12.2(33)SXH1 или выше. VSS

/image/gif/paws/109573/vss-migration4.gif

Два коммутатора Cisco Catalyst серии 6500 с супервизорами VS-S720-10G-3C/XL.

/image/gif/paws/109573/vss-migration5.gif

Обновление ПО — выпуск Cisco IOS 12.2(33)SXH1 или выше. VSS

/image/gif/paws/109573/vss-migration4.gif

Обзор схемы переноса

Общая конфигурация в автономной среде

/image/gif/paws/109573/vss-migration6.gif

Функции и протоколы, действующие между ядром 3-го уровня (L3) и распределительной топологией 2-го/3-го уровней:

  • Протоколы маршрутизации IP

  • Каналы портов 3-го уровня или и функция маршрутизации IP EqualCost MultiPath

Функции и протоколы, действующие между распределительной топологией 2-го/3-го уровней и уровнем доступа:

  • Протокол STP (Spanning Tree Protocol)

  • Протоколы маршрутизации на первом переходе (FHRP)

  • Политики: QoS, ACL

  • Групповые каналы 2-го уровня, сети VLAN, каналы портов

Перенос в систему VSS

Процесс переноса состоит из нескольких шагов. Каждый шаг поясняется в этом разделе.

/image/gif/paws/109573/vss-migration7.gif

Порядок переноса между ядром и распределительным уровнем:

  • настройка канала MultiChassis EtherChannel (MEC);

  • изменение конфигурации маршрутизации IP и удаление команд, переставших быть необходимыми.

Порядок переноса между распределительным уровнем и уровнем доступа:

  • настройка канала MEC;

  • сохранение в действии протокола STP;

  • изменение команд FHRP;

  • переносом QoS и политик с помощью в MEC посредством списков ACL (при необходимости);

  • перенос конфигурации групповых каналов 2-го уровня в MEC.

Пошаговый процесс переноса

Выполните следующие действия:

  1. В первоначальной автономной конфигурации обычно применяется выравнивание нагрузки от трафика между распределительными коммутаторами с использованием механизмов распределения нагрузки VLAN и конфигурации HSRP.

    /image/gif/paws/109573/vss-migration8.gif

  2. Измените конфигурации HSRP и STP таким образом, чтобы для всех потоков активным стал коммутатор Distribution-1, а соседние устройства обнаружили это изменение и направляли весь трафик коммутатору Distribution-1.

    /image/gif/paws/109573/vss-migration9.gif

  3. Остановите физические интерфейсы коммутатора Distribution-2, чтобы изолировать его от сети.

    /image/gif/paws/109573/vss-migration10.gif

    .

    После окончательного выбытия коммутатора Distribution-2 из сети можно переключить его в режим VSS без помех для полезного трафика.

  4. Установите новый супервизор (VS-SUP720-10G), если он не был установлен ранее, и проверьте его состояние.

    Distribution-2#show module
    Mod Ports Card Type                              Model              Serial No.
    --- ----- -------------------------------------- ------------------ -----------
      5    5  Supervisor Engine 720 10GE (Active)    VS-S720-10G        SAD104707BB
      9   48  CEF 720 48 port 10/100/1000mb Ethernet WS-X6748-GE-TX     SAL1020NGY3
  5. Скопируйте программное обеспечение Cisco IOS, совместимое с системой VSS, на носитель sup-bootdisk:

    Distribution-2#copy ftp: sup-bootdisk:
    Address or name of remote host []? 172.16.85.150
    Source filename []? s72033-ipservices_wan_vz.122-33.SXH1.bin
    Destination filename [s72033-ipservices_wan_vz.122-33.SXH1.bin]?
    Accessing ftp://172.16.85.150/s72033-ipservices_wan_vz.122-33.SXH1.bin...
  6. Обновите настройку bootvar для загрузки ПО Cisco IOS, скопированного на sup-bootdisk:

    Distribution-2(config)#boot system flash sup-bootdisk:s72033-ipservices_wan_vz.122-33.SXH1.bin
    
    
  7. Для работы коммутатора Distribution-2 в режиме VSS необходим канал виртуального коммутатора (VSL). VSL можно организовать на основе текущего канала PortChannel между коммутаторами Distribution-1 и Distribution-2.

    /image/gif/paws/109573/vss-migration11.gif

  8. Настройте атрибуты виртуального коммутатора:

    1. номер домена виртуальной коммутации (уникален в пределах сети);

    2. номер виртуального коммутатора (уникален в пределах домена);

    3. канал виртуальной коммутации (VSL).

    Distribution-2(config)#hostname VSS
    
    VSS(config)#switch virtual domain 100
    
    VSS(config-vs-domain)#switch 1
    
    
    !--- After conversion Distribution-2 will be noted 
    !--- as Switch 1 in VSS mode.
    
    VSS(config-vs-domain)# exit
    VSS(config)#interface port-channel 1
    VSS(config-if)#switch virtual link 1
    
    VSS(config-if)#interface TenG 5/4
    VSS(config-if)#channel-group 1 mode on
    VSS(config-if)#interface TenG 5/5
    VSS(config-if)#channel-group 1 mode on
    VSS(config-if)# ^Z
    VSS#
  9. Переведите коммутатор Distribution-2 в режим VSS.

    Примечание. Выполните в консоли коммутатора следующую команду:

    VSS#switch convert mode virtual
    
    This command will convert all interface
    names to naming convention "interface-type
    switch-number/slot/port",
    save the running config to startup-config and
    reload the switch.
    Do you want to proceed? [yes/no]: yes
    Converting interface names
    Building configuration...
    
    
    !--- At this point the switch will reboot
    
    
    
    !--- snippet of the console output
    
    System detected Virtual Switch configuration...
     Interface TenGigabitEthernet 1/5/4 is member of
    PortChannel 1
     Interface TenGigabitEthernet 1/5/5 is member of
    PortChannel 1
    
    !--- snippet of the console output
    
    00:00:23: %PFREDUN-6-ACTIVE: Initializing as ACTIVE
    processor for this switch
    
    !--- snippet of the console output
    
    00:00:28: %VSL_BRINGUP-6-MODULE_UP: VSL module in slot 5
    switch 1 brought up
    Initializing as Virtual Switch Active
    
  10. Проверьте перевод коммутатора Distribution-2 в режим VSS.

    VSS#show switch virtual role
    
    Switch  Switch Status  Preempt    Priority   Role     Session ID
            Number         Oper(Conf) Oper(Conf)          Local  Remote
    -------------------------------------------------------------------
    LOCAL    1     UP      FALSE(N)    110(110)  ACTIVE    0      0
    
    In dual-active recovery mode: No

    Коммутатор Distribution-2 успешно переведен и работает в режиме VSS. Шаги предварительной настройки можно выполнить и после перевода коммутатора Distribution-1. Вместе с тем, предварительная настройка помогает уменьшить потери пакетов во время переноса.

    /image/gif/paws/109573/vss-migration12.gif

  11. Для предварительной настройки коммутатора Switch-1 в системе VSS выполните следующие шаги:

    1. настройте MEC с использованием локальных интерфейсов коммутатора Switch-1; интерфейсы коммутатора Switch-2 (в данный момент — Distribution-1) можно добавить к MEC после его перевода в режим VSS;

      • настройте MEC;

      • переместите конфигурацию интерфейса в MEC;

      • переместите политики QoS и ACL в MEC.

      Первоначальная конфигурация
      interface TenGigabitEthernet1/2/1
       ip address 192.168.4.2 255.255.255.0
      
      interface GigabitEthernet1/1/2
       switchport
       switchport trunk encapsulation dot1q
       switchport trunk allowed vlan 10,20
      Изменения в конфигурации
      
      !--- MEC to Core layer
      
      VSS(config)# int ten 1/2/1
      VSS(config-if)# no ip address
      VSS(config-if)# interface po20
      VSS(config-if)# ip address 192.168.4.2 255.255.255.0
      VSS(config-if)# no shut
      VSS(config-if)# interface ten1/2/1
      VSS(config-if)# channel-group 20 mode desirable
      
      
      !--- MEC to Access layer
      
      VSS(config-if)# interface po10
      VSS(config-if)# switchport
      VSS(config-if)# switchport trunk encapsulation dot1q
      VSS(config-if)# switchport trunk allowed vlan 10,20
      VSS(config-if)# no shut
      VSS(config-if)# interface gig1/1/2
      VSS(config-if)# switchport
      VSS(config-if)# channel-group 10 mode desirable
      Настройте соседние устройства для канала PortChannel

      В этот момент соединения между коммутатором Switch-1 системы VSS и его соседними устройствами нет. Поэтому канал порта можно настроить, не нарушая движение трафика через коммутатор Distribution-1.

      
      !--- In Core layer devices
      
      Core(config)# int gig 1/1
      Core(config-if)# no ip address
      Core(config-if)# int po20
      Core(config-if)# ip address 192.168.4.1 255.255.255.0
      Core(config-if)# no shut
      Core(config-if)# int gig 1/1
      Core(config-if)# channel-group 20 mode desirable
      
      !--- In Access layer devices
      
      Access(config)# int po10
      Access(config-if)# switchport
      Access(config-if)# switchport trunk encapsulation dot1q
      Access(config-if)# switchport trunk
      Access(config-if)# no shut
      Access(config-if)# int gig 1/1
      Access(config-if)# channel-group 10 mode desirable
    2. В системе VSS активное и резервное шасси используют запрограммированный в активное шасси MAC-адрес и IP-адрес сети VLAN. HSRP более не требуется.

      • Переместите виртуальные IP-адреса HSRP на интерфейсы VLAN.

      • Удалите конфигурацию HSRP с интерфейсов VLAN.

      Первоначальная конфигурация
      interface Vlan10
       ip address 10.1.1.2 255.255.255.0
       standby 10 ip 10.1.1.1
       standby 10 priority 110
      !
      interface Vlan20
       ip address 20.1.1.2 255.255.255.0
       standby 20 ip 20.1.1.1
       standby 20 priority 110
      !
      Изменения в конфигурации
      VSS(config)# interface Vlan10
      VSS(config-if)# no standby 10 ip 10.1.1.1
      VSS(config-if)# no standby 10 priority 110
      VSS(config-if)# ip address 10.1.1.1 255.255.255.0
      VSS(config-if)# interface Vlan20
      VSS(config-if)# no standby 20 ip 20.1.1.1
      VSS(config-if)# no standby 20 priority 110
      VSS(config-if)# ip address 20.1.1.1 255.255.255.0

      Примечание. Записи ARP оконечных устройств будут по-прежнему указывать на MAC-адреса HSRP. До истечения периода действия этих записей или отправки очередного пакета ARP для обновления кэша связь будет недоступна.

    3. Включите функцию NSF-SSO для используемых протоколов маршрутизации IP. VSS упрощает настройку маршрутизации, снимая необходимость в некоторых сетевых операторах. По этой причине данные операторы могут быть удалены.

      VSS Switch-1
      VSS#show running-config | begin ospf
      router ospf 1
       log-adjacency-changes
       network 10.1.1.0 0.0.0.255 area 0
       network 20.1.1.0 0.0.0.255 area 0
       network 192.168.4.0 0.0.0.255 area 0
       network 192.168.5.0 0.0.0.255 area 0
      
      !--- rest of output elided
      
      
      
      !--- Previous L3 interfaces are merged as MEC, hence some
      routing statements are no longer required.
      
      
      VSS(config)# router ospf 1
      VSS(config-router)# nsf
      VSS(config-router)# no network 192.168.5.0 0.0.0.255 area 0
      Ядро
      Core#show running-config | begin ospf
      router ospf 1
       log-adjacency-changes
       network 192.168.4.0 0.0.0.255 area 0
       network 192.168.5.0 0.0.0.255 area 0
      
      !--- rest of output elided
      
      
      
      !--- Previous L3 interfaces are merged as MEC, hence some
      routing statements are no longer required.
      
      
      Core(config)# router ospf 1
      Core(config-router)# nsf
      Core(config-router)# no network 192.168.5.0 0.0.0.255 area 0
    4. Измените конфигурацию STP таким образом, чтобы коммутатор Switch-1 системы VSS стал корневым для всех сетей VLAN.

  12. Проверьте конфигурацию и подключение коммутатора VSS Switch-1.

    • Включите интерфейсы VSS коммутатора Switch-1.

    • Проверьте связь на 2-м уровне с другими устройствами уровня доступа.

    • Проверьте связь на 3-м уровне с другими устройствами уровня ядра.

    /image/gif/paws/109573/vss-migration13.gif

  13. После проверки связи с коммутатором Switch-1 системы VSS остановите интерфейсы коммутатора Distribution-1 для переключения трафика на систему VSS.

    /image/gif/paws/109573/vss-migration14.gif

  14. Повторите шаги по настройке коммутатора Distribution-1 для его перевода в предпочтительный резервный режим VSS.

    Distribution-1(config)#hostname VSS
    
    VSS(config)#switch virtual domain 100
    
    VSS(config-vs-domain)#switch 2
    
    
    !--- After conversion Distribution-1 will be noted 
    !--- as Switch 2 in VSS mode.
    
    VSS(config-vs-domain)# exit
    VSS(config)#interface port-channel 2
    VSS(config-if)#switch virtual link 2
    
    VSS(config-if)#interface TenG 5/4
    VSS(config-if)#channel-group 2 mode on
    VSS(config-if)#interface TenG 5/5
    VSS(config-if)#channel-group 2 mode on
    VSS(config-if)# ^Z
    VSS#
    
    VSS#switch convert mode virtual
    
    This command will convert all interface
    names to naming convention "interface-type
    switch-number/slot/port",
    save the running config to startup-config and
    reload the switch.
    Do you want to proceed? [yes/no]: yes
    Converting interface names
    Building configuration...
    
    
    !--- At this point the switch will reboot
    
    
    
    !--- snippet of the console output
    
    System detected Virtual Switch configuration...
     Interface TenGigabitEthernet 2/5/4 is member of
    PortChannel 2
     Interface TenGigabitEthernet 2/5/5 is member of
    PortChannel 2
    
    !--- snippet of the console output
    
    00:00:23: %PFREDUN-6-ACTIVE: Initializing as ACTIVE
    processor for this switch
    
    !--- snippet of the console output
    
    00:00:28: %VSL_BRINGUP-6-MODULE_UP: VSL module in slot 5
    switch 2 brought up
    Initializing as Virtual Switch Standby
    
  15. После загрузки резервного коммутатора VSS конфигурация активного коммутатора VSS автоматически синхронизируется с резервным коммутатором VSS. При загрузке интерфейсы резервной VSS (Switch-2) находятся в отключенном состоянии.

    /image/gif/paws/109573/vss-migration15.gif

  16. Завершите настройку виртуального коммутатора.

    Примечание. Этот критический завершающий шаг необходим только при первоначальном переводе коммутатора. Если перевод коммутатора выполнялся ранее полностью или частично, эта команда действовать не будет. В этих случаях будет выдаваться сообщение об ошибке:

    11:27:30: %PM-SP-4-ERR_DISABLE: channel-misconfig error detected
    on Po110, putting Gi9/2 in err-disable state
    

    Для автоматического задания конфигурации резервного виртуального коммутатора на активном виртуальном коммутаторе можно выполнить эту команду:

    VSS#switch accept mode virtual
    
    This command will bring in all VSL configurations from the standby 
    switch and populate it into the running configuration.
    In addition the startup configurations will be updated with the 
    new merged configurations.
    Do you want proceed? [yes/no]: yes
    Merging the standby VSL configuration. . .
    Building configuration...

    Примечание. Помните, что команда switch accept mode virtual начиная с выпуска ПО Cisco IOS 12.2 SXI более не требуется, поскольку конфигурации объединяются автоматически.

  17. Добавьте к MEC интерфейсы коммутатора Switch-2.

    • VSS
      
      !--- To Core layer
      
      VSS(config)# interface range tengig 1/2/1, tengig2/2/1
      VSS(config-if-range)# channel-group 20 mode desirable
      VSS(config-if-range)# no shut
      
      
      !--- To Access layer
      
      VSS(config)# interface range gig 1/1/2, gig 2/1/2
      VSS(config-if-range)# switchport
      VSS(config-if-range)# channel-group 10 mode desirable
      VSS(config-if-range)# no shut
      
    • Соседний узел VSS — ядро
      Core(config)# interface range gig 1/1, gig 1/2
      Core(config-if-range)# channel-group 20 mode desirable
      Core(config-if-range)# no shut
    • Соседний узел VSS — доступ
      Access(config)# interface range gig 1/1, gig 1/2
      Access(config-if-range)# channel-group 10 mode desirable
      Access(config-if-range)# no shut

    Перенос в систему VSS завершен. В этот момент работают оба коммутатора системы VSS, и нагрузка от трафика выравнивается между всеми восходящими интерфейсами.

    /image/gif/paws/109573/vss-migration16.gif


Связанные обсуждения сообщества поддержки Cisco

В рамках сообщества поддержки Cisco можно задавать и отвечать на вопросы, обмениваться рекомендациями и совместно работать со своими коллегами.


Дополнительные сведения


Document ID: 109573