Интерфейсы и модули Cisco : Cisco Catalyst 6500 Series Multilayer Switch Feature Card

EIGRP Catalyst 6500 по облегченному VRF примеру конфигурации

20 октября 2016 - Машинный перевод
Другие версии: PDF-версия:pdf | Английский (22 августа 2015) | Отзыв


Содержание


Введение

Этот документ описывает, как настроить EIGRP через передачу виртуального маршрута (VRF) - облегченный на коммутаторе Cisco Catalyst серии 6500. Статический маршрут настроен на коммутаторах и перераспределен через EIGRP между коммутаторами.

Предварительные условия

Требования

Компания Cisco рекомендует предварительно ознакомиться со следующими предметами:

  • Базовые знания о EIGRP

  • Базовые знания о конфигурации Catalyst 6500

Используемые компоненты

Сведения в этом документе основываются на Коммутаторах серии Catalyst 6500, которые работают под управлением ПО версии 12.2 (33).SXH6.

Сведения, представленные в этом документе, были получены от устройств, работающих в специальной лабораторной среде. Все устройства, описанные в этом документе, были запущены с чистой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Условные обозначения

Дополнительные сведения об условных обозначениях см. в документе Условные обозначения технических терминов Cisco.

Общие сведения

Облегченный VRF позволяет поставщику услуг поддерживать две или больше VPN с перекрывающимся IP-адресом с помощью одного интерфейса. Облегченный VRF также назван CE мульти-VRF или Пограничным устройством заказчика мульти-VRF. В прошлом облегченный VRF поддерживался только с RIP, OSPF и BGP. Но в последних версиях, облегченных VRF, также поддерживается с EIGRP. Этот документ предоставляет пример EIGRP по облегченной VRF конфигурации интерфейса командой строки, где статические маршруты VRF перераспределены через EIGRP к другим коммутаторам.

Настройте облегченный VRF через Catalyst 6500

Это рекомендации для настройки облегченный VRF через Catalyst 6500:

  • Коммутатор с облегченным VRF разделен нескольками пользовательских устройств, и у всех клиентов есть свои собственные таблицы маршрутизации.

  • Поскольку клиенты используют другие таблицы VRF, те же IP-адреса могут быть снова использованы. Перекрытые IP-адреса позволены в других VPN.

  • Облегченный VRF позволяет несколькам пользовательских устройств совместно использовать то же физическое соединение между PE и CE. Магистральные порты с отдельными пакетами несколько интерфейсов VLAN среди клиентов. У всех клиентов есть свои собственные VLAN.

  • Для Периферийного маршрутизатора нет никакого различия между использованием облегченного VRF или использованием множественного CEs.

  • Клиент может использовать несколько интерфейсов VLAN, пока они не накладываются на те из других клиентов. VLAN клиента сопоставлены с определенным ID таблицы маршрутизации, который используется для определения соответствующих таблиц маршрутизации, сохраненных на коммутаторе.

  • Облегченный VRF не влияет на скорость коммутации пакетов.

Конфигурация интерфейса командой строки CLI

Этот раздел показывает конфигурацию интерфейса командой строки:

 6500A(config)#ip vrf TEST-LAB
 6500A(config)#rd 10.244.0.10:100

 6500A(config)#interface Loopback100
 6500A(config-if)#ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.129.1 255.255.255.255
 6500A(config-if)#exit

 6500A(config)#interface GigabitEthernet7/1
 6500A(config-if)# ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.128.121 255.255.255.252
 6500A(config-if)#exit

 6500A(config)#no snmp trap link-status
 6500A(config)#interface TenGigabitEthernet8/6
 6500A(config-if)#ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.128.21 255.255.255.252
 6500A(config-if)#exit
 6500A(config)# no snmp trap link-status
 6500A(config)# router eigrp 99
 6500A(config-router)# network 10.0.0.0
 6500A(config-router)# no auto-summary
 6500A(config-router)# address-family ipv4 vrf TEST-LAB
 6500A(config-router)# redistribute static metric 10000 100 255 1 1500
 
 
!--- Redistribute static routes

 6500A(config-router)# network 10.244.128.0 0.0.0.255
 6500A(config-router)# network 10.244.129.0 0.0.0.255 
 6500A(config-router)# autonomous-system 99
 6500A(config-router)#exit-address-family
 6500A(config-router)#exit  
 6500A(config)#ip classless
 6500A(config)#ip route vrf TEST-LAB 10.0.0.0 255.0.0.0 10.244.129.251
 6500A(config)#interface Vlan129
 6500A(config)#ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.129.250 255.255.255.248
 6500A(config)#ip vrf TEST-LAB
 6500A(config)#rd 10.244.0.10:100

 6500A(config)#interface Loopback100
 6500A(config-if)#ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.129.1 255.255.255.255
 6500A(config-if)#exit

 6500A(config)#interface GigabitEthernet7/1
 6500A(config-if)# ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.128.121 255.255.255.252
 6500A(config-if)#exit

 6500A(config)#no snmp trap link-status
 6500A(config)#interface TenGigabitEthernet8/6
 6500A(config-if)#ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.128.21 255.255.255.252
 6500A(config-if)#exit
 6500A(config)# no snmp trap link-status
 6500A(config)# router eigrp 99
 6500A(config-router)# network 10.0.0.0
 6500A(config-router)# no auto-summary
 6500A(config-router)# address-family ipv4 vrf TEST-LAB
 6500A(config-router)# redistribute static metric 10000 100 255 1 1500
 
 
!--- Redistribute static routes

 6500A(config-router)# network 10.244.128.0 0.0.0.255
 6500A(config-router)# network 10.244.129.0 0.0.0.255 
 6500A(config-router)# autonomous-system 99
 6500A(config-router)#exit-address-family
 6500A(config-router)#exit  
 6500A(config)#ip classless
 6500A(config)#ip route vrf TEST-LAB 10.0.0.0 255.0.0.0 10.244.129.251
 6500A(config)#interface Vlan129
 6500A(config)#ip vrf forwarding TEST-LAB
 6500A(config-if)#ip address 10.244.129.250 255.255.255.248

 6500c(config)#ip vrf TEST-LAB
 6500c(config)#rd 10.244.0.10:100
!
 6500c(config-if)#interface Loopback0
 6500c(config-if)#ip vrf forwarding TEST-LAB
 6500c(config-if)#ip address 1.1.1.1 255.255.255.0
!         
 6500c(config-if)#interface GigabitEthernet1/1
 6500c(config-if)#switchport
 6500c(config-if)#switchport access vlan 129
 6500c(config-if)#no ip address
!                  
 6500c(config-if)#interface Vlan129
 6500c(config-if)#ip vrf forwarding TEST-LAB
 6500c(config-if)#ip address 10.244.129.251 255.255.255.248

EIGRP устранения неполадок

Общая проблема, замеченная с EIGRP, является локальным маршрутизатором, не устанавливает отношение Соседнего eigrp с соседними маршрутизаторами.

Статический маршрут не Redistriubted к EIGRP

  1. Используйте значение метрики по умолчанию для статических маршрутов в команде redistribute static.

  2. Удалите и добавьте команду redistribute static на маршрутизаторе; статический маршрут 10.0.0.0/8 показывает под Топологией EIGRP.


Дополнительные сведения


Document ID: 112245